¡Promoción especial hasta el 30 de Noviembre!   Descuento 5% en Hosting y 15% en Packs

Jueves, 17 Noviembre 2011 22:50

Liberado Kunena 1.7.1 para Joomla! 1.5 y 1.7

Escrito por 
CMS:  Joomla! |  Versión:  1.7 |  Nivel de dificultad:  Básico |  Tiempo estimado de lectura:  5 minutos



Kunena 1.7.0 para Joomla! 1.5 1.7El equipo de Kunena ha lanzado Kunena 1.7.1 como una extensión nativa para Joomla! 1.5 y 1.7. Esta es una versión de seguridad y sustituye a todas las versiones anteriores de Kunena por lo que se recomienda que todos los usuarios se actualicen a Kunena 1.7.1 lo antes posible.

Con el fin de lograr la interoperabilidad con Joomla! 1.5 y 1.7, han sido atendidas varias cuestiones importantes en Kunena antes de la próxima versión de Kunena 2.0 a finales de este año. Algunos usuarios que utilizan plantillas de terceros escritas para versiones anteriores de Kunena se encuentran que sus estas no pueden trabajar con esta última versión motivado por los cambios, que eran necesarios para adaptarse a la nueva rama de Joomla! 1.7. En particular, muchas de las plantillas de terceros escrito parr Kunena 1.6, en sus primeras etapas, puede causar problemas. En caso de duda, ponerse en contacto con los autores(s) responsables de estas plantillas.

Nota: Joomla! 1.6 ya no tiene soporte oficial.

En este momento todas las extensiones publicadas anteriormente de Kunena se han actualizado y deberán ser instaladas por separado. Al igual que con todas las otras versiones, Kunena 1.7.1 está disponible para su descarga en la página de descarga oficial.

Cambios Destacados:

  • Un solo paquete para Joomla 1.5 y Joomla 1.7 (en concreto, Joomla! 1.5.25 y 1.7.3).
  • Se mejora el nivel de acceso de soporte.
  • Mejor integración con el componente Community Builder y AlphaUserPoints.
  • Corrección de algunos errores encontrados en la versión anterior.
  • Corregidos algunos problemas de seguridad:
    • Flujo de actividad de JomSocial no muestra las categorías restringidas.
    • Ocultar la información sensible del informe de configuración de Kunena.
    • Exploit XSS en las URL canónicas.

Acceder a la lectura del README completo en línea.

Acceder a la lectura del CHANGELOG completo en línea.

Requisitos del sistema:

  • Joomla 1.5.25 o Joomla 1.7.3.
  • Kunena 1.7 no utiliza jQuery y necesita MooTools 1.2.4+.
  • Con la liberación de Joomla! 1.5.25 y 1.7.3, la librería del sistema de Mootools ha sido actualizada para su compatibilidad con Joomla con los navegadores web Firefox 7 e Internet Explorer 9.
  • PHP 5.2.3 - Kunena 1.7 requiere PHP 5.2.3 o superior. En general, se recomienda actualmente el uso de PHP 5.3.6 debido a su madurez.
  • MySQL 5

Kunena en general y en especial la versión 1.7.x se basa en las características avanzadas de SQL introducidas en MySQL 5.0.x. MySQL 4.x ya no es soportado a pesar de que en Joomla! 1.5 se puede ejecutar en ciertas versiones de MySQL 4.x. La principal diferencia es la cantidad de carga de trabajo de la base de datos generada por el componente de foro en comparación con las funcionalidades básicas del CMS.

Requisitos de los componentes de terceros:

Si deseas integrar JomSocial, Community Builder, uddeIM o Alpha User Points con Kunena, debes consultar con los desarrolladores de las extensiones para asegurarte de que cumple con los requisitos. La siguiente lista es sólo una guía y está sujeta a cambios sin previo aviso:

  • JomSocial 2.x.x
  • Community Builder 1.4 o 1.7 (Joomla! 1.7).
  • UddeIm 2.x
  • Alpha User Points 1.5.12 (Joomla! 1.5.x); 1.6.3 (Joomla! 1.7).

Aunque los desarrolladores están haciendo todo lo posible para asegurarse de que Kunena continúe trabajando con las extensiones mencionadas anteriormente, no hay garantías de que las versiones futuras de estos productos sigan siendo siendo compatibles con esta versión de Kunena.

Requisitos para componentes ACL de terceros:

Si deseas utilizar componentes de ACL de terceros con Kunena 1.7.1 y Joomla! 1.5, puedes utilizar los siguientes:

Soporte de idiomas:

Kunena está diseñado para trabajar en una serie de escenarios de idiomas no ingleses. La disponibilidad de traducciones de Kunena requiere de la capacidad de las personas de traducir Kunena los paquetes de idiomas de Inglés a otras lenguas. Cuando las nuevas versiones de Kunena están listas para liberarse, a veces no es posible incluir todas las traducciones posibles de Kunena a tiempo para el lanzamiento. A veces también es necesario eliminar algunos idiomas de Kunena, por razones técnicas. Por lo tanto, antes de actualizar a la última versión de Kunena, es esencial asegurarse, mediante la Lista de Cambios (CHANGELOG) si el idioma que necesitas está incluido. Si un paquete de idioma no está disponible en el momento de la publicación de una nueva versión de Kunena, cuando el idioma esté disponible, el paquete de idiomas estará disponible para su descarga en el foro oficial del proyecto.

Es posible que un idioma disponible sea de una versión anterior de Kunena y no estará disponible en la versión que desea actualizar, por lo que se recomienda verificar primero las notas del lanzamiento.

Descarga de Kunena:

Últimos archivos de instalación del paquete.

El proyecto Kunena utiliza Github como repositorio público de código fuente y anima a todos los usuarios y desarrolladores de código abierto a ayudar desarrollando soluciones, funciones y mejoras al código base existente. Si está interesado en participar, por favor proporcione un parche o una rama mayor y sera tenida en cuenta para su inclusión en la rama de código principal (calidad y nuevas características permitidas).

Repositorio GIT del código fuente.

Las distribuciones oficiales de Kunena están disponibles en el enlace de arriba o directamente en el sitio oficial de www.kunena.org. Actualmente no hay espejos alternativos (mirros) para descargas soportados oficialmente, los usuarios están invitados a visitar www.kunena.org para descargar la versión más reciente de todos los paquetes disponibles de Kunena.

Compatibilidad con plantillas de terceros para Kunena:

Plantillas diseñadas para Kunena 1.5.x no funcionarán con Kunena 1.7.1, debido a importantes cambios en el código y la estructura. Algunas plantillas de terceros desarrolladas para versiones anteriores de Kunena 1.6.x también pueden ser incompatibles y afectar todas las funciones de Kunena disponibles. En caso de duda, ponte en contacto con el autor(s) responsable de tu plantilla de Kunena.

Compatibilidad con módulos de terceros para Kunena:

Kunena 1.7.0 no es compatible con los módulos o plug-ins diseñados para versiones anteriores y se recomienda desinstalar todas las extensiones para Kunena 1.5 antes de instalar o actualizar su componente a Kunena 1.7.1.

Kunena 1.7.x ofrece ahora una API actualizada para crear fácilmente módulos o plug-ins. El equipo de Kunena ha creado algunos nuevos plug-ins y módulos que aprovechan la nueva API y puede ser utilizados con Kunena 1.7. Estas extensiones se pueden encontrar en el directorio de extensiones de Kunena. En caso de duda, ponte en contacto con el autor(s) responsable de tu extensión.

Instalar o actualizar Kunena:

Para instalar Kunena, asegurate de leer las instrucciones de instalación antes de comenzar. Para actualizar desde versiones anteriores de Kunena (incluyendo FireBoard), asegurate de leer las instrucciones de actualización.

El instalador de Kunena ahora maneja tanto las instalaciones como las actualizaciones de las instalaciones existentes sin la necesidad de la intervención del usuario, la ejecución manual de SQL o los procedimientos de migración. También mantiene un registro detallado de todas las versiones Kunena instaladas en su sitio con el fin de realizar actualizaciones incrementales cuando sea necesario. Esto significa que el administrador de un sitio no tiene que preocuparse con una instalación complicada o con los procedimientos de actualización.

Hacemos hincapié en la importancia de realizar copias de seguridad antes y después de cualquier proceso de actualización, preferiblemente con Akeeba Backup. Nunca realizar una instalación o actualización sin una copia de seguridad completa.



¿Te ha resultado interesante este artículo?

Suscríbete para recibir consejos exclusivos para WordPress, Joomla y PrestaShop