Descuento 20% Diciembre
Plugin Optimización de Imágenes Gratuito para WordPress
Miércoles, 27 Febrero 2013 16:55

Actualización importante del Framework T3 de JoomlArt

Escrito por 
CMS:  Joomla! |  Versión:  2.5.x |  Nivel de dificultad:  Básico |  Tiempo estimado de lectura:  5 minutos


Framework T3 de JoomlArtAcaba de ser liberada una versión del Framework T3v3 estable, concretamente la versión 1.1.0 de JoomlArt que corrige una serie de fallos y al que se recomienda actualizar de forma urgente previa copia de seguridad.

Después de 4 meses de trabajo, JoomlArt ha liberado el Framework T3v3 en su versión estable para Joomla! 2.5 y Joomla! 3.0 hace unos días acompañado de JAEM (Administrador de Extensiones de JoomlArt) que corrige errores del plugin T3 utilizado en las plantillas de JoomlArt y sus extensiones. Es importante tener claro que el "framework" es una cosa y el plugin JA T3 otra bien diferente y aunque ambas deberían ser actualizadas, en la mayoría de casos (quien no utilice el framework) es suficiente con actualizar el plugin.

Por ello, todos los usuarios que hagan uso de plantillas o extensiones de JoomlArt deben plantearse la actualización del framework para corregir estos problemas, siempre previa realización de una copia de seguridad, ya sea con Akeeba Backup o con XCloner.

Durante el último par de meses, JoomlArt ha ido liberando una versión beta y algunas versiones RC del Framework T3 recibiendo numerosos comentarios del equipo de desarrollo de Joomla! para mejorar el framework.

La versión estable del framework T3v3, la 1.1.0 para Joomla! 2.5 y Joomla! 3.0 se ha liberado con nuevas características (actualización a la versión 2.3.0 de Bootstrap, añadir la opción Activar en Megamenu), mejoras (reestructuración de código, botón de acción en Megamenu, añadir archivos de estilo, etc.) y corrección de errores.


Actualizar el plugin T3 utilizando JAEM (Administrador de Extensiones de JoomlArt)

¿Cual es la manera más fácil de actualizar el Plugin de T3 a la versión estable?. Se puede utilizar JAEM (Administrador de Extensiones de JoomlArt) para actualizar el plugin de T3, pues todos los problemas de actualización ya están resueltos.

También se puede actualizar el plugin T3 directamente a través del Gestor de Actualizaciones de Joomla!, Actualizar o simplemente mediante la instalación de la nueva versión sobre la anterior. Como decimos siempre, es importante tener una copia de seguridad antes de seguir adelante.


En este vídeo realizamos la actualización del plugin desde el Gestor de Extensiones de Joomla.



Descargar el Plugin JA T3v2 System Plugin para Joomla! 2.5 y Joomla! 3.0 desde la web oficial de JoomlaArt.



Actualizar el Framework T3v3

Si no ha probado todavía el Framework T3v3 y ha estado esperando todo este tiempo para que T3v3 versión estable, es buen momento para experimentar las excelencias de este framework que mejoran el uso de sus plantillas y extensiones basadas en este.


Descargar Framework T3 versión 3 estable 1.1.0 desde la web oficial de JoomlaArt.



Correcciones, mejoras y nuevas características del Framework T3v3, versión: 1.1.0 Estable:

Nuevas funciones:

  • Actualizada versión 2.3.0 de Bootstrap 2.3.0
  • Megamenu: Añadido alternar "ocultar cuando colapso" de la columna y del submenú.
  • Megamenu: Añadida la opción Mostrar siempre submenú al colapsar.

Mejoras:

  • Reestructuración del código.
  • Administración Megamenu: el uso del icono para el botón de acciones.
  • Añadido "t3.less" y "t3 responsive.less-" para diferentes estilos de T3.
  • Sobrescribir: Actualizado fallo de sobrescribir HTML para componentes y módulos de Joomla.
  • Actualizado el enlace a la página principal de T3 en la cabecera de paquete.
  • Utilizada la biblioteca JS de Bootstrap T3 en lugar del Bootstrap de Joomla.
  • Actualizados los estilos de navegación - Añadido "estado activo" a "abrir Estado" para un mejor estilo.

Fallos corregidos:

  • Los Iconos de imagenes no se muestran correctamente en la configuración Megamenu.
  • Configuración Megamenu en admin se pierde al cambiar de estilo de plantilla para la página de Inicio (por defecto).
  • Megamenu: Error al cambiar el orden de menú.
  • Megamenu-responsive.less variables @baseLineHeight es undefined.
  • Corregida disposición SearchButton en bootstrap.
  • Corregido límite de 4096 selectores CSS en Internet Explorer.
  • ThemeMagic: Corregido comportamiento del botón Minimizar.
  • ThemeMagic: Corregido cambio jadepend => t3depend.
  • Responsive: Corregido mostrar/ocultar bloque.
  • Corregida la desalineación en "Barra de herramientas de iconos" en la interfaz de Administrador.
  • Less: Corregido Thememagic no puede cargar los iconos del menú.
  • AJAX: Corregido t3action.
  • Less: Mejorado UX, añadido administrador de errores para manejar LESS.
  • Menú: Corregido comportamiento menú.
  • Thememagic: no funciona en la versión 19.x de Firefox.

Tan importante es mantener el core de Joomla! actualizado siempre a la última versión estable, como lo es mantener las plantillas, extensiones y en este caso el Framework T3 en su última versión estable, lo que comporta correcciones importantes en el código, mejoras en el uso de plantillas y extensiones y disponer de funcionalidades nuevas.



¿Te ha resultado interesante este artículo?

Suscríbete para recibir consejos exclusivos para WordPress, Joomla y PrestaShop



Luis Méndez Alejo

Miembro del equipo técnico de Webempresa.
Coordinador de contenidos en el Blog y en Youtube.
Google+


Plugin Optimización de Imágenes Gratuito para WordPress