Viernes, 20 Marzo 2015 15:51

Actualizar Pack Tienda Joomla con Framework Gantry de Joomla 2.5 a Joomla 3

Escrito por 
CMS:  Joomla! |  Versión:  3.x |  Nivel de dificultad:  Medio |  Tiempo estimado de lectura:  10 minutos


Actualizar Pack Tienda Joomla con Framework Gantry de Joomla 2.5 a Joomla 3Con la salida de Virtuemart 3 por fin es posible utilizar Joomla 3 para nuestra web, ya que las versiones anteriores solo eran compatibles con Joomla 2.5.

Los Packs Tienda Joomla actuales ya vienen con Joomla 3 y Virtuemart 3 integrados. Sin embargo, nos podemos encontrar en la situación de que tengamos ya un Pack Tienda funcionando con Joomla 2.5 y queramos actualizarlo a Joomla 3.

En este artículo vamos a ver los pasos que hay que seguir para actualizar los Pack Tienda Joomla de Webempresa que utilizan el framework Gantry. Por tanto, este tutorial solo será válido para los siguientes Packs: Epimeteo, Helena, Anthe, Prometeo, Jano y Mimas.

Antes de empezar habrá que tener en cuenta algunas consideraciones. Por un lado, si hemos realizado modificaciones en el código de la plantilla para cambiar el diseño de la web, estos cambios se pueden perder con la actualización, en especial si son cambios relativos al propio Virtuemart.

Por otro lado, si hemos añadido a nuestro Joomla extensiones adicionales que no venían con el pack tendremos que asegurarnos de que estas son compatibles con Joomla 3. En caso contrario tendremos que actualizar la extensión a una versión compatible con Joomla 3 o, de no existir una, desinstalar la extensión.

Será imprescindible realizar una copia de seguridad completa de la web antes de comenzar con el proceso, porque es posible que puedan surgir problemas que dejen inutilizada la web. Incluso, una buena opción sería realizar un clon de la web en otro directorio de nuestra cuenta de alojamiento para hacer pruebas antes de aplicar los cambios en la web real. De hacer esto, sigue siendo imprescindible la copia de seguridad.

Sin más introducción, vamos a revisar los distintos pasos a seguir para actualizar de Joomla 2.5 con Virtuemart 2 a Joomla 3.X con Virtuemart 3:

  • Poner Joomla en mantenimiento durante los cambios, ya que se pueden producir errores durante el proceso. Se puede hacer desde Sitio->Configuración Global activando el parámetro Sitio desactivado.
  • Desinstalar las siguientes extensiones, ya que no son compatibles con Joomla 3:
    • Módulo mod_kc_admin_quickicons
    • Plugin VM - Custom, stockable variants (VM campo personalizado con control de stock)
    • Componente Sales Analytics
    • Componente Atend Framework
    • Componente CSVI Free
    • Componente eXtplorer
    • Componente Favicon Package
    • Todas las extensiones de Wishlist
  • Desactivar el plugin Easy Calc Check.
  • Actualizar Virtuemart de la versión 2.6 a la 3. Podemos descargar la actualización desde la página de descargas de Virtuemart. El archivo descargado, que tendrá un nombre como com_virtuemart.XX_extract_first.zip (cambiando XX por la versión de Virtuemart) deberemos descomprimirlo. Dentro veremos varios instaladores. Desde Extensiones->Gestor de Extensiones tendremos que instalar los archivos com_virtuemart.XX.zipcom_virtuemart.XX_ext_aio.zip, que se corresponde al Virtuemart y a las extensiones (módulos y plugins) de la tienda.
  • Ir a Componentes->virtuemart-aio y pulsar en el botón Actualizar tablas de Plugins VM.
  • Desinstalar el componente VirtueMart_allinone.
  • Actualizar de Joomla 2.5 (preferiblemente de la versión 2.5.28) a la última versión de Joomla 3. Si queremos actualizar Joomla de forma manual podemos descargar la actualización desde la página de descargas de Joomla e instalarla desde Extensiones->Gestor de extensiones. Hay que tener en cuenta que este proceso puede tardar unos minutos.
  • Instalar la última versión del idioma Español para Joomla 3. Podemos descargar el paquete de idioma desde la página de idiomas oficiales de Joomla. Se puede instalar desde Extensiones->Gestor de extensiones.
  • Instalar la última versión del idioma Español para Virtuemart 3. Podemos descargar el paquete de idioma desde la página de idiomas oficiales de Virtuemart. Se puede instalar desde Extensiones->Gestor de extensiones.
  • Actualizar el plugin Easy Calc Check a la versión compatible con Joomla 3. Podemos descargarla desde la página de los desarrolladores. La instalamos desde Extensiones->Gestor de extensiones sin necesidad de desinstalar previamente la versión que teníamos. Una vez instalada podemos ir a Extensiones->Gestor de plugins y activamos el plugin System - EasyCalcCheck PLUS - ECC+.
  • Actualizar el Akeeba Backup a la última versión disponible, que podremos descargar desde la página del autor. La instalamos desde Extensiones->Gestor de extensiones sin necesidad de desinstalar antes la versión que teníamos.
  • En la administración de Virtuemart ir a "Campos personalizados". Aquí habrán 2 nuevos campos Categorías relacionadas y Productos relacionados que sirven para mostrar estos datos en la ficha del producto. Editar estos registros y dejar vacíos los campos Descripción y Descripción emergente. En el apartado Seleccione un plugin dejar activada solo la opción Mostrar imagen de categoría.
  • Para el módulo de productos Virtuemart desactivar la caché (hay 2 sitios donde hacerlo). Además en este mismo módulo es recomendable dejar desactivado el parámetro ¿Mostrar enlace añadir al carro?.
  • Renombrar los directorios templates/NOMBRE_TEMA/html/com_virtuemart/user y templates/NOMBRE_TEMA/html/com_virtuemart/cart. Para realizar esta tarea podemos utilizar el Administrador de archivos de CPanel.
  • Descargar el parche que encontraremos en el área de cliente de Webempresa para nuestro pack, dentro de Soporte->Descargas. Subimos el parche (un archivo zip) en la raíz de nuestro sitio web y lo descomprimimos. Para realizar esta tarea podemos utilizar el Administrador de archivos de CPanel. Ojo, cada parche solo es válido para un pack en concreto, no servirá para otros.

Una vez aplicados todos estos cambios deberíamos tener nuestra tienda online funcionando con Joomla 3.X y Virtuemart 3. En caso de que se produzcan errores deberemos verificar que no hayamos añadido otras extensiones por nuestra cuenta que no sean compatibles con Joomla 3. Si no encontramos la causa del error tendremos que restaurar la copia de seguridad que hayamos realizado antes de comenzar con el proceso.

En el siguiente vídeo se puede ver de forma más detallada los pasos seguidos para actualizar nuestro Virtuemart 2 con Joomla 2.5 a Virtuemart 3 con Joomla 3:



¿Te ha resultado interesante este artículo?

Suscríbete para recibir consejos exclusivos para WordPress, Joomla y PrestaShop