Descuento 20% Diciembre
Plugin Optimización de Imágenes Gratuito para WordPress
Lunes, 05 Marzo 2012 22:19

Liberado Akeeba Backup 3.4.0 para Joomla! 1.5 y 2.5 con soporte mejorado para DropBox

Escrito por 
CMS:  Joomla! |  Versión:  2.5.x |  Nivel de dificultad:  Básico |  Tiempo estimado de lectura:  5 minutos


Akeeba Backup 3.4.0El equipo de desarrollo de AkeebaBackup.com acaba de anunciar la disponibilidad inmediata de Akeeba Backup 3.4.0.

Akeeba Backup 3.4.0 es la nueva versión estable del componente de copias de seguridad más conocido y utilizado en el CMS Joomla!. Esta nueva versión incorpora características, tales como la integración del servicio de Box.net muy solicitado por los usuarios y la importación directa de archivos arbitrarios desde Amazon S3, y la corrección de errores en la integración de Dropbox. A partir de esta versión, sólo será compatible con Joomla! 1.5, 1.7 y 2.5.

Akeeba Backup 3.4.0 no se instalará en sitios desarrollados con Joomla! 1.6. El soporte a PHP 5.2 se considera obsoleto y se eliminará en una versión futura de Akeeba Backup.

Los usuarios de la versión profesional de Akeeba Backup deben tener en cuenta que con la nueva integración de Dropbox ya no se guarda la dirección de correo electrónico de Dropbox y la contraseña en la configuración de Akeeba Backup. Sólo se almacena una copia, lo que permite a Akeeba Backup (y solo a Akeeba Backup) acceder a su cuenta de Dropbox. Esto aumenta aún más la seguridad de su sitio y de su cuenta de Dropbox, por no mencionar que ahora se está utilizando la API oficial de Dropbox que no es propensa a romperse en el futuro.

Obtener Akeeba Backup y recibir soporte

Como siempre, puedes descargar la versión gratuita, Akeeba Backup Core, desde la página oficial de descargas del proyecto sin cargo alguno. Si eres suscriptor profesional puedes descargar Akeeba Backup Professional desde la misma página, sólo asegúrate de que estar logeado antes de visitar la página de descargas. Alternativamente, puedes utilizar la función integrada de actualización en vivo incorporada en la extensión, desde tu backend, para actualizar de forma automática en entornos de servidores compatibles.


Ver y valorar Akeeba Backup en el Joomla! Extensions Directory.

Descargar Akeeba Backup 3.4.0 desde la página web oficial del proyecto.


El equipo de Akeeba Backup, desde 07 de julio 2011, solo proporciona soporte únicamente a los suscriptores.

Versiones soportadas

La política de soporte de Akeeba Backup consiste en prestar soporte sólo a la última versión publicada estable de Akeeba Backup, así como a la última versión previa publicada (alfa, beta o release candidate "RC") liberada, si hay alguna disponible.

Por otra parte, sólo dan soporte sobre versiones de Joomla! soportadas oficialmente por el proyecto Joomla!. Debido a la gran cantidad de versiones de Joomla! activas, se han consolidado las condiciones de soporte a las diferentes combinaciones de versiones de Akeeba Backup y Joomla! en la siguiente tabla:

Joomla! 1.5

Joomla! 1.6

Joomla! 1.7

Joomla! 2.5

Akeeba Backup 3.4.0 *

Hasta el 1 de Agosto de 2012***

No soportada

Hasta el 1 de Junio de 2012***

Hasta Agosto de 2013 **

Akeeba Backup 3.3.13

Hasta el 12 de Marzo de de 2012

No soportada

Hasta el 12 de Marzo de 2012

Hasta el 12 de Marzo de 2012

Versiones antiguas

Sin soporte
(puedes usar Akeeba Backup 3.2.7 en Joomla! 1.6 o en servidores con PHP 5.1.x bajo tu propio riesgo)

Sin soporte: (puedes usar Akeeba Backup 3.2.7 en Joomla! 1.6 o en servidores con PHP 5.1.x bajo tu propio riesgo).

* Sólo la última versión de Akeeba Backup 3.4.x es compatible. Compatibilidad limitada ofrecida para versiones anteriores (una semana después de liberar una actualización), y si se detecta que se ha visto comprometida por un problema conocido corregido se pide que actualices a la última versión antes de proporcionar cualquier asistencia adicional.

** Si una nueva serie de Akeeba Backup (es decir, 3.5) se libera antes de agosto de 2013, Akeeba Backup 3.4.x dejará de ser compatible, de acuerdo con la política de soporte del proyecto.

*** Joomla! 1.5 y 1.7 son compatibles con Akeeba Backup durante aproximadamente 4 meses después de haber alcanzado oficialmente al final de su vida. Esto debe dar tiempo suficiente para migrar los sitios a la versión actual soportada de Joomla! 2.5.

Ten en cuenta que Akeeba Backup 5.2.7 requiere PHP 3.3.x o superior para funcionar. Si tienes una versión anterior de PHP, consulta a tu Hosting para actualizarlo inmediatamente. PHP 4, 5.0, 5.1 y 5.2 están al final de su vida útil, abandonados hace más de un año por sus desarrolladores, pues contienen vulnerabilidades de seguridad conocidas.


Lista de Cambios (Changelog):

Nuevas características:

  • ABI: Actualización de jQuery y jQuery UI.
  • ABI: Recuerda la preferencia para borrar la información de conexión de la base de datos cuando se navega entre pasos.
  • # 120 ABI: Capacidad para saltar restaurar bases de datos seleccionados, excepto del sitio (Saltando a la Siguiente).
  • # 121 Importación de archivos arbitrarios desde S3.
  • # 248 Integración con Box.net proveedor de almacenamiento en la nube.
  • El script CRON backup.php ahora es compatible con el conmutador --debug para volcar todos los errores de PHP.
  • Buscador de tablas (que puede ser reconstruido en cualquier momento) ahora se saltan por defecto, lo que lleva una mejora de rendimiento importante cuando se respalda sitios en Joomla! 2.5.

Cambios varios:

  • Reimplementar la integración de DropBox con la API oficial.
  • Corrección de errores:

    • El plug-in de notificación de actualización se ejecutaba varias veces si no era capaz de actualizar su registro de tiempo en la última ejecución.
    • ABI no es compatible con la conexión a puertos MySQLi no estándar (non-3306).
    • Regresión: copia de seguridad de múltiples bases de datos no funciona.
    • El script CRON backup.php no soporta la característica de enviar por correo electrónico en Joomla! 2.5.x.

    En el siguiente vídeo realizamos la actualización de Akeeba Backup desde una versión anterior a la actual estable por medio del icono de acceso rápido del componente en el backend.



    Mantener las extensiones actualizadas es importante para garantizar la seguridad de nuestros sitios web desarrollados con Joomla!



¿Te ha resultado interesante este artículo?

Suscríbete para recibir consejos exclusivos para WordPress, Joomla y PrestaShop



Luis Méndez Alejo

Miembro del equipo técnico de Webempresa.
Coordinador de contenidos en el Blog y en Youtube.
Google+


Plugin Optimización de Imágenes Gratuito para WordPress