Jueves, 28 Febrero 2013 22:51

Vídeos aleatorios en Joomla 2.5 con Random Youtube Video

Escrito por 
CMS:  Joomla! |  Versión:  2.5.x |  Nivel de dificultad:  Básico |  Tiempo estimado de lectura:  5 minutos


Random Youtube VideoUna gran mayoría de plantillas, principalmente de JoomlArt, Gavick y RocketTheme suelen presentar módulos con vídeos en determinadas posiciones de la plantilla, para que los contenidos multimedia estén más presentes en la web, pero el 90% de los casos se trata de "módulos personalizados con html" (personalizar HTML) que incluyen directamente una llamada al vídeo de forma manual:

< iframe width="208" height="117" src="http://www.youtube.com/embed/qT0QKOZwDNg" frameborder="0" allowfullscreen>< /iframe>

Cuando el usuario o desarrollador de la página quiere utilizar dicho módulo para mostrar vídeos propios o de un canal se encuentra con que no dispone de una extensión al uso que le permita automatizar este proceso sin tener que editar cada vez el módulo para cargar un nuevo vídeo, lo que por otro lado no es nada practico.

Es en estos casos cuando extensiones como Random Youtube Video desempeñan un papel importante, pues facilitan la automatización del proceso de carga de nuevos vídeos, ya sean leídos de una ruta o cargados desde un canal como por ejemplo Youtube.

Random Youtube Video muestra un vídeo al azar para un usuario específico. Este módulo permite ajustar la anchura y la altura del vídeo a mostrar para adaptarlo lo mejor posible a la posición, permitiendo también controlar si se deben mostrar uno o más vídeos, o enlaces, y también controlar el texto de este enlace. También permite mostrar un solo vídeo de YouTube en el módulo pero al azar (aleatorio).

El módulo utiliza el API de datos de Google para YouTube para cargar vídeos aleatoriamente a través del ID del usuario.

El módulo incluye la librería Zend 1.9, soportada por la mayoría de servidores Apache, para que los visitantes que no tienen Zend puedan visualizarlos.


Ver y valorar Random Youtube Video en el Joomla! Extensions Directory.


Requisitos del módulo:

  • Joomla 1.5 o 2.5.
  • Libreria Zend 1.9.

En el siguiente vídeo realizamos la instalación y sustitución del módulo personalizado de html de la plantilla del Pack Noticias NEX para Joomla 2.5.




¿Te ha resultado interesante este artículo?

Suscríbete para recibir consejos exclusivos para WordPress, Joomla y PrestaShop



Luis Méndez Alejo

Miembro del equipo técnico de Webempresa.
Coordinador de contenidos en el Blog y en Youtube.
Google+