Foro de soporte WordPress en español


Soporte WordPress en español Soporte gratuito para webs alojadas en Webempresa.com
Habilitado para todos los clientes con planes de Hosting Alto Rendimiento a partir de 3GB y planes XL.

No ofrecemos soporte a webs alojadas en servidores externos o localhost, ni soporte css o programación.

Te recomendamos que leas esta información sobre nuestro sistema de soporte en el foro, te ayudará a sacar el máximo partido de nuestro conocimiento: Cómo podemos ayudarte.


Encuentra la solución a tu problema, buscando en nuestro foro:
Bienvenido, Invitado
Nombre de Usuario: Contraseña: Recordarme
Consultas relacionadas con la extensión BreezingForms para la creación de Formularios en Joomla.
  • Página:
  • 1
  • 2

TEMA: No funciona boton enviar y he puesto "validate_submit"

No funciona boton enviar y he puesto "validate_submit" 5 años 6 meses antes #142938

Hola amigos.
He creado dos formularios con breezengforms, uno de contacto y el otro de cotiza con nosotros.
El boton regular de enviar no funciona ya que al enviar no se envía. Esto lo tengo muy bien configurado como muestro en las siguientes capturas. Este proceso lo he hecho con buenos resultados en varios otros sitios que tengo y sin problemas. La verdad es que no se qué pueda estar pasando ya que segun yo lo tengo todo muy bien configurado.
Dejo capturas.

Saludos.
validate.JPG


enviar.JPG


enviar1.JPG



URL del sitio: Contenido oculto para usuarios invitados. Por favor, inicie su sesión para poder verlo.
  • Raul Venegas
  • Avatar de Raul Venegas
  • DESCONECTADO
  • Navegador Platino
  • Mensajes: 535
  • Gracias recibidas 3
  • Karma: 1
El administrador ha desactivado la escritura pública.
Mejora la velocidad de tu WordPress

No funciona boton enviar y he puesto "validate_submit" 5 años 6 meses antes #142941

Hola Raul,

Al analizar con Firebug, y pulsar en el botón enviar, muestra el error:
ReferenceError: ff_validate_submit is not defined 	  ff_validate_submit(this,'click');

Revisa lo que se indica en www.webempresa.com/foro/6-Joomla!-15/84008-Problemas-para-enviar-formularios-en-breez.html#84908

Saludos
  • Jordi Sala
  • Avatar de Jordi Sala
  • DESCONECTADO
  • Administrador
  • Mensajes: 12048
  • Gracias recibidas 1317
  • Karma: 276
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
El administrador ha desactivado la escritura pública.
trasladar web gratis

No funciona boton enviar y he puesto "validate_submit" 5 años 6 meses antes #142966

Hola Jordi, gracias por responder.
He hecho todo lo que me dice el hilo del foro que me dejaste, fui a piezas de formulario=>despues del formulario y el librería puse la opcion FF::ff_ initlib y no pasa nada, sigue ocurriendo el mismo error.
Será algún conflicto con la plantilla?.

Este sitio que envío a ustedes y que tiene una url de un pack de webempresa lo trasladé mediante akeeba backup al servidor donde estába alojado el dominio original, pero como sé que no atienden a casos que no sean en los hostings vuestros he dejado la url que envié para que me pudiesen ayudar.
Puede ser que por el hecho de tener dos joomlas iguales en distintos servidores esté ocurriendo el error???.

Nota, hacer pruebas en el formulario de "cotiza con nosotros"

Bueno, espero poder solucionar esto ya que es lo más importante del sitio web.

Saludos.
  • Raul Venegas
  • Avatar de Raul Venegas
  • DESCONECTADO
  • Navegador Platino
  • Mensajes: 535
  • Gracias recibidas 3
  • Karma: 1
El administrador ha desactivado la escritura pública.
solucionar problemas wordpress

No funciona boton enviar y he puesto "validate_submit" 5 años 6 meses antes #142977

Hola,

Veo que el problema realmente lo tienes con los 2 formularios, por lo que es posible que no sea cosa de la configuración de los formularios sino del propio BreezingForms.

Edita alguno de los formulario y verificar que tienes la configuración de la pestaña Piezas del Formulario como en la siguiente captura de pantalla.

formulario.png


Si ya está así entonces el problema podría estar en que le faltan librerías a tu instalación de BreezingForms. Para verificarlo vete en la administración de BreezingForms a Administrar Piezas. En el filtro Paquete que se muestra en la parte superior selecciona FF. Verifica si aquí te sale una librería con el nombre ff_InitLib.
  • Pablo Velasco
  • Avatar de Pablo Velasco
  • DESCONECTADO
  • Moderador
  • Mensajes: 20369
  • Gracias recibidas 2734
  • Karma: 758
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.
El administrador ha desactivado la escritura pública.

No funciona boton enviar y he puesto "validate_submit" 5 años 6 meses antes #142981

Gracias Pablo por responder a mi consulta.
Te comento que persiste el problema, como muestro en las siguientes capturas ya he hecho el primer paso del que me hablas y la librería con el nombre ff_InitLib. también está.
De verdad debe ser algo de breezengforms ya que ambos formularios no funcionan.
Pero sé que nuevamente con vuestra ayuda lo resolveré.

Saludos.
breez.JPG


breez1.JPG
  • Raul Venegas
  • Avatar de Raul Venegas
  • DESCONECTADO
  • Navegador Platino
  • Mensajes: 535
  • Gracias recibidas 3
  • Karma: 1
El administrador ha desactivado la escritura pública.

No funciona boton enviar y he puesto "validate_submit" 5 años 6 meses antes #142992

Hola,

Aparéntemente lo tienes todo bien. Podría tratarse de un conflicto con alguna extensión que hayas podido añadir (módulo o plugin) o con la propia plantilla de Joomla que estés usando.

Prueba a desactivar las extensiones que hayas añadido y cambia la plantilla de Joomla para ver si así el formulario funciona. De esta forma podremos saber si el problema con alguna extensión o la plantilla.
  • Pablo Velasco
  • Avatar de Pablo Velasco
  • DESCONECTADO
  • Moderador
  • Mensajes: 20369
  • Gracias recibidas 2734
  • Karma: 758
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.
El administrador ha desactivado la escritura pública.

¿Te ha resultado interesante esta entrada del foro?

Suscríbete para recibir consejos y trucos útiles para tu Web.

No funciona boton enviar y he puesto "validate_submit" 5 años 6 meses antes #143019

Hola.
Desactivé todas las extensiones que he instalado y fui probando una por una y a la vez fui probando el formulario y no tengo buenas noticias. También desactivé la platilla y deje la jpuriti que traia por defecto con malas noticias nuevamente, en aquella plantilla sucede el mismo problema. Debe ser algo que haya que configurar en mi joomla o bien hacerlo en breezingforms. Dejo una captura de como está configurado la configuración de breezingforms.

Saludos.


breez3.JPG
  • Raul Venegas
  • Avatar de Raul Venegas
  • DESCONECTADO
  • Navegador Platino
  • Mensajes: 535
  • Gracias recibidas 3
  • Karma: 1
El administrador ha desactivado la escritura pública.

No funciona boton enviar y he puesto "validate_submit" 5 años 6 meses antes #143040

Hola

Sale un errror :

ff_validate_submit is not defined

Para descartar problema de BF o de formulario prueba hacer un nuevo formulario o mostrar alguno de los que te vienen por defecto, prueba en diferentes modos y verifica si te sucede lo mismo, tu formulario debe ser simple pero debe incluír un boton de envó.

Saludos.
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.
El administrador ha desactivado la escritura pública.

No funciona boton enviar y he puesto "validate_submit" 5 años 6 meses antes #143320

Hola.
Lamentablemente sigo con los problemas, ya estoy pensando que es el componente que está mal instalado o algo así.
Ahora he realizado el formulario de "cotiza con nosotros" en modo Rápido tal cual como lo muestra el siguiente video de webempresa .
Ahora resulta que mientras lo iba creando me pareció muy raro que no me mostrara la vista previa ni la previsualización del sitio, todo esto aparecía en blanco en todo momento en que le pedía que me mostrara, sin embargo seguí adelante creyendo que en el sitio me iba a mostrar pero no fue así, una vez terminado de configurar y guardado dicho formulario copié y pegué el nombre que en este caso es: "cotiza_con_nosotros", esto como siempre lo pegué en "cotiza con nosotros" del menú principal con el tipo de elemento de menu "añadir formulario". Pero nada de nada, no se ve dicho formulario y ya no sé que pueda estar pasando, he probado de todo y no resulta, al parecer no es la plantilla ya que probé con la que viene por defecto y tampoco resultaba.
Quizás haya algo más que configurar.
Dejo seis capturas para que comprueben todo lo que les digo.

Saludos y espero poder resolver esto pronto.


rapido1.JPG


rapido2.JPG


rapido3.JPG


rapido4.JPG


rapido5.JPG


rapido6.JPG
  • Raul Venegas
  • Avatar de Raul Venegas
  • DESCONECTADO
  • Navegador Platino
  • Mensajes: 535
  • Gracias recibidas 3
  • Karma: 1
El administrador ha desactivado la escritura pública.

No funciona boton enviar y he puesto "validate_submit" 5 años 6 meses antes #143322

Hola Raul,

Entiendo que estas trabajando con una versión estable de BreezingForms ¿correcto? y que no usas extensiones de "cookies" o similares ¿correcto?.

Revisa este artículo por si te afecta: www.webempresa.com/blog/item/1347-actualizacion-critica-de-seguridad-del-gestor-de-formularios-breezingforms.html

Facilitanos el código completo de ff_submit de tu formulario, mételo entre etiquetas Saludos[code]

Saludos
  • Luis Mendez Alejo
  • Avatar de Luis Mendez Alejo
  • DESCONECTADO
  • Administrador
  • Mensajes: 23257
  • Gracias recibidas 2410
  • Karma: 514
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.
El administrador ha desactivado la escritura pública.

No funciona boton enviar y he puesto "validate_submit" 5 años 6 meses antes #143325

actualmente estoy utilizando la version estable 1.8.3 como muestro en la captura.

Lo que no sé es donde conseguir dicho código completo de ff_submit y como se mete entre etiquetas code.

Saludos.


version.JPG
  • Raul Venegas
  • Avatar de Raul Venegas
  • DESCONECTADO
  • Navegador Platino
  • Mensajes: 535
  • Gracias recibidas 3
  • Karma: 1
El administrador ha desactivado la escritura pública.

No funciona boton enviar y he puesto "validate_submit" 5 años 6 meses antes #143328

Hola,

El problema debe puede estar provoca por un conflicto, varios de los casos donde se hay tratado el tema ha sido por esto:

www.webempresa.com/foro/22-BreezingForms/60909-Submit-no-funciona.html?limitstart=0&start=15
www.webempresa.com/foro/22-BreezingForms/90100-No-funciona-enviar-en-BreezingForms.html?limitstart=0&start=15
www.webempresa.com/foro/27-Joomla!-25/66472-boton-enviar-BreezingForms.html?limitstart=0&start=15

Puedes exportar el formulario y adjuntarlo para nosotros realizar la prueba?

Saludos.
Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.
El administrador ha desactivado la escritura pública.

No funciona boton enviar y he puesto "validate_submit" 5 años 6 meses antes #143334

function ff_validate_submit(element, action)
{
if(typeof bfUseErrorAlerts != 'undefined'){
JQuery(".bfErrorMessage").html('');
JQuery(".bfErrorMessage").css("display","none");
}
error = ff_validation(0);
if (error != '') {

if(typeof bfUseErrorAlerts == 'undefined'){
alert(error);
} else {
bfShowErrors(error);
}
ff_validationFocus();
} else
ff_submitForm();
} // ff_validate_submit
  • Raul Venegas
  • Avatar de Raul Venegas
  • DESCONECTADO
  • Navegador Platino
  • Mensajes: 535
  • Gracias recibidas 3
  • Karma: 1
El administrador ha desactivado la escritura pública.

No funciona boton enviar y he puesto "validate_submit" 5 años 6 meses antes #143335

Hola,

No comprendo lo que adjuntaste, entiendo que quieres exportar el formulario, para eso tienes que realizar los pasos que menciono en este enlace: www.webempresa.com/foro/22-BreezingForms/60909-Submit-no-funciona.html?limitstart=0&start=15#60987

Saludos.
Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.
El administrador ha desactivado la escritura pública.

No funciona boton enviar y he puesto "validate_submit" 5 años 6 meses antes #143337

No.Solo quiero que funcione y no pasa nada. El del modo clasico no me funciona el boton enviar y ya hice todo lo que hay que hacer y el del modo rapido no se ve en la página. No se a que te refieres con exportar.
Puse ese código ya que Luis me dijo "Facilitanos el código completo de ff_submit de tu formulario, mételo entre etiquetas " y ese código fue lo más parecido que encontré.

Saludos.
  • Raul Venegas
  • Avatar de Raul Venegas
  • DESCONECTADO
  • Navegador Platino
  • Mensajes: 535
  • Gracias recibidas 3
  • Karma: 1
El administrador ha desactivado la escritura pública.

No funciona boton enviar y he puesto "validate_submit" 5 años 6 meses antes #143339

Hola,

No veo problemas en ese script. La solucitud de exportación del formulario es para nosotros probar si el formulario funciona en otra web, en caso de funcionar en otro sitio web significaría que el problema esta en tu web y que existe algún conflicto con alguna extension.

Saludos.
Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.
El administrador ha desactivado la escritura pública.

No funciona boton enviar y he puesto "validate_submit" 5 años 6 meses antes #143415

Te refieres a que si mi breezingforms no sirve (porque ya he probado por todos los medios de crear los formularios) puedo crear un formulario en otro joomla y exportarlo al joomla donde necesito que se vea??.
Gracias.
  • Raul Venegas
  • Avatar de Raul Venegas
  • DESCONECTADO
  • Navegador Platino
  • Mensajes: 535
  • Gracias recibidas 3
  • Karma: 1
El administrador ha desactivado la escritura pública.

No funciona boton enviar y he puesto "validate_submit" 5 años 6 meses antes #143417

Aaaa ok, disculpa que no había visto la página dos, entonces como puedo descubrir cual es la extensión que provoca el conflicto??. Pregunto esto ya que desabilité todos los plugins y módulos que instalé y fui probando uno por uno sin embargo el problema persistía.
Será que puedo desinstalar e instalar nuevamente breezingforms??. Aunque no sé si allí estará el problema, la cuestión es que esto ya me tiene colapsado...jejej.

Saludos.
  • Raul Venegas
  • Avatar de Raul Venegas
  • DESCONECTADO
  • Navegador Platino
  • Mensajes: 535
  • Gracias recibidas 3
  • Karma: 1
El administrador ha desactivado la escritura pública.

No funciona boton enviar y he puesto "validate_submit" 5 años 6 meses antes #143448

Hola,

Podrías probar a reinstalar el BreezingForms para verificar si así funciona. Es posible que en tu instalación esté algo mal.
  • Pablo Velasco
  • Avatar de Pablo Velasco
  • DESCONECTADO
  • Moderador
  • Mensajes: 20369
  • Gracias recibidas 2734
  • Karma: 758
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.
El administrador ha desactivado la escritura pública.

No funciona boton enviar y he puesto "validate_submit" 5 años 6 meses antes #143662

Tengo que descargar la extensión para reinstalartlo?.
Yo no lo he instalado, esta venía instalada en el pack webempresa. Estoy viendo en el JED que hay dos versiones, me sirve la versión no comercial??.

Saludos.
  • Raul Venegas
  • Avatar de Raul Venegas
  • DESCONECTADO
  • Navegador Platino
  • Mensajes: 535
  • Gracias recibidas 3
  • Karma: 1
El administrador ha desactivado la escritura pública.
  • Página:
  • 1
  • 2

Temas Relacionados

5 Respuestas emo
Categoría: BreezingForms
Tema iniciado 7 años 5 meses antes por Joxean
5164 Visitas
10 Respuestas emo
Categoría: BreezingForms
Tema iniciado 5 años 11 meses antes por SALVADOR
1435 Visitas
2 Respuestas emo
Categoría: BreezingForms
Tema iniciado 5 años 8 meses antes por Virginia Navarrete
1147 Visitas
16 Respuestas emo
Categoría: Joomla 2.5
Tema iniciado 6 años 1 mes antes por Salvador
2943 Visitas
2 Respuestas emo
Categoría: Joomla 2.5
Tema iniciado 5 años 11 meses antes por juan fran
1641 Visitas
6 Respuestas emo
Categoría: BreezingForms
Tema iniciado 7 años 7 meses antes por Aitor
6167 Visitas
1 Respuestas emo
Categoría: BreezingForms
Tema iniciado 6 años 7 meses antes por Virginia Navarrete
3895 Visitas
4 Respuestas emo
Categoría: BreezingForms
Tema iniciado 6 años 4 meses antes por MIREIA
1625 Visitas
1 Respuestas emo
Categoría: BreezingForms
Tema iniciado 4 años 1 mes antes por Juan
994 Visitas
15 Respuestas emo
Categoría: BreezingForms
Tema iniciado 6 años 6 meses antes por David
3222 Visitas

Tiempo de carga de la página: 0.551 segundos