Foro de soporte WordPress en español


Soporte WordPress en español Soporte gratuito para webs alojadas en Webempresa.com
Habilitado para todos los clientes con planes de Hosting Alto Rendimiento a partir de 3GB y planes XL.

No ofrecemos soporte a webs alojadas en servidores externos o localhost, ni soporte css o programación.

Te recomendamos que leas esta información sobre nuestro sistema de soporte en el foro, te ayudará a sacar el máximo partido de nuestro conocimiento: Cómo podemos ayudarte.


Encuentra la solución a tu problema, buscando en nuestro foro:
Bienvenido, Invitado
Nombre de Usuario: Contraseña: Recordarme
  • Página:
  • 1
  • 2

TEMA: Problemas con el sitemap

Problemas con el sitemap 2 años 9 meses antes #269358

Hola! :)

He intentado poner el sitemap en la consolar de Google pero no logro crearlo desde la web. Es curioso.

Lo he intentado desde el plugin de SEO by Yoast. También desde varios plugin que se supone que sirven para eso... vamos. Que he estado isnstalando y desinstalando 3 ó 4 plugin para ese fin pero no lo he logrado y no sé porqué.

No sé si el problema podría venir de que se trata de un multisite. De todos modos no debería porque algún plugin decía específicamente que lo soportaba. Tampoco debería dar problemas por tener un certificado SSL...

No sé si podría tener algo que ver con el archivo de robots aunque tampoco lo creo.

La verdad es que he pensado en múltiples variantes pero no se porqué me ocurre.

Tengo la última versión de WP, todos los plugin y tema actualizados.

Sé que no es algo grave pero sí que quería hacer el sitemap.

A alguien más le ha llegado a ocurrir? Incluso probé a subir un sitemap genérico a modo de prueba para ver lo que decía y entonces detectaba el que subía y me decía que ya había uno (aunque no le metí información no sea que justo en ese momento llegase un robot de Google!). y acto seguido lo borré.

Tampoco debería ser problema de la caché porque ahora mismo no está activada.

URL del sitio: Contenido oculto para usuarios invitados. Por favor, inicie su sesión para poder verlo.
  • Emilio
  • Avatar de Emilio
  • DESCONECTADO
  • Navegador Superior
  • Mensajes: 47
  • Gracias recibidas 2
  • Karma: 2
El tema ha sido cerrado.
Mejora la velocidad de tu WordPress

Problemas con el sitemap 2 años 9 meses antes #269362

Hola Emilio, Buenos Días.

Suelo utilizar el plugin ' Google XML Sitemaps '

Una vez que este instaló, solamente hay que presionar en Ajustes -> XML Sitemaps y aparece un menú llamado XML-Sitemap. Al entrar en esta opción, veras un mensaje que indica que el Sitemap todavía no existe, y pinchando en la opción remarcada se creará automáticamente.

Si quieres revisar que tu Sitemap haya sido bien agregado antes de enviarlo , puedes probar su funcionamiento ingresando enContenido oculto para usuarios invitados. Por favor, inicie su sesión para poder verlo.. Si todo está bien, te aparecerá una imagen con las diferentes páginas que componen tu sitio web.

El último paso es agregar el mapa del sitio a Google Webmasters.
En la ventana principal de la opción Sitemaps hay un botón que dice Agregar/ Probar Sitemap.

Para subir el Sitemap, click en el botón Submit Sitemap .
Con estos pasos ya tendrás tu Sitemap listo.

Te dejo información de nuestro blog donde se explican los pasos para crearlo con el plugin que te indico.
Generar sitemaps en WordPress para Google, Yahoo, Bing y otros buscadores

Un saludo
  • Pepe
  • Avatar de Pepe
  • CONECTADO
  • Administrador
  • Mensajes: 19806
  • Gracias recibidas 1588
  • Karma: 574
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.
Última Edición: 2 años 9 meses antes por Pepe.
El tema ha sido cerrado.
trasladar web gratis

Problemas con el sitemap 2 años 9 meses antes #269367

Hola Pepe!

Ese plugin es uno de los que ya había probado..

He vuelto a instalarlo y sin problemas aparentes.

Voy a ajustes y a XML Sitemaps. Una vez dentro tengo una pantalla con montón de opciones como páginas a incluir o excluir y frecuencia del cambio... prioridades... etc

AL final del todo le doy a GRABAR CAMBIOS. Me indica lo siguiente:

Configuración actualizada
Páginas guardadas

Por tanto parece que ya está. Pero voy a donde lo tiene que generar y veo que no!

Hago una búsqueda por otros directorios por si está creado pero en alguna ruta extraña desde el explorador de archivos de Cpanel. Tampoco lo encuentro. Qué fastidio!

Procedo a desinstalar un segundo el plugin de SEO (por si hay algún tipo de conflicto):

Lo hago y entro de nuevo en el Google XML sitemap. El resultado vuelve a ser el mismo.

Incluso restauro la configuración predeterminada y no ocurre nada nuevo.

Sigo como al principio! :ohmy:
  • Emilio
  • Avatar de Emilio
  • DESCONECTADO
  • Navegador Superior
  • Mensajes: 47
  • Gracias recibidas 2
  • Karma: 2
El tema ha sido cerrado.
solucionar problemas wordpress

Problemas con el sitemap 2 años 9 meses antes #269374

Hola Emilio.

Ok, deja solo instalado el plugin XML Sitemaps, si lo tienes instalado elimínalo por completo y lo vuelves a instalar.

En la configuración no toques nada déjalo todo como viene como predefinido y solo pulsa en el botón Grabar cambios

Cuando lo tengas adjunta una captura de pantalla del modulo, la opcion ' Search engines haven't been notified yet ' y lo indicas para que lo revisemos.


screenshot-joomlero-cp95.webjoomla.es-2017-01-29-13-41-59.png


Un saludo
  • Pepe
  • Avatar de Pepe
  • CONECTADO
  • Administrador
  • Mensajes: 19806
  • Gracias recibidas 1588
  • Karma: 574
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.
El tema ha sido cerrado.

Problemas con el sitemap 2 años 9 meses antes #269377

Ok.

Primero desactivé Yoast SEO.

Después instalé (desde 0) Google XML sitemap y me da lo que envió como adjunto!

Gracias!
  • Emilio
  • Avatar de Emilio
  • DESCONECTADO
  • Navegador Superior
  • Mensajes: 47
  • Gracias recibidas 2
  • Karma: 2
Última Edición: 2 años 9 meses antes por Emilio.
El tema ha sido cerrado.

Problemas con el sitemap 2 años 9 meses antes #269381

Hola Emilio.

En principio lo que muestras esta bien y el archivo lo tendrías que tener en la raiz de la instalación de esa web.

Puede ser que tengas algunos problemas con los permisos en las carpetas.
.- Realiza una revisión de tu cuenta con el Asistente Virtual Stephan desde tu área de clientes y comprueba si corrige algún problema de permisos o te indica algún error que tengamos que revisar.

Un saludo
  • Pepe
  • Avatar de Pepe
  • CONECTADO
  • Administrador
  • Mensajes: 19806
  • Gracias recibidas 1588
  • Karma: 574
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.
El tema ha sido cerrado.

¿Te ha resultado interesante esta entrada del foro?

Suscríbete para recibir consejos y trucos útiles para tu Web.

Problemas con el sitemap 2 años 9 meses antes #269384

Hola!

No se me había ocurrido ( a veces con sólo hacer eso se solucionan cosas).

No he visto nada que me pueda dar pistas desde el asistente virtual.

Sin embargo, lo que me dices cambia un poco la película, y me explico:

En su momento tuve unos archivos error_log (en 2 web) que me generaban una cantidad de información tremenda. Ninguna en este hosting pero ahí estuvieron. Estuvo generado por los upload_path incorrectos.

Podría ser que estén incorrectos también en esta web?????? Porque por ahí podríamos tener una pista!

Aunque ahora que lo miro lo primero que veo es esto:

muriasdigital.es/wp-content/uploads/2017/01/.....

Por tanto creo que no debería tener problemas por ahí no?
  • Emilio
  • Avatar de Emilio
  • DESCONECTADO
  • Navegador Superior
  • Mensajes: 47
  • Gracias recibidas 2
  • Karma: 2
Última Edición: 2 años 9 meses antes por Emilio. Razón: más información
El tema ha sido cerrado.

Problemas con el sitemap 2 años 9 meses antes #269385

Hola Emilio.

Comprueba el .htaccess de la instalación del dominio.
Revisa que tengas bien la directiva RewriteBase, tendría que ser como te indico:
# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
# END WordPress

.- Edita el archivo y comprueba este como el anterior.

Un saludo
  • Pepe
  • Avatar de Pepe
  • CONECTADO
  • Administrador
  • Mensajes: 19806
  • Gracias recibidas 1588
  • Karma: 574
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.
El tema ha sido cerrado.

Problemas con el sitemap 2 años 9 meses antes #269386

Uffff fíjate todo lo que tengo.

Lo del final es la parte que carga el SSL.

Pero en todas esas condicionales ya me pierdo!

Me sugieres cambiar toda esa parte superior directamente al que me acabas de pasar? O ves algo raro? (aparte de todo ese código)

Gracias!
Adjuntos:
  • Emilio
  • Avatar de Emilio
  • DESCONECTADO
  • Navegador Superior
  • Mensajes: 47
  • Gracias recibidas 2
  • Karma: 2
El tema ha sido cerrado.

Problemas con el sitemap 2 años 9 meses antes #269416

Hola Emilio.
Le pedido a un compañero de hosting que realizara el cambio.

¿ puedes comprobar si ahora te crea el archivo sitemap y lo pone en la raíz. ?

Deja instalado el plugin XML Sitemaps y no lo elimines, así si el resultado no fuera bueno veríamos que problema puede tener el plugin.

Un saludo
  • Pepe
  • Avatar de Pepe
  • CONECTADO
  • Administrador
  • Mensajes: 19806
  • Gracias recibidas 1588
  • Karma: 574
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.
El tema ha sido cerrado.

Problemas con el sitemap 2 años 9 meses antes #269421

Hola pepe!

Se ve que algo ha ocurrido porque no puedo acceder al panel de administración.

La web sigue funcionando (supongo que por el magic cache) pero me da un error 500

Podrías avisar para que lo revisen?

Seguro que si restablezco el htaccess se soluciona pero ya que lo están mirando..

gracias!
  • Emilio
  • Avatar de Emilio
  • DESCONECTADO
  • Navegador Superior
  • Mensajes: 47
  • Gracias recibidas 2
  • Karma: 2
El tema ha sido cerrado.

Problemas con el sitemap 2 años 9 meses antes #269422

Hola Emilo.

Ya esta, comprueba si puedes acceder.
Por favor deja el plugin XML Sitemaps activado para que revisemos lo del sitemap.

Un saludo
  • Pepe
  • Avatar de Pepe
  • CONECTADO
  • Administrador
  • Mensajes: 19806
  • Gracias recibidas 1588
  • Karma: 574
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.
El tema ha sido cerrado.

Problemas con el sitemap 2 años 9 meses antes #269424

listo!
  • Emilio
  • Avatar de Emilio
  • DESCONECTADO
  • Navegador Superior
  • Mensajes: 47
  • Gracias recibidas 2
  • Karma: 2
El tema ha sido cerrado.

Problemas con el sitemap 2 años 9 meses antes #269469

Hola

Estas usando el plugin SEO by Yoast, has revisado?
kb.yoast.com/kb/enable-xml-sitemaps-in-the-wordpress-seo-plugin/

Es decir con estos pasos deberías obtener una url de un sitemap generado, envía algunas capturas de pantalla.
La ruta apunta a un archivo .xml que no se muestra como archivo físico ya que el sitemap se crea dinámicamente.

Saludos.
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.
El tema ha sido cerrado.

Problemas con el sitemap 2 años 9 meses antes #269472

Hola John.

Efectivamente utilizaba el plugin SEA Yoast.

Sin embargo lo desactivé para que puedan ver lo que ocurre desde Google XML Sitemaps. En principio cualquiera de los dos debería crear el archivo.

Ahora lo tengo desconectado porque me pidieron dejar funcionando solamente el Google XML Sitemaps para ver lo que ocurría.

Pero te paso captura de pantalla para que veas que cuando sale el botón desde el cual al pinchar se accede al sitemap no sale ese botón sino simplemente el texto y si le pincho me sale error no sé si 503 o así. Vamos que no existe el sitemap en esa ruta.

Gracias!
30-01-201716-43-26.jpg
  • Emilio
  • Avatar de Emilio
  • DESCONECTADO
  • Navegador Superior
  • Mensajes: 47
  • Gracias recibidas 2
  • Karma: 2
El tema ha sido cerrado.

Problemas con el sitemap 2 años 9 meses antes #269490

Hola

Te sugiero agotar la posibilidades de usar el sitemap que te genera SEO Yoast, SEO Yoast no te genera un archivo, te cre la url de manera dinàmica, indícanos que url exacta te da el link de Mapa del sitio (según tu captura de pantalla)

Si tienes algún archivo sitemap.xml o similar en la raiz de tu cuenta eliminalo ya que esto podría traer conflictos con el que te genera SEO by Yoast.

Desactiva también temporalmente el otro plugin de mapa de sitio.

Saludos.
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.
El tema ha sido cerrado.

Problemas con el sitemap 2 años 9 meses antes #269493

Hola de nuevo John!

Si miro el que me había intentado preparar el plugin de Google XML sitemaps es el siguiente muriasdigital.es/sitemap.xml

Desinstalando este plugin y colocando SEO Yoast me da esta dirección:

muriasdigital.es/sitemap_index.xml

He revisado para intentar encontrar el sitemap pero no lo veo en el directorio raiz. He puesto en búsqueda tanto uno como otro archivo (por si salen en alguna ruta equivocada pero tampoco he obtenido resultados).

Edito: acabo de probar en otra web a generar desde el plugin de SEO Yoast el sitemap y me lo hizo en un segundo.

latienditafrontera.es/sitemap_index.xml
  • Emilio
  • Avatar de Emilio
  • DESCONECTADO
  • Navegador Superior
  • Mensajes: 47
  • Gracias recibidas 2
  • Karma: 2
Última Edición: 2 años 9 meses antes por Emilio. Razón: ampliar información
El tema ha sido cerrado.

Problemas con el sitemap 2 años 9 meses antes #269501

Añado una actualización:

Si en el htacess añado el siguiente código:


# WordPress SEO - XML Sitemap Rewrite Fix
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^sitemap_index.xml$ /index.php?sitemap=1 [L]
RewriteRule ^([^/]+?)-sitemap([0-9]+)?.xml$ /index.php?sitemap=$1&sitemap_n=$2 [L]
</IfModule>
# END WordPress SEO - XML Sitemap Rewrite Fix


Entonces consigo que no me genere el error 404. El problema es que preparo el sitemap y sale una página en blanco.

He probado a cargar nuevamente el anterior archivo y al recargar la página automáticamente me salió el error 404.

Por tanto creo que el error viene por ahí cerca.

He probado a regenerar los enlaces permanentes (en algunos sitios parece que sólo con hacer eso ya funcionaba) e incluso a desactivar la función en el plugin para sitemaps y luego volver a activarla y tampoco funcionó.

Sigo intentando enterarme de qué problema es realmente el que me está causando este dolor de cabeza jajaaj

ah. Se arregla parcialmente (ya que no da error 404) para el caso del plugin SEO yoast. En el caso del Google SML sitemap daba el mismo error. Obviamente habría que meter otro código para ese plugin
  • Emilio
  • Avatar de Emilio
  • DESCONECTADO
  • Navegador Superior
  • Mensajes: 47
  • Gracias recibidas 2
  • Karma: 2
El tema ha sido cerrado.

Problemas con el sitemap 2 años 9 meses antes #269503

Hola

Tal como te comenté SEO by Yoast no genera un archivo físico, esa url de sitemap se genera dinámicamente
Prueba renombrando tu .htaccess , desactiva las otras extensiones de sitempas, luego desactiva temporalmente las urls amigables de tu sitio y verifica si te funciona el link de Yoast

Prueba reinstalando el plugin de SEO by Yoast y verifica si te sucede lo mismo.

Saludos.
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.
El tema ha sido cerrado.

Problemas con el sitemap 2 años 9 meses antes #269505

Por fin!!!!!!!

Si elimino:

# BEGIN WordPress
<IfModule mod_rewrite.c>




RewriteCond %{HTTP_HOST} =lapalmae-cp28.wordpresstemporal.com
RewriteCond %{REQUEST_URI} ^/muriasdigital.es/.*$
RewriteRule . - [E=REWRITEBASE:/muriasdigital.es/]
RewriteRule ^index.php - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !(.action|.aro|.ascx|.asf|.asp|.aspx|.asx|.avi|.bat|.bmp|.ca|.cfg|.cfm|.cgi|.class|.css|.de|.divx|.dk|.dll|.doc|.docx|.ee|.el|.eot|.es|.et|.exe|.fbcindex|.gif|.gz|.gzip|.htaccess|.ico|.inc|.ini|.jpe|.jpeg|.jpg|.js|.log|.m4a|.m4v|.mdb|.mid|.midi|.mov|.mp3|.mp4|.mpe|.mpeg|.mpg|.mpp|.nl|.no|.nsf|.odb|.odc|.odf|.odg|.odp|.ods|.odt|.ogg|.pdf|.php|.phtml|.pl|.png|.pot|.pps|.ppt|.pptx|.properties|.pt-br|.qt|.ra|.ram|.rtf|.rtx|.sh|.shtml|.svg|.svgz|.swf|.tar|.tif|.tiff|.ttf|.tw|.txt|.wav|.wax|.wma|.wmv|.wmx|.wof|.wri|.wsgi|.wwwacl|.xla|.xls|.xlsx|.xlt|.xlw|.xml|.xsd|.xsl|.zip)$ [NC]
RewriteCond %{HTTP_HOST} =lapalmae-cp28.wordpresstemporal.com
RewriteCond %{REQUEST_URI} ^/muriasdigital.es/.*$
RewriteRule . /muriasdigital.es/index.php [L]


RewriteCond %{HTTP_HOST} =muriasdigital.es
RewriteCond %{REQUEST_URI} ^/.*$
RewriteRule . - [E=REWRITEBASE:/]
RewriteRule ^index.php - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !(.action|.aro|.ascx|.asf|.asp|.aspx|.asx|.avi|.bat|.bmp|.ca|.cfg|.cfm|.cgi|.class|.css|.de|.divx|.dk|.dll|.doc|.docx|.ee|.el|.eot|.es|.et|.exe|.fbcindex|.gif|.gz|.gzip|.htaccess|.ico|.inc|.ini|.jpe|.jpeg|.jpg|.js|.log|.m4a|.m4v|.mdb|.mid|.midi|.mov|.mp3|.mp4|.mpe|.mpeg|.mpg|.mpp|.nl|.no|.nsf|.odb|.odc|.odf|.odg|.odp|.ods|.odt|.ogg|.pdf|.php|.phtml|.pl|.png|.pot|.pps|.ppt|.pptx|.properties|.pt-br|.qt|.ra|.ram|.rtf|.rtx|.sh|.shtml|.svg|.svgz|.swf|.tar|.tif|.tiff|.ttf|.tw|.txt|.wav|.wax|.wma|.wmv|.wmx|.wof|.wri|.wsgi|.wwwacl|.xla|.xls|.xlsx|.xlt|.xlw|.xml|.xsd|.xsl|.zip)$ [NC]
RewriteCond %{HTTP_HOST} =muriasdigital.es
RewriteCond %{REQUEST_URI} ^/.*$
RewriteRule . /index.php [L]
</IfModule>


Y añado las líneas

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress

Entonces sí que funciona el enlace a la primera desde el plugin SEO.

Ahora voy a volver a cargar el original para ver lo que pasa:

Pues lo que pasa es que automáticamente da un error 404!

El fallo está en esa parte del código....

Y claro hay que analizar exactamente qué puede ser. Es eso!

30-01-201722-54-42.jpg
  • Emilio
  • Avatar de Emilio
  • DESCONECTADO
  • Navegador Superior
  • Mensajes: 47
  • Gracias recibidas 2
  • Karma: 2
Última Edición: 2 años 9 meses antes por Emilio. Razón: Jesús. Me quedaba por el medio la imagen de nuevo
El tema ha sido cerrado.
  • Página:
  • 1
  • 2

Temas Relacionados

9 Respuestas emo
Categoría: Plugins WordPress
Tema iniciado 10 meses 3 semanas antes por Montse
169 Visitas
1 Respuestas emo
Tema iniciado 5 años 4 meses antes por Marcos
2033 Visitas
4 Respuestas emo
Categoría: Plugins WordPress
Tema iniciado 3 años 1 semana antes por Marina
928 Visitas
3 Respuestas emo
Categoría: Plugins WordPress
Tema iniciado 1 mes 1 semana antes por Eduardo
17 Visitas
13 Respuestas emo
Categoría: Plugins WordPress
Tema iniciado 2 años 3 meses antes por RENE
1351 Visitas
10 Respuestas emo
Tema iniciado 3 meses 2 semanas antes por Asociación Enfermos Fibrosis Quística del País vasco
83 Visitas
3 Respuestas emo
Tema iniciado 5 años 4 meses antes por Luis Alberto
1938 Visitas
2 Respuestas emo
Tema iniciado 5 años 2 meses antes por Santi
1942 Visitas
1 Respuestas emo
Tema iniciado 4 años 8 meses antes por Jose Pablo
1095 Visitas
1 Respuestas emo
Tema iniciado 2 años 8 meses antes por Alexandra
460 Visitas

Moderadores: Johnny Heredia Montiel
Tiempo de carga de la página: 0.680 segundos