Foro de soporte WordPress, Joomla y PrestaShop en español


Soporte WordPress en español Soporte gratuito para webs alojadas en Webempresa.com
Habilitado para todos los clientes con planes de Hosting Alto Rendimiento a partir de 3GB y planes XL.

No ofrecemos soporte a webs alojadas en servidores externos o localhost, ni soporte css o programación.

Te recomendamos que leas esta información sobre nuestro sistema de soporte en el foro, te ayudará a sacar el máximo partido de nuestro conocimiento: Cómo podemos ayudarte.


Encuentra la solución a tu problema, buscando en nuestro foro:
Bienvenido, Invitado
Nombre de Usuario: Contraseña: Recordarme
Resolvemos dudas sobre el uso de plugins en WordPress. Soluciones para conseguir funcionalidades para tu Web. Consejos sobre instalación y configuración de Plugins. 100% en español.

TEMA: Problemas con stripe y memberpress

Problemas con stripe y memberpress 3 meses 1 semana antes #301721

Buenos días:

Aunque estoy tratando este tema también mediante los tickets, lo pongo aquí por dos razones:

1)Ver si alguien le ha pasado lo mismo y poder solucionarlo.
2)Que quede constancia por aquí de la solución y sea más fácil encontrarla en un futuro.

Antecedentes:

Estábamos en otro hosting antes, que daba muchos errores 500 y, además, tardaba 6-7 segundos en cargar la página, además de 14 segundos en registrar usuarios y procesar pagos.

El problema:

El lunes nos cambiamos a webempresa. La carga ha bajado a 2 segundos, lo que está genial, pero el registro de usuarios ha pasado a durar 60-90 segundos y el pago 7 minutos. 7 interminables minutos en los que el navegador dice: "enviando petición a invoxmedical". Si se le da al botón de enviar (por aquello de los nervios), aparece "esperando a q.stripe.com...". Pero hasta que no pasan 7 minutos o más, no redirige a la pantalla de gracias.

La cosa es que en el panel de admin puedes ver que a la transacción, registro o reembolso están hechos desde los 10 segundos más o menos, sin embargo el navegador no devuelve la página de que está todo Ok.

En stripe se observa que hay error en uno de los webhooks y no lo capta, devolviendo un: (Timed out) ERR.

No sabemos qué puede ser, pensamos que es el servidor, ya que hasta hace 5 días funcionaba en el anterior. El servicio técnico ha cambiado reglas de seguridad para habilitar unas cosas pero no ocurre nada. En todos los casos en los que hay demora, las peticiones se envían también a otros servidores (corporativo para los registros o stripe para los pagos, por ejemplo).

¿Alguna idea?

Muchas gracias.

URL del sitio: Contenido oculto para usuarios invitados. Por favor, inicie su sesión para poder verlo.
Adjuntos:
  • Juan Salvador
  • Avatar de Juan Salvador
  • DESCONECTADO
  • Navegador Iniciado
  • Mensajes: 6
  • Gracias recibidas 1
  • Karma: 0
El administrador ha desactivado la escritura pública.
Mejora la velocidad de tu WordPress

Problemas con stripe y memberpress 3 meses 1 semana antes #301738

Hola Juan.

Ok, lo que veo si analizo tu web desde el inspector del navegador los tiempos de carga mayores son del captcha y de analitycs

Desktopscreenshot18.jpg


¿ utilizas algún módulo de estadísticas para google, es decir ves las estadísticas desde el propio administrador de la web ? , Si es así prueba a desactivarlas.

las peticiones se envían también a otros servidores (corporativo para los registros
Puedes explicarnos un poco esto, ¿ os registros a parte de almacenarlos en la BD de tu instalacin se mandan a otros servidores ? ¿ Cómo recoges los datos y los mandas, módulo, manual, script, etc... )

Te agradezco tu colaboración, contar con toda la información que puedas darnos nos ayudará a darte más rápidamente una solución.

Un saludo
  • Pepe
  • Avatar de Pepe
  • CONECTADO
  • Administrador
  • Mensajes: 13167
  • Gracias recibidas 1092
  • Karma: 370
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.
El administrador ha desactivado la escritura pública.
trasladar web gratis

Problemas con stripe y memberpress 3 meses 6 días antes #301831

Buenos días:

Ayer, los técnicos me respondieron con el siguiente cambio:

"He recargado la configuración del dominio en el servidor."

Con esto, los tiempos bajaron de 7 minutos a 1 minuto y 30 segundos (en los pagos) y de 5 minutos a 2 minutos y 15 segundos (en las cancelaciones). Es una mejora considerable pero insuficiente para una web que vende un producto online.

En nuestro caso, tenemos el dominio contratado con otro proveedor, no sé hasta qué punto puede esto afectar.

No veo nada de analytics en wordpress, todo en google. Como plugins adicionales tengo: memberpress, google maps responsive, awesome support, yoast, email marketing by drip, visual composer, design themes core features (venían con el tema escogido).

Los registros se almacenan en la base de datos y se envían a nuestro servidor corporativo a través de un evento (para lo cual creamos un plugin en wordpress que coge los datos y los reenvía).

El problema de los tiempos de carga no puede estar en esta integración porque en el otro proveedor de hosting lo teníamos igual y no tardaba más de 14 segundos (aceptable para nosotros, como ya estábamos acostumbrados...). Tampoco puede estar en los plugins, ya que antes cargaba en 14 segundos teniendo los mismos.

He pedido que aumenten el memory limit del php y, una vez esté hecho, actualizaré php a versión 7. No debería influir, ya que en el otro proveedor el límite era de 256Mb y la versión php era la 5.6, como aquí... Pero bueno, si con eso se soluciona, por mí perfecto.

Si necesitas más información, dímelo.

Un saludo.
  • Juan Salvador
  • Avatar de Juan Salvador
  • DESCONECTADO
  • Navegador Iniciado
  • Mensajes: 6
  • Gracias recibidas 1
  • Karma: 0
El administrador ha desactivado la escritura pública.
solucionar problemas wordpress

Problemas con stripe y memberpress 3 meses 6 días antes #301833

Hola.

Ok Juan, entonces esperemos a ver lo que te contestan desde soporte.

El problema de los tiempos de carga no puede estar en esta integración porque en el otro proveedor de hosting lo teníamos igual y no tardaba más de 14 segundos

¿ Las dos bases estaban en el mismo hosting ? esto sí que puede repercutir en los tiempos

para lo cual creamos un plugin en wordpress que coge los datos y los reenvía
Si es con un plugin puedes probar a desactivarlo momentáneamente con eso comprobaremos si el problema viene por la comunicación entre los dos.

Un saludo
  • Pepe
  • Avatar de Pepe
  • CONECTADO
  • Administrador
  • Mensajes: 13167
  • Gracias recibidas 1092
  • Karma: 370
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.
El administrador ha desactivado la escritura pública.

Problemas con stripe y memberpress 3 meses 6 días antes #301837

Desde el soporte dicen que han aplicado nuevos cambios, y que ya teníamos 512Mb asignados de memory_limit. No ha repercutido en nada.

No, nuestro servidor corporativo siempre ha estado a parte del proveedor de hosting.

Hemos probado a desactivar el plugin y tarda lo mismo.

Desde soporte no nos han dicho que vayan a probar algo más, les he dicho que probaré el cambio a php7. Estoy haciendo un BackUp y probaré si eso mejora algo, pero vemos las perspectivas un poco negras. Si no encontramos una solución hoy, posiblemente volvamos a nuestro anterior proveedor y sus errores 500...

Edito: hemos actualizado a php 7.1 y no ha mejorado la carga. ¿alguna idea?
  • Juan Salvador
  • Avatar de Juan Salvador
  • DESCONECTADO
  • Navegador Iniciado
  • Mensajes: 6
  • Gracias recibidas 1
  • Karma: 0
Última Edición: 3 meses 6 días antes por Juan Salvador .
El administrador ha desactivado la escritura pública.

Problemas con stripe y memberpress 3 meses 6 días antes #301846

Hola Juan.

Acabo de pasar nota a un administrador de sistemas para que revise tu cuenta, están viendo con detalle lo que puede estar pasando, con lo que sea te respondo en este misma entrada o te responden desde ticket.

Tranquilo que de una manera u otra intentaremos ver de donde proviene y solventarlo.

Un saludo
  • Pepe
  • Avatar de Pepe
  • CONECTADO
  • Administrador
  • Mensajes: 13167
  • Gracias recibidas 1092
  • Karma: 370
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.
El administrador ha desactivado la escritura pública.

¿Te ha resultado interesante esta entrada del foro?

Suscríbete para recibir consejos y trucos útiles para tu Web.

WordPress    PrestaShop

Problemas con stripe y memberpress 3 meses 6 días antes #301853

Hola Juan.

Creo que te contestaron desde soporte.

Segun me comentan los accesos a stripe aparecian logueados en la URL temporal y que añadieron las Ip's de stripe en la lista blanca para que no se bloqueen.

Espero que esto lo solucione, si no es así por favor indícalo para que podamos seguir revisando.

Un Saludo
  • Pepe
  • Avatar de Pepe
  • CONECTADO
  • Administrador
  • Mensajes: 13167
  • Gracias recibidas 1092
  • Karma: 370
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.
El administrador ha desactivado la escritura pública.

Problemas con stripe y memberpress 3 meses 5 días antes #301954

Buenos días, Pepe:

¡Por fin está solucionado! Te comento, dejando constancia, de los errores:

-El último cambio realizado por los técnicos de soporte consiguieron bajar de 1 minuto y 22 segundos a 50-60 segundos la carga de las pantallas de gracias, envíos de correo, etc.

Repasando la configuración de wordpress que teníamos con arsys y, analizando una idea que nos dio Salvador Gómez de soporte, pudimos comprobar que el error se encontraba en una función php mailer que creamos. Arsys no dejaba enviar emails a través de la función de wordpress, así que tuvimos que crear una función phpmailer para enviar los correos. Esta función entraba en conflicto (por lo que sea) con los parámetros de vuestros servidores. Comentamos la función de php mailer y... ¡et voilà!, funcionó. Ahora usamos la función de wordpress y los correos se envían correctamente. El tiempo de ejecución es de 12 segundos, que es lo que tarda stripe y el banco en procesar las órdenes.

Solo nos queda agradecerles las horas dedicadas a nuestro problema (consiguieron reducir, mediante los cambios, la carga de 7 minutos a 1 minuto) y la ayuda prestada.

Dejo constancia del problema por si alguna vez pasase algo parecido.

P.D: ya se puede cerrar el tema.

Un saludo.
  • Juan Salvador
  • Avatar de Juan Salvador
  • DESCONECTADO
  • Navegador Iniciado
  • Mensajes: 6
  • Gracias recibidas 1
  • Karma: 0
El administrador ha desactivado la escritura pública.

Problemas con stripe y memberpress 3 meses 4 días antes #301975

Hola Juan Salvador, buenos días


¡Perfecto! Nos alegra enormemente que finalmente se haya solucionado tu problema y se haya reducido tanto el tiempo de carga.

Gracias por compartir la solución ya que puede ser útil para otros usuarios.


¿Nos dejas tu testimonio? :)

Nos sería de mucha utilidad que nos dejases tu testimonio, solicitamos testimonios para colocar en nuestra página y ayudar a otros posibles clientes a decidirse por nuestros servicios:

Puedes crear el testimonio aquí: www.webempresa.com/testimonios.html?view=form&layout=edit

Si nos quieres enviar tu experiencia con nuestro servicio, la publicaremos en nuestra página con un link hacia tu Web.

Si ya lo solicitamos anteriormente y nos lo facilitaste, puedes dejar otro testimonio si tienes otra página alojada con nosotros y deseas añadir un link para mejorar el posicionamiento.

Nuestro dominio webempresa.com tiene una autoridad alta, así que el link siempre te ayudará en el posicionamiento en buscadores de tu Web.

Gracias por publicar tu testimonio y por tus palabras de agradecimiento :)
  • Adrián
  • Avatar de Adrián
  • DESCONECTADO
  • Administrador
  • Mensajes: 82
  • Gracias recibidas 6
  • Karma: 3
El administrador ha desactivado la escritura pública.

Temas Relacionados

5 Respuestas emo
Categoría: Plugins WordPress
Tema iniciado 2 años 3 meses antes por Jose Ramon
633 Visitas
3 Respuestas emo
Tema iniciado 1 mes 1 semana antes por Alex
30 Visitas
7 Respuestas emo
Categoría: Pack Tienda WordPress
Tema iniciado 1 año 6 meses antes por CARLOS ALBERTO
661 Visitas
1 Respuestas emo
Categoría: Pack Tienda WordPress
Tema iniciado 11 meses 1 semana antes por CARLOS ALBERTO
544 Visitas
6 Respuestas emo
Categoría: Plugins WordPress
Tema iniciado 1 año 3 meses antes por Alexandro
491 Visitas
3 Respuestas emo
Categoría: Pack Tienda WordPress
Tema iniciado 1 año 7 meses antes por CARLOS ALBERTO
417 Visitas
8 Respuestas emo
Categoría: Pack Tienda WordPress
Tema iniciado 1 año 2 meses antes por Guillermo
408 Visitas
15 Respuestas emo
Categoría: Pack Tienda WordPress
Tema iniciado 1 año 2 meses antes por Guillermo
582 Visitas
1 Respuestas emo
Tema iniciado 3 años 10 meses antes por paula
619 Visitas
8 Respuestas emo
Tema iniciado 3 años 9 meses antes por Carles
677 Visitas

Moderadores: Johnny Heredia Montiel
Tiempo de carga de la página: 0.454 segundos