Foro de soporte WordPress en español


Soporte WordPress en español Soporte gratuito para webs alojadas en Webempresa.com
Habilitado para todos los clientes con planes de Hosting Alto Rendimiento a partir de 3GB y planes XL.

No ofrecemos soporte a webs alojadas en servidores externos o localhost, ni soporte css o programación.

Te recomendamos que leas esta información sobre nuestro sistema de soporte en el foro, te ayudará a sacar el máximo partido de nuestro conocimiento: Cómo podemos ayudarte.


Encuentra la solución a tu problema, buscando en nuestro foro:
Bienvenido, Invitado
Nombre de Usuario: Contraseña: Recordarme

TEMA: Nuevos productos incrementan el gasto de envío

Nuevos productos incrementan el gasto de envío 3 años 10 meses antes #232140

Esta mañana he desinstalado desde cpanel 2 prestashop que instalé para probar, desde que he hecho eso (no se si tiene relación) los nuevos productos que meto en la pagina incrementan el gasto de envío, es decir, si ya había un producto en el carro, no mantienen el gasto de envio que ya había si no que suma otro gasto de envío más.

Productos con los que pasa:
www.rbdenda.com/cremas-de-manos/37-crema-de-manos-yogur-y-maracuya.html
www.rbdenda.com/mantequillas-cremas-corporales/38-mantequilla-corporal-oliva-y-yogur-200ml.html

Curiosamente si meto en el carro solo esos 2 el gasto de envio sale bien. Los productos se han creado como siempre y no he tocado nada en transportistas.



URL del sitio: Contenido oculto para usuarios invitados. Por favor, inicie su sesión para poder verlo.
  • Miguel Angel
  • Avatar de Miguel Angel
  • DESCONECTADO
  • Navegador Superior
  • Mensajes: 62
  • Karma: 1
El administrador ha desactivado la escritura pública.
Mejora la velocidad de tu WordPress

Nuevos productos incrementan el gasto de envío 3 años 10 meses antes #232142

Hola,

A priori, el hecho de que desinstales otros PrestaShop no tendría que influir en la web actual, siempre que estos se encontraran en directorios diferentes.

Sobre el tema de los portes, tendrías que indicarnos los transportistas que tienes configurados en tu PrestaShop y enviarnos capturas de pantalla de la configuración de los mismos, en especial lo que se configura en el paso 2 de la configuración del transportista.

Por otro lado, podría estar ocurriendo que si tienes más de un transportista y estás asignando diferentes transportistas a los productos el importe de los portes de envío sea la suma de los portes de envío de los transportistas.

Te pongo un ejemplo: supongamos que tienes un "Producto 1" que tiene asociado el "Transportista 1" y un "Producto 2" que tiene asociado el "Transportista 2". Si se añaden ambos productos al carro los portes de envío serán la suma de los portes de ambos transportistas, ya que son independientes.
  • Pablo Velasco
  • Avatar de Pablo Velasco
  • DESCONECTADO
  • Moderador
  • Mensajes: 20369
  • Gracias recibidas 2735
  • Karma: 758
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.
El administrador ha desactivado la escritura pública.
trasladar web gratis

Nuevos productos incrementan el gasto de envío 3 años 10 meses antes #232166

Tienes razón en que la desinstalación aparentemente no tiene nada que ver ya que me he dado cuenta de que pasa con otro producto que creé ayer por la noche

No es el caso ya que solo tengo 2 transportistas definidos y todos los productos funcionan con esos 2, uno es envío gratuito y el otro un mensajero que aun no tiene nombre, al principio me pasaba esto pq el transportista mensajero tenia una cantidad metida en "gastos de envio adicionales", cuando definia los productos, pero de eso hace 10 días que lo corregí. Estos nuevos productos no tienen nada ahí y suman.....
adjunto 2 pantallazos de lo que creo que me pides, la parte de arriba de la pantalla y la de abajo, no se como meter todo en una.

transp1.png



transp2.png


No he tocado nada de los transportistas, ni siquiera he tocado el fichero de la plantilla de estimación de gasto, no se que pasa, ayer al mediodía se me bloqueo mi ip al acceder a las webs y estuve un buen rato sin acceder, antes he entrado desde el móvil y antes de entrar en la página me ha puesto un mensaje de error diciendo que había demasiadas redirecciones o algo así.
  • Miguel Angel
  • Avatar de Miguel Angel
  • DESCONECTADO
  • Navegador Superior
  • Mensajes: 62
  • Karma: 1
El administrador ha desactivado la escritura pública.

Nuevos productos incrementan el gasto de envío 3 años 10 meses antes #232206

HOla

Prueba eliminando tu transportista, el de mensajería y crealo nuevamente
Lo de las redirecciones es un problema a nivel de cuenta y no creo que tenga q ver con la configuración de transportista, si sigues con problemas de redirección mejor consultarlo por tickets si te vuelve a suceder.

Saludos
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.
El administrador ha desactivado la escritura pública.

Nuevos productos incrementan el gasto de envío 3 años 10 meses antes #232267

Aún no lo he eliminado, pero cual es el sentido de eliminarlo? por que? no está en la base de datos? si suma es que para esos 3 nuevos productos ese transportista es distinto al que había antes, o en la configuración del producto se guarda en base de datos que si suma a los gastos de envío, ¿pero por que?

¿Aquí me voy a pasar toda la vida vaciando caches y borrando cosas pq dejan de funcionar de la noche a la mañana?
  • Miguel Angel
  • Avatar de Miguel Angel
  • DESCONECTADO
  • Navegador Superior
  • Mensajes: 62
  • Karma: 1
El administrador ha desactivado la escritura pública.

Nuevos productos incrementan el gasto de envío 3 años 10 meses antes #232303

Hola,

He realizado algunas pruebas de añadir productos al carro de compra. Edita los productos con los que tienes problemas en los portes y verifica que en la pestaña Transportista tienes todos los valores a 0, y que en la caja Transportistas seleccionados no tienes añadido ningún transportista. De esta forma al producto se le añaden todos los transportistas creados.
  • Pablo Velasco
  • Avatar de Pablo Velasco
  • DESCONECTADO
  • Moderador
  • Mensajes: 20369
  • Gracias recibidas 2735
  • Karma: 758
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.
El administrador ha desactivado la escritura pública.

¿Te ha resultado interesante esta entrada del foro?

Suscríbete para recibir consejos y trucos útiles para tu Web.

Nuevos productos incrementan el gasto de envío 3 años 10 meses antes #232322

A los 2 productos que puse en el 1er post habría que añadir
www.rbdenda.com/perfumes/36-perfume-hombre-100ml.html

Lo primero que miré es que en la parte del transporte de cada producto todo estuviese a 0 y como ya comenté estos últimos productos los hice como todos los anteriores, cogí por costumbre seleccionar los 2 transportistas para todos los productos, ya me dí cuenta de que seleccionar todos es lo mismo que no seleccionar ninguno.

Necesito una solución rápida, borro y vuelvo a crear a ver que pasa? o esto se arregla de otra forma, pero tengo la pag. parada ya un día y tengo muchos productos que meter.
  • Miguel Angel
  • Avatar de Miguel Angel
  • DESCONECTADO
  • Navegador Superior
  • Mensajes: 62
  • Karma: 1
El administrador ha desactivado la escritura pública.

Nuevos productos incrementan el gasto de envío 3 años 10 meses antes #232357

Hola

He realizado una prueba pero veo que permanece el gasto de envío

Tal vez te sucede con un usuario conectado, envia las credenciales de algún usuario para el front-end de tu sitio para verificar

Saludos.
Adjuntos:
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.
El administrador ha desactivado la escritura pública.

Nuevos productos incrementan el gasto de envío 3 años 10 meses antes #232381

Jhon Marreros Guzman escribió:
Hola

He realizado una prueba pero veo que permanece el gasto de envío
.
Como ya dije antes si los combinas entre ellos sale bien. Da igual logarse o no para ver el error
he borrado el transportista mensajero que había y he creado el definitivo.
Tengo 2 transportistas
1-recogida en tienda
2- (el creado nuevo) redyser

Ahora el comportamiento es el siguiente:
Los primeros 21 productos que creé no reconocen ese transportista pese a no tener ninguno seleccionado en su configuración

primeros21productos.png


Los últimos 3 productos, los que daban problemas, si reconocen ese transportista y el de recogida gratuita funcionando bien (como antes) si solo metes en el carro esos productos

ultimos3productos.png


Aunque a esos 21 productos les asigne los 2 transportistas en su configuración siguen ignorando el nuevo, veo que cuando hago esto se guarda el valor en la base de datos, pero algo hay que cuando se monta la pagina el código hace caso omiso a esa tabla, no sirve de nada.

He incluido un nuevo producto y coge los 2 transportistas

¿Qué debo hacer ahora para que los primeros 21 productos que tengo y que no pienso borrar vean Redyser?
  • Miguel Angel
  • Avatar de Miguel Angel
  • DESCONECTADO
  • Navegador Superior
  • Mensajes: 62
  • Karma: 1
Última Edición: 3 años 10 meses antes por Miguel Angel. Razón: mas pruebas
El administrador ha desactivado la escritura pública.

Nuevos productos incrementan el gasto de envío 3 años 10 meses antes #232436

Hola,

Ignoro el número de productos que tienes. La mejor opción sería editar todos los productos y no dejar ningún transportista seleccionado en el campo Transportistas seleccionados. De esta forma te asegurarías que todos los productos tienen todos los transportistas asignados y que, además, usan transportistas comunes.

Además, si eliminas un transportista y creas uno nuevo no será necesario realizar la asignación del nuevo transportista a todos los productos. De hecho, esta es la razón por la que ahora no te sale en nuevo transportista en los productos: aunque lo llames igual, se utiliza el id del transportista para hacer la asociación, y ese sí cambia.
  • Pablo Velasco
  • Avatar de Pablo Velasco
  • DESCONECTADO
  • Moderador
  • Mensajes: 20369
  • Gracias recibidas 2735
  • Karma: 758
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.
El administrador ha desactivado la escritura pública.

Nuevos productos incrementan el gasto de envío 3 años 10 meses antes #232485

Pablo Velasco escribió:
Hola,

Ignoro el número de productos que tienes. La mejor opción sería editar todos los productos y no dejar ningún transportista seleccionado en el campo Transportistas seleccionados. De esta forma te asegurarías que todos los productos tienen todos los transportistas asignados y que, además, usan transportistas comunes.
.

eso lo hice ayer por la mañana, y no va.

Tengo 25 productos, los 4 últimos ahora funcionan bien, los primeros 21 no, aunque a uno de los 21 primeros le asigne el nuevo transportista lo sigue sin coger. Todos los productos están sin transportista asignado

Ya veo que nadie puede ayudarme, ni nadie sabe como funcionan las tablas, ni la programación.... te recuerdo que todo empezó con la desaparición de los iconos debido a no se que historias de la caché, o sea, fallos que no están en mi mano solucionar.

Por si a alguien aun le interesa esto.....
Borré los 2 transportistas y los creé con nombres distintos, los productos no los cojen

He instalado otro Amaltea, he creado 2 transportistas, he creado un producto y ese producto solo coge uno de ellos.
  • Miguel Angel
  • Avatar de Miguel Angel
  • DESCONECTADO
  • Navegador Superior
  • Mensajes: 62
  • Karma: 1
Última Edición: 3 años 10 meses antes por Miguel Angel.
El administrador ha desactivado la escritura pública.

Nuevos productos incrementan el gasto de envío 3 años 10 meses antes #232499

Hola

Los productos anteriores que no te funcionan, tienen algo de diferente, alguna categoría asignado o algo diferente como importarlos desde un archivo?

En este punto según entendemos los nuevos productos que creas si que tienen un comportamiento correcto, no asi los anteriores, podrías probar eliminarlos y crear nuevamente los productos

Saludos.
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.
El administrador ha desactivado la escritura pública.

Nuevos productos incrementan el gasto de envío 3 años 10 meses antes #232522

Jhon Marreros Guzman escribió:
Hola

En este punto según entendemos los nuevos productos que creas si que tienen un comportamiento correcto, no asi los anteriores, podrías probar eliminarlos y crear nuevamente los productos

Saludos.

esta visto q no hay más remedio....
  • Miguel Angel
  • Avatar de Miguel Angel
  • DESCONECTADO
  • Navegador Superior
  • Mensajes: 62
  • Karma: 1
Última Edición: 3 años 10 meses antes por Miguel Angel.
El administrador ha desactivado la escritura pública.

Nuevos productos incrementan el gasto de envío 3 años 10 meses antes #232570

Hola,

Necesariamente tiene que haber diferencias en la configuración de los transportistas entre los productos donde te función la selección de transportista y los que no. Si en la pestaña Transportista ves lo mismo en los productos que funcionan y los que no el problema puede venir provocado por algunos datos erróneos que estén almacenados en la base de datos de forma que, aunque no se muestran en la administración, sí que afectan a la selección del transportista.

Péganos un enlace de un producto donde funcionen bien los transportistas y otro que no para ver si notamos alguna diferencia y podamos hacer pruebas.
  • Pablo Velasco
  • Avatar de Pablo Velasco
  • DESCONECTADO
  • Moderador
  • Mensajes: 20369
  • Gracias recibidas 2735
  • Karma: 758
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.
El administrador ha desactivado la escritura pública.

Temas Relacionados

2 Respuestas emo
Tema iniciado 5 años 9 meses antes por Alberto
3720 Visitas
27 Respuestas emo
Categoría: Módulos PrestaShop
Tema iniciado 3 años 3 meses antes por Carlos Alberto
  • Página:
  • 1
  • 2
1300 Visitas
2 Respuestas emo
Tema iniciado 5 años 10 meses antes por Alberto
3270 Visitas
9 Respuestas emo
Tema iniciado 2 años 9 meses antes por Costica
527 Visitas
4 Respuestas emo
Tema iniciado 4 años 3 meses antes por FRANCISCO
3113 Visitas
1 Respuestas emo
Tema iniciado 1 año 3 meses antes por ROLANDO
207 Visitas
4 Respuestas emo
Tema iniciado 3 años 4 meses antes por Sandra
1159 Visitas
16 Respuestas emo
Categoría: Módulos PrestaShop
Tema iniciado 4 años 8 meses antes por Alejandro
3665 Visitas
3 Respuestas emo
Categoría: Módulos PrestaShop
Tema iniciado 1 año 9 meses antes por Daniel
355 Visitas
13 Respuestas emo
Categoría: Módulos PrestaShop
Tema iniciado 1 año 1 mes antes por Carlos
188 Visitas

Moderadores: Pablo Velasco
Tiempo de carga de la página: 0.997 segundos