Foro de soporte WordPress en español


Soporte WordPress en español Soporte gratuito para webs alojadas en Webempresa.com
Habilitado para todos los clientes con planes de Hosting Alto Rendimiento a partir de 3GB y planes XL.

No ofrecemos soporte a webs alojadas en servidores externos o localhost, ni soporte css o programación.

Te recomendamos que leas esta información sobre nuestro sistema de soporte en el foro, te ayudará a sacar el máximo partido de nuestro conocimiento: Cómo podemos ayudarte.


Encuentra la solución a tu problema, buscando en nuestro foro:
Bienvenido, Invitado
Nombre de Usuario: Contraseña: Recordarme

TEMA: no cambia los símbolos especiales en la traducción

no cambia los símbolos especiales en la traducción 3 meses 1 semana antes #332288

Hola chicos, revisando varias cosas en la web me he dado cuenta que cuando tiene que mostrar varios articulos que estan repartidos por varias páginas, no realiza la traducción del mensaje " mostrando 1 de 3 elementos" y a parece "mostrando %1$d - %2$d de%3$d elementos".
Como puedo solucionar esto, porque ya lo he modificado varias veces poniéndolo directamente, copiando y traduciendo manualmente o simplemente dejándolo como está sin traducir en Localización-traducciones-frontoffice-mi tema-paginación, y sigue sin mostrarlo correctamente.
gracias por vuestra ayuda os adjunto imágenes del front office y del backoffice por si estas os ayudan

URL del sitio: Contenido oculto para usuarios invitados. Por favor, inicie su sesión para poder verlo.
Adjuntos:
  • JAVIER
  • Avatar de JAVIER
  • DESCONECTADO
  • Navegador Dorado
  • Mensajes: 182
  • Karma: 0
El tema ha sido cerrado.
Mejora la velocidad de tu WordPress

no cambia los símbolos especiales en la traducción 3 meses 1 semana antes #332297

Hola javier.

Si no recuerdo mal habia un bug en las versiones de prestashop 1.6 que no dejaba modificar las traducciones que tenían caracteres especiales.

Previa copia de seguridad actualiza a la última versión que es la 1.6.1.24 y comprueba si puedes modicar los textos.

Un saludo
  • Pepe
  • Avatar de Pepe
  • CONECTADO
  • Administrador
  • Mensajes: 18842
  • Gracias recibidas 1521
  • Karma: 539
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.
El tema ha sido cerrado.
trasladar web gratis

no cambia los símbolos especiales en la traducción 3 meses 1 semana antes #332299

Hola Pepe, como puedo hacer esa copia de seguridad antes de actualizar a la versión estable que me recomiendas, gracias
  • JAVIER
  • Avatar de JAVIER
  • DESCONECTADO
  • Navegador Dorado
  • Mensajes: 182
  • Karma: 0
El tema ha sido cerrado.
solucionar problemas wordpress

no cambia los símbolos especiales en la traducción 3 meses 1 semana antes #332303

Hola Javier,

Dispones de copias de seguridad de los últimos 30 días que puedes restaurar fácilmente desde tu cuenta de cPanel, con la herramienta Super Backup.

En la guía del siguiente enlace tienes documentación
-> guias.webempresa.com/preguntas-frecuentes/gestionar-copias-de-seguridad-con-superbackup-en-cpanel/

Cualquier duda que tengas al respecto puedes comunicarlo.

Un saludo.
  • Pepe
  • Avatar de Pepe
  • CONECTADO
  • Administrador
  • Mensajes: 18842
  • Gracias recibidas 1521
  • Karma: 539
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.
El tema ha sido cerrado.

no cambia los símbolos especiales en la traducción 3 meses 1 semana antes #332375

Hola Pepe, después de actualizar la versión, he vuelto a intentar cambiar lo de la traduccion en la paginacion pero sigue sin dejarme, de hecho ponga lo que ponga no aparece modificado en el fron office de la tienda, he probado dejandolo en ingles, cambiando solo las palabras sin tocar los simbolos e incluso dejandolo vacio o poniendo cualquier cosa para probar , pero sigue igual a las imagenes que te envie,
Algún consejo de que más puedo modificar, gracias quedo a la espera
un saludo
  • JAVIER
  • Avatar de JAVIER
  • DESCONECTADO
  • Navegador Dorado
  • Mensajes: 182
  • Karma: 0
El tema ha sido cerrado.

no cambia los símbolos especiales en la traducción 3 meses 1 semana antes #332382

Hola Javier.

El código que tienes añadido en pagnacion no esta bien:
En la traducción tienes añadido el siguiente código:
Mostrando% 1 $ d -% 2 $ d de% 3 $ d elementos

Tiene que tener esta estructura:
Mostrando %1$d - %2$d de %3$d items

Si te das cuenta tienes separaciones que no se respetan.
Utiliza la estructura que te indique y revisa si se muestra bien.

Un saludo
  • Pepe
  • Avatar de Pepe
  • CONECTADO
  • Administrador
  • Mensajes: 18842
  • Gracias recibidas 1521
  • Karma: 539
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.
El tema ha sido cerrado.

¿Te ha resultado interesante esta entrada del foro?

Suscríbete para recibir consejos y trucos útiles para tu Web.

no cambia los símbolos especiales en la traducción 3 meses 1 semana antes #332383

hola pepe, he copiado la estructura tal y como la pones y la he pegado en su sitio, pero sigue sin cambiar nada
  • JAVIER
  • Avatar de JAVIER
  • DESCONECTADO
  • Navegador Dorado
  • Mensajes: 182
  • Karma: 0
El tema ha sido cerrado.

no cambia los símbolos especiales en la traducción 3 meses 1 semana antes #332388

Hola Javier,

Por favor, ¿Puedes enviar una captura de pantalla de la página donde haz realizado las modificaciones?

Saludos.
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.
El tema ha sido cerrado.

no cambia los símbolos especiales en la traducción 3 meses 1 semana antes #332390

Hola John, te las adjunto en el archivo del principio de la conversación, pero te las reenvio nuevamente
Adjuntos:
  • JAVIER
  • Avatar de JAVIER
  • DESCONECTADO
  • Navegador Dorado
  • Mensajes: 182
  • Karma: 0
El tema ha sido cerrado.

no cambia los símbolos especiales en la traducción 3 meses 1 semana antes #332391

Hola Javier,

¿Puedes reemplazar el texto que has modificado por el original, el cual se encuentra a la izquierda y en inglés? Solo para probar.

Saludos.
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.
El tema ha sido cerrado.

no cambia los símbolos especiales en la traducción 3 meses 1 semana antes #332397

hola John, lo he modificado tal cual dices e incluso para asegurarme de que se ejecutaba borre la cache del navegador y del sitio web, pero sin éxito, sigue igual
  • JAVIER
  • Avatar de JAVIER
  • DESCONECTADO
  • Navegador Dorado
  • Mensajes: 182
  • Karma: 0
El tema ha sido cerrado.

no cambia los símbolos especiales en la traducción 3 meses 1 semana antes #332402

Hola Javier,

En tu sitio web veo que no se han realizado los cambios que te sugerí, por favor intenta desactivando la caché de Prestashop (también cache smarty) temporalmente y tambien los parámetros de compresión.

Contenido oculto para usuarios invitados. Por favor, inicie su sesión para poder verlo.

Si tienes dudas envíanos una captura de pantalla de los parámetros de optimización que tienes.

Saludos.
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.
El tema ha sido cerrado.

no cambia los símbolos especiales en la traducción 3 meses 1 semana antes #332417

Hola John, te adjunto los archivos con las imágenes de los parámetros de optimización que tengo puestos.
Cuando dices "a los cambios que te sugerí" a que te refieres?, porque si son los de la traducción te adjunto también imagen para que puedas ver qué está hecho tal cual me dijiste.
quedo pendiente de tu respuesta , gracias por tu ayuda
Adjuntos:
  • JAVIER
  • Avatar de JAVIER
  • DESCONECTADO
  • Navegador Dorado
  • Mensajes: 182
  • Karma: 0
El tema ha sido cerrado.

no cambia los símbolos especiales en la traducción 3 meses 1 semana antes #332421

Hola Javier.

Modifica el texto directamente en el archivo.

.- Accede a themes -> themes -> leo_shopping -> modules -> leoproductsearch -> translations y edita el archivo es.php

.- Busca la cadena de texto y lo modificas directamente en el archivo

Un saludo
  • Pepe
  • Avatar de Pepe
  • CONECTADO
  • Administrador
  • Mensajes: 18842
  • Gracias recibidas 1521
  • Karma: 539
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.
El tema ha sido cerrado.

no cambia los símbolos especiales en la traducción 3 meses 1 semana antes #332430

hola Pepe, lo que veo en la traducción en el archivo que me indicas,(adjunto imagen) es que ya esta traducido, lo único fuera de lo normal que veo, son los caracteres especiales que están con espacio entre ellos, no se si eso es lo que le afecta?, he dejado marcada con una flecha roja las líneas para que se vean bien, ya me dices, gracias
Adjuntos:
  • JAVIER
  • Avatar de JAVIER
  • DESCONECTADO
  • Navegador Dorado
  • Mensajes: 182
  • Karma: 0
El tema ha sido cerrado.

no cambia los símbolos especiales en la traducción 3 meses 1 semana antes #332434

Hola Javier.

son los caracteres especiales que están con espacio entre ellos, no se si eso es lo que le afecta?

Si, es eso y los caracteres especiales tienen que estar como te indique en las anteriores respuestas, si accedes a traducciones en la parte izquierda veras como se construye.

screenshot-www.webempresa.com-2019.05.07-13-55-59.jpg


Los símbolos son los que determinan el total de páginas que hay para esa búsqueda y tiene qu etener el formato adecuado, si no tienen el formato adecuado los muestra como texto.

Un saludo
  • Pepe
  • Avatar de Pepe
  • CONECTADO
  • Administrador
  • Mensajes: 18842
  • Gracias recibidas 1521
  • Karma: 539
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.
El tema ha sido cerrado.

no cambia los símbolos especiales en la traducción 3 meses 1 semana antes #332437

hola pepe, he probado aquí en el archivo a juntar los caracteres y dejar sin espacios los mismos o a copiarlos directamente desde las traducciones pero sigue apareciendo mal en el front office,
que estoy haciendo mal ?
  • JAVIER
  • Avatar de JAVIER
  • DESCONECTADO
  • Navegador Dorado
  • Mensajes: 182
  • Karma: 0
El tema ha sido cerrado.

no cambia los símbolos especiales en la traducción 3 meses 1 semana antes #332443

Hola Javier.

No veo que tengas modificado el archivo que te indique.

screenshot-www.recambioshosteleria.es-2019.05.07-16-35-36.jpg


Accede al archivo y modifica lo siguiente:
$_MODULE['<{leoproductsearch}leo_shopping>pagination_08d8f2394d17064e1c505e3d6ef7ef12'] = 'Mostrando% 1 $ d -% 2 $ d de% 3 $ d elementos';

Por esto:
$_MODULE['<{leoproductsearch}leo_shopping>pagination_08d8f2394d17064e1c505e3d6ef7ef12'] = 'Mostrando %1$d-%2$d de %3$d elementos';

La cadena que tienes que utilizar es la siguiente:
Mostrando %1$d-%2$d de %3$d elementos

Un saludo
  • Pepe
  • Avatar de Pepe
  • CONECTADO
  • Administrador
  • Mensajes: 18842
  • Gracias recibidas 1521
  • Karma: 539
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.
Última Edición: 3 meses 1 semana antes por Pepe.
El tema ha sido cerrado.

no cambia los símbolos especiales en la traducción 3 meses 1 semana antes #332446

ahora si que si, muchas gracias Pepe, como te digo siempre eres el mejor
un saludo
  • JAVIER
  • Avatar de JAVIER
  • DESCONECTADO
  • Navegador Dorado
  • Mensajes: 182
  • Karma: 0
El tema ha sido cerrado.

Temas Relacionados

13 Respuestas emo
Tema iniciado 5 años 4 meses antes por Vidal
3332 Visitas
7 Respuestas emo
Tema iniciado 2 años 11 meses antes por Mª ISABEL
454 Visitas
4 Respuestas emo
Tema iniciado 5 años 1 mes antes por Claudio
2852 Visitas
3 Respuestas emo
Tema iniciado 8 meses 2 semanas antes por Joaquin
153 Visitas
7 Respuestas emo
Categoría: Módulos PrestaShop
Tema iniciado 3 años 11 meses antes por Juana
1745 Visitas
2 Respuestas emo
Tema iniciado 5 años 6 meses antes por Alberto
884 Visitas
7 Respuestas emo
Tema iniciado 2 años 9 meses antes por Susana
1091 Visitas
1 Respuestas emo
Tema iniciado 1 año 2 meses antes por Teresa
298 Visitas
7 Respuestas emo
Tema iniciado 5 años 4 meses antes por Paqui
3135 Visitas
3 Respuestas emo
Tema iniciado 5 años 4 meses antes por Paqui
4641 Visitas

Moderadores: Pablo Velasco
Tiempo de carga de la página: 0.537 segundos