Foro de soporte WordPress en español


Soporte WordPress en español Soporte gratuito para webs alojadas en Webempresa.com
Habilitado para todos los clientes con planes de Hosting Alto Rendimiento a partir de 3GB y planes XL.

No ofrecemos soporte a webs alojadas en servidores externos o localhost, ni soporte css o programación.

Te recomendamos que leas esta información sobre nuestro sistema de soporte en el foro, te ayudará a sacar el máximo partido de nuestro conocimiento: Cómo podemos ayudarte.


Encuentra la solución a tu problema, buscando en nuestro foro:
Bienvenido, Invitado
Nombre de Usuario: Contraseña: Recordarme
Resuelve tus problemas y dudas con la instalación y actualización de PrestaShop.
Especialistas PrestaShop en español

TEMA: Al actualizar a 1.7.6 se me han perdido todos los enlaces de los e-mails

Al actualizar a 1.7.6 se me han perdido todos los enlaces de los e-mails 4 semanas 12 horas antes #336174

Hola
Al actualizar a 1.7.6 se me han perdido todos los enlaces de los e-mails os adjunto panallazos para que veais lo que pasa, todo funcionaba bien pero no se si fué al actualizar o al crear los servidores de medios para la cache, son las dos cosas que he hecho ultimamente
Gracias

URL del sitio: Contenido oculto para usuarios invitados. Por favor, inicie su sesión para poder verlo.
Adjuntos:
  • Josep
  • Avatar de Josep
  • DESCONECTADO
  • Navegador Superior
  • Mensajes: 49
  • Karma: 0
Última Edición: 4 semanas 12 horas antes por Josep.
El administrador ha desactivado la escritura pública.
Mejora la velocidad de tu WordPress

Al actualizar a 1.7.6 se me han perdido todos los enlaces de los e-mails 4 semanas 12 horas antes #336176

Hola

Es posible que sea algún problema con la cache, desde Parámetros Avanzados > Rendimiento, en la sección smarty selecciona: Forzar la recompilación de cache.

Si sigues con problemas prueba desactivar igualmente la cache general y los otros parámetros de optimización que hayas configurado.

Saludos.
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.
El administrador ha desactivado la escritura pública.
trasladar web gratis

Al actualizar a 1.7.6 se me han perdido todos los enlaces de los e-mails 3 semanas 6 días antes #336189

Hola,
he forzado la recopilación y sigue pasandome lo de los mails he puesto el prestashop en modo depuración y me sale (Adjunto imagen)
Que puedo hacer
Gracias
manel
Adjuntos:
  • Josep
  • Avatar de Josep
  • DESCONECTADO
  • Navegador Superior
  • Mensajes: 49
  • Karma: 0
Última Edición: 3 semanas 6 días antes por Josep.
El administrador ha desactivado la escritura pública.
solucionar problemas wordpress

Al actualizar a 1.7.6 se me han perdido todos los enlaces de los e-mails 3 semanas 6 días antes #336206

Hola Josep.

Revisa esta entrada del blog de prestashop donde tratan el tema:
-> www.prestashop.com/forums/topic/507460-solucionado-error-7bhistory_url7d-en-los-emnsajes-no-funcionan-los-links/

Un saludo
  • Pepe
  • Avatar de Pepe
  • DESCONECTADO
  • Administrador
  • Mensajes: 18838
  • Gracias recibidas 1521
  • Karma: 539
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.
El administrador ha desactivado la escritura pública.

Al actualizar a 1.7.6 se me han perdido todos los enlaces de los e-mails 3 semanas 6 días antes #336226

Hola estoy haciendo todo lo que dice el post y los e-mails siguen saliendo mal, el enlace "shop_name" me lo sustituye siempre por: "Prestashop" en lugar de "Audenis" que es el nombre de la empresa y el que ha estado saliendo los ultimos 4 años...
No se que mas hacer
  • Josep
  • Avatar de Josep
  • DESCONECTADO
  • Navegador Superior
  • Mensajes: 49
  • Karma: 0
Última Edición: 3 semanas 6 días antes por Josep.
El administrador ha desactivado la escritura pública.

Al actualizar a 1.7.6 se me han perdido todos los enlaces de los e-mails 3 semanas 6 días antes #336230

Hola

Las capturas de pantalla que enviaste reportarn problemas con un ORM tienes algún módulo externo relacionado con esto?

Las plantillas de correos pueden ser sobreescritas por el tema que usas, podrías probar cambiar temporalmente de tema usa el tema Classic que viene por defecto con PS 1.7 y verifica. Mejor poner tu tienda en mantenimiento temporalmente para realizar este prueba ya que es posible que pierdas el diseño e incluso que tengas que recuperar una copia de seguridad, realiza esta preuba cuando tengas menos tráfico.

Saludos
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.
El administrador ha desactivado la escritura pública.

¿Te ha resultado interesante esta entrada del foro?

Suscríbete para recibir consejos y trucos útiles para tu Web.

Al actualizar a 1.7.6 se me han perdido todos los enlaces de los e-mails 3 semanas 6 días antes #336232

Hola acabo de probar deactivando todos los modulos no nativos de prestashop y sigue igual, ahora are lo de cambiar al tema por defecto para ver
Ya te diré
Saludos
manel
  • Josep
  • Avatar de Josep
  • DESCONECTADO
  • Navegador Superior
  • Mensajes: 49
  • Karma: 0
El administrador ha desactivado la escritura pública.

Al actualizar a 1.7.6 se me han perdido todos los enlaces de los e-mails 3 semanas 6 días antes #336235

Hola he cambiado el tema al de prestashop y sigue sin enlazar bien los e-mails, las plantillas dl tema por defecto de prestashop salen sin enlazar con los datos correctos
No se que mas hacer
Saludos
  • Josep
  • Avatar de Josep
  • DESCONECTADO
  • Navegador Superior
  • Mensajes: 49
  • Karma: 0
El administrador ha desactivado la escritura pública.

Al actualizar a 1.7.6 se me han perdido todos los enlaces de los e-mails 3 semanas 6 días antes #336240

Hola

Desde qué versión actualizaste?
Prueba limpiar la cache, o mejor desactívala, desde: Parámetros Avanzados > Rendimiento, desactiva los parámetros CCC igualmente.

Saludos.
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.
El administrador ha desactivado la escritura pública.

Al actualizar a 1.7.6 se me han perdido todos los enlaces de los e-mails 3 semanas 6 días antes #336242

Esto ya lo he probado y no lo soluciona , actualicé de 1.7.5.4 a 1.7.6
Saludos
  • Josep
  • Avatar de Josep
  • DESCONECTADO
  • Navegador Superior
  • Mensajes: 49
  • Karma: 0
El administrador ha desactivado la escritura pública.

Al actualizar a 1.7.6 se me han perdido todos los enlaces de los e-mails 3 semanas 6 días antes #336243

Hola

El hecho de que no haga el reemplazo tiene que ver con smarty.

Verifica en los archivos de tu sitio web, ubica la carpeta de cache , dentro busca smarty y renombra esa carpeta, debería generarse nuevamente. Puedes usar el Administrador de Archivos de tu Cpanel para realizar esto.

Saludos
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.
El administrador ha desactivado la escritura pública.

Al actualizar a 1.7.6 se me han perdido todos los enlaces de los e-mails 3 semanas 5 días antes #336261

Hola,
he cambiado el nombre de la carpeta smarty y he recopilado de nuevo he borrado la caché y siguen saliendo los e-mails sin cambiar los parametros "shop_name" me lo sustituye siempre por: "Prestashop" en lugar de "Audenis"
No lo entiendo supongo que és al actualizar a 1.7.6 porque todo lo demás que había hecho lo he desecho pero sigue saliendo mal.
Gracias, por vuestra paciencia pero no sé que hacer
saludos
manel
  • Josep
  • Avatar de Josep
  • DESCONECTADO
  • Navegador Superior
  • Mensajes: 49
  • Karma: 0
El administrador ha desactivado la escritura pública.

Al actualizar a 1.7.6 se me han perdido todos los enlaces de los e-mails 3 semanas 5 días antes #336266

Hola Josep.

Ok por favor explicame un poco con capturas que es exactamente lo que pasa.

el enlace "shop_name" me lo sustituye siempre por: "Prestashop" en lugar de "Audenis"
¿ Quieres decir que pone prestashop en el enlace en vez de Audenis ? ¿ El enlace funciona bien y dirige a la página del usuario o tu plantilla ?

Explicame un poco el problema que tienes por qué no lo tengo claro cual es el problema :huh:

Un saludo
  • Pepe
  • Avatar de Pepe
  • DESCONECTADO
  • Administrador
  • Mensajes: 18838
  • Gracias recibidas 1521
  • Karma: 539
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.
El administrador ha desactivado la escritura pública.

Al actualizar a 1.7.6 se me han perdido todos los enlaces de los e-mails 3 semanas 5 días antes #336268

Como veras en las capturas no hace el cambio correctamente de las variables, en asunto me aparece prestashop y en todos los mails no salen los datos correctamente.
Lo hemos probado todo y nada funciona, hace 4 años que funciona la tienda y siempre han funcionado correctamente los emails hasta hace unos días que han empezado a fallar, igual ha sido por la actualización a 1.7.6 no se
Ya me dirás
Manel
Adjuntos:
  • Josep
  • Avatar de Josep
  • DESCONECTADO
  • Navegador Superior
  • Mensajes: 49
  • Karma: 0
El administrador ha desactivado la escritura pública.

Al actualizar a 1.7.6 se me han perdido todos los enlaces de los e-mails 3 semanas 5 días antes #336281

Hola Josep.

en asunto me aparece prestashop y en todos los mails no salen los datos correctamente.
Prueba lo siguiente:

.- Edita el archivo mail.php que encontrarás en la carpeta classes
.- Busca el siguiente código:
$subject = '['.Configuration::get('PS_SHOP_NAME', null, null, $idShop).'] '.$subject;
            $message->setSubject($subject);
 
            $message->setCharset('utf-8');

Modifica por lo siguiente:
/* $subject = '['.Configuration::get('PS_SHOP_NAME', null, null, $idShop).'] '.$subject;
            $message->setSubject($subject);
 
            $message->setCharset('utf-8'); */

para modificar el enlace inferior:
.- edita el archivo themes/tu_plantilla/mails/es order_conf.txt
.- En al parte inferior verás lo siguiente:
{shop_name} [{shop_url}] powered by
PrestaShop(tm) [http://www.prestashop.com/]

Modifica el texto y la URL.

Nota: recuerda descargar una copia de los archivos antes de realizar la modificación.

Un saludo
  • Pepe
  • Avatar de Pepe
  • DESCONECTADO
  • Administrador
  • Mensajes: 18838
  • Gracias recibidas 1521
  • Karma: 539
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.
El administrador ha desactivado la escritura pública.

Temas Relacionados

11 Respuestas emo
Tema iniciado 2 años 2 días antes por Juan Enrique
514 Visitas
1 Respuestas emo
Tema iniciado 2 años 10 meses antes por Juan
629 Visitas
3 Respuestas emo
Tema iniciado 3 años 6 meses antes por Jesús
672 Visitas
14 Respuestas emo
Tema iniciado 3 años 6 meses antes por JOEL
1621 Visitas
8 Respuestas emo
Tema iniciado 4 años 7 meses antes por Francisco
1079 Visitas
2 Respuestas emo
Tema iniciado 11 meses 2 semanas antes por Francisco
193 Visitas
7 Respuestas emo
Tema iniciado 3 años 10 meses antes por Jordi
1220 Visitas
1 Respuestas emo
Categoría: Módulos PrestaShop
Tema iniciado 4 años 7 meses antes por Jose S.
892 Visitas
2 Respuestas emo
Tema iniciado 4 años 10 meses antes por Francisco
1479 Visitas
2 Respuestas emo
Tema iniciado 3 años 2 semanas antes por Jose Maria
479 Visitas

Moderadores: Pablo Velasco
Tiempo de carga de la página: 0.503 segundos