Foro de soporte WordPress en español


Soporte WordPress en español Soporte gratuito para webs alojadas en Webempresa.com
Habilitado para todos los clientes con planes de Hosting Alto Rendimiento a partir de 3GB y planes XL.

No ofrecemos soporte a webs alojadas en servidores externos o localhost, ni soporte css o programación.

Te recomendamos que leas esta información sobre nuestro sistema de soporte en el foro, te ayudará a sacar el máximo partido de nuestro conocimiento: Cómo podemos ayudarte.


Encuentra la solución a tu problema, buscando en nuestro foro:
Bienvenido, Invitado
Nombre de Usuario: Contraseña: Recordarme

TEMA: Problema tras activar Magic cache / Varnish Cache

Problema tras activar Magic cache / Varnish Cache 3 años 2 días antes #264574

Buenas.

Tuve mi web de prestashop funcionando perfectamente en vuestro servidores la última semana.

El problema fue que me activasteis el magic cache/varnish cache y hay un plugin que no me esta funcionando correctamente.

Es el de las cookies. Aunque aprete aceptar o lo ponga en modo continuar navegando, el aviso de las cookies no desaparece

Cuando me desactivais el varnish cache, el problema desaparece y si que cierra el aviso.

Un compañero del servicio de tickets, me modificó algo en header.tpl de la plantilla y funcionó correctamente, pero luego me volvieron a poner el archivo original (eso creo) y ahora vuelvo a tener ese problema

He vaciado la cache de prestashop y la del addon de varnish.

En concreto el plugin de cookies es este addons.prestashop.com/es/8734-ley-europea-de-cookies-aviso-bloqueador-de-cookie.html

No tengo vuestro addon bloqueado en el plugin tampoco de las cookies. Necesito este plugin porque tengo analytics activado y no quiero que instale ninguna cookie hasta que acepten.

Creo que es porque cachea las cookies o algo asi, nose


Un saludo y gracias.

URL del sitio: Contenido oculto para usuarios invitados. Por favor, inicie su sesión para poder verlo.
  • Maria Elena
  • Avatar de Maria Elena
  • DESCONECTADO
  • Navegador Iniciado
  • Mensajes: 2
  • Karma: 0
El tema ha sido cerrado.
Mejora la velocidad de tu WordPress

Problema tras activar Magic cache / Varnish Cache 3 años 2 días antes #264601

Hola,

Debido a la forma en la que trabaja Magic Caché, no es compatible con todo los módulos.

Para el problema que comentas prueba a editar el archivo header.tpl y añade el siguiente código:

<style type="text/css">
 div.lgcookieslaw_banner {
    display:none;
 }
</style>
 
<script type="text/javascript">
 
window.onload = function() {
    function getCookie(cname) {
        var name = cname + "=";
        var ca = document.cookie.split(';');
        for(var i = 0; i <ca.length; i++) {
            var c = ca[i];
            while (c.charAt(0)==' ') {
                c = c.substring(1);
            }
            if (c.indexOf(name) == 0) {
                return c.substring(name.length,c.length);
            }
	}
	return "";
    }
 
    if (!getCookie("__lglaw")){
      document.querySelector("div.lgcookieslaw_banner").style.display = "block";
    }
 
}
 
</script>

Verifica si así se soluciona el problema.
  • Pablo Velasco
  • Avatar de Pablo Velasco
  • DESCONECTADO
  • Moderador
  • Mensajes: 20369
  • Gracias recibidas 2735
  • Karma: 758
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.
El tema ha sido cerrado.
trasladar web gratis

Problema tras activar Magic cache / Varnish Cache 2 años 11 meses antes #264934

Buenas.

Efectivamente el banner desaparece. PERO:

1. Este plugin tiene una funcion de bloquear los módulos hasta que se aceptan las cookies o si se pone en modo aceptarlas con navegación, esos módulos se cargan (analytics, facebook, etc..). Con varnish activado y el codigo que me habeis pasado, no cargan los plugins cuando aceptan o navegan.

2. Si pongo el plugin en modo aceptar las cookies si continua navegando (en vez de boton aceptar), que es como lo tenía anteriormente, el baner continua apareciendo.

3. He hablado ya con el creador del plugin, aver si lo solucionamos entre todo, que es una pena ya que funciona muy bien el varnish.

Un saludo.
  • Maria Elena
  • Avatar de Maria Elena
  • DESCONECTADO
  • Navegador Iniciado
  • Mensajes: 2
  • Karma: 0
El tema ha sido cerrado.

Problema tras activar Magic cache / Varnish Cache 2 años 10 meses antes #267641

Hola, pudiste solucionar tu problema? que mas modulos de prestashop entran en conflicto con magic cache?
Gracias
  • Angel
  • Avatar de Angel
  • DESCONECTADO
  • Navegador Junior
  • Mensajes: 31
  • Karma: 0
El tema ha sido cerrado.

Problema tras activar Magic cache / Varnish Cache 2 años 10 meses antes #267644

Hola Angel.

Por favor no edites una entrada de otro usuario, si necesitas realizar una consulta, hazlo abriendo una entrada nueva con la consulta que quieras plantear.

En este caso la entrada estaba en espera y si no lo hubiéramos revisado no lo encontraríamos y se quedaría en espera.

Por favor abre otra entrada con la consulta que tengas.

Un saludo
  • Pepe
  • Avatar de Pepe
  • DESCONECTADO
  • Administrador
  • Mensajes: 19980
  • Gracias recibidas 1594
  • Karma: 582
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.
El tema ha sido cerrado.

Temas Relacionados

3 Respuestas emo
Categoría: Módulos PrestaShop
Tema iniciado 2 años 4 meses antes por antonio
724 Visitas
2 Respuestas emo
Tema iniciado 4 meses 3 semanas antes por Jonas
89 Visitas
2 Respuestas emo
Tema iniciado 5 años 3 meses antes por Luis
2018 Visitas
3 Respuestas emo
Tema iniciado 4 años 7 meses antes por Estructuras y Contratas del Levante SL
1254 Visitas
1 Respuestas emo
Tema iniciado 4 años 2 meses antes por Alexandra
1406 Visitas
4 Respuestas emo
Tema iniciado 3 años 1 mes antes por Maria de las Mercedes
706 Visitas
4 Respuestas emo
Tema iniciado 2 años 6 meses antes por Walter
1075 Visitas
5 Respuestas emo
Tema iniciado 2 años 2 meses antes por Juan David
507 Visitas
3 Respuestas emo
Tema iniciado 1 año 7 meses antes por Gabriel
626 Visitas
13 Respuestas emo
Tema iniciado 2 años 7 meses antes por Javier
807 Visitas

Moderadores: Pablo Velasco
Tiempo de carga de la página: 0.502 segundos