Foro de soporte WordPress, Joomla y PrestaShop en español


Soporte WordPress en español Soporte gratuito para webs alojadas en Webempresa.com
Habilitado para todos los clientes con planes de Hosting Alto Rendimiento a partir de 3GB y planes XL.

No ofrecemos soporte a webs alojadas en servidores externos o localhost, ni soporte css o programación.

Te recomendamos que leas esta información sobre nuestro sistema de soporte en el foro, te ayudará a sacar el máximo partido de nuestro conocimiento: Cómo podemos ayudarte.


Encuentra la solución a tu problema, buscando en nuestro foro:
Bienvenido, Invitado
Nombre de Usuario: Contraseña: Recordarme

TEMA: Problemas con carro y login en la home al habilitar las URL Amigables

Problemas con carro y login en la home al habilitar las URL Amigables 1 año 10 meses antes #256987

Buenos días, anteayer realicé un traslado de un e-comere Joomla-virtuemart alojado en otro servidor a Webempresa, la idea es hacer algunas mejoras en la web antes de re-dirigir los DNS definitivamente.
En la página tengo un error que estoy intentando solventar vía la redirección en Cpanel, pero no me funciona como creo que debería y no se qué estoy haciendo mal.
La web funciona perfectamente, pero cuando habilito la Urls amigables se genera un error en el carrito de la compra y en el login, pero solo en la home.
Si la url calcetin-cp515.webjoomla.es/ es solo el dominio no funciona bien, pero si añado en el navegador a la URL calcetin-cp515.webjoomla.es/latienda/ funciona perfecto.
Entiendo que htacces lleva implementada la desaparición de .index.php de ahí que el dominio queda limpio, pero eso me genera el error en el carro y el login.
He intentado a través de Cpanel crear una redirección concreta de calcetin-cp515.webjoomla.es/index.php a calcetin-cp515.webjoomla.es/tienda/
Pero no funciona tampoco, y no se si es porque al ser un enlace del virtuemart como este : index.php?option=com_virtuemart&view=category&virtuemart_category_id=0&virtuemart_manufacturer_id=0&categorylayout=default&showcategory=1&showproducts=1&productsublayout=0 no sirve la redirección desde cPanel

¿Me explico?

Os adjunto pantallazos

URL del sitio: Contenido oculto para usuarios invitados. Por favor, inicie su sesión para poder verlo.
Adjuntos:
  • Merche
  • Avatar de Merche
  • DESCONECTADO
  • Navegador Iniciado
  • Mensajes: 18
  • Karma: 0
El administrador ha desactivado la escritura pública.
Mejora la velocidad de tu WordPress

Problemas con carro y login en la home al habilitar las URL Amigables 1 año 10 meses antes #257008

Hola Merche.

Según lo que comentas es por que instalaste la web en la carpeta tienda en vez de en la raiz de tu web que es donde tendría que estar para que se muestre con la url que indicas.

¿ El traslado lo realizamos nosotros o lo realizasteis vosotros ?

En estos casos tienes dos opciones, eliminar lo que tienes de la web actual y realizar una instalación de nuevo pero desde la raiz del hosting.

La segunda opción es cambiar de ruta la web o moverla al directorio ( Public_html )
Revisa esta entrada del blog, donde se explica como moverlo.
Mover un Pack Joomla! a la carpeta /public_html del Hosting

Un saludo
  • Pepe
  • Avatar de Pepe
  • DESCONECTADO
  • Administrador
  • Mensajes: 14349
  • Gracias recibidas 1167
  • Karma: 405
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.
El administrador ha desactivado la escritura pública.
trasladar web gratis

Problemas con carro y login en la home al habilitar las URL Amigables 1 año 10 meses antes #257010

No, en realidad ya está en la carpeta pública, eso es lo raro.
El error ocurre al pasar de calcetin-cp515.webjoomla.es/index.php a calcetin-cp515.webjoomla.es/
cuando pongo /latienda/ es, no por la carpeta, sino porque es como se llama el botón de "Inicio" y como sería la ruta amigable si no fuera la HOME. Pero el error ocurre porque desaparece el .index.php.
  • Merche
  • Avatar de Merche
  • DESCONECTADO
  • Navegador Iniciado
  • Mensajes: 18
  • Karma: 0
El administrador ha desactivado la escritura pública.
solucionar problemas wordpress

Problemas con carro y login en la home al habilitar las URL Amigables 1 año 10 meses antes #257042

Hola Merche.

Ok, puedes hacernos el favor de adjuntarnos una captura de lo que tienes en ( Public_html ).

.- Accede a cPanel -> Administrador de archivos
.- selecciona la carpeta ( Public_html ) y adjúntanos una captura de dicha carpeta.

Un saludo
  • Pepe
  • Avatar de Pepe
  • DESCONECTADO
  • Administrador
  • Mensajes: 14349
  • Gracias recibidas 1167
  • Karma: 405
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.
El administrador ha desactivado la escritura pública.

Problemas con carro y login en la home al habilitar las URL Amigables 1 año 10 meses antes #257047

Gracias Pepe, te adjunto la imagen, y no te contesté antes a cómo traspasé la web, fue a través del Supermigrator.

Yo sospecho que pueda ser algún problema del .htacces porque cuando he intentando crear una re-dirección en el Cpanel de calcetin-cp515.webjoomla.es/index.php a calcetin-cp515.webjoomla.es/tienda/ es como si no funcionara bien.

También intenté modificar en el htacces el RewriteBase / para que no sea solo / sino que fuera /latienda para el caso de la home pero no me funciona.

Te adjunto el htacces que tengo y que creo que se modifico durante la migración porque no es como el que tenía antes e imagino que se adapta durante al migración.
Adjuntos:
  • Merche
  • Avatar de Merche
  • DESCONECTADO
  • Navegador Iniciado
  • Mensajes: 18
  • Karma: 0
El administrador ha desactivado la escritura pública.

Problemas con carro y login en la home al habilitar las URL Amigables 1 año 10 meses antes #257082

Hola

No he podido detectar el error, cuando ingreso a :
Contenido oculto para usuarios invitados. Por favor, inicie su sesión para poder verlo.

Navego correctamente con urls amigables, en que opción debo clickear para que se vea el erro de llevarte a la ruta que comentas?

Saludos.
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.
El administrador ha desactivado la escritura pública.

¿Te ha resultado interesante esta entrada del foro?

Suscríbete para recibir consejos y trucos útiles para tu Web.

WordPress    PrestaShop

Problemas con carro y login en la home al habilitar las URL Amigables 1 año 10 meses antes #257087

Para detectar el error, estando en la home (la tienda) inserta un producto en el carro y ves al carro, en el icono del carro verás el importe de la compra, pero si vuelves a clicar en la tienda porque decides volver a comprar más productos el icono del carro ya no muestra el importe, mientras sí lo hace en cualquiera de las otras páginas virtuemart, como si entras a ver los detalles de un producto etc.. funciona en todas.

También funciona cuando en vez de calcetin-cp515.webjoomla.es/ añades index.php a la url ej: calcetin-cp515.webjoomla.es/index.php o ej: calcetin-cp515.webjoomla.es/latienda. entonces se visualiza correctamente el importe del producto en el carro.

Algo muy similar ocurre con el login de ENTRAR, si intento un login en calcetin-cp515.webjoomla.es/ no funciona, si lo intento en calcetin-cp515.webjoomla.es/index.php o calcetin-cp515.webjoomla.es/latienda sí puedo.

Es como si al perder el index.php de la URL perdiera la conexión al usuario y al carro.
Por eso pienso que, o es un problema de redirección en el Htacess o que al menos lo podría solucionar desde ahí con algún código ya que si desactivo las URL amigables funciona perfectamente.
  • Merche
  • Avatar de Merche
  • DESCONECTADO
  • Navegador Iniciado
  • Mensajes: 18
  • Karma: 0
El administrador ha desactivado la escritura pública.

Problemas con carro y login en la home al habilitar las URL Amigables 1 año 10 meses antes #257108

Hola,

Podría ser un problema de cache, tienes alguno activo? de ser así realiza la prueba desactivándolo.
Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.
El administrador ha desactivado la escritura pública.

Problemas con carro y login en la home al habilitar las URL Amigables 1 año 10 meses antes #257126

Tengo la caché des-habilitada desde que hice la migración, en el plugin System- caché, que tenia activado el navegador, lo he desactivado. Pero sigue sin solucionarse, he borrado el historial del navegador y también la caché virtuemart, pero nada.
Lo que no entiendo muy bien es que sí se solucione al des-habilitar las URL amigables. ¿Qué conexión existe entre la URL amigables y la caché?
¿Eso significa que cuando haga la re-dirección de DNS no deberé activar la caché? ¿Es incompatible con Virtuemart?
  • Merche
  • Avatar de Merche
  • DESCONECTADO
  • Navegador Iniciado
  • Mensajes: 18
  • Karma: 0
El administrador ha desactivado la escritura pública.

Problemas con carro y login en la home al habilitar las URL Amigables 1 año 10 meses antes #257156

Hola,

He intentado reproducir el error, pero no me ha salido.

He hecho lo siguiente: entro en la web y añado un producto al carro. Me voy al carro de compra. Pulso en el enlace de menú "La tienda". Aquí sigo viendo el importe en el módulo del carro.

¿No estoy siguiendo los pasos correctos?
  • Pablo Velasco
  • Avatar de Pablo Velasco
  • DESCONECTADO
  • Administrador
  • Mensajes: 20282
  • Gracias recibidas 2716
  • Karma: 754
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.
El administrador ha desactivado la escritura pública.

Problemas con carro y login en la home al habilitar las URL Amigables 1 año 10 meses antes #257158

Al des-habilitar la caché system parece funcionar mejor, pero no del todo, si pones un segundo producto en el carro lo suma, pero si vuelves a la tienda ves el importe anterior, no el nuevo.
  • Merche
  • Avatar de Merche
  • DESCONECTADO
  • Navegador Iniciado
  • Mensajes: 18
  • Karma: 0
El administrador ha desactivado la escritura pública.

Problemas con carro y login en la home al habilitar las URL Amigables 1 año 10 meses antes #257184

Hola,

He realizado pruebas agregando varios productos al carro y después pulsando sobre "La tienda" y veo que siempre me mantiene el importe correcto, suma de todos los productos añadidos.
  • Pablo Velasco
  • Avatar de Pablo Velasco
  • DESCONECTADO
  • Administrador
  • Mensajes: 20282
  • Gracias recibidas 2716
  • Karma: 754
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.
El administrador ha desactivado la escritura pública.

Problemas con carro y login en la home al habilitar las URL Amigables 1 año 10 meses antes #257186

Entonces es que en mis navegadores aun queda algo de caché. Voy a borrar todos los históricos de nuevo.
Gracias por hacer la comprobación.
¿Eso quiere decir que debo dejar para siempre la caché de sistema des-habilitada? Me refiero a una vez re-dirija las DNS y deje la tienda ya online? No me puede penalizar google por eso? Ahora mismo tengo un 98/100 en google speed...y no querría perderlo.
¿Qué me recomiendas?
  • Merche
  • Avatar de Merche
  • DESCONECTADO
  • Navegador Iniciado
  • Mensajes: 18
  • Karma: 0
El administrador ha desactivado la escritura pública.

Problemas con carro y login en la home al habilitar las URL Amigables 1 año 10 meses antes #257218

Hola

La cache de tu sitio si la puedes habilitar, lo que te comentamos que compruebes es lo que se queda en cache de tu navegador que es algo diferente.

Sin embargo te recomiendo habilitar sólo la cache de tu sitio cuando ya hayas finalizado las modificaciones en t web.

Saludos
Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.
El administrador ha desactivado la escritura pública.

Temas Relacionados

11 Respuestas emo
Categoría: Joomla 3.0
Tema iniciado 1 año 6 meses antes por maite
462 Visitas
4 Respuestas emo
Categoría: VirtueMart 2.0
Tema iniciado 2 años 4 meses antes por Juan
415 Visitas
7 Respuestas emo
Categoría: Pack Tienda Joomla
Tema iniciado 2 años 11 meses antes por Marco
610 Visitas
4 Respuestas emo
Categoría: Pack Tienda Joomla
Tema iniciado 5 años 5 meses antes por Osvaldo
1006 Visitas
1 Respuestas emo
Categoría: Joomla 1.5
Tema iniciado 7 años 6 meses antes por Jose
1370 Visitas
5 Respuestas emo
Categoría: Joomla 1.5
Tema iniciado 6 años 10 meses antes por Atica
2340 Visitas
13 Respuestas emo
Categoría: VirtueMart 2.0
Tema iniciado 5 años 11 meses antes por valentin
1592 Visitas
3 Respuestas emo
Tema iniciado 5 años 8 meses antes por ANTONIO
873 Visitas
7 Respuestas emo
Categoría: Joomla 3.0
Tema iniciado 3 años 6 meses antes por Manuel Pedro
751 Visitas
4 Respuestas emo
Categoría: Virtuemart
Tema iniciado 7 años 10 meses antes por Lula
2991 Visitas

Tiempo de carga de la página: 0.367 segundos