No me aparece un transportista a la hora de elegirlo  

Página 1 / 2
 
David
 David
Reputable Member

No me aparece un transportista que he creado, lo borré y lo volví a crear, pero sigue igual, no tiene ninguna restricción de tamaño o peso, y no me aparece para elegirlo. No sé que ha podido ocurrir. Si me pudieran ayudar......
Gracias.
Atentamente y Feliz Año. David Cervera

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 01/01/2019 11:09 am
David
 David
Reputable Member

Ya se cual es el problema, al crear un transportista nuevo, eliminando el que había previamente, no se ha incorporado a cada uno de los productos, por lo tanto habría que incluir el transportista para cada uno de los productos, pero para hacerlo, ¿como podría hacerlo de manera masiva? Mediante CSV o existe alguna otra manera. Gracias

ResponderCitar
Respondido : 01/01/2019 12:48 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Podrías ayudarte de un parámetro adicional, prueba hacerlo con el peso, tal como se comenta en:
https://www.webempresa.com/foro/44-M%C3%B3dulos-PrestaShop/138890-Especificar-el-transportista-a-los-productos-en-una-importacion-csv.html

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 01/01/2019 5:03 pm
David
 David
Reputable Member

No entiendo muy bien, a qué se refiere con esto,

Podrías utilizar algún parámetro como el peso de los productos. Por ejemplo, podrías probar a dejar un peso 0 para los productos gratuitos y un peso mayor que cero para el resto de producto (por ejemplo, 1Kg.). Luego, para la configuración del transportista con el envío gratuito podrías poner que ese transporte se aplique hasta un peso máximo de 0,1Kg.

¿al peso del producto?, para eso debería especificar el peso de cada producto??, tampoco es factible ya que casi todo pesa lo mismo y yo establezco el envío gratuito por importe de compra.

De otra manera he visto lo siguiente:

Por lo tanto si no especifico ninguno en "Transportistas seleccionados" (que lo he hecho eliminando los que tenía hechos y creándolos nuevos), es decir ningún producto tiene transportistas seleccionados.
Se supone que deberían estar disponibles para elegirlos en el Front en cada pedido sin embargo sigue apareciendo lo siguiente:

Espero que puedan ayudarme.
Muchas gracias. David Cervera

ResponderCitar
Respondido : 01/01/2019 6:06 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Lo que se comenta en el post de referencia es que no es necesario asignar un transportista a un producto para que aparezca, este transportista podría basarse en el peso del producto (o productos)

Sin embargo si quieres asignar un transportista específico entonces si que sería asignarlo manualmente o a través de BD por consultas SQL, revisa por ejemplo: https://www.prestashop.com/forums/topic/321041-set-carrier-for-product-using-import-csv/

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 01/01/2019 6:37 pm
David
 David
Reputable Member

Lo que se comenta en el post de referencia es que no es necesario asignar un transportista a un producto para que aparezca, este transportista podría basarse en el peso del producto (o productos)

¿Entonces es necesario que cada producto del catálogo tenga un peso establecido?
Porque ahora ningún producto del catálogo tiene un peso establecido.

ResponderCitar
Respondido : 01/01/2019 8:50 pm

Cursos Gratuitos WordPress

David
 David
Reputable Member

Y con respecto a este mensaje

que aparece en el que yo entiendo que si no hay ningún transportista seleccionado se supone que aparecen todos para poder ser elegidos. ¿Es así o no?

ResponderCitar
Respondido : 01/01/2019 8:53 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola David.

Voy a revisar tu instalación para ver que puede estar causando ese error, en cuando lo tenga te contesto en esta misma entrada.

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 02/01/2019 1:36 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

David
 David
Reputable Member

Gracias Pepe, te lo agradezco, como no tengo conocimiento para lanzar las consultas a la base de datos (que es la solución que se ha propuesto), no tengo transportistas activos.

ResponderCitar
Respondido : 02/01/2019 1:52 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Prueba primero activar todos los paises para el método de transporte que tienes, tal como se muestra en la primera imagen.

Para comprobar si aparece el método de envío habilita el módulo de estimación de envío, desde modulos > modulos, este módulo aparecerá antes de hacer la compra en el carrito

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 02/01/2019 6:02 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

David
 David
Reputable Member

Jhon, no funciona, adjunto imágenes

ResponderCitar
Respondido : 03/01/2019 6:04 am
David
 David
Reputable Member

Buenos días;
PROBLEMA 1
Se supone que si no se seleccionan ninguno de los transportistas para un producto, en esta pantalla

estarán disponibles para poder elegirlos en la siguiente pantalla

Pero esto no ocurre, y no sé como solucionarlo, ya que todo lo que leo me hace referencia a que deberían aparecer los transportistas para poder elegirlos.

PROBLEMA 2
Después de muchos días con este problema, he descargado el módulo http://store.nemops.com/free-modules/43-carrier-assigner-free-module.html#.XC2eT1xKiM8
Que establece de manera masiva un transportista a todos los productos de una categoría, y lo hace eficientemente, ya que por ejemplo todos mis productos de la categoría "HOMBRE", tienen los dos transportistas asignados, según esta imagen

Luego, por lo tanto se supone que al hacer la compra de este artículo se tienen que activar todos los transportistas, pero ocurre esto

Activé el módulo "Estimación de gastos de envío" y marqué en el Transportista ¡Todos los países! (como indicó Jhon Marreros) pero tampoco dio resultado. Entonces pensé si podía ser la configuración del Transportista, y aquí os dejo las imágenes de la configuración por si hubiese algún error.

Por lo tanto, imaginé que podía ser error de la configuración del transportista

Y la última pantalla como no me deja adjuntarla, pongo aquí el texto
El transportista es no gratis y el tiempo estimado de envío es: 24/72 horas.
El precio de compra se ha calculado en en función del precio total y la regla de precio No hay impuesto ha sido aplicada.
Este transportista puede entregar los pedidos de 0.000000 € a 1000.000000 €. Si el pedido está fuera de rango, el comportamiento es aplicar el coste más alto de la gama definida. Si el pedido está fuera de rango, el comportamiento es de @s3
Este transportista será propuesto para estas zonas de entrega
Africa
Asia
Baleares
Canarias
Central America/Antilla
Ceuta y Melilla
Europe
Europe (out E.U)
North America
Oceania
Península
South America
Y será propuesto para estas grupos de cliente
Visitor
Guest
Customer
www.calzadosdavid.com TPV
UsadoBienvenida

Espero que puedan ayudarme, ya que si no se encontrase una solución entiendo que puede ser problema de la instalación de Prestashop, y no se debería poner ticket al Hosting de Webempresa para poder solucionar este problema.

Gracias, y espero que puedan ayudarme lo más pronto posible

ResponderCitar
Respondido : 03/01/2019 7:33 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Pepe
 Pepe
Soporte CMS Webempresa Admin

Hoal David.

Vamos a probar algo.

.- Accede a tu cuenta de cPanel -> phpMyAdmin

.- Selecciona la base de datos que utiliza tu instalación
.- Selecciona todas las tablas con el nombre " _carrier " y pulsa en " Exportar "

.- Selecciona " Vaciar " en todas las tablas " _carrier "

.- Accede a la administración de prestashop y vuelve a crear los transportáis y las zonas.

Revisa si con esos pasos se soluciona.

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 03/01/2019 10:36 am
David
 David
Reputable Member

Buenos días Pepe, Vacié primero las tablas, y para las zonas supongo que te refieres a las "Zonas geográficas" que se accede desde Localización->Zonas Geográficas, están así configuradas

Pero tampoco funciona, sigue saliendo el mismo error, no aparecen los transportistas.
¿Crees que debo poner un ticket en el hosting?
Esto ya parece grave, no??

ResponderCitar
Respondido : 03/01/2019 11:25 am

Cursos Gratuitos WordPress

Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola David.

Ok, dame esta mañana que lo pueda revisar con tiempo y te contesto en esta misma entrada.
No es un problema muy común pero veremos que es lo que puede estar provocando ese error 😉

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 03/01/2019 11:43 am
Página 1 / 2

Por favor Iniciar Sesión o Registro