Avisos
Vaciar todo

Joomla 1.6 + Kunena o Joomla 1.5 +phpBB3  

Página 1 / 2
 
Jorge
 Jorge
Estimable Member

Hola buenos tardes,

Tengo previsto empezar en breve a desarrollar un nuevo espacio web y quería que me aconsejaráis un poquito al respecto.
Actualmente tengo contratado con Uds, un pack 300MB, en el cual administro una web sobre Joomla 1.5 con foros phpbb3.

Mi primera pregunta es si ahora que es una web nueva sería conveniente realizarla con Joomla 1.6 y la última versión de foros Kunena o seguir bajo Joomla 1.5 mas phhpbb3?

Los foros de Kunena quedan totalmente integrados de forma que el que se loguee en la web de Joomla también lo estará en el foro?

Admiten la posibilidad de crear subforos dentro de un mismo foro?

Es posible crear foros o subforos de carácter privado mediante permisos o incluso ocultos a otros usuarios?

Kunena admite la posiblidad de añadir imagenes descriptivas para cada categoría o foro?

A medida que vaya leyendo algo mas sobre Joomla 1.6 y Kunena, os iré consultando antes de formalizar el pedido del nuevo pack.

Un saludo y muchas gracias por adelantado

Citar
Respondido : 07/07/2011 3:02 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Jorge

Si es posible crear subforos en kunena, además que esta totalmente integrado con los usuarios de Joomla, y en Joomla 1.6 tienes la ventaja de una ACL integrada para manejar permisos.

Lo que tienes que evaluar a parte de la extensión del foro es otro tipo de extensiones que te encuentres usando actualmente en Joomla 1.5, revisa si están disponibles para Joomla 1.6. La mayoría de usuarios usualmente se pasa a Joomla 1.6 por el uso de su pontente ACL ya que fácilmente podrías también instalar kunena con Joomla 1.5.

Saludos.

ResponderCitar
Respondido : 07/07/2011 6:22 pm

Cursos Gratuitos WordPress

Jorge
 Jorge
Estimable Member

Hola buenas tardes,

Jhon, la posibilidad de crear grupos con diferentes permisos de acceso me interesa mucho y si el Joomla 1.6 lo trae de forma nativa pues casi mejor que andar buscando una extensión de terceros.
Por otro lado, la posibilidad de crear subforos en Kunena y el que se pueda integrar en Joomla sin plugins de por medio también lo veo necesario.

Siguiendo tus indicaciones, he estado mirando las extensiones que mas necesito y creo que si están para Joomla 1.6:

  • PhocaMaps v 2.0.0 --> para los mapas de Google
  • Aunque el JComments que es el que uso para Joomla 1.5 no está para Joomla 1.6 he visto el yvComments 2.00.003. que parece que también tiene buenas referencias

El resto creo que ya los trae el Pack de Webempresa:

  • BrezingForms
  • JCE Editor
  • Banners
  • Akeeba
  • JNews

Que Pack de Webempresa habría que solicitar que contenga Joomla 1.6.3 (creo que es la última estable sino me equivoco) y Kunena 1.6.3?

Un saludo

ResponderCitar
Respondido : 10/07/2011 8:46 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Jorge,

Antes de meterte en temas de 1.6 (en día 19 de julio se libera Joomla! 1.7 y mañana 1.6.5) analiza bien que extensiones necesitarás, ya que migrar Joomla! no significa tener disponibles todas la extensiones en la nueva rama.

Uno de los grandes problemas que esta ralentizando las migraciones es la falta de disponibilidad de los desarrolladores para escribir los plugins necesarios para que sus extensiones sean portadas.

¿Que extensiones podremos instalar tras la migración en Joomla! 1.6 del pack Webempresa?

BreezingForms 1.7.3 (build 741) (componente)
http://extensions.joomla.org/extensions/access-a-security/site-security/backup/1606 - Akeeba Backup 3.2.7 (componente)
http://extensions.joomla.org/extensions/edition/editors/88 - JCE 2.0.0beta2 (componente)
http://extensions.joomla.org/extensions/core-enhancements/file-management/2630 - eXtplorer 2.1.0 RC3 (componente) - (en sustitución de NinjaXplorer).
http://extensions.joomla.org/extensions/style-a-design/design/3343 - Phoca Favicon 2.0.0 (componente)
http://extensions.joomla.org/extensions/structure-a-navigation/site-map/3066 - Xmap 2.0 beta 2 (componente)
http://extensions.joomla.org/extensions/photos-a-images/photo-gallery/1468 - Simple Image Gallery 2.1 (plugin)
http://extensions.joomla.org/extensions/news-production/content-submission/6260 - Simple Content Versioning 1.92 (componente)

¿Que extensiones no migraremos del pack Webempresa?

http://extensions.joomla.org/extensions/administration/extensions-quickicons/463- CQI - CustomQuickIcons (componente)
VirtueMart 1.1.8 e inferiores (componente)
http://extensions.joomla.org/extensions/administration/admin-desk/6327 - J!Position (componente)
http://www.baticore.com/index.php?option=com_docman&task=cat_view&gid=2&Itemid=3 - Mass Content (componente)
http://extensions.joomla.org/extensions/core-enhancements/file-management/4746 - NinjaXplorer (componente)
http://extensions.joomla.org/extensions/multimedia/multimedia-players/video-players-a-gallery/812 - AllVideos (plugin)
http://extensions.joomla.org/extensions/access-a-security/site-security/backup/5762 - JomBackup (plugin)
http://extensions.joomla.org/extensions/administration/admin-interface/6001 - Better Preview (plugin)
http://extensions.joomla.org/extensions/site-management/site-analytics/6170 - BIGSHOT Google Analytics (plugin)
http://extensions.joomla.org/extensions/style-a-design/browsers-a-web-standards/7623 - IE8 Compatibility (plugin)
http://extensions.joomla.org/extensions/style-a-design/design/859 - Ultimate PNG Fix (plugin)

Extensiones incompatibles con JUpgrade que no podrán ser migradas:

  • Plugin RokBox RocketTheme
  • Plugin System - Auto Refresh
  • Plugin kSecure
  • Plugin Button - JA Typography

Extensiones que aún no han sido portadas a la nueva rama incluidas en nuestros packs:

VirtueMart (Pendiente de ser liberada la versión 1.9.0 que trabajará de forma nativa en Joomla! 1.6, aunque recientemente con motivo del J and Beyond se liberó la [url=la http://virtuemart.net/news/list-all-news/403-virtuemart-2-release-candidate-ready-for-download]RC 2.0[/url] -Se prevee que en un plazo de entre 2 y 4 meses podamos disponer de una versión estable posiblemente para la rama 1.7 de Joomla!).

Analiza bien todo esto antes de seguir adelante. La cautela es buena siempre que afecta a un sitio en producción.

Saludos

ResponderCitar
Respondido : 10/07/2011 9:08 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Jorge
 Jorge
Estimable Member

Buenas tardes Luis,

Pues la verdad no tengo nada claro por donde tirar y eso que el tiempo me apremia un poquito, he estado leyendo bastante toda la información que habéis ido aportando al foro en relación a Joomla 1.6 y me había hecho la idea de que para proyectos nuevos partiendo de cero era más recomendable que la versión 1.5.

Yo por esperar hasta el día 19 de julio no tendría problema pues estamos hablando de pocos días y si creéis conveniente empezar con Joomla 1.7 pues así lo haría, todo sea por evitar el máximo de problemas e inconvenientes.
El tema está es que todas las extensiones que he visto eran para las versiones de Joomla 1.5 y 1.6 y no he visto nada para la 1.7.

Como ya os he comentado mi idea era aprovechar por necesidad las ventajas del ACL integrado en Joomla y los foros Kunena por la posibilidad de crear subforos.

Esto último ya me lo habéis aclarado que si se pueden crear subforos pero me queda una duda importante.
Necesito que algunos foros o subforos sean ocultos y que solo se muestren a ciertos grupos de usuarios que serán diferentes unos de otros, es posible realizar esto en Kunena?

En el listado que me muestras de que extensiones se podrán instalar tras migrar a Joomla 1.6 con el Pack de Webempresa, veo que los principales o los que mas se usan si que será posible utilizarlos.
No obstante, pienso que todas estas extensiones que no migraréis tendrán alguna otra alternativa, no?

En principio, quizás un problema pueda tenerlo con el plugin de AllVideos para la colocación de los vídeos de Youtube en los artículos, pero creo que en el JED me ha parecido ver una versión de este para Joomla 1.6 llamada Plugin ALLVideosReMix 4.0.2J16 que prácticamente debe hacer lo mismo.

Lo de los mapas de Google he visto que si hay versión para la 1.6, PhocaMaps v2.0.0.

Estos dos últimos citados si me son necesarios pues se utilizan para la publicación del 95% de los artículos.

Otros plugins que me imagino que si estarán de forma nativa son: Pagebreack, Page Navigation, Readmore.

Por otro lado, sería posible seguir utilizando la plantilla Ja Purity o me vería obligado a dejarla de lado?

Mira a ver si por favor me aclaras las dudas de los párrafos subrayados.

Venga un saludo y muchas gracias.

ResponderCitar
Respondido : 11/07/2011 2:48 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Jorge,

Te comento, para intentar aproximarte al momento que viven las ramas de Joomla!.

Yo por esperar hasta el día 19 de julio no tendría problema pues estamos hablando de pocos días y si creéis conveniente empezar con Joomla 1.7 pues así lo haría, todo sea por evitar el máximo de problemas e inconvenientes.
El tema está es que todas las extensiones que he visto eran para las versiones de Joomla 1.5 y 1.6 y no he visto nada para la 1.7.

Por esperar puedes esperar y perderte las evoluciones de Joomla! y entiendo que no es tu objetivo, sobre todo porque te apremia el tiempo.

La cuestión es que se libera la 1.7 estable el 19 de julio pero eso no quiere decir que todas las extensiones portadas a 1.6 vayan a correr en 1.7, lo normal seria que si, pero aún hay algunas que están dando problemas al respecto, a lo que habría que añadir que al ser la 1.7 una rama de transición hacia la 1.8 que sera la estable de larga duración (LTS) muchos desarrolladores -lamentablemente- estan retrasando su adaptación de estas extensiones lo que sin duda es un error que nos perjudica a todos.

Como ya os he comentado mi idea era aprovechar por necesidad las ventajas del ACL integrado en Joomla y los foros Kunena por la posibilidad de crear subforos.

Por suerte el proyecto Kunena esta colaborando aceptablemente (el único que junto con AdminPraise se ha tomado en serio la migración) y podrás usar Kunena para tu Foro con total tranquilidad en la 1.7 y la 1.8, pero no puedo decir esto mismo para otras extensiones de terceros que pudieran afectar a Kunena.

Lo de los mapas de Google he visto que si hay versión para la 1.6, PhocaMaps v2.0.0.

Efectivamente así es y el equipo de desarrollo de Phoca.cz suele ser muy eficaz y liberaran versión estable de sus extensiones para la 1.7 como ya es habitual en ellos.

En principio, quizás un problema pueda tenerlo con el plugin de AllVideos para la colocación de los vídeos de Youtube en los artículos, pero creo que en el JED me ha parecido ver una versión de este para Joomla 1.6 llamada Plugin ALLVideosReMix 4.0.2J16 que prácticamente debe hacer lo mismo.

Si hace lo mismo, aunque personalmente prefiero AVReloaded (todo incluido).

Por otro lado, sería posible seguir utilizando la plantilla Ja Purity o me vería obligado a dejarla de lado?

Si miras el Showcase de JoomlArt http://www.joomlart.com/joomla/templates/showcase podrás ver las que van portando a la rama 1.6 y que por ende deberían funcionar en la 1.7, aunque ya se sabe que de momento es teoría. No obstante, torciendo en favor de JoomlArt diré que siempre procuran tener sus plantillas al día, de los que más se preocupan de este tema, a pesar de que ya han etiquetado la 1.6 como "OUT". :/

Saludos

ResponderCitar
Respondido : 11/07/2011 3:01 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jorge
 Jorge
Estimable Member

Buenas tardes Luis,

Antes que nada agradecerte tu respuesta tan detallada.

Miraré el AVReloaded que me indicas, ya que prefiero decantarme por los que me recomendéis vosotros que los conocéis antes que otros que pueda ir encontrando yo.
Y referente a la plantilla, miraré la página que me indicas a ver que saco en limpio, aunque me imagino que en el Pack de Webempresa vendrán varias disponibles donde elegir en un principio.

Me podrías aclarar por favor esta otra que es muy importante para decidir si optar por Kunena si o no.

Ya me habéis aclarado que si se pueden crear subforos pero me queda esta otra duda muy importante.
Necesitaría que algunos foros o subforos fueran ocultos y que solo se muestren a ciertos grupos de usuarios que serán diferentes unos de otros, sería posible realizar esto en Kunena?

Venga un saludo y gracias nuevamente

ResponderCitar
Respondido : 11/07/2011 3:53 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Jorge,

Decirte con respecto a AllVideos y AvReloaded que no están disponibles para Joomla! 1.6 actualmente (si en breve según desarrolladores) y la alternativa que si funciona en Joomla! 1.6 es JPlayer:

- JPlayer: http://extensions.joomla.org/extensions/multimedia/multimedia-players/video-players-a-gallery/11572

Además al ser un plugin puedes llamarlo desde módulos personalizados o artículos de contenido con una sintaxis similar a:

{flv}your-flv-video|640|480|0|1{/flv}

Que es la misma que utiliza en AllVideos o AvReloaded.

Saludos

ResponderCitar
Respondido : 11/07/2011 8:37 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Jorge
 Jorge
Estimable Member

Hola buenas tardes,

Luis, pues ese mismo usaría si está garantizado que en Joomla 1.6 funciona correctamente pues perfecto, ya que realmente es lo que importa.

Por otro lado, veo que se os ha pasado responderme a lo de la posibilidad de crear en Kunena foros o subforos que fueran ocultos y que solo se muestren a ciertos grupos de usuarios que serán diferentes unos de otros, sería posible realizar esto en Kunena?

Este tema es muy importante y por mas que he buscado no he encontrado nada que me aclare si es posible o no.

Mira a ver si por favor me aclaráis este punto.

Un saludo

ResponderCitar
Respondido : 12/07/2011 3:05 pm
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Jorge,

El tema que indicas está relacionado con el ACL, te será de utilidad ver el artículo de nuestro blog

Saludos,

ResponderCitar
Respondido : 13/07/2011 7:47 am

Cursos Gratuitos WordPress

Jorge
 Jorge
Estimable Member

Buenas tardes Jordi,

Te agradezco la información que me facilitas con este enlace pues seguro que me me va a resultar muy interesante, yo me refería a un pequeño detalle que no me aclaraba ninguna de las respuestas dadas aunque pudieran guardar relación con ello.

Al final ya he conseguido saber que sí, que en Kunena es posible crear foros y subforos que puedan quedar ocultos según nuestra propia conveniencia o interés.

Venga un saludo

ResponderCitar
Respondido : 13/07/2011 3:46 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Jorge,

Luis, pues ese mismo usaría si está garantizado que en Joomla 1.6 funciona correctamente pues perfecto, ya que realmente es lo que importa.

Si te refieres a JPlayer, decirte que si funciona en Joomla! 1.6 con total normalidad y hasta que joomlaworks (AllVideos), -al que ya he consultado- no libere la versión para 1.6/1.7 no queda más opción que decantarse por este plugin.

- JPlayer: http://extensions.joomla.org/extensions/multimedia/multimedia-players/video-players-a-gallery/11572

Saludos

ResponderCitar
Respondido : 13/07/2011 6:28 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Jorge
 Jorge
Estimable Member

Buenas tardes Luis,

Si me refería a JPlayer que me lo habías citado en una respuesta interior.

Avanzando un poco mas en este tema, ya he contratado el nuevo pack de 300MB en Webempresa, pero no voy a instalar el Joomla 1.5 para luego hacer la migración mediante JUpgrade pues creo que me resultará mas complicado y con mas riesgos de que se tuerza todo.

Me gustaría poder instalar la versión 1.6.5 pero solo está en inglés y no se lo que puede tardar que saquen la versión en castellano, así que de momento he descargado el Joomla 1.6.4 spanish para tenerlo listo para cuando me hayan activado el sitio.
Luego en cuanto aparezca la versión 1.6.5 en castellano ya lo actualizaré.

De esta manera lo tendré ya preparado para cuanto liberen la versión 1.7 y así migrar a ella contando con ese mes que dan de plazo para dejar sin asistencia Joomla 1.6.

De momento, estoy descargando las extensiones que me indicasteis que me harían falta para la 1.6 para tenerlas preparadas y en cuanto tenga el espacio activado procederé a instalarlo.

Venga un saludo

ResponderCitar
Respondido : 14/07/2011 6:03 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Jorge,

Me gustaría poder instalar la versión 1.6.5 pero solo está en inglés y no se lo que puede tardar que saquen la versión en castellano, así que de momento he descargado el Joomla 1.6.4 spanish para tenerlo listo para cuando me hayan activado el sitio.

Te recomiendo esperes unos días, total el 19 de julio sale oficialmente la 1.7 y Webempresa disponibilizará el pack traducido en su Blog por lo que no tendrás problemas en instalarlo y utilizarlo.

- https://www.webempresa.com/blog/joomla-17-preguntas-frecuentes-faqs.html

Saludos

ResponderCitar
Respondido : 14/07/2011 6:51 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jorge
 Jorge
Estimable Member

Buenas tardes Luis,

Pues de maravilla, por esperar unos días no me importa y si de esta manera puedo instalar la 1.7 directamente y en castellano, mejor todavía.

Mientras seguiré recopilando las extensiones que me hacen falta y exponiéndoos las dudas que tengo con alguna de ellas.

Un saludo

ResponderCitar
Respondido : 14/07/2011 7:45 pm
Página 1 / 2