Avisos
Vaciar todo

Hosting WordPress 70% dto Dominios promo

[Resuelto] No sé actualizar Wordpress  

Página 1 / 2
 
Javier
 Javier
Usuario activo

Hola,

Vuestro compañero Salvador Gómez me ha comentado que entrara aquí porque mi sitio web tiene la versión 4.9.24 y dice que he de actualizarla sí o sí.

No me llegan los correos de los compradores y no puedo instalar el plugin Easy WP SMTP.

Hace meses le di a la opción 'actualizar' y la web dejó de funcionar. Así que volví a como estaba anteriormente.

No tengo los conocimientos suficientes para actualizarla correctamente.

Por favor, ¿podéis decirme cómo hacerlo?

Muchas gracias.

Contenido solo visible a usuarios registrados

Respondido : 02/02/2024 12:09 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Javier.

Veo que el plugin que te causa el error es woocommerce direct checkout

.- Accede a plugins y desactiva el plugin woocommerce direct checkout y el plugin Slider Revolution

.- Empieza actualizar los plugins uno a uno.

.- Accede a Escritorio -> Actualizaciones y Actualiza WordPress

Revisa que todo cargue bien después de eso, si ves que se cae la web, por favor no hagas nada y lo indicas para que veamos donde está el problema.

Por cierto modifique la version de PHP que tenías la 7.2 y es muy baja, la cambie por la version 7.4

 

Una cosa mas, tienes que actualizar también WPBakery Page Builder y la plantilla Betheme pero eso ya es de pago y si no tienes la licencia no podrás actualizarlo directamente.

-> https://support.muffingroup.com/documentation/installation-updates/

 

Un Saludo

Respondido : 02/02/2024 3:07 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Javier
 Javier
Usuario activo

Hola, gracias por la ayuda.

 

He hecho todo lo que me has dicho y al parecer todo funciona bien, excepto que sigo sin recibir el aviso de correo de los pedidos de WooCommerce.

He hecho un pedido de prueba y no me llega el mensaje de aviso.

He instalado el plugin que decís, Easy WP SMTP, y da este error al enviar un mensaje de prueba:

Versions:
WordPress: 6.4.3
WordPress MS: No
PHP: 7.4.33
Easy WP SMTP: 2.2.0

Params:
Mailer: smtp
Constants: No
ErrorInfo: SMTP Error: Could not connect to SMTP host.
Host: studiosmastersound@gmail.com
Port: 465
SMTPSecure: ssl
SMTPAutoTLS: bool(true)
SMTPAuth: bool(true)

Server:
OpenSSL: OpenSSL 1.1.1p 21 Jun 2022
Apache.mod_security: No

Debug:
Origen del correo electrónico: Easy WP SMTP Mailer: Otro SMTP SMTP Error: Could not connect to SMTP host.

SMTP Debug:
Invalid host: studiosmastersound@gmail.com
SMTP Error: Could not connect to SMTP host.


Puedes decirme qué estoy haciendo mal?
Lo he configurado como puedes ver abajo.
Gracias.

studiosmastersound@gmail.com

SSL
 
465
 
 
smtp.gmail.com
 

 

Ajustes generales
 

Mastersound Studios

Esta publicación ha sido modificada el hace 4 meses por Javier
Respondido : 03/02/2024 11:10 am
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Javier.

Los datos no estan bien.

Servidor SMTP: smtp.gmail.com

Nombre de usuario SMTP: tu cuenta de correo.

 

Revisa la configuración y comprueba si se envia el correo de prueba.

 

Un Saludo

Respondido : 03/02/2024 12:17 pm

Javier
 Javier
Usuario activo

Gracias.

He hecho lo que me has dicho y da el error.

Versions:
WordPress: 6.4.3
WordPress MS: No
PHP: 7.4.33
Easy WP SMTP: 2.2.0

Params:
Mailer: smtp
Constants: No
ErrorInfo: SMTP Error: Could not authenticate.
Host: smtp.gmail.com
Port: 465
SMTPSecure: ssl
SMTPAutoTLS: bool(true)
SMTPAuth: bool(true)

Server:
OpenSSL: OpenSSL 1.1.1p 21 Jun 2022
Apache.mod_security: No

Debug:
Origen del correo electrónico: Easy WP SMTP Mailer: Otro SMTP SMTP Error: Could not authenticate.

SMTP Debug:
2024-02-03 12:20:43 Connection: opening to ssl://smtp.gmail.com:465, timeout=30, options=array()
2024-02-03 12:20:43 Connection: opened
2024-02-03 12:20:43 SERVER -> CLIENT: 220 smtp.gmail.com ESMTP f12-20020a0560001b0c00b0033b31040c1fsm691061wrz.65 - gsmtp
2024-02-03 12:20:43 CLIENT -> SERVER: EHLO www.mastersoundstudios.org
2024-02-03 12:20:43 SERVER -> CLIENT: 250-smtp.gmail.com at your service, [51.91.61.104]250-SIZE 35882577250-8BITMIME250-AUTH LOGIN PLAIN XOAUTH2 PLAIN-CLIENTTOKEN OAUTHBEARER XOAUTH250-ENHANCEDSTATUSCODES250-PIPELINING250-CHUNKING250 SMTPUTF8
2024-02-03 12:20:43 CLIENT -> SERVER: AUTH LOGIN
2024-02-03 12:20:43 SERVER -> CLIENT: 334 VXNlcm5hbWU6
2024-02-03 12:20:43 CLIENT -> SERVER: [credentials hidden]
2024-02-03 12:20:43 SERVER -> CLIENT: 334 UGFzc3dvcmQ6
2024-02-03 12:20:43 CLIENT -> SERVER: [credentials hidden]
2024-02-03 12:20:43 SERVER -> CLIENT: 534-5.7.9 Application-specific password required. For more information, go to534 5.7.9 https://support.google.com/mail/?p=InvalidSecondFactor f12-20020a0560001b0c00b0033b31040c1fsm691061wrz.65 - gsmtp
2024-02-03 12:20:43 SMTP ERROR: Password command failed: 534-5.7.9 Application-specific password required. For more information, go to534 5.7.9 https://support.google.com/mail/?p=InvalidSecondFactor f12-20020a0560001b0c00b0033b31040c1fsm691061wrz.65 - gsmtp
SMTP Error: Could not authenticate.
2024-02-03 12:20:43 CLIENT -> SERVER: QUIT
2024-02-03 12:20:43 SERVER -> CLIENT: 221 2.0.0 closing connection f12-20020a0560001b0c00b0033b31040c1fsm691061wrz.65 - gsmtp
2024-02-03 12:20:43 Connection: closed
SMTP Error: Could not authenticate.
Respondido : 03/02/2024 12:21 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Javier.

El error SMTP Error: Could not authenticate se debe a que los datos introducidos no estan bien.

Por lo que indican la contraseña es lo que no está bien " SMTP ERROR: Password command failed: "

Lo primero comprueba si la contraseña que estás añadiendo es la correcta.

Si es la correcta:

Tienes habilitada la autenticación de 2 factores el Gmail ?

.- accede a tu cuenta de Google:

-> https://myaccount.google.com/

 .- Accede a seguridad y comprueba Si tienes activa la verificación en dos pasos, si la tienes la desactivas.

screenshot myaccount.google.com 2024.02.03 16 19 35

 

Un saludo

 

Respondido : 03/02/2024 3:23 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Javier
 Javier
Usuario activo

Hola,

He quitado el Authenticator y luego la verificación de dos pasos y sigue saliendo el error.

La contraseña que pongo es la correcta.

No obstante, no puedo quitar esas dos protecciones porque el año pasado tuve problemas con las cuentas ya que me hackearon varias.

Qué puedo hacer?

Versions:
WordPress: 6.4.3
WordPress MS: No
PHP: 7.4.33
Easy WP SMTP: 2.2.0

Params:
Mailer: smtp
Constants: No
ErrorInfo: SMTP Error: Could not authenticate.
Host: smtp.gmail.com
Port: 465
SMTPSecure: ssl
SMTPAutoTLS: bool(true)
SMTPAuth: bool(true)

Server:
OpenSSL: OpenSSL 1.1.1p 21 Jun 2022
Apache.mod_security: No

Debug:
Origen del correo electrónico: Easy WP SMTP Mailer: Otro SMTP SMTP Error: Could not authenticate.

SMTP Debug:
2024-02-03 16:01:28 Connection: opening to ssl://smtp.gmail.com:465, timeout=30, options=array()
2024-02-03 16:01:28 Connection: opened
2024-02-03 16:01:28 SERVER -> CLIENT: 220 smtp.gmail.com ESMTP fc19-20020a05600c525300b0040fbba734f3sm3258710wmb.34 - gsmtp
2024-02-03 16:01:28 CLIENT -> SERVER: EHLO www.mastersoundstudios.org
2024-02-03 16:01:28 SERVER -> CLIENT: 250-smtp.gmail.com at your service, [51.91.61.104]250-SIZE 35882577250-8BITMIME250-AUTH LOGIN PLAIN XOAUTH2 PLAIN-CLIENTTOKEN OAUTHBEARER XOAUTH250-ENHANCEDSTATUSCODES250-PIPELINING250-CHUNKING250 SMTPUTF8
2024-02-03 16:01:28 CLIENT -> SERVER: AUTH LOGIN
2024-02-03 16:01:28 SERVER -> CLIENT: 334 VXNlcm5hbWU6
2024-02-03 16:01:28 CLIENT -> SERVER: [credentials hidden]
2024-02-03 16:01:28 SERVER -> CLIENT: 334 UGFzc3dvcmQ6
2024-02-03 16:01:28 CLIENT -> SERVER: [credentials hidden]
2024-02-03 16:01:28 SERVER -> CLIENT: 535-5.7.8 Username and Password not accepted. For more information, go to535 5.7.8 https://support.google.com/mail/?p=BadCredentials fc19-20020a05600c525300b0040fbba734f3sm3258710wmb.34 - gsmtp
2024-02-03 16:01:28 SMTP ERROR: Password command failed: 535-5.7.8 Username and Password not accepted. For more information, go to535 5.7.8 https://support.google.com/mail/?p=BadCredentials fc19-20020a05600c525300b0040fbba734f3sm3258710wmb.34 - gsmtp
SMTP Error: Could not authenticate.
2024-02-03 16:01:28 CLIENT -> SERVER: QUIT
2024-02-03 16:01:28 SERVER -> CLIENT: 221 2.0.0 closing connection fc19-20020a05600c525300b0040fbba734f3sm3258710wmb.34 - gsmtp
2024-02-03 16:01:28 Connection: closed
SMTP Error: Could not authenticate.
Respondido : 03/02/2024 4:03 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Javier.

El error como te comente antes es por que WordPress no puede establecer una conexión con el servidor SMTP.

El mismo Debug ya te indica el error " 2024-02-03 16:01:28 SMTP ERROR: Password command failed: 535-5.7.8 Username and Password not accepted. "

Revisa esta documentación e intenta generar una contraseña de aplicación:

-> https://easywpsmtp.com/docs/setting-up-the-other-smtp-mailer/#generating-app-passwords

 

Un Saludo

Respondido : 03/02/2024 4:35 pm

Cursos Gratuitos WordPress

Javier
 Javier
Usuario activo

Por fin! Ya funciona.

Puedo activar ahora el Authenticator?

Gracias por tu gran ayuda.

Estos días aprovecharé para hacerte alguna consulta más 😊 

Saludos y buen fin de semana.

Respondido : 03/02/2024 4:51 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Javier.

Genial !!! Me alegra que se solucionaras.

Puedo activar ahora el Authenticator?

Si, yo creo que no tendras problemas en activarlo.

Estos días aprovecharé para hacerte alguna consulta más

Lo que necesites aquí nos podrás encontrar 😀 

 

Un saludo y Buen Finde, descansa.......

Esta publicación ha sido modificada el hace 4 meses por Pepe
Respondido : 03/02/2024 4:58 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Javier
 Javier
Usuario activo

Hola,

Veo que no funciona el plugin Slider Revolution.

Cuando intento actualizarlo me da este error:

 

Updating Plugin: Slider Revolution

Descargando la actualización desde http://api.muffingroup.com/plugins/download.php?code=43dd105b-a505-43fc-9c9e-aea8a904a362&plugin=revslider

Descomprimiendo la actualización…

Instalando la última versión…

No se ha podido descomprimir el paquete. El paquete no contiene archivos.

Ha fallado la actualización del plugin.

La verdad es que este plugin lo necesito.

Qué ha pasado para que ahora no funcione?

 

Gracias.

Respondido : 05/02/2024 3:55 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Javier.

Lo que te indica es que el paquete de actualización no contiene archivos y no puede hacer la actualización.

Una opción es que lo descarges manualmente:

-> https://www.sliderrevolution.com/faq/quick-setup-slider-revolution/

Una vez descargado:

.- Accede a tu cuenta de wePanel -> Administrador de archivos

.- Accede a la carpeta donde tienes la instalación

.- Accede a wp-content -> plugins

 .- Renombra la carpeta del plugin Revolution

.- Sube el archivo comprimido que te descargaste

.- Descomprime el archivo y lo revisas

 

Ten en cuenta que el plugin es de pago y para actualizarlo necesitas la licencia del plugin.

 

Un Saludo

Respondido : 05/02/2024 4:08 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Javier
 Javier
Usuario activo

Gracias, pero yo nunca pagué por este plugin.

Si me dices que es de pago no lo instalo. No estoy para gastos actualmente.

Antes estaba en INICIO, pero ahora veo que arriba sale esto: [rev_slider_vc alias=”slider”]

Qué hago para que no salga? He desinstalado Slider Revolution pero sigue apareciendo ese texto.

Por eso no quería actualizar mi web, porque me temía que habría plugins que eran gratis que ahora serían de pago...

 

 

 

 

Respondido : 05/02/2024 4:18 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola javier.

porque me temía que habría plugins que eran gratis que ahora serían de pago...

Puedes descargar la última version de la plantilla:

-> https://themeforest.net/item/betheme-responsive-multipurpose-wordpress-theme/7758048

Una vez descargada descomprimes el archivo que se descarga y dentro de la carpeta plugins tienes que tener la última version del plugin Rev Slider

Qué hago para que no salga? 

Edita la página donde tienes el Slider y elimina el ShortCode que carga el Slider "  [rev_slider_vc alias=”slider”] "

 

Un Saludo

Respondido : 05/02/2024 4:35 pm

Javier
 Javier
Usuario activo

Gracias, pero no tengo tantos conocimientos como para hacer lo que dices.

He borrado el texto [rev_slider_vc alias=”slider”] de chiripa, porque no me entero mucho del WP.

La página me la hizo una empresa que ya no existe y yo la llevo como puedo.

Veo que me he quedado sin el Revolution Slider. La verdad es que me gustaba. Qué se le va a hacer...

Estos días iré haciendo cosas e la web para ver que todo funcione correctamente y te cuento.

Gracias por la ayuda.

 

Respondido : 05/02/2024 4:48 pm
Página 1 / 2