Url amigables en wordpress  

Página 1 / 2
 
Jose
 Jose
Usuario eminente

Estimado Sr.:
Quisiera que cuando click en un post de mi web, en la barra de navegador aparezca la url amigable con el título del post. He señalado las opciones dentro de ajustes de enlaces permanentes pero sigue apareciendo el número de entrada. ¿ qué tengo que cambiar ? Muchisimas gracias.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 14/01/2013 2:47 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Jose

Envía una captura de pantalla para ver cómo tienes configurado actualmente

Puede utilizar alternativamente el formato personalizado :

/%category%/%postname%/ 

y verfica si te funciona

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 14/01/2013 8:20 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Jose
 Jose
Usuario eminente

Hola Jon:
Adjunto le envio la captura de pantalla de cómo está configurado. Es que no puedo configurarlo en modo personalizado, porque cuando pongo postame como tu me dices , resulta que al guardarlo , se me cambia y se me señala la opción de arriba. Muchas gracias.

ResponderCitar
Respondido : 15/01/2013 9:14 am
David Noguera
 David Noguera
Miembro Admin

Hola Jose, debes de marcar la opción de estructura personalizada y colocar lo que te ha indicado Jhon.

Si no se guardan los cambios, revisa que los permisos de los ficheros wp-settings.php y wp-config.php están en 644 desde el administrador de ficheros de tu cPanel.

Gracias

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 15/01/2013 11:11 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Jose
 Jose
Usuario eminente

Hola Jon o David:
Los permisos de esos archivos están en 644, adjunto captura. No se que pasa pero señalo la opción personalizada con el /%postname%/ y no se me guarda. Ayuda por favor. A ver qué es lo que tengo mal. Muchisimas gracias.

ResponderCitar
Respondido : 15/01/2013 12:09 pm
David Noguera
 David Noguera
Miembro Admin

Hola Jose, veo que los permisos del fichero .htaccess están en 777, no debería haber ningún fichero con esos permisos, quizás tenga que ver.

Hemos pasado una revisión de permisos a la cuenta de tu cPanel y

-- Hemos encontrado los siguientes ficheros que no tenían permisos 644 y los hemos corregido:

/home/fotodenu/public_html/elegireleito.com/.htaccess
/home/fotodenu/public_html/elegireleito.com/.ftpquota
/home/fotodenu/public_html/.ftpquota
/home/fotodenu/public_html/administrator/components/com_akeeba/backup/site-fotodenuncias.info-20121105-130504.zip
/home/fotodenu/public_html/administrator/components/com_akeeba/backup/akeeba.backend.log
/home/fotodenu/public_html/cgi-bin/entropybanner.cgi
/home/fotodenu/public_html/cgi-bin/cgiemail
/home/fotodenu/public_html/cgi-bin/cgiecho
/home/fotodenu/public_html/cgi-bin/randhtml.cgi
/home/fotodenu/public_html/modules/mod_menu/helper.php
/home/fotodenu/public_html/modules/mod_menu/mod_menu.php
/home/fotodenu/public_html/modules/mod_menu/index.html
/home/fotodenu/public_html/modules/mod_menu/tmpl/default_component.php
/home/fotodenu/public_html/modules/mod_menu/tmpl/default.php
/home/fotodenu/public_html/modules/mod_menu/tmpl/default_separator.php
/home/fotodenu/public_html/modules/mod_menu/tmpl/index.html
/home/fotodenu/public_html/modules/mod_menu/tmpl/default_url.php
/home/fotodenu/public_html/modules/mod_menu/mod_menu.xml
/home/fotodenu/public_html/configuration.php

Check Permisos en directorios incorrectos ...

-- Hemos encontrado los siguientes directorios que no tenían permisos 755 y los hemos corregido:

/home/fotodenu/public_html/images/.tmb
/home/fotodenu/public_html/site-fotodenuncias

Prueba de nuevo a ver si te deja cambiar esa opción.

Saludos!

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 15/01/2013 12:28 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jose
 Jose
Usuario eminente

Hola David, sin resultado alguno. En el campo de estructura personalizada dentro de ajustes de enlaces permanentes, tengo insertado /%postname%/ , pues cuando le doy a guardar, automáticamente se me señala la opción de arriba "nombre de entrada". No me deja guardar!!!!!
Qué puede ser. ???? Muchas gracias.

ResponderCitar
Respondido : 15/01/2013 1:01 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Jose,

¿Que versión exacta de WordPress tienes?

Verifica que tengas archivo .htaccess correcto en tu instalación de WordPress y que incluya:

RewriteEngine On
RewriteBase /carpeta donde tengas instalado WP/
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /carpeta donde tengas instalado WP/index.php [L]

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 15/01/2013 2:54 pm

Cursos Gratuitos WordPress

Jose
 Jose
Usuario eminente

Hola Luis:
Exactamente esto es lo que hay dentro de .htaccess :

# BEGIN WordPress

RewriteEngine On
RewriteBase /
RewriteRule ^index.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]

# END WordPress

ResponderCitar
Respondido : 15/01/2013 11:19 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Jose,

Creo que en mi código te puse claro que el RewriteBase y RewriteRule deben apuntar a la ruta donde este tu WordPress.

RewriteBase /carpeta donde tengas instalado WP/

Si tu WP está en la ruta: public_html/elegireleito.com entonces algo falla en tu código ¿no?.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 16/01/2013 12:39 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Jose
 Jose
Usuario eminente

Hola Luis, sin resultado alguno. ¿ Podrían indicarme qué tengo que cambiar para hacer mis url amigables? Modifico archivo htaccess tal y como me dicen, poniendo la carpeta donde está el wp instalado y le doy a guardar. De seguido voy a mi pagina de administrador , ajustes de enlaces permanentes, selcecciono opcion personalizada con /%postname%/ y le clikeo en guardar, pues justo cuando clik en guardar, se me señala la opción que hay justo encima. No lo entiendo, cómo lo hace la gente??... Muchas gracias.

ResponderCitar
Respondido : 17/01/2013 10:37 am
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Jose,

Para habilitar urls amigables en WordPress debes proceder como sigue:

1. Accede al panel de administración de WordPress ( http://tudominio.com/wp-admin).
2. Configuración (Settings).
3. Permalinks.
4. Selecciona el formato de URL deseado entre las distintas opciones que te ofrece la aplicación. La más recomendable es la que incorpora la fecha de publicación y el título del post.

Verifica si tras esto dispones de URLS más amigables en tu Blog.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 17/01/2013 2:39 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Jose
 Jose
Usuario eminente

Hola Luis , muchas gracias antes de nada. Se me está haciendo largo esto de las url amigables. Te explico. En el caso de señalar la fecha y el nombre, sí que queda guardado, pero cuando vuelvo a la web y clickeo en la entrada, en el título, me sale mensaje diciendo algo así como que no encuentro lo que estoy buscando.... El caso es que tengo muchas ganas de seguir publicando en mi nuevo blog y no quiero hacerlo hasta que no tenga bien configurado las url. Algun error debe haber en algún sitio, ¿no?

ResponderCitar
Respondido : 18/01/2013 9:17 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Jose,

En vez de poner en la estructura personalizada /%postname%/, ¿ has probado a utilizar %postname% ?

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 18/01/2013 9:29 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jose
 Jose
Usuario eminente

Hola Jordi:
¡¡¡¡¡ Bien !!!! ya por lo menos cuando hago click en guardar, se me guarda correctamente. Pero vuelvo al blog, hago click en la entrada y en la barra de navegador, no aparece url amigable, sigue saliendo el nº 29. A ver si tu sabes que puede ser. Por lo menos ya me deja guardar la estructura personalizada!!! Muchíiiiiisimas gracias. A ver si damos con la tecla. Un saludo.

ResponderCitar
Respondido : 18/01/2013 10:19 am
Página 1 / 2

Por favor Iniciar Sesión o Registro