Activar la compresión Gzip de nuestra plantilla?  

Página 1 / 2
 
Jose Mª Martínez
 Jose Mª Martínez
Usuario activo

Hola a todos, os hago una preguntilla a ver si podéis ayudarme: es recomendable activar la compresión Gzip de nuestra plantilla? yo supongo que si, pero desconozco las ventajas y desventajas de hacerlo.

Un saludo y gracias.

Citar
Respondido : 28/05/2010 3:40 pm
David Noguera
 David Noguera
Miembro Admin

Hola Charlibrawn,

si estas desarrollando la plantilla te recomiendo que no la actives, ya que puede dificultar el acceso a los CSS, saber que fichero hay que modificar, etc.. Yo uso Firebug que me dice en que fichero está cada selector, y la compresión gzip, puede dificultarte esta tarea.

Una vez en producción acelera la carga de la página, reduce el número de peticiones HTTP y reduce el tamaño de los ficheros CSS. Si tu plantilla es sencilla no se notará mucho, pero si estás usando plantillas más complejas como la JA Teline III que tiene mucho Javascript y mucho CSS, si puede que lo notes, sobre todo con usuarios con conexiones lentas.

Saludos.

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 28/05/2010 3:51 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Jose Mª Martínez
 Jose Mª Martínez
Usuario activo

Hola David, gracias por tu rápida respuesta. Yo utilizo una plantilla de Yootheme, y en el apartado de preferencias de la plantilla viene esa opción, que actualmente la tengo desactivada y tenía la duda de si activarla o no.

Un saludo.

ResponderCitar
Respondido : 28/05/2010 3:55 pm
David Noguera
 David Noguera
Miembro Admin

Pues tú mismo, el cambio no es brutal pero ayuda a que la página cargue un poco más rápido. Si a esto le sumas otras optimizaciones como usar un CDN externo en un dominio diferente para cargar los fichero estáticos (imagenes, css,js), activar la caché del sitio y alguna otra optimización más.. puedes conseguir más velocidad de carga.

Saludos.

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 28/05/2010 3:59 pm

Cursos Gratuitos WordPress

Lucas
 Lucas
Miembro Admin

Hola,

Supongo que te refieres a activar la compresión gzip de joomla, si, es un buen sistema aunque no en todos los hostings te funcionará. Nosotros recomendamos activarlo siempre.

Al activar la compresión gzip el html, css y javascript entre el servidor y el navegador del cliente viaja zipeado, en la mayoría de los casos notarás una mejora en velocidad.

Una vez tengas tu joomla finalizado también es conveniente que actives la cache en la configuración general y en todos los módulos que no muestren contenido que quieras que esté actualizado en todo momento. Recuerda que si activas el cache tendrás que vaciar el cache desde tu administración si haces un cambio y no lo ves visible al momento. En las webs que no cambian mucho también recomendamos activar el cache y poner 1440 minutos como tiempo de cache para que se actualice el cache cada 24 horas.

Aquí puedes encontrar varios tips sobre como optimizar tu joomla:

http://www.joomlaperformance.com/articles/performance/so_you_want_to_speed_up_joomla_3_14.html

http://www.joomspot.net/how-to-speed-up-optimize-joomlas-performance.html

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 28/05/2010 4:01 pm
Jose Mª Martínez
 Jose Mª Martínez
Usuario activo

Gracias David y Lucas, me ha sido de gran ayuda vuestra explicación.
Un saludo y probaremos lo que me habéis comentado.

ResponderCitar
Respondido : 28/05/2010 4:30 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Vicente
 Vicente
Usuario activo

Hola a todos.

Primeramente felicitar al equipo de webempresa (en especial a Lucas 😉 ) por el trabajo que estan realizando.

Para optmizar la pagina web (plantilla teline iii) he seguido todos vuestros consejos, gzip si, cache si con 15 minutos, y tras leer los dos articulos que recomienda Lucas he optimizado las tablas de la base de datos.

El modulo janews2 me arroja un error en la llavecita cuando no se esta registrado. ¿Donde he cometido el error y como resolverlo?

Otra pregunta, ¿si pongo a "si" todos los parametros de optmizacion de seo renombrando el archivo htaccess.txt y me diese problemas , podria deshacer los cambios en la pagina sin consecuencias irreversibles o debo hacer copias de seguridad primeamente?

Unsaludo a todos

ResponderCitar
Respondido : 15/06/2010 12:39 am
Lucas
 Lucas
Miembro Admin

Hola Guitart,

Gracias por las felicitaciones, nos alegramos que te guste nuestro foro. 😉

Respecto a lo que comentas, ok cache si 15 minutos pero yo aumentaría el cache al tiempo que realmente actualices noticias, por ejemplo si actualizas a diario puedes poner 1.440 minutos = 24 horas, etc, por otro lado recuerda que en todos los módulos debes activar el cache si no es necesario que se refresque esa información al momento y decidir el tiempo o bien indicar que use la configuración global de cache.

No entiendo lo de la llavecita del módulo janews2, entiendo que te refieres al front end (la parte del usuario y no la de administración), presupongo que es porque muestras artículos que son para usuarios registrados, si no es así envía mejor la url para que podamos ver el error.

Si pones SI a los tres valores de SEO (Optimización para buscadores) aunque te falle podrás seguir entrando en la configuración, de todos modos, los tres valores están en el configuration.php por lo que también podrías editar el configuration.php y volver a dejarlo como estaba, te recomiendo que ante estos cambios realices siempre un backup, en este caso no es imprescindible pero más vale prevenir que curar. 😉

Estos vídeos te pueden ser útiles para hacer backups con Akeeba Backup:
https://www.webempresa.com/videos/akeeba_copiadeseguridad/akeeba_copiadeseguridad.html
https://www.webempresa.com/videos/akeeba_restauracion/akeeba_restauracion.html

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 15/06/2010 1:47 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Vicente
 Vicente
Usuario activo

Hola de nuevo.

Los articulos que se muestran en el janews2 son publicos. En la imagen veras a que me refiero con la llavecita.

En cuanto a los parametros seo hae una copia del archivo configuration.php, hare copia de BD y seguire tus consejos.

Por ciero, me parece que me voy a enganchar a este foro. Un saludo a todos.

ResponderCitar
Respondido : 15/06/2010 2:32 am
Lucas
 Lucas
Miembro Admin

Hola,

Respecto al ja-news2 creemos que debes tener el plugin System - JA User Setting publicado solo para usuarios registrados, mira si es eso, deja el plugin con acceso público y dinos si te funciona así.

Ok configuration.php.

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 15/06/2010 2:55 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Vicente
 Vicente
Usuario activo

Hola a todos.

El plugin esta bien (publico). He reinstalado el janews2 y nada. El codigo solo sale cuando no se esta registrado y el error partio cuando puse si a cache, si a gzip, y al optimizar las tablas de la BD.

Otro problema que he tenido es que dar si a todos los parametros seo de la configuracion y modificar el htaccess.txt he perdido la ruta de todas las imagenes y no salen. Antes de eso tuve que modificar el .htaccess ya que cuando activo la url amigable me da error 404.

Muchos problemas y os agradeceria algo de ayuda.

Un saludo

ResponderCitar
Respondido : 15/06/2010 7:34 pm
Lucas
 Lucas
Miembro Admin

Hola,

Vayamos por partes:

1º Desactiva el cache de la configuración global y del módulo ja-news2 si lo tienes activado.
2º Desactiva las tres opciones de SEO dejándolas las tres a NO.
3º Ves a Herramientas - Limpiar la Cache.

Dinos si así te funciona el ja-news2.

En el caso que funcione activa el seo y verifica si sigue funcionando.

Envíanos una url del sitio ya que lo de las imágenes que comentas tendríamos que verlo en la url.

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 15/06/2010 7:38 pm

Cursos Gratuitos WordPress

Vicente
 Vicente
Usuario activo

Hola Lucas

No funciona tampoco asi el janews2.

Lo que si se ha corregido es lo de las imagenes, ya que he vuelto a dejarlo todo como estaba.

Un saludo

ResponderCitar
Respondido : 15/06/2010 9:59 pm
Lucas
 Lucas
Miembro Admin

Hola,

Ok, pues tocará seguir haciendo pruebas, yo haría lo siguiente:

Instalar un nuevo joomla con esta plantilla y ver si en uno nuevo te pasa lo mismo, no se que versión de Joomla usas.

Entiendo que la plantilla es original bajada de joomlart, hemos utilizado más de 20 teline III y en ninguna tenemos este problema.

Si la plantilla es original y instalando un joomla limpio te va bien ya sabes que el problema es de algo de tu joomla actual y podrás comparar uno con el otro.

Yo tiraría por aquí.

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 16/06/2010 1:58 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Vicente
 Vicente
Usuario activo

Hola Lucas.

El problema que tengo con las url amigables es que la imagenes no encuentran la ruta correcta, es decir que la ruta que deberia de ser esta: Contenido solo visible a usuarios registrados

me la convierte a: http://www.midominio.com/ carpeta/subcarpeta/images/resized/images/stories/gestion/clavespuzzle.jpg en donde como puedes ver se ha incluido en la ruta y por tanto no las localiza.

He leido algo sobre rutas relativas, y no se muy bien si puede tener algo que ver.

Si usas rutas amigables del tipo misitio.com/categoria/miproducto
Las rutas relativas que antes llamaban a las imágenes, hojas de estilo y javascript dejan de funcionar ya que se asume que estás dentro de una carpeta la solución más simple desafortunadamente no funciona bien en IE6(cuando no)
1

Esa simple linea de codigo hace que el browser se olvide de tu ruta actual y unicamente use el path que asignas

Ya que la solución más práctica no es crossbrowser hay que cambiar todo a rutas absolutas para no tener que hacerlo a mano para ello creamos una constante con nuestro path absoluto
1

define("_mipath", "http://www.misitio.com/")

Y para agregarlo a nuestros archivos sería
1

<img src="miimagen.jpg">

Hacerlo no es tan traumático como parece ya que imagino estás usando una web modular y basta modificar unos cuantos archivos sin web modular no veo como puedas usar url amigable

Y otro comentario comenta que lo soluciono asi:

Una solución sería cambiar el href por una dirección absoluta, pero a mi modo de ver es una solución cutre. Tiene que haber alguna otra opción para hacer esto elegantemente.

¿Alguien podría explicar cómo?

Un saludo!

EDIT: ¡¡¡SOLUCIONADO!!!

Joder, menuda tontería... Era simplemen

te añadiendo dentro de la siguiente etiqueta:

Me gustaria colocar url amigables pues noto que la pagina va mejor y tengo entendido que es mejor para los motores de busqueda, pero si no encuentro la solucion tendre que dejarlo como esta que por cierto ha mejorado muchisimo despues de leer vuestros consejos.

Un saludo de VCA

ResponderCitar
Respondido : 16/06/2010 2:50 pm
Página 1 / 2

Por favor Iniciar Sesión o Registro