como se pueden añadir las imagenes de menu  

Página 1 / 4
 
david
 david
Reputable Member

Hola a todos.
Mi pregunta es como se pueden añadir las imagenes de menu en la pagina, en concreto en ja_zeolite.

El problema que estoy experimentando, tal y como me comento anteriormente un compañero vuestro de como tenia que hacerlo, es que no me aparece el menu principal de la web como un modulo donde pueda decidir si quiero o no ver las imagenes.

Modifico los items del menu, pero creo que hay algo en la web que hace que ese menu en concreto no se muestre, ya que anteriormente a esta plantilla tenia instalada la de it_automag.

Si intento hacer esto en el menu izquierdo, si que puedo porque me lo identifica como un modulo.

Me guustaria ppder insertar alguna imagen en este menu, pero me veo negado porque no soy capaz de encontrarlo.

Gracias por adelantado.

Y tu, ya practicas el e-compring?
From webdelop.com

Citar
Respondido : 27/09/2010 8:48 pm
Leonel Cantón
 Leonel Cantón
Estimable Member

Que tal davidsg3,

Desde el administrador de módulos, te debería de aparecer algún modulo que maneje el menú superior, debes buscar los que sean del tipo mod_mainmenu (haz el filtro para que sea más fácil verlo), te deberia quedar como esta en la imagen

Y luego revisa que exista un módulo de menú en la posición que deseas (en esta maquina no tengo dicho template para decirte como se llama dicha posición), pero la podrías averiguar con index.php?tp=1.

Adicionalmente a esta verificación, revisar la configuración del menu (configuración del módulo anterior) y revisa que en “parametros avanzados“ -> “Sufijo de clase del menú“ no tenga nada o tenga ja_splitmenu.

Saludos,

Leonel

ResponderCitar
Respondido : 27/09/2010 9:00 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

david
 david
Reputable Member

hola leonel.

Ya lo he mirado todo y me estoy volviendo loco.
me acabo de dar cuenta ademas que en la edicion d ela plantilla, si coloco el tipo de menu en css no me sale la imagen, y en cambio si lo pongo como split menu, si sale la imagen pero rota.

Algo muy extraño, la verdad.No soy capaz de encontrar ese menu, puesto que todos los demas si quedan como modulos menos el principal.

y cuando selecciono una busqueda para mainmenu, el que necesito editar no sale.

Y tu, ya practicas el e-compring?
From webdelop.com

ResponderCitar
Respondido : 27/09/2010 9:06 pm
Leonel Cantón
 Leonel Cantón
Estimable Member

En la imagen que adjuntas aparece “Menu Principal“, entonces cual es que no te aparece?

Por cierto que mas detalles aparecen en la tabla, me interesa ver el del menú principal.

El hecho de que te salga cortada, puede ser porque las imágenes que estas probando son muy grandes, o porque has editado algo mas en el css del tema.

Saludos,

Leonel

ResponderCitar
Respondido : 27/09/2010 9:10 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

david
 david
Reputable Member

la posicion del menu, teoricamente, es la de ja_menu.
Pero es que igualmente esa posicion, en mi administrador de joomla no aparece, y en cambio el menu esta puesto donde toca.

Creo que hay algun parametro que descuadra a otro y afecta al menu.
Ya me ha psado con alguna otra template /yagendoo/ donde el menu principal ni aparecia, cambiando la template de it_automag que tenia por esa.

Otra cosa que me pasa es que si cambio a split menu sin imagenes, los menus se salen del espacio que deberian ocupar (se salen de la caja) y quedan por debajo.

que estresssss

Y tu, ya practicas el e-compring?
From webdelop.com

ResponderCitar
Respondido : 27/09/2010 9:12 pm
david
 david
Reputable Member

los detalles de la tabla en referencia a mainmenu son estos

Y tu, ya practicas el e-compring?
From webdelop.com

ResponderCitar
Respondido : 27/09/2010 9:14 pm

Cursos Gratuitos WordPress

david
 david
Reputable Member

Es curioso porque dentro de la edicion de la plantilla, si cambio el menu type de mainmenu como esta ahora, con los menus de la pagina; a other menu (que son los campos del menu principal alojado a la izquierda), bien se cambian.

Si deshabilito el menu principal se me borra el menu de la izquierda, y cuando voy y busco el "mainmenu", me sale despublicado el que en teoria esta funcionando porque ademas es un menu ice_mod_menu, provinente de it_automag.

es un embrollo considerable.

Y tu, ya practicas el e-compring?
From webdelop.com

ResponderCitar
Respondido : 27/09/2010 9:21 pm
Leonel Cantón
 Leonel Cantón
Estimable Member

En esta última imágen aparece que el menú principal está publicado en la posición left o izquierda, el hecho de que se llame izquierda no garantiza que este a la izquierda. Puede estar pasando que en tu otro template la posición izquierda estaba ubicada en la cabecera en cambio en ja_zeolite no se llama así.

La verdad no estoy seguro (no tengo el template a la mano) la posición donde debería de estar el menú principal es top y no left.

Para solucionar el problema el primer paso es ver que salga el menú donde debe y con las imágenes, el segundo paso seria ubicarlas bien para que no se salgan de la caja que mencionas.

Saludos,

Leonel

ResponderCitar
Respondido : 27/09/2010 9:21 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

david
 david
Reputable Member

Gracias leonel.

Lo que estoy sopesando es de desinstalar algunos modulos y volver a crearlos de nuevo, con los menus desde el inicio. Esta claro a veces que querer aprovechar el trabajo solo hace que doblarlo.

A ver si me aclaro con todo lo que tengo, que no es poco
Gracias

Y tu, ya practicas el e-compring?
From webdelop.com

ResponderCitar
Respondido : 27/09/2010 9:24 pm
Leonel Cantón
 Leonel Cantón
Estimable Member

Yo te recomendaría mejor que probaras instalando en local otro Joomla y allí hicieras los cambios para veas como funciona todo y luego replicar los cambios en tu sitio de producción (si es que es eso sobre el que estas trabajando, lo cual no es aconsejable)

Saludos,

Leonel

ResponderCitar
Respondido : 27/09/2010 9:25 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

david
 david
Reputable Member

Leonel, acabo de hacer un tp=1 y la posicion que ocupa el menu no tiene asignado ningun nombre, a diferencia de las demas.
te adjunto una captura para que lo veas, pues es para mi super extraño!

Y tu, ya practicas el e-compring?
From webdelop.com

ResponderCitar
Respondido : 27/09/2010 9:31 pm
Leonel Cantón
 Leonel Cantón
Estimable Member

Eso estaba viendo, y también aparecen unas posiciones abajo del formato verde (en el ejemplo) que no se logran leer. Lo más seguro es ir al código fuente (index.php) del tema y ver que posición tiene asignada, nos podrías incluir ese fragmento de código para verlo (aproximadamente donde aparece el div header)

Saludos,

Leonel

ResponderCitar
Respondido : 27/09/2010 9:44 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

david
 david
Reputable Member

hola leonel.

te paso el codigo:

por lo que yo he visto, es el ja_header...

que sorprendentemente a mi no me sale como posicion

 
	
You are here:

e-compring

Respondido : 27/09/2010 9:57 pm
Leonel Cantón
 Leonel Cantón
Estimable Member

El código que me interesa ver, es el que esta en templates/ja_zeolite/index.php y no el que se genera en tu web. Es decir ve abre el archivo con tu editor predilecto y nos copias el código de allí.

Saludos,

Leonel

ResponderCitar
Respondido : 27/09/2010 10:01 pm

Cursos Gratuitos WordPress

david
 david
Reputable Member

okokok

Y tu, ya practicas el e-compring?
From webdelop.com

ResponderCitar
Respondido : 27/09/2010 10:02 pm
Página 1 / 4

Por favor Iniciar Sesión o Registro