Editar articulos  

Página 1 / 2
 
Antonio
 Antonio
Estimable Member

alguien me pudiera ayudar para sabe porqu me esta poniendo esto, volvi a instalar mi servidor localhost en mi PC instale mi plantilla, instale mis componentes entre ellos el JCE despues importe mi BD que cuenta con mis datos originales y que son los que tengo en producción en mi sitio remoto (Hosting) pero a la hora que quiero editar mis articulos me marca esto que anexo y no se a que se debe ????

Ojala me puedan ayudar ????

Citar
Respondido : 01/10/2010 7:27 am
Jose Miguel
 Jose Miguel
Estimable Member

Hola compañero, te dire que tienes que hacer, es fácil;

Te vas a tu joomla y buscas la siguiente ruta :huh: :

ejemplo :blink: .- c:...tujoomlalibrariesjoomlahtmleditor.php

Abres con notepad o worpad y editas :dry: .

Busca sobre el final del archivo, esta secuencia o instruccion :cheer: ;

// Try to authenticate
$result[] = $plugin->onDisplay($editor);

....buscala que está, solo cuesta de encontrarla un poco, bien después, seleccionas desde las "//" hasta ";" ambos inclusive y lo sustituyes por esta otra instrucción ;

// Try to authenticate
if (method_exists($plugin, 'onDisplay')) {
$result[] = $plugin->onDisplay($editor);
}

....todo hasta el corchete "}" y lo dejas tal cual, y asunto resuelto.

Al pacerecer es de un pluging que ya no esta en nuestra instalación, esto es debido a actualizaciones o desplazamientos de un joomla a otro lugar, etc.

Espero que te sirva 😉 , ya me cuentas, a mi me funcionó :woohoo: . "aqui hay que buscarse la vida como sea, jejejeje 😆 "

Nota.- Post Editado, corrijo ruta, quise decir "tujoomla" y no "tutemplate"

Un salu2

ResponderCitar
Respondido : 01/10/2010 12:59 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Antonio
 Antonio
Estimable Member

Kenedi te anexo el error y el archivo donde hice las modificaciones ya que ahora es otro error el que me arroja

Parse error: parse error, expecting `T_FUNCTION' in C:wampwwwD34librariesjoomlahtmleditor.php on line 320

justamente es lo ultimo la ultima llave que esta cerrando las instrucciones, ojala me puedas apoyar ?????

ResponderCitar
Respondido : 01/10/2010 8:08 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola atalavera,

Adjunta tu archivo editor.php para que lo podamos revisar y ver si tienes algún error sintáctico, ya que ese "parse" apunta a eso.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 01/10/2010 9:02 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Antonio
 Antonio
Estimable Member

Claro que si GANUMAX haber que puede tener:

 

Link a post de foro, solo visible a usuarios registrados
This post was modified hace 6 meses por antonio
ResponderCitar
Respondido : 01/10/2010 9:19 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola

He revisado el archivo editor.php y es exactamente igual al original del pack, o sea no ha cambiado nada, no obstante te he cambiado la codificación del mismo. Bájatelo, (comprime previamente tu editor.php en tu WAMPP) y sustitúyelo por el que te adjunto y prueba de nuevo a ver si sigue marcando el parse.

En caso de que siga marcando el parse mira si tiene errores en tus logs y sino en tu configuración global habilita el modo depuración a ver que más cosas salen en esa pantalla donde te muestra el error.

P/D: GANUMAX 🙁 gnumax 🙂

Saludos

Link a post de foro, solo visible a usuarios registrados
This post was modified hace 6 meses por antonio

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 01/10/2010 9:45 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Antonio
 Antonio
Estimable Member

Si gracias GNUMAX hago la prueba y lo comento para haber que pasa ahora ????

ResponderCitar
Respondido : 01/10/2010 11:19 pm
Jose Miguel
 Jose Miguel
Estimable Member

Hola de nuevo, te pregunto, hiciste lo que te dije?, el error te vino despues? comprobaste que tuviesen todos los "{" que no faltase ninguno?, :dry: :blush: , solo que directamente te salio ese error?, no se, dime que hicistes porque creo que te comistes un "{", aunque gnumax, entiende de esto un monton, pero alguien no ha jugado a los 8 errores? pues esto es algo similar con tu anterior editor.php.
Si ya te han pasado uno que marcha bien...di como quedó la cosa.

Salu2

ResponderCitar
Respondido : 02/10/2010 1:49 am

Cursos Gratuitos WordPress

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Kenedi,

Por la parte que me toca yo me he limitado a ver la primera captura que adjunto y ver que tiene problemas de codificación (posiblemente guardada en ANSI) que es como yo encontré el archivo cuando lo envió, le cambie la codificación a UTF-8 y espero que le resuelva la situación.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 02/10/2010 2:08 am
Antonio
 Antonio
Estimable Member

GNUMAC, KENEDI el archivo que me enviaste gnumax ya loprobe pero sigue con el mismo error, solo que lo estuve revisando y esta también igual que el original ganumax ?????

como se me hacen complicados estos problemitas cuando se ve que es algo muy facil pero no queda ???

Fatal error: Call to undefined method stdClass::onDisplay() in C:wampwwwD34librariesjoomlahtmleditor.php on line 268

ResponderCitar
Respondido : 02/10/2010 3:36 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola atalavera,

He hecho una modificación en el archivo editor.php, bájalo y prueba nuevamente a ver si ahora te funciona.

Saludos

Link a post de foro, solo visible a usuarios registrados
This post was modified hace 6 meses por antonio

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 02/10/2010 4:56 am
Antonio
 Antonio
Estimable Member

GANUMAX mira ya logre corregir lo del priemr error que me parcaba pero ahora me marca:

Parse error: parse error, expecting `T_FUNCTION' in C:wampwwwD34librariesjoomlahtmleditor.php on line 319

Anexo parte del código que la linea 319 es en el final en la llave pero no le encuentro algo de raro ??? a que se debe este error GANUMAX de T_FUNCTION.

ResponderCitar
Respondido : 02/10/2010 5:06 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Antonio
 Antonio
Estimable Member

lo que vi de diferente GANUMAx y por lo que comentaste en un mensaje que lo cambie a la codificación a UTF-8 porque no estaba grabado asi pero la verdad ya no se que pasa imaginate cada que me marque un error de estos volvere a hacer el sitio jajajaja la primer vez asi me paso y si tuve que volverlo hacer ???? nimodo.

ResponderCitar
Respondido : 02/10/2010 5:12 am
Antonio
 Antonio
Estimable Member

Efectivamente GANUMAX y KENEDI la solucion a esto es modificar las lineas en el archivo editor.php que mencionaste KENEDI y ademas grabarlo como lo hizo GANUMAX con la codificación UF-8 fabuloso ya lo puedo ver de maravilla heeeee Feliciades el merito es para los 2 chicos.

Saludos y gracias por el apoyo

ResponderCitar
Respondido : 02/10/2010 6:18 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jose Miguel
 Jose Miguel
Estimable Member

Las gracias para gnumax 😉 , él es el figura :woohoo: , yo solo me limité a darte solución a un problema idéntico que tuve y que solucione con la modificación del archivo "editor.php", gracias a otro foro :blush: (pero en inglish). De todos modos, Gnumax te fuese dado la solución, solo que yo me adelanté 😆 , la verdad me alegro, gracias a gente como gnu, hacen que este foro, sea el mejor de foro de habla hispana de joomla existente, ya que hay un buenísimo nivel, seguid así, mis felicitaciones a todos.

Un salu2

ResponderCitar
Respondido : 02/10/2010 10:22 am
Página 1 / 2

Por favor Iniciar Sesión o Registro