Enlaces sobre imágenes  

 
José Manuel Rodríguez
 José Manuel Rodríguez
Usuario experto

Hola a todos.

El problema que tengo es que tengo en mi web varios enlaces con imágenes, que en todos los navegadores, excepto IE, sale una linea gruesa delimitando el enlace.

¿Se puede quitar esta linea, sin afectar al enlace?

Saludos

José Manuel Rodríguez

Los podéis ver en mi web: www.agricolacarmonense.es

José Manuel Rodríguez

Citar
Respondido : 08/10/2010 12:54 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola josemanuel22,

Si los enlaces de dichas imágenes los introduces desde el editor WYSIWYG en el Gestor de Artículos, la manera más sencilla es diciéndole a la imagen (antes o después de insertar el enlace) que el borde de la misma es cero (0) de este modo no pintara ningún borde cuando tengan un hipervínculo.

También podrías editar la clase img de tu hoja de estilos y añadirle un border: 0px; o modificarlo en caso de existir.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 08/10/2010 3:37 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

José Manuel Rodríguez
 José Manuel Rodríguez
Usuario experto

Cuando voy a al editor, no tiene ningún borde y si le pongo borde=0 continua igual. Modificar la hoja de estilos no lo se. Pero antes de nada os pongo una imagen para que veáis lo que digo. Esto solo ocurre cuando paso con el ratón por encima, circunstancia que anteriormente no la había dicho.

Saludos.

José Manuel Rodríguez

ResponderCitar
Respondido : 08/10/2010 4:39 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola josemanuel22,

He revisado tu página y veo que en esa posición a ese módulo le está aplicando la clase "ja-box-ct clearfix" y uno de los atributos en CSS es color: #00A75F; que es el verde que sale por debajo, aunque en realidad bordea toda la imagen solo que no lo percibes porque excepto por debajo, por el resto desborda el tamaño y no se muestra.

La solución rápida seria a ese módulo "Galería de imágenes" que carga en "left" aplicarle como "Sufijo de la clase módulo" un "_blank" para que no herede estilos y no reciba entre otros el de ".a".

Prueba a ver si funciona, sino vemos como modificar ese estilo para que no te pinte el rectángulo verde.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 08/10/2010 5:20 pm

Cursos Gratuitos WordPress

José Manuel Rodríguez
 José Manuel Rodríguez
Usuario experto

Lo he hecho y me desaparece la linea gris gruesa de encima, pero continua apareciendo la linea verde

Saludos

José Manuel Rodríguez

José Manuel Rodríguez

ResponderCitar
Respondido : 08/10/2010 6:03 pm

Por favor Iniciar Sesión o Registro