Avisos
Vaciar todo

Joomfish y K2  

 
Alex
 Alex
Estimable Member

Puede ser que el tema se haya tratado pero no lo encuentro en el foro.

El tema es que tengo instalado el componente K2 con la última versión y joomfish. He traducido los elementos y las categorias. Cuando veo la web en el idioma secundario, en este caso el inglés, me genera bien la página con todos los datos traducidos, pero la URL no me la traduce. Me sale en español con la etiqueta "en/" delante.

Tengo el componente sh404sef instalado también, pero lo he probado con este componente desactivado y sigue saliendo mal.

¿Tenéis alguna idea?

Gracias

Citar
Respondido : 08/01/2013 5:43 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Alex,

Se agradece que cuando formules una consulta:

- Antes de abrir un tema nuevo, realiza una consulta por si la solución ya está en un mensaje anterior.
- Verifiques que tu sitio web NO está cerrado por "mantenimiento".
- Facilites la URL "exacta" de tu sitio web, donde podamos ver el problema concreto que consultas.
- Trates de documentarla lo mejor posible, con capturas y enlaces concretos que apunten al problema.
- Los formatos de capturas admitidos son .jpg y .png
- Con una explicación clara del problema que podamos entender, si es posible explicando por pasos para que podamos reproducir la incidencia o al menos situarnos.
- Informando de que versión de Joomla! utilizas así como la versión de la extensión que se encuentre afectada en tu problema concreto, así descartamos vulnerabilidades o incompatibilidades de versiones antiguas.
- Aquella información adicional que consideres importante que debamos tener en cuenta para ayudarte mejor.
- Que realices la consulta en la Categoría adecuada del Foro, nos ayuda a mantenerlo más organizado y que otros usuarios encuentren mejor las respuestas ya dadas.
- No realices más de una consulta de diferente naturaleza al problema tratado en un mismo hilo, dificulta las respuestas a los técnicos y no permite una correcta búsqueda de soluciones a otros usuarios.
- No escribas en mayúsculas, no es de netiqueta. 

Saludos y gracias por tu colaboración.

ResponderCitar
Respondido : 08/01/2013 6:41 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Alex
 Alex
Estimable Member

Bueno lo siento. Quizas con las prisas de querer solucionar el problema se me haya olvidado alguna cosa pero pienso que la pregunta esta bien clara. Joomfish no traduce las url del componente K2 para joomla 1.5

Por cierto lo de las mayusculas no lo entiendo, solo me referia a la url por ser unas iniciales. Ya se que no hay que escribir en mayusculas.

Gracias

ResponderCitar
Respondido : 08/01/2013 8:04 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola Alex,

Puedes adjuntarnos la url del sitio web mediante las etiquetas [hide] para verificar el problema.

Saludos.

ResponderCitar
Respondido : 08/01/2013 11:51 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Alex
 Alex
Estimable Member

Os paso el link de la web y pantallazo

Contenido solo visible a usuarios registrados

ResponderCitar
Respondido : 09/01/2013 7:40 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Alex,

Revisa http://www.microteching.com/joomla/problema-al-traducir-un-link-de-menu-de-k2-con-joomfish

Saludos

ResponderCitar
Respondido : 09/01/2013 7:54 am

Cursos Gratuitos WordPress

Alex
 Alex
Estimable Member

Pues no funciona, es más al hacer el cambio se me ha estropeado la base de datos y tengo que volver a restaurar la copia.

Tengo el sh404sef instalado. Si lo desabilito como me dice el link funciona pero claro la url no está optimizada.

ResponderCitar
Respondido : 09/01/2013 8:40 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Alex,

Es importante antes de realizar cambios, realizar una copia de seguridad. Si la has realizado recientemente pues perfecto.

El tema de las url's y su traducción está relacionado con sh404sef, ya que siguiendo los pasos del enlace http://www.microteching.com/joomla/problema-al-traducir-un-link-de-menu-de-k2-con-joomfish indicas que funciona, aunque se han producido otros errores.

El componente sh404SEF http://extensions.joomla.org/extensions/site-management/sef/10134 es de tipo comercial, contacta con los desarrolladores para ver si ofrecen soluciones en este sentido de traducir url's de K2 con Joomfish.

Saludos

ResponderCitar
Respondido : 09/01/2013 9:00 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Alex
 Alex
Estimable Member

He probado a usar el sef de joomla y sigue saliendo mal. Me he puesto en contacto con sh404sef y me dicen que no es problema del componente sh404sef.

La verdad no se que hacer.

Te adjunto pantallazo de con la url generada por el sef de joomla. si que traduce la categora pero no el articulo.

La web siempre aparece en el idioma traducido tanto con sh404sef que con el sef de joomla. Solo es problema de la url

ResponderCitar
Respondido : 09/01/2013 10:51 am
Hicham
 Hicham
Miembro Admin

Hola Alex

Si estas trabajando en un portal con K2 y JoomFish, es fácil que te ocurra que no funcionan bien los links de los menús del tipo ‘categoría de K2’ o similar.
Si vamos al administrador de traducciones de joomfish y vemos las traducciones de esos ítems de menú, veremos que están incompletos.
Lo peor es que aunque le demos a copiar y guardemos, vemos que el link sigue mal traducido.

Para arreglar esto tenemos que aplicar la solución encontrada : http://getk2.org/community/advsearch?q=joomfish-menu-translation

Básicamente se trata de:

1. Ir a la ruta “administrator/components/com_joomfish/contentelements”
2. Editar el archivo “menu.xml” (haz copia)
3. Sustituir esto: Link
4. Por esto: Link

Una vez hecho esto, ya podemos ir al administrador de traducciones, y editar todos los items de menú para ahora sí, poder copiar la url original y guardar sin problemas.

Si además, tenemos el sh404sef activado puede que sigamos teniendo problemas.
En este caso, solo tenemos que ir al panel de control de sh, y en la opción “Enable URL optimization” ponemos NO.
Aunque parezca que no tiene sentido, el resultado es muy satisfactorio. Se mantienen las url’s optimizadas.

ResponderCitar
Respondido : 09/01/2013 11:57 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Alex
 Alex
Estimable Member

Esto es lo mismo de antes...

Además si desactivo el sh404sef para que me sirve?

ResponderCitar
Respondido : 09/01/2013 12:07 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Alex

Te sugiero primero solucionar el problema sin el Sh404Sef, por lo que mantenlo desactivado o desinstalalo

Configura k2 con joomfish como se te indicó anteriormente, luego trabaja con las urls amigables de joomla que tiene de manera standar , revisa el siguiente artículo

https://www.webempresa.com/blog/item/317-urls-amigables-en-joomla.html

Saludos.

ResponderCitar
Respondido : 09/01/2013 7:31 pm

wpdoctor-revisa-la-salud-de-tu-wordpress