Problema con el SEO  

Página 1 / 2
 
Kike
 Kike
Estimable Member

Hola:

Estoy desarrollando esta web http://www.institutblanchreumatologia.com/ y cuando conecto el SEO y clico en cualquier pestaña del menú me sale este mensaje.

Not Found

The requested URL /es/concertar-visita.html was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Me pasaba una cosa parecida el otro día con Virtuemart y ahora me pasa con Joomla.
¿Sabéis a que se debe?

Citar
Respondido : 14/09/2010 9:41 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola,

Hemos visualizado tu sitio web, pero vemos que has desactivado el SEO.
Para que funcione correctamente, hay que tener en configuración global --> Parámetros de optimización de SEO --> al menos tener los dos primeros activados. (Comprobar tal como indica en el aviso del segundo parámetro renombrar el archivo htaccess.txt a .htaccess).

Es distinta la problemática que puedas tener en Joomla! que en Virtuemart, ya que los parámetros de optimización SEO no afectan a Virtuemart, para que Virtuemart funcione con url's amigables hay que instalar extensiones de terceros que nos permitan tener la funcionalidad.

Saludos,

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 14/09/2010 10:57 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Kike
 Kike
Estimable Member

Hola Jordi:

Había desactivado el SEO para que no me diese problemas. Ya lo he vuelto a activar.
El archivo htaccess.txt que me comentas no está visible en la FTP.
Tengo instalado el Joomla de Web Empresa y con otras webs que tengo con vostros no me ha hecho falta renombrar ese archivo. De hecho, siempre me ha pasado lo mismo. No estaba visible.
¿Puede ser que esto que ocurre tenga que ver con la última versión de tengo instalada?
En otra web (www.seadivers.es) no me ocurre y no renombré el archivo.

ResponderCitar
Respondido : 14/09/2010 4:12 pm
Jordi Sala
 Jordi Sala
Miembro Admin

Hola,

A veces en algunos programas ftp, no visualizan por defecto los archivos "ocultos" a menos que se realice un cambio en su configuración. Si usas cPanel puedes visualizar esos archivos desde el "administrador de archivos" (indicando que deseas ver archivos ocultos), y podrás visualizar si tiene el archivo .htaccess (puede que ya haya sido renombrado del htaccess.txt).

Saludos,

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 14/09/2010 6:46 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Kike
 Kike
Estimable Member

Hola Jordi:

He mirado en el Administrador de archivos de cpanel y no aparece el archivo .htaccess.
¿Es eso posible?
He marcado la casilla mostrar archivos ocultos.

Saludos

ResponderCitar
Respondido : 14/09/2010 10:27 pm
Kike
 Kike
Estimable Member

Perdona Jordi:

Lo he encontrado y aparece como .htaccess.
¿Cómo es que me sale el error 404 si en teoría está todo correcto?

Saludos

ResponderCitar
Respondido : 14/09/2010 10:32 pm

Cursos Gratuitos WordPress

Leonel Cantón
 Leonel Cantón
Estimable Member

Que tal Kike, veo que has indicado que el archivo se llama .htaccess. (es decir que tiene un punto de mas al final), esto hace que el archivo no sea encontrado y marque los errores 404.

Modifica el nombre de dicho archivo y nos cuentas

Saludos,

Leonel

ResponderCitar
Respondido : 14/09/2010 11:39 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Kike,

¿Te has fijado si ese archivo .htaccess esta a 0 bytes? Si lo está o bien lo editas y añades la siguiente información (válida en los Hostings de Webempresa) o lo eliminas y creas uno nuevo con el contenido mencionado:

##
# @version $Id: htaccess.txt 10492 2008-07-02 06:38:28Z ircmaxell $
# @package Joomla
# @copyright Copyright (C) 2005 - 2008 Open Source Matters. All rights reserved.
# @license  http://www.gnu.org/copyleft/gpl.html  GNU/GPL
# Joomla! is Free Software
##


#####################################################
#  READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE
#
# The line just below this section: 'Options +FollowSymLinks' may cause problems
# with some server configurations.  It is required for use of mod_rewrite, but may already
# be set by your server administrator in a way that dissallows changing it in
# your .htaccess file.  If using it causes your server to error out, comment it out (add # to
# beginning of line), reload your site in your browser and test your sef url's.  If they work,
# it has been set by your server administrator and you do not need it set here.
#
#####################################################

##  Can be commented out if causes errors, see notes above.
Options +FollowSymLinks

#
#  mod_rewrite in use

RewriteEngine On

########## Begin - Rewrite rules to block out some common exploits
## If you experience problems on your site block out the operations listed below
## This attempts to block the most common type of exploit `attempts` to Joomla!
#
# Block out any script trying to set a mosConfig value through the URL
RewriteCond %{QUERY_STRING} mosConfig_[a-zA-Z_]{1,21}(=|%3D) [OR]
# Block out any script trying to base64_encode crap to send via URL
RewriteCond %{QUERY_STRING} base64_encode.*(.*) [OR]
# Block out any script that includes a  tag in URL
RewriteCond %{QUERY_STRING} (|%3E) [NC,OR]
# Block out any script trying to set a PHP GLOBALS variable via URL
RewriteCond %{QUERY_STRING} GLOBALS(=|[|%[0-9A-Z]{0,2}) [OR]
# Block out any script trying to modify a _REQUEST variable via URL
RewriteCond %{QUERY_STRING} _REQUEST(=|[|%[0-9A-Z]{0,2})
# Send all blocked request to homepage with 403 Forbidden error!
RewriteRule ^(.*)$ index.php [F,L]
#
########## End - Rewrite rules to block out some common exploits

#  Uncomment following line if your webserver's URL
#  is not directly related to physical file paths.
#  Update Your Joomla! Directory (just / for root)

# RewriteBase /


########## Begin - Joomla! core SEF Section
#
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !^/index.php
RewriteCond %{REQUEST_URI} (/|.php|.html|.htm|.feed|.pdf|.raw|/[^.]*)$  [NC]
RewriteRule (.*) index.php
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]
#
########## End - Joomla! core SEF Section

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 14/09/2010 11:47 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Kike
 Kike
Estimable Member

Muchas gracias gnumax.
El archivo estaba vacío, he copiado el código que me has pasado y ya no me da ningún error.
Gracias de nuevo.

ResponderCitar
Respondido : 15/09/2010 10:37 am
Kike
 Kike
Estimable Member

Hola Leonel:

Gracias por tu interés y tu consejo.
He seguido las instrucciones de gnumax y el problema ha quedado solucionado.
Nos vemos.

ResponderCitar
Respondido : 15/09/2010 10:39 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Kike
 Kike
Estimable Member

Hola:

Parece que el error 404 con el SEO me persigue.
Ahora me vuelve a suceder lo mismo cuando activo el SEO en una tienda online que estoy haciendo ( http://www.bolsosonline.net/)
El archivo .htaccess está vacío y si le copio el código que me pasasteis, tampoco me funciona.

Saludos

ResponderCitar
Respondido : 26/09/2010 10:38 pm
Kike
 Kike
Estimable Member

Hola:

Parece que el error 404 con el SEO me persigue.
Ahora me vuelve a suceder lo mismo cuando activo el SEO en una tienda online que estoy haciendo (www.bolsosonline.net/)
El archivo .htaccess está vacío y si le copio el código que me pasasteis, tampoco me funciona.

Saludos

ResponderCitar
Respondido : 27/09/2010 9:36 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Leonel Cantón
 Leonel Cantón
Estimable Member

Que tal Kike, este otro sitio en que hosting lo tienes?

Cuando ocurren estos casos extraños, lo mejor es ir probando de poco a poco. Ya probaste copiar el código standard de joomla del .htaccess el que viene en el pack original de joomla?.

Prueba lo siguiente.
1. Copia el código original y revisa el sitio (sin activar nada en joomla, solo detectar la presencia del htaccess)
2. Activa el SEO de joomla y has nuevamente la prueba.

Saludos,

Leonel

ResponderCitar
Respondido : 27/09/2010 9:54 pm
Lucas
 Lucas
Miembro Admin

Hola Kike,

Si no te va es que tienes el htaccess vacío, veo que estás en nuestro hosting.

Asegúrate también de que tengas los tres parámetros de SEO de Joomla activados.

Saludos
Lucas

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 27/09/2010 10:01 pm

Cursos Gratuitos WordPress

Kike
 Kike
Estimable Member

Hola:

Tengo activados los tres parámetros de SEO y el htaccess está vacio y si le copio el siguiente código no me funciona:

## 
# @version $Id: htaccess.txt 10492 2008-07-02 06:38:28Z ircmaxell $ 
# @package Joomla 
# @copyright Copyright (C) 2005 - 2008 Open Source Matters. All rights reserved. 
# @license  http://www.gnu.org/copyleft/gpl.html  GNU/GPL 
# Joomla! is Free Software 
## 
 
 
##################################################### 
#  READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE 

# The line just below this section: 'Options +FollowSymLinks' may cause problems 
# with some server configurations.  It is required for use of mod_rewrite, but may already 
# be set by your server administrator in a way that dissallows changing it in 
# your .htaccess file.  If using it causes your server to error out, comment it out (add # to 
# beginning of line), reload your site in your browser and test your sef url's.  If they work, 
# it has been set by your server administrator and you do not need it set here. 

##################################################### 
 
##  Can be commented out if causes errors, see notes above. 
Options +FollowSymLinks 
 

#  mod_rewrite in use 
 
RewriteEngine On 
 
########## Begin - Rewrite rules to block out some common exploits 
## If you experience problems on your site block out the operations listed below 
## This attempts to block the most common type of exploit `attempts` to Joomla! 

# Block out any script trying to set a mosConfig value through the URL 
RewriteCond %{QUERY_STRING} mosConfig_[a-zA-Z_]{1,21}(=|%3D) [OR] 
# Block out any script trying to base64_encode crap to send via URL 
RewriteCond %{QUERY_STRING} base64_encode.*(.*) [OR] 
# Block out any script that includes a  tag in URL 
RewriteCond %{QUERY_STRING} (|%3E) [NC,OR] 
# Block out any script trying to set a PHP GLOBALS variable via URL 
RewriteCond %{QUERY_STRING} GLOBALS(=|[|%[0-9A-Z]{0,2}) [OR] 
# Block out any script trying to modify a _REQUEST variable via URL 
RewriteCond %{QUERY_STRING} _REQUEST(=|[|%[0-9A-Z]{0,2}) 
# Send all blocked request to homepage with 403 Forbidden error! 
RewriteRule ^(.*)$ index.php [F,L] 

########## End - Rewrite rules to block out some common exploits 
 
#  Uncomment following line if your webserver's URL 
#  is not directly related to physical file paths. 
#  Update Your Joomla! Directory (just / for root) 
 
# RewriteBase / 
 
 
########## Begin - Joomla! core SEF Section 

RewriteCond %{REQUEST_FILENAME} !-f 
RewriteCond %{REQUEST_FILENAME} !-d 
RewriteCond %{REQUEST_URI} !^/index.php 
RewriteCond %{REQUEST_URI} (/|.php|.html|.htm|.feed|.pdf|.raw|/[^.]*)$  [NC] 
RewriteRule (.*) index.php 
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L] 

########## End - Joomla! core SEF Section

ResponderCitar
Respondido : 27/09/2010 10:12 pm
Página 1 / 2

Por favor Iniciar Sesión o Registro