Problema URL's amigables y menús!!!  

 
Laura
 Laura
Usuario eminente

Tengo en un item del menú un Enlace Externo en el que pasa lo siguiente:

* NO Activo Url Amigables - Botón menú se queda activo (color amarillo) .
* SI Activo Url Amigables - Botón menú no se queda activo.

¿Qué ocurre?

Otra cosa rara, el item del menú Enlace Externo, no tiene Parámetros del Sistema para poner el Título de la Página, y por defecto pone el mismo del título del menú.

Pero si activo las URL Amigables ya no pone ese Título de la Página pone el nombre del sitename.

Me estoy volviendo loca.

Por cierto alguien sabe donde están ubicados (supongo que serán ficheros xml) de los item de menú de los componentes, es que en uno quisiera cambiar el enlace por otro.

Muchas gracias por leerme.

Saludos.

Citar
Respondido : 21/08/2010 8:20 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Chisca,

Tanto con URL,s amigables activadas como sin ellas, un vínculo en un menú mainmenu u otro a un enlace externo no tendría porque darte problemas, ya que solo implica llamar a una URL y abrirla en función de los parámetros marcados en el ítem de menú.

Otra cosa es que tengas instaladas cosas como FLEXIcontent, por ejemplo, y que algunos ítemes de menú te los esconda o muestre por razones varias que no sabría precisarte sin ver plantilla que usas, etc.

Lo de que el ítem del menú de enlaces externos no tenga "Parámetros" ya es mas raro, cuando menos, ya que todos deben tenerlos en mayor o menor medida y ese concretamente tiene Parámetros - Básico, Menú de Imágenes, y los "avanzados" vacíos.

Lo dicho, algún detalle o pista que oriente sobre tu problema.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 21/08/2010 10:04 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Laura
 Laura
Usuario eminente

No uso FLEXIcontent.

Estoy usando el item de menú Enlace externo para colocar un enlace a un componente. Ya que este componente tiene puesto en enlace un enlace que no es el que necesito. Y la cosa es que funciona correctament hasta que pongo lo de las url amigables.

Necesito modificar los params de un item de un menú, ¿sabes dónde están ubicados? Es para cambiar el enlace que tiene como predeterminado por otro.

Gracias.

Saludos.

ResponderCitar
Respondido : 21/08/2010 10:55 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Chisca,

Tras realizar varias pruebas los resultados son estos:

Con URL,s amigables activadas en Configuración Global ( URLs amigables para motores de búsqueda ) he creado 3 ítemes de menú:

Enlace al Foro seleccionando el ítem desplegable de extensiones, Kunena, como se haria con cualquier extensión a enlazar:
index.php?option=com_kunena

Enlace al Foro utilizando del ítem desplegable la opción "URL externa" y poniendo la siguiente:
/foro.html

Enlace al Foro utilizando del ítem desplegable la opción "URL externa" y poniendo la siguiente:
index.php?option=com_kunena&Itemid=76&lang=es

En los 3 casos el acceso funciona exactamente igual para los 3 sin problemas.

Posteriormente desactivo las URL,s amigables y recargo la web, limpiando la cache previamente y en los 3 casos los enlaces cargan sin problemas el foro y la url que muestran en la barra de navegación es la siguiente:
index.php?option=com_kunena&Itemid=76&lang=es <-- Para el primer y segundo caso.
index.php?option=com_kunena&Itemid=84&lang=es <- Para el tercer caso.

La conclusión que saco es que si el componente está correctamente instalado y copias la url relativa correctamente y la utilizas para crear un vínculo externo para llamar un componente interno el comportamiento debe ser correcto tal como he tratado de ilustrarte.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 22/08/2010 12:18 am

Cursos Gratuitos WordPress

Laura
 Laura
Usuario eminente

Pero el problema es cuando en el enlace hay más variables, como por ejemplo esto:

index.php?option=com_kunena&Itemid=191&func=userlist&lang=es

Con este enlace iríamos a la "Lista de Usuarios", pero activando las url amigables el botón del menú no se queda activo, en mi caso se tendría que poner amarillo.

Creo que tiene que ver con el fichero .htaccess, no sé...prueba a ti si te funciona, por favor.

Ya me dirás que tal te ha ido, gracias.

ResponderCitar
Respondido : 22/08/2010 10:12 am
Lucas
 Lucas
Miembro Admin

Hola Chisca,

Sin ver la url es difícil ayudarte.

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 22/08/2010 12:37 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Chisca,

Probando los enlaces que comentas con URLs amigables y sin ellas enlazando a la Lista de Usuarios de Kunena:

Con URLs amigables enlaza esta URL correctamente con la Lista de Usuarios de Kunena:
/component/kunena/userlist.html

Sin URLs amigables enlaza esta URL correctamente con la Lista de Usuarios de Kunena:
/index.php?option=com_kunena&Itemid=191&func=userlist&lang=es

He probado algunas combinaciones más, incluso a otros componentes y el comportamiento en ambos casos es siempre el mismo.

Entiendo que no utilizas ningún plugin o extensión SEF o similar y que solo con la activación y desactivación de "URLs amigables" en Configuración Global es como te sucede esto que comentas ¿correcto?.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 22/08/2010 12:55 pm
Laura
 Laura
Usuario eminente

Parece que el SEO que lleva por defecto Joomla no es suficiente.

Estoy probando con JoomSef y ahora funciona.

Luego a ver que pasa cuando ponga el Joomfish, espero que se acoplen bien.

Gracias por el interés.

Saludos.

ResponderCitar
Respondido : 22/08/2010 3:03 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Webempresa
 Webempresa
Usuario eminente

Por favor Iniciar Sesión o Registro