Avisos
Vaciar todo

ver imagenes ja flowlist en frontend  

Página 1 / 2
 
Daniel
 Daniel
Usuario experto

Tenemos una web con la plantilla ja labra y queremos presentar el módulo ja flowlist, pero a la hora de designar una carpeta de imágenes que se verán en la web no aparece nada, y he probado con varias carpetas. ¿Algún sitio dónde consultar con detalle este problema? ¿Qué carpeta habría que indicar? Además, si indicamos Content, tampoco pasa nada y nunca se ven imágenes.

¿Podéis ayudarnos?

Nuestra página es www.diezlibros.com.

Gracias

Citar
Respondido : 07/08/2011 9:56 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Daniel,

¿Puedes ponernos una captura de la configuración de los parámetros del módulo?.

La documentación (en inglés) del módulo la tienes en la siguiente url:

- http://demo.joomlart.com/extensions15/index.php?option=com_content&view=article&id=128#

Aunque como verás es demasiado sencilla sobre los parámetros a configurar.

Saludos

ResponderCitar
Respondido : 07/08/2011 10:11 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Daniel
 Daniel
Usuario experto

Hola, Gnumas,

esta es la captura de pantalla del módulo abierto de flowlist, la parte de abajo que no se ve tiene todos los parámetros tal como están en la demo.

Gracias, saludos.

ResponderCitar
Respondido : 07/08/2011 10:52 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Daniel,

Revisa el archivo "error_log" de /public_html a ver si hay alguna entrada que haga referencia a este problema y nos comentas.

Saludos

ResponderCitar
Respondido : 07/08/2011 10:56 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Daniel
 Daniel
Usuario experto

No hay ninguna referencia, si atendemos a la fecha de los errores señalados. Os copio todo el contenido del archivo:

[27-Jul-2011 15:16:26] PHP Fatal error: Call to a member function get() on a non-object in /home/diezlibr/public_html/templates/rhuk_milkyway/index.php on line 23
[27-Jul-2011 15:16:37] PHP Fatal error: Call to a member function get() on a non-object in /home/diezlibr/public_html/templates/rhuk_milkyway/index.php on line 23
[27-Jul-2011 15:16:57] PHP Fatal error: Call to a member function get() on a non-object in /home/diezlibr/public_html/templates/rhuk_milkyway/index.php on line 23
[27-Jul-2011 15:17:33] PHP Fatal error: Call to a member function get() on a non-object in /home/diezlibr/public_html/templates/rhuk_milkyway/index.php on line 23
[27-Jul-2011 15:19:51] PHP Fatal error: Call to a member function get() on a non-object in /home/diezlibr/public_html/templates/rhuk_milkyway/index.php on line 23
[01-Aug-2011 00:07:16] PHP Warning: imagecopyresampled(): supplied argument is not a valid Image resource in /home/diezlibr/public_html/modules/mod_jaslideshow/mod_jaslideshow.php on line 341

Saludos.

ResponderCitar
Respondido : 07/08/2011 11:15 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Daniel,

Ninguno tiene que ver con el módulo en cuestión.

¿Las imágenes las tienes en la ruta /images/stories/demo?

Trata tu de aportar datos que puedan ayudarnos para no tener que estar preguntándote una a una cada cosa 🙂

Saludos

ResponderCitar
Respondido : 07/08/2011 11:31 pm

Cursos Gratuitos WordPress

Daniel
 Daniel
Usuario experto

La ruta que tengo puesta es esa, y en la carpeta están precisamente las imágenes de la demo.

El problema es que no sé muy bien que datos daros, pero se me ha ocurrido mirar los permisos, porque en un mensaje más o menos relacionado en el foro de joomlart algo comentaban, y son diferentes el número que veo en el ninjaxplorer del que veo en la misma carpeta en cpanel. En Ninja, en la carpeta /images/stories/demo el número del permiso es 755 con las indicaciones de las casillas interiores marcadas así: -rwxr-xr-x -que no sé muy bien lo que significan, tal vez read, write, change...-, y en el mismo archivo en CPanel el número es 0644.

¿Puede ser esto? ¿Cambio un número por otro, bien en ninja, bien en el cpanel?

También se me ocurre que en la página no tenemos prácticamente artículos, y quiero enlazar a esa carpeta porque tiene imágenes, aunque en otra, dentro de images, he subido varias portadas de libros, que tampoco se consigue ver.

También, no sé si es normal que se dupliquen carpetas con el mismo nombre, tal como puedes ver en el recorte que te adjunto del listado de directorios y carpetas, las de imágenes en public_html.

¿Qué otros datos podría buscar y daros para que tengáis más información?

Saludos.

ResponderCitar
Respondido : 07/08/2011 11:56 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Daniel,

Los permisos de la carpeta son siempre 755 y los del archivo (s) son 644 y así deben ser sea cual sea la extensión, otros permisos (777 o 666) no funcionan en nuestros servidores que están 100% optimizados para Joomla!.

Verifica si tienes habilitado el plugin "Sistema - Plugin Mootools Upgrade" en el Gestor de Plugins.

Saludos

ResponderCitar
Respondido : 08/08/2011 12:14 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Daniel
 Daniel
Usuario experto

Hola,

no lo tenía publicado y lo he cambiado, aunque siguen sin aparecer las imágenes del flowlist.

¿Os puedo dar más datos?

Saludos.

ResponderCitar
Respondido : 08/08/2011 12:35 am
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Daniel,

He probado el módulo en 2 servidores distintos de Webempresa y se instala correctamente y pasa los parámetros pero no se ejecuta el script, por lo que podría ser algún problema de bloqueo del Firewall (no es determinante pero cabe esa posibilidad).



 <object type="application/x-shockwave-flash" data="http://pruebas.com/modules/mod_jaflowlist/ja_flowlist/flowlist_xml.swf" width="100" height="300"> <param name="allowScriptAccess" value="sameDomain" /> <param name="allowFullScreen" value="true" /> <param name="movie" value="http://pruebas.com/modules/mod_jaflowlist/ja_flowlist/flowlist_xml.swf" /> <param name="quality" value="high" /> <param name="bgcolor" value='' /> </object> 

Una opción seria verificarlo en un hosting externo y otra abrir un ticket de soporte comentando este inconveniente, básicamente para descartar que no se trate de un bloqueo del script.

Saludos

ResponderCitar
Respondido : 08/08/2011 1:31 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Daniel
 Daniel
Usuario experto

Gracias por todos los esfuerzos. mañana enviaré un tiquet, porque no sé cómo podría verificar el módulo en un hosting externo.

Por ahora, lo dejo en suspenso, y mañana a ver que dicen al tiquet.

Saludos.

ResponderCitar
Respondido : 08/08/2011 1:55 am
Daniel
 Daniel
Usuario experto

Buenas,

os informo de la respuesta del departamento de atender los tiquets de consulta, lo que me ha ocasionado un nuevo problema, porque desde webempresa se me bloqueaba el acceso desde mi ip, lo que me ha pasado hoy repetidas veces, e incluso en este momento, a pesar de rogar de que me lo indicaran, no lo han hecho, decirme si puedo enviar tiquets sin problemas, porque si se arregló el simple acceso a la página de webempresa -tampoco me han dicho a qué se debía este problema, a pesar de preguntárselo, pero, en fin, no tienen por qué saber todo, todos tenemos nuestras limitaciones- y el caso es que todavía no sé si se me bloqueará el acceso si envío un tiquet o no.

Bueno, el caso es que ese departamento me contestó que no era un problema de scripts, y me pidieron que les enviara la url desde donde se carga el módulo flowlist, se lo envié, y en esto sí, rápida y amablemente me han contestado lo siguiente:

"Hemos enviado una consulta a JoomlArt para que nos den indicaciones de esta disfuncionalidad en el módulo, pues observamos que se comporta así en todas las instalaciones que realizamos y creemos que es un problema de programación del archivo .xml que pasa incorrectamente la ruta de la carpeta de imágenes."

Por lo tanto, por el momento seguiré a la espera de sus noticias, o sea, de las de Joomlart. Esto parece que va para largo.

Simplemente, os envío esta información para que otros sepan que este módulo parece que da problemas en general, y por el momento no usen la plantilla ja labra, y para que quienes atendéis el foro también lo sepáis, después de tantas vueltas y esfuerzo que ayer, Gnumax, le estuviste dando a este problema, lo que te agradezco de veras.

Saludos.

ResponderCitar
Respondido : 08/08/2011 9:57 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Daniel

os informo de la respuesta del departamento de atender los tiquets de consulta, lo que me ha ocasionado un nuevo problema, porque desde webempresa se me bloqueaba el acceso desde mi ip, lo que me ha pasado hoy repetidas veces, e incluso en este momento, a pesar de rogar de que me lo indicaran, no lo han hecho, decirme si puedo enviar tiquets sin problemas, porque si se arregló el simple acceso a la página de webempresa -tampoco me han dicho a qué se debía este problema, a pesar de preguntárselo, pero, en fin, no tienen por qué saber todo, todos tenemos nuestras limitaciones- y el caso es que todavía no sé si se me bloqueará el acceso si envío un tiquet o no.

¿Puedes documentar de que bloqueo se trata? Webempresa no realiza ningún tipo de bloqueo, no tiene sentido y en todo caso si el Firewall te bloquea es por alguna acción concreta. ¿Que tareas ejecutas cuando te bloquea?.

Por lo tanto, por el momento seguiré a la espera de sus noticias, o sea, de las de Joomlart. Esto parece que va para largo.

Nosotros planteamos dudas a JoomlArt como a otros desarrolladores y no esta en nuestras manos que nos respondan antes o después ya que no somos el soporte de estas plantillas o extensiones si tienen fallos o comportamientos erráticos puntuales documentados o no.

Cuando conocemos la solución sobre una plantilla o extensión que causa conflictos lo informamos de inmediato pero no depende siempre de nosotros, ni siquiera del desarrollador, pues muchas disfuncionalidades en plantillas o extensiones son causadas por desconocimiento del uso por parte de usuario y que aquí tratamos de documentar y ayudar a solventar.

¿Puedes indicar que permisos tiene en tu módulo el archivo content_xml.php?

Saludos

ResponderCitar
Respondido : 08/08/2011 10:23 pm
Lucas
 Lucas
Miembro Admin

Hola Daniel,

Me comentan que el motivo por el cual se te ha bloqueado el acceso al enviarnos un ticket era porque en el contenido del ticket tenías código que nuestro firewall de aplicaciones ha detectado como malicioso y te ha bloqueado, en el momento que nos has comentado que tenías ese problema para enviar tickets te han desbloqueado, el falso positivo que te ha bloqueado hoy no te volverá a pasar si envías el mismo código pero te podría pasar otra vez si envías código que nuestro sistema identifica como malicioso, no nos suele ocurrir pero es mejor que para evitar esto envíes el código en un documento adjunto comprimido.

Otra opción que tienes es enviar un email al Departamento de Soporte o bien responder por email los emails que recibas nuestro y así no hace falta que te logees en nuestro area de cliente para responder los tickets o crear uno nuevo.

Sobre el problema que tienes con el módulo de tu plantilla un técnico a estado revisando y ha visto que el problema era que tu módulo carga mal la ruta de las imagenes:

En el código fuente de tu página se puede ver que tu módulo genera este html:

var flashvars = {}; flashvars.myxmlpath = 'http://www.diezlibros.com/modules/mod_jaflowlist/ja_flowlist/content_xml.php?modid=44'; flashvars.type = 'folder'; flashvars.decription = '0'; flashvars.textstyle = ''; flashvars.descordinate = ''; flashvars.startItem = '0'; flashvars.flowFadeSpace = '100'; flashvars.flowAnimationTweenType = 'Regular'; flashvars.flowAnimationSpeed = '5'; flashvars.slideShowTime = '100'; flashvars.slideShow = '1'; flashvars.slideShowLoop = '1'; flashvars.imagePadding = '50'; flashvars.angle = '45'; flashvars.vertical = '0.2'; flashvars.iwidth = '50'; flashvars.iheight = '70'; flashvars.listheight = '75'; flashvars.alpha = '40'; flashvars.clipAlpha = '100'; flashvars.distance = '2'; flashvars.matrixRatio = '255'; flashvars.matrixDropOff = '3'; ...

y si accedes a la url:

 http://www.diezlibros.com/modules/mod_jaflowlist/ja_flowlist/content_xml.php?modid=44 

Si miras el código fuente de la página verás que no te devuelve contenido, gnumax nos ha comentado que había instalado el módulo en una web de pruebas en otro servidor y hemos visto ahí que el módulo estaba cargando incorrectamente la ruta de las imágenes y hemos puesto un ticket a joomlart para saber si lo tenían solucionado en una versión superior del módulo o bien si es un bug que tienen resuelto.

Te recomiendo que revises si tienen ese mismo módulo más actualizado en la web de joomlart, hemos revisado su foro y no hemos encontrado mensajes al respecto.

En todo caso por curiosidad nosotros ya hemos puesto el ticket y estamos esperando que nos respondan.

ResponderCitar
Respondido : 08/08/2011 11:00 pm

Cursos Gratuitos WordPress

Daniel
 Daniel
Usuario experto

Hola,

lo del bloqueo parece solucionado; me ha pasado esto: cuando intentaba enviar el tiquet que me aconsejaste, al pinchar en enviar desapareció la página en la que estaba,y al intentar entrar en la página de inicio de Webempresa para volver a acceder a la de los tiquets de consulta, me salía error de conexión y por más que lo intentaba no podía entrar, aunque sí a cualquier otra página en internet. He llamado al 902 y me han pedido mi ip, desbloqueándome el acceso, y la explicación que me ha dado mi interlocutor es que había habido más de 5 intentos de acceso desde mi ip y que desde Webempresa se podría haber bloqueado mi acceso como medida automática y general de seguridad.

He vuelto a la página de tiquets, con la intención de enviar el famoso tiquet, y me ha vuelto a pasar lo mismo. He vuelto a llamar y me han dicho que lo mejor era que enviara un correo a soporte, cosa que he hecho. Un rato después se había solucionado el problema, es decir, volví a acceder a la página de inicio de Webempresa, y me han contestado a la consulta que intentaba enviar con el tiquet, pero en ningún momento me han dicho que si intento entrar a enviar un tiquet de consulta no me volveré a ver bloqueado, por el motivo que sea, que desconozco, para entrar al inicio de Webempresa, por lo que no me atrevo a enviar ningún tiquet, así que si lo necesitara, lo enviaría por mail a soporte. Como les he vuelto a escribir, me contestarán a esto con la respuesta que haya.

En lo de ja flowlist, evidentemente el tiempo que tarden en Joomlart en contestar es una cuestión que depende de ellos; y por otro lado, por supuesto el problema puede ser que en mi desconocimiento haya metido la pata a fondo al querer configurar el módulo.

Sobre los permisos del módulo content_xml.php, son los siguientes:

644
-rw-r--r--

Propietario r - w
Grupo r
P�blico r

Saludos.

ResponderCitar
Respondido : 08/08/2011 11:00 pm
Página 1 / 2