Avisos
Vaciar todo

Captcha Breezing forms & navegador web  

 
Esteban
 Esteban
Usuario activo

Hola a todos,
Después de ver los vídeos de webempresa he logrado configurar tres formularios para mi nueva web empresarial http:\www.ejccomunicaciones.com

Inicialmente todo funciona y han quedado en una primera fase unos formularios suficientes para que nuestros clientes puedan hacer sus peticiones, pero ya sabia yo que tenían que aparecer problemas de lo contrario no seria normal. Resulta que nos han llamado varios clientes para decirnos que la imagen del Captcha no les aparece y por consiguiente no pueden enviarnos el formulario. Desde nuestra oficina hemos detectado que en un ordenador utilizando IEplorer no aparece Captcha pero si que aparece utilizando Chrome y Firefox. He intentado buscar información sobre esto pero no he logrado encontrar nada.
Mi Joomla es 1.6.4 y Breezing 1.7.3 Stable (build 744). Quisiera saber si sabéis los niveles de seguridad y otros temas que tenga que considerar para utilizar Captcha.

Gracias por vuestras respuestas.

Citar
Respondido : 20/09/2011 8:36 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Esteban,

Visualizando con IE8. Detalles de error de página web:

----------------------------------------------

Mensaje: El objeto no acepta esta propiedad o método
Línea: 52
Carácter: 3
Código: 0
URI: http://www.ejccomunicaciones.com/templates/theme726/javascript/hide.js

Esta relacionado con la plantilla, probad de activar otra plantilla, para ver si sigue el error.

----------------------------------------------

Mensaje: El objeto no acepta esta propiedad o método
Línea: 1
Carácter: 81199
Código: 0
URI: http://www.ejccomunicaciones.com/media/system/js/mootools-core.js

¿Tenéis activado o desactivado el plugin de motools?

------------------------------------------

Saludos,

ResponderCitar
Respondido : 20/09/2011 11:21 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Esteban
 Esteban
Usuario activo

Hola,

He visto que esto sucede solo con navegadores Iexplorer pero no en todos por lo que veo que es un tema de versión, en los equipos que tienen Windows 7 funciona perfectamente. Por cierto no he visto el plugin motools instalado en mi Joomla, ignoro que función tiene.

Saludos

ResponderCitar
Respondido : 20/09/2011 4:48 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Esteban

Tal vez con la nueva versión de breezing forms soluciones el problema, aunque es de pago.

Te sugiero evaluar migrar tu sitio web a Joomla 1.7 ya que Joomla 1.6 no tiene soporte en caso de detectarse algún fallo.

Saludos.

ResponderCitar
Respondido : 20/09/2011 7:38 pm

Cursos Gratuitos WordPress

Esteban
 Esteban
Usuario activo

Hola,
Me parece sorprendente que los problemas solo se reproduzcan utilizando Iexplorer.
Por la actualización de Joomla debo de hablar con el departamento comercial pues he intentado aplicar la nueva versión pero hay un conflicto con la versión del idioma que no entiendo, si te fijas al entrar en la web aparece en la dirección "en" pero debería de ser "es" y esto es un problema a la hora de actualizar. Por otro lado ignoro que es el plugin motools del que Jordi ha comentado.

Gracias por vuestras aportaciones.

ResponderCitar
Respondido : 21/09/2011 9:09 am
Esteban
 Esteban
Usuario activo

Hola,

He logrado actualizar a 1.6.6 y luego ha 1.7.0. Hasta la fecha no lo había logrado pero hoy sin problemas ni mensajes se ha instalado.

Los problemas del navegador continúan pero centrados en el Iexplorer bajo windows XP

Saludos.

ResponderCitar
Respondido : 21/09/2011 9:33 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Jordi Sala
 Jordi Sala
Miembro Admin

Hola Esteban

Esta relacionado con la plantilla, probad de activar otra plantilla, para ver si sigue el error.

¿Lo habeis probado para descartar que sea la plantilla?. Tampoco se visualiza el captcha con IE8 en windows 7.

He logrado actualizar a 1.6.6 y luego ha 1.7.0. Hasta la fecha no lo había logrado pero hoy sin problemas ni mensajes se ha instalado.

Desconozco si has actualizado correctamente, pero el tema del idioma no es normal. Desactivad el plugin Sistema - Filtrar idiomas. Hay cambios de en el sistema de idiomas de 1.6 a 1.7, a parte de que se añaden tablas, mirad a través del phpmyadmin si tenéis una tabla llamada associations.

Indicarte que las url's amigables no las teneis correctas, no tiene que aparecer ese index.php, en sitio --> configuración global --> Configuración SEO --> activad Usar Apache mod_rewrite

Saludos,

ResponderCitar
Respondido : 21/09/2011 9:53 am
Esteban
 Esteban
Usuario activo

Hola,

Indicarte que las url's amigables no las teneis correctas, no tiene que aparecer ese index.php, en sitio --> configuración global --> Configuración SEO --> activad Usar Apache mod_rewrite

Esta opción no la tengo en esta pantalla:ohmy:

Desconozco si has actualizado correctamente, pero el tema del idioma no es normal. Desactivad el plugin Sistema - Filtrar idiomas. Hay cambios de en el sistema de idiomas de 1.6 a 1.7, a parte de que se añaden tablas, mirad a través del phpmyadmin si tenéis una tabla llamada associations.

Tabla desactivada, ignoro como funciona phpmyadmin pero he logrado ver que hay una tabla associations. exactamente document_associations con el siguiente contenido:

1 id varchar(50) utf8_general_ci No Cap Canvi Canvi Elimina Elimina Més Mostra més accions
2 context varchar(50) utf8_general_ci No Cap Canvi Canvi Elimina Elimina Més Mostra més accions
3 key char(32) utf8_general_ci No Cap Canvi Canvi Elimina Elimina Més Mostra més accions

Indexos: Documentació
Acció Nom de clau Tipus Única Comprimit Columna Cardinalitat Ordenació Nul Comentari
Edita Edita Elimina Elimina PRIMARY BTREE Si No context 0 A
id 0 A
Edita Edita Elimina Elimina idx_key BTREE No No key 0 A

Utilització d'espai Tipus Ús
Dades 0 B
Índex 1,024 B
Total 1,024 B
Estadística de files Sentències Valor
Format dinàmic
Ordenació utf8_general_ci
Fila 0
Creació 21-09-2011 a les 10:28:17
Darrera actualització 21-09-2011 a les 10:28:17
Obrir nova finestra de phpMyAdmin

Ya me diras,

atentamente

Jordi.

ResponderCitar
Respondido : 23/09/2011 7:59 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Esteban
 Esteban
Usuario activo

He localizado este forum donde ya se registran estos problemas.
http://forums.asp.net/t/1409091.aspx/1

Acabando por indicar aplicar esta solución donde parece ser que la cosa se soluciona,
http://smart2dotnet.wordpress.com/category/captcha/

Ignoro si esto es propio de la plantilla pero parace ser que es algo relacionado con la programación del sitio, desafortunadamente ignoro también por completo el significado de tanto codigo pues no soy programador.

Quizas deba hablar con los creadores de la plantilla, de todas maneras otro caso mas para no recomendar el uso de Internet Explorer.

ResponderCitar
Respondido : 23/09/2011 8:17 am
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Esteban

Veo que deshabilitaste las urls amigables.

He realizado una prueba de envío en IE8 y IE7 en ambas se envió el formulario.
En IE7 el mensaje de problemas en javascript aparece al centro de la pantalla, IE8 lo marca en la parte inferior, pero como te comenté en ambos casos veo que funciona correctamente.

Los links enviados corresponden a artículos relacionados con ASP.net , Joomla trabaja con PHP por lo que no creo que sean de mucha ayuda.

Saludos.

ResponderCitar
Respondido : 23/09/2011 7:46 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Esteban
 Esteban
Usuario activo

Hola,

Gracias por tus pruebas y comentarios. Durante esta mañana procedo a revisar otra vez el formulario desde los equipos de mi oficina.

Por otro lado, no acabo de entender que sucede al activar o desactivar urls amigables no. Todas las paginas de mi web tiene SEO informado y me temo que se puede ignorar por los robots si tengo esta opción desactivada.

Saludos.

ResponderCitar
Respondido : 26/09/2011 7:14 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Esteban,

Si accedo a http://www.ejccomunicaciones.com y hago clic en productos, es la url http://www.ejccomunicaciones.com/index.php?option=com_content&view=article&id=124&Itemid=543 si tuvieras los parámetros de SEO activados se convertiría en http://www.ejccomunicaciones.com/productos o http://www.ejccomunicaciones.com/productos.html de dependiendo de si activas los 2 o 3 parámetros de SEO en la configuración global.

En casos de que hay algún error en un sitio web, en algunos casos solicitamos desactivar url's amigables, ya que algunas extensiones algunas veces puedan producir error con las mismas activadas.

No es que los buscadores dejen de buscar por tu sitio web, pero es mucho mejor tener activado, a nivel de indexación por los buscadores, ya que les da más información una url http://www.ejccomunicaciones.com/productos que otra del tipo http://www.ejccomunicaciones.com/index.php?option=com_content&view=article&id=124&Itemid=543

Saludos,

ResponderCitar
Respondido : 26/09/2011 8:33 am

Cursos Gratuitos WordPress

Esteban
 Esteban
Usuario activo

Bien pues entendido, creo que ya puedo cerrar, este tiquet pues incluso con Iexplorer 6 se puede ver el captcha. Las modificaciones efectuadas permiten gestionar los formularios.

Muchas gracias por todo.

ResponderCitar
Respondido : 26/09/2011 11:26 am