Idiomas y k2  

Página 1 / 2
 
Jordi
 Jordi
Estimable Member

Hola,
vuelvo a tener problemas con los idiomas en la web http://farreras-cp43.webjoomla.es
He cambiado un elemento de menú (inicio) a K2 y ha desaparecido el Catalan.
No hay manera de volverlo a configurar.
Por otra parte, k2 no me traduce. Debo descargar algún ficherop adicional de idiomas para k2?
A ver si me podeis indicar como solucionarlo....
Gracias
Jordi
(adjunto captura de pantalla)

Citar
Respondido : 14/02/2012 6:22 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Jordi,

¿Trabajas con multiidiomas y los tienes configurados y habilitados? el error de la primera captura parece indicar que tienes algún problema con los idiomas habilitados o configurados.

- Idiomas en Joomla 1.7 (multi-idioma): https://www.webempresa.com/blog/item/515-idiomas-en-joomla-17-multi-idioma.html

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 15/02/2012 1:48 am

Cursos Gratuitos WordPress

Jordi
 Jordi
Estimable Member

Hola Luís,
hasta que he instalado K2 funcionaba perfectamente.
Pero los artículos en K2 no admiten idiomas como Joomla....
por otra parte, he visto que no de meja cargar Catalán con el instalador de ficheros.
Me puedes decir donde encontrar la última version de catalan para k2?
la que conseguí no es para la útlima versión de k2 y no me deja instalarla.
gracias
Jordi

ResponderCitar
Respondido : 16/02/2012 3:26 pm
David Noguera
 David Noguera
Miembro Admin

Hola Jordi, puedes conseguir la última versión del idioma Catalán para K2 aquí:

http://getk2.org/extend/translations

Saludos!

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 16/02/2012 3:44 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Jordi
 Jordi
Estimable Member

Gracias David!!!
pero sigo sin poder poner el elemento inicio en catalan. me dice que debe estar en "todos"
cuando antes estaba en catalán ...
no entiendo nada.
Jordi

ResponderCitar
Respondido : 16/02/2012 6:19 pm
Jordi
 Jordi
Estimable Member

He hecho esto:
1. Abra el gestor de idiomas y asegúrese de que los idiomas de contenido están publicados y tienen un código de idioma para la URL, así como el prefijo para la imagen usada en el módulo selector del idioma.
2. Cree una página de inicio asignando un idioma a un elemento de menú, y defínalo como predeterminado de la página de inicio para cada contenido publicado en un idioma.
3. A partir de ahí, usted puede asignar un idioma a cualquier artículo, categoría, módulo, noticias externas, o enlace web de Joomla!.
4. Asegúrese de que tanto el módulo como el plugin están habilitados.

y sigue igual.... no me deja poner el catalan como predeterminado de inicio.
J

ResponderCitar
Respondido : 16/02/2012 6:26 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jordi
 Jordi
Estimable Member

Una pregunta:
tengo instalados un módulo selector de idiomas para cada idioma.
Pongo solo uno y lo dejo en "todos" ?
Gracias
Jordi

ResponderCitar
Respondido : 16/02/2012 7:01 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Jordi,

¿Puedes facilitarnos una captura de los que comentas para entender mejor que configuración estas realizando?.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 16/02/2012 7:34 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Jordi
 Jordi
Estimable Member

Hola Luís, gracias por resonderme.
Adjunto 4 capturas:
modulo selector idiomes
idiomas instalados
catalan (el que ha dejado de funcionar con K2
y francés (que nunca ha funcionado....)
Gracias
Jordi

ResponderCitar
Respondido : 16/02/2012 8:15 pm
Jordi
 Jordi
Estimable Member

Disculpa Luís, me había dejado la captura de idiomas del contenido.
Gracias
Jordi

ResponderCitar
Respondido : 16/02/2012 8:17 pm

Cursos Gratuitos WordPress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Jordi

Deberías sólo tener un módulo selector de idioma , es decir asígnale como idiomas Todos.

Por otro lado, cuando envíes tus capturas de pantalla trata de que muestren de que captura se trata mostrando el título de la pantalla en la imagen.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 17/02/2012 7:55 pm
Jordi
 Jordi
Estimable Member

Gracias jhon,
Tomo nota de las capturas 🙂
Ahora tengo solamente un selector de idiomas, en todas las páginas y idioma "todos"
En el menú principal, submenu inicio (es un módulo de notícias), intento poner que la página de inicio sea idioma "Catalán" y me vuelve a decir :
Se ha producido un fallo al guardar con el siguiente error: El parámetro del idioma para este elemento del menú debe estar asignado en 'Todos'. Siempre y cuando que el sitio esté configurado para funcionar con múltiples idiomas, por lo menos un elemento del menú predeterminado debe tener asignado en 'Todos' el campo del idioma.
Lo raro es que en el módulo que contiene el menu principal, he cambiado expresamente un submenu a todos y sigue sin funcionar.
Help....
Gracias
Jordi

ResponderCitar
Respondido : 18/02/2012 9:17 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Jordi
 Jordi
Estimable Member

Jhon,
adjunto captura del menú inicio.
El submenu "Novetats" es el elemento de inicio predeterminado en catalán.
Como ves, he puesto otro elemento en "todos" a ver si así funcionaba según lo que decía el error, pero nada.
Saludos
Jordi

ResponderCitar
Respondido : 18/02/2012 9:30 am
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Jordi,

Navego por tu sitio web y lo primero que me llama la atención es que estando por defecto en Catalán, el selector de idiomas (esquina superior derecha) no me muestra la bandera de Catalán tal como puedes ver en la captura:

¿Es de propósito o es que no está habiltada en Joom!Fish?

He navegado por "Novetats" y lo veo correcto, todos los items me cargan en Catalán y no veo errores por ninguna parte ¿lo has corregido?.

Nota, las captura si pudieras adjuntarlas en jpg o png seria más fácil consultarlas.

Para realizar una captura de pantalla puedes emplear las siguientes opciones en función del sistema operativo que utilices:

Windows: - La forma más rápida es pulsado la tecla "Impr-Pant" (habitualmente en la parte superior derecha del teclado) o en ordenadores portátiles "fn"+"impr-pant" lo que genera una captura de la pantalla actual en la memoria de su PC. Posteriormente debe abrir un programa de gestión de imágenes, Paint, Photoshop, etc., crear un documento "Nuevo" y pegar la captura desde el menú "Edición" -> "Pegar" o utilizando la combinación de teclas: "Control"+"V". Posteriormente guardar la captura preferiblemente en formato ".jpg".

En la medida de lo posible trata de evitar incrustar capturas en documentos de Word ya que la perdida de resolución es grande y dificulta la correcta visualización de la imagen.

Mac: - Pulsar la combinación de teclas "cmd"+"Shift"+"3 para capturas de pantalla completa o "cmd"+"Shift"+"4" para seleccionar una zona a capturar.

Linux: - Pulsar la tecla "Impr-Pant" (habitualmente en la parte superior derecha del teclado). Eso abrirá una ventana con la imagen capturada con las opciones de "Copiar al portapapeles" o "Guardar" como archivo .png (por defecto).

También puedes utilizar algunas de estas extensiones para Firefox y Chrome que te permiten realizar capturas de "área visible", "página completa" o "área seleccionada" y guardar las capturas directamente en formato .jpg o .png:

- ScreenGrab Firefox: https://addons.mozilla.org/es-ES/firefox/addon/1146/
- ScreenGrab Chrome: https://chrome.google.com/extensions/detail/mdddabjhelpilpnpgondfmehhcplpiin?hl=es-ES
- Awesome Screenshot - Capture and Annotate - Firefox: https://addons.mozilla.org/es-ES/firefox/addon/awesome-screenshot-capture-/

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 18/02/2012 7:10 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jordi
 Jordi
Estimable Member

Gracias Luis,
De lo mismo me quejo yo!
Porque ha desaparecido la banderita?
Porque me da el error descrito al intentar predeterminar el catalan?
Me esta volviendo loco este asunto y de veras que es sumamente im
Portante, pues segun el idioma debe ir a una pagina u otra...
A ver si podemos solucionarlo... asi como el frances desaparecido tambien!
Saludos
Jordi

ResponderCitar
Respondido : 19/02/2012 7:19 pm
Página 1 / 2

Por favor Iniciar Sesión o Registro