Avisos
Vaciar todo

k2 Content + Sección Especifica Web  

 
Juan Díaz
 Juan Díaz
Usuario eminente

Buenas.

Tengo un pequeño problema con el modulo k2 Content.

Actualmente estoy desarrollando la siguiente web http://www.vetsalou.com/ la cual tiene una sección de blog: http://www.vetsalou.com/blog que esta montada con K2. Hasta aquí todo perfecto.

El problema radica en el modulo de "Últimos Artículos", que es un k2 Content, muestra las últimas entradas de las diferentes categorías de la sección blog, si estas navegando por la web y picas en una noticia de las que aparece en dicho modulo se carga la noticia/entrada pero visualmente como si estubiera fuera del apartado blog, es decir no respeta breadcrumbs, imagenes asociadas a la sección blog.... he revisado varias veces la configuración y no consigo arreglar esto.

Articulo clickado desde dentro del blog:
http://www.vetsalou.com/blog/item/5-art%C3%ADculo_sobre_leismaniosis

Mismo artículo cargado desde otra sección pero clickando en el articulo dentro del modulo Ultimas noticias, k2 content:
http://www.vetsalou.com/component/k2/item/5-art%C3%ADculo_sobre_leismaniosis

Desde ya, muchas gracias!

Citar
Respondido : 12/01/2012 10:23 am
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Parece que el problema está en que los enlaces del módulo K2 Content no se están asociando correctamente con el elemento de menú "El Blog" que carga los artículos de K2. Para que esto funcionase bien el menú "El Blog" debería de estar configurado para cargar las mismas categorías de K2 que el módulo.

Prueba también a desactivar el SEO para ver si así funciona. Con el SEO desactivado tendría que coincidir el Itemid del menú "El Blog" con el de los enlaces del módulo K2 Content.

ResponderCitar
Respondido : 12/01/2012 11:32 am

Cursos Gratuitos WordPress

Juan Díaz
 Juan Díaz
Usuario eminente

Buenas Pablo.

Ante todo muchas gracias por tu pronta y sabia respuesta!!

Has dado en el clavo. Te comento para que esta info pueda ayudar a futuras consultas 😉

El problema radicaba en que el item de menú "El Blog" muestra categorias y subcategorias, pero solo estaba seleccionada la categoría padre, ya que marque el mostrar subcategorias, ya que cuando cree el item no existian subcategorias.
Al crear nuevas subcategorias y configurar el modulo k2 content a este si que le asociaba tanto la categoria del blog padre como las subcategorias.

Resumiendo y para que se entienda, para que el modulo de k2 content haga correctamente su trabajo y enlace bien con el apartado de blog de la web, tanto modulo k2 content como item de menu del blog deben tener seleccionandas las mismas categorías, tanto madre como subcategorias.

De nuevo muuuchas gracias por la ayuda y pronta respuesta. Se agradece enormemente el trabajo que hacéis.

Saludos!

ResponderCitar
Respondido : 12/01/2012 11:56 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Juan,

Nos alegra que te guste nuestro servicio.

Normalmente solicitamos testimonios para colocar en nuestra página y ayudar a otros posibles clientes a decidirse: https://www.webempresa.com/testimonios.html

Si nos quieres enviar tu testimonio podemos colgarlo en nuestra página con un link hacia la tuya que siempre te ayudará a posicionarse porque nuestra página tiene un Page Rank de Google alto.

En este artículo de nuestro blog se explica como dar de alta un testimonio:

https://www.webempresa.com/testimonios.html

Saludos

ResponderCitar
Respondido : 12/01/2012 3:21 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Juan Díaz
 Juan Díaz
Usuario eminente

Jordi, ya está enviado el testimonio.

De nuevo y como siempre muchas gracias.

ResponderCitar
Respondido : 12/01/2012 5:43 pm