Problema en el modulo GK4 y unas dudas para cambio de banner.  

Página 1 / 3
 
Ginés
 Ginés
Reputable Member

Buenas tardes.

Lo primero de todo quiero dar las gracias por la labor del equipo en intentar ayudar y resolver nuestras dudas con joomla.

En segundo lugar quiero que sepan que esta consulta se la hago después del gran quebradero de cabeza que llevo con mi joomla.

Cuento un poquito la historia.

Soy una persona que sigue los mercados de acciones desde hace más de una decada, en 2003 cuando nace este proyecto "inveuro.com" vivia en Barcelona, fué algo particular y de forma anónima. Pues aquel proyecto web que ayudaba a inversores particulares y no tan particulares tuvo mucho éxito. Como fué algo que no tenia ningún lucro terminó por cansar, ya que trabajando casi 10 horas al dia en otro trabajo como administrativo en una empresa y luego llegar a casa para actualizar la web suponia que prácticamente no tenia tiempo para nada, ni para la familia, decidí paralo.

Pues como digo aquello acabó cansando, después de unos años de mucha actividad quedó parada, siempre fuí renovando el hosting y domino con la empresa que lo tenia (y sigo teniendo actualemnte). Bueno digo que sigo teniendo porque en breve me vencen sus servicios y no tengo ni la más mínima duda que el dominio que tengo con esta emrpesa externa lo voy a trasladar con vosotros también, ya que el hosting ya lo tengo con ustedes.

Aprovechando la oferta de registro de un nuevo domino registré en Webempresa "inveuro.es" y la verdad que no puedo estar más contento, precio, servicio y todo lo que queda por venir.

Siguiendo la historia, llega el dia, (hace algunos meses) que me vuelvo a plantear relanzar la web, pero esta vez cambiando el php-nuke por este joomla que he descubierto este mismo año.

Tengo que felicitar expresamente al equipo que ha tenido la maravillosa idea de lanzar las 30 sesiones sobre joomla, me han gustado tanto que los he bajado, (con vuestro permiso) para esas veces que no tienes conexión, o cuando necesitas consultar algo rápido. Són un total de de 168 videos, los tengo numerados y clasificados como "oro en paño" :), no me falta ni uno, divididos en 30 sesiones como digo. Esto lo digo porque el problema que tengo en la web joomla no es algo que me halla surgido hoy, ni ayer, sino que lleva dias y muchas, pero muchas horas realizando pruebas y no consigo encontrar el problema.
Antes de seguir por las ramas, lo dicho, chapó por esos videotutoriales, de verdad enhorabuena.

Bueno como les decia tengo un problema, después de ver todos los videos, me decidí a comprar el template "Financial Business" de Gavick.com que según vuestro comercial teneis un acuerdo con él y conoceis los "entresijos" por así decirlo de sus templates.

He de decir que me he puesto en contacto con Gavick en no menos de 12 ocasiones, entre foro y ticket de consulta abiertos, y entre que me inglés no es muy allá que digamos, que uso google traductor, y que él tampoco sinceramente ha puesto mucho de su parte para ayudarme, me veo abocado a pediros ayuda.

Tengo subida la web para mostrarla a Gavick y a vosotros, porque le he mandado infinidad de capturas de pantalla con el problema y lo que necesito, pero a dia de hoy sigo sin poder solucionarlo.

Esta parte que tengo problemática es el "Pilar fundamental" de la web, ya que es donde voy a colgar los análisis de los valores y donde los usuarios buscan el apoyo a sus decisiones de inversión.

Este módulo que falla es el "News" en la plantilla de gavick, se encuentra en la posición "header2" y el archivo es "mod_news_pro_gk4".

Como les digo he subido la web en la que estoy trabajando, me quedan algunas cosas por terminar, pero como digo si este módulo no me funciona el resto de la web no tiene sentido.

La web:

Contenido solo visible a usuarios registrados

He facilitado todos los datos posibles para que no falte nada por aportar y puedan ayudarme a enfocar y solucionar este problema.

Finalmente el problema que tengo, después de pinchar en cualquier noticia o titular del modulo "Ultimos Analisis" o del modulo de bajo "Analisis" que se encuentra en la posición "user1" o el modulo de al lado que pone "Curso Bolsa" posición "user2" AL PINCHAR NO SE VA A LA CORRESPONDIENTE NOTICIA O CURSO, SE QUEDA EN EL HOME, en la barra de arriba del navegador aparece la ruta de la noticia pero la web se queda en el Home.

He probado de todo, he añadido nuevas categorias, nuevos modulos, nuevos articulos, etc... infinidad de pruebas y no consigo sacar el problema.

Les aseguro que esta consulta la he meditado antes de enviar nada, ya que soy de las personas que me gustan encontrar las soluciones antes de pedir ayuda, son muchas como dije arriba las horas que estoy dedicando a este nuevo proyecto y muchas las horas en este problema.

Aquí una captura de pantalla con el problema de los modulos que no funcionan.

/

Y aquí una captura de un par de cuestiones que gavick no me responde.

/

Una cuestión y muy imporante es poder poner un banner de publicidad entre el logo y el login, existe un espacio perfecto para eso.

El modulo banner1 lo he utilizado para colocar un modulo que hace que los titulares de las noticias se desplazen encima del cuerpo principal, pero NECESITO ACORTAR ESO QUE INDICO EN UN CUADRO ROJO, para ajustarlo más y no encuentro al archivo donde tocar, he repasado varias veces los videotutoriales donde se toca fireburg para sacar la ruta y no la encuentro. (SOLUCIONADO ESTE PROBLEMA, EL MENOR DE TODOS, PERO ALGO ES ALGO: SOLUCIÓN EN EL TEMPLATE.CSS EN LA LINEA 45 ENCONTRÉ EL LUGAR DE BAJAR Y AJUSTAR, TENIA UN VALOR DE 20px LO HE BAJADO A 2px Y YA ESTÁ) Lo dejo en rojo para que vayamos sacando adelante las soluciones y si alguno más lo tiene algún dia pueda verlo, ahora a por el resto de problemas, que són los importantes.

Sacrificaria este modulo para moverlo arriba donde necesito un banner publicitario, (si es necesario) pero quziás se pueda duplicar ese código de ese modulo "banner1" y subir a ese espacio entre logo de la empresa y Registro.

Bueno, este post es extenso y largo, os pido muchas disculpas por el mismo, pero necesito solucionar este par de incovenientes como sea, el problema del modulo, subir el banner y acortar el modulo de los titulares desplazandose.

Si como les digo me pueden echar una mano, me hacen un mundo, he repasado muchos post de este foro y no encuentro problema parecido al mio.

Un saludo, Ginés

Citar
Respondido : 13/11/2011 3:21 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Ginés

Con respecto a tu problema de las urls que llevan a la página de inicio, veo que por ejemplo la siguiente url

Contenido solo visible a usuarios registradosl

Tiene dos partes, como si hiciera referencia doblemente a un artículo, tienes algún componente de urls amigables adicional instalado?

Te sugiero deshabilitar de Joomla las url amigables para ver como se forma la dirección.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 13/11/2011 4:48 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Ginés
 Ginés
Reputable Member

Gracias jhon por contestar.

No tengo ningún componente instalado de urls amigables.

He desactivado el url amigables para que veas como se forma la dirección completa, pero no encuentro solución posible.

ResponderCitar
Respondido : 13/11/2011 5:01 pm
Ginés
 Ginés
Reputable Member

Por favor alguien me puede echar una mano? No encuentro la solución y sigo intentando de todo, venga maestros una ayudita pleasse !!!

Gracias de antemano.

ResponderCitar
Respondido : 14/11/2011 8:21 am

Cursos Gratuitos WordPress

Jordi Sala
 Jordi Sala
Miembro Admin

Hola Ginés,

Contenido solo visible a usuarios registradosno se visualizan.

No puedo saber cuando indicas que es el módulo de la posición Header2, si te refieres al del desfile de imágenes o al de Últimos Análisis.

¿ Has probado a instalar de Gavick, el Quickstart for J! 1.7 gk_financial_business_quickstart_J17.zip (Size: 14 Mb | Hits: 1327) para ver si funciona correctamente ?.

Saludos,

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 14/11/2011 9:56 am
Ginés
 Ginés
Reputable Member

Gracias Jordi, por contestar.

En primer lugar me puedes decir como activo la visualizacion de la plantilla, eso es algo que he visto en los videotutoriales y probé con mi template pero no aparecian.

Como puedo activarla?

En segundo lugar, sí, efectivamente he instalado el Quickstart que indicas completo de Gavick, y funciona correctamente con sus articulos y sus categorias.

Pero si intento meter yo mis categorias y mis articulos me encuentro con este problema.

Te asguro que llevo una cantidad inmensa de horas trabajando en este template y sobre todo con este problema.

Gracias por echarme un cable, espero que pueda solucionarlo, dime como activo esa opción, aunque la posición header2 es la que indico en el demo de su template.

http://demo.gavick.com/joomla16/jun2011/index.php/template/lorem-ipsum/module-positions

Es la que corresponde en mi web con "Ultimos Analisis"

También ocurre lo mismo con los articulos de Analisis abajo de mi web, y Curso de Bolsa, todos los links me vuelven al home, y en la barra de direcciones se queda el link completo.

🙁

ResponderCitar
Respondido : 14/11/2011 10:02 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Jordi Sala
 Jordi Sala
Miembro Admin

Hola Ginés,

En primer lugar me puedes decir como activo la visualización de la plantilla, eso es algo que he visto en los videotutoriales y probé con mi template pero no aparecian.

Acceder a administración --> extensiones --> gestor de plantillas --> opciones --> Vista previa de las posiciones de los módulos --> habilitar, guardar y cerrar.

En segundo lugar, sí, efectivamente he instalado el Quickstart que indicas completo de Gavick, y funciona correctamente con sus articulos y sus categorías.
Pero si intento meter yo mis categorías y mis artículos me encuentro con este problema.

Creo que debes tener una configuración diferente en el módulo de la plantilla que no funciona, al Quickstart. Abre dos pantallas y realiza una comparación de los parámetros para ver cual está distinto.

Aquí tienes información sobre el Servicio de Mantenimiento Joomla!:
https://www.webempresa.com/web-empresa-joomla-servicios/soporte-joomla.html

Saludos,

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 14/11/2011 11:42 am
Ginés
 Ginés
Reputable Member

Gracias Jordi, acabo de activar la visualización de la posición de los módulos por si quieres pegar un vistazo.

Por otro lado, sigo sin encontrar la solución a este problema, me surge la duda de como instalar de nuevo el template de gavick sin perder los datos de todo lo que he realizado hasta ahora, modulos, articulos, categorias, etc...

Una consulta más.

¿Es aconsejable instalar el foro kunena que tengo pensado poner en la web, una vez esté lista sólo a falta de dicho foro, o se puede instalar ya?

¿Es aconsejable instalarlo en local o una vez subida a la red?

En la última parte haces mención al mantenimiento, te refieres a mi petición de colocar el banner arriba?

Bueno, voy a pedir presupuesto por esta labor, aunque viendo los precios de los paquetes me tirar para atrás, ya que sólo necesito esta mejora.

Gracias Jordi por ayudarme.

ResponderCitar
Respondido : 14/11/2011 12:04 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Ginés

Se puede apreciar que las urls estan formandose mal, debido tal vez a alguna configuración

Url real :
Contenido solo visible a usuarios registrados

Puedes enviar una captura de pantalla para ver como tienes configurado el módulo que se muestra en la posición user1 (la captura debe ser de los parámetros del módulo)

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 14/11/2011 3:50 pm
Ginés
 Ginés
Reputable Member

Buenas tardes Jhon, Jordi, ambos aportando vuestras ayudas.

He conseguido solucionar el problema, gracias también a webempresa por todo los medios que ponen de su parte ayudando a la gente con joomla.

La solución era tan sencilla como publicar las noticias a través del módulo k2 y no como estaba yo realizando desde los articulos normales de joomla.

Estos articulos de esta plantilla en concreto de gavick van enlazados al k2, fijate tú, si es un tren me pasa por encima 🙂

Ahora me queda una última lucha, y es intentar poner un banner arriba, entre el logo del template y el login/registro, sitio para ello tengo.

Pero creo que esta labor es ya más del servicio técnico.

Gracias por vuestra ayuda, desde luego otra cosa no, pero ayudar ayudais mucho a la gente.

Saludos, seguiremos viendonos, o más bién, posteando.

ResponderCitar
Respondido : 14/11/2011 4:47 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Jordi Sala
 Jordi Sala
Miembro Admin

Hola Ginés,

Te será de utilidad el artículo Agregar Nueva Posición a un Template en Joomla :
https://www.webempresa.com/blog/agregar-posicion-template-joomla.html

Saludos,

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 15/11/2011 2:32 pm
Ginés
 Ginés
Reputable Member

Gracias Jordi por este docomento para colocar el banner arriba.

Estoy fuera de casa en un ordenador sin sonido, por lo que el video no puedo oirlo, pero observo que se coloca el banner en la parte superior, incluso encima del logo.

En la plantilla de ejemplo de ese tutorial la del template de Gavick es la yourshop, tienen espacio para colocarlo entre el logo y el carrito, me surge la duda de si será complicado colocarlo en ese lugar.

Arrriba parece fácil porque es colocar el código al principio, antes del logo según se explica, pero la idea para no desajustar muco nuestra web y que se vea ordenado todo seria donde digo, entre el logo y el carrito en este template, parecido seria en mi web.

Crees que será complicado esto?

Esta noche en casa con sonido examinaré más detenidamente el video.

En cualquier caso montones de gracias Jordi por el documento.

ResponderCitar
Respondido : 15/11/2011 3:29 pm

Cursos Gratuitos WordPress

Ginés
 Ginés
Reputable Member

Jordi o Jhon, voy a intentar explicar con detalle mi idea y mostrar con imágenes lo que me encuentro para hacer esta modificación, haber si podeis echarme un cable.

1º Imagen los archivos de mi template (financial business) de Gavick.

2ª Imagen del contenido del archivo top.php que hace referencia el articulo que me has mostrado Jordi, no creo que sea este el lugar para meter ese código por la estructura de mi template.

3ª Imagen del archivo header.php donde he encontrado el código del banner1, posición del banner en el template de gavick donde lo tengo utilizado con un modulo de noticias, pero que podria copiarse arriba.

4º Imagen original del template de gavick, con la posición de los módulos, se puede ver esta posición del banner1 donde está, y entre logo y userarea existe el sitio perfecto para el banner que quiero colocar.

5ª Imagen de mi web, donde indico que la posición banner1 la tengo utilizada con ese modulo que me muestra los titulares, la idea seria colocar ese banner donde indico, en el cuadro rojo,

Creo que muestro bién todo el detalle de la idea que quiero realizar, ahora que sea fácil no lo sé, por eso pregunto a los maestros.

Cuando podais me tirais un cable o una soga 🙂

Gracias de antemano.

ResponderCitar
Respondido : 15/11/2011 4:11 pm
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Ginés,

Te hemos facilitado los datos y la información disponible (en casos similares) para que puedas realizarlo.

A la pregunta de si es fácil o difícil de realizar, todo depende de los conocimientos que uno tenga de CSS, PHP y de Joomla!, y del tiempo que desees emplear estudiando como realizar, o realizando esos cambios si se tiene el conocimiento necesario para acometerlos.

Para este tipo de consultas, disponemos de un Pack de Horas que te permitirá que uno de nuestros técnicos realice las modificaciones por ti, aquí tienes más información sobre el Servicio de Soporte Técnico por horas que ofrecemos: https://www.webempresa.com/web-empresa-joomla-servicios/soporte-joomla.html

Saludos,

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 16/11/2011 9:10 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Ginés
 Ginés
Reputable Member

Gracias Jordi por todo lo aportado a lo largo de este hilo, intentaré realizar esta modificación por mi mismo, así voy manejando algo más este lenguaje.

Entiendo lo del paquete por horas, pero de momento se escapa de mi presupuesto.

Sólo una pregunta, el archivo que debo tocar no es el top.php que me indicas en el manual verdad?

El código lo debo iinsertar en el header.php?

Esta respuesta creo que si puedes aportarla, espero.

Lo dicho, gracias en cualquier caso por la gran ayuda que aportais a toda la comunidad joomla.

ResponderCitar
Respondido : 16/11/2011 9:51 am
Página 1 / 3

Por favor Iniciar Sesión o Registro