Avisos
Vaciar todo

Traducir joomla 1.7.4 al español  

Página 1 / 2
 
Tonino
 Tonino
Estimable Member

Hola a todos. He instalado un quickstart, de gavick concretamente, y se ha instalado joomla 1.7.4. El caso es que he querido traducirlo con los parches de idioma de joomlaspanish y me encuentro con el siguiente problema, (envío pantalla).

Gracias
Saludos

Citar
Respondido : 26/01/2012 6:40 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Tonino,

Para poder instalar el pack de idioma español de Joomla!Spanish debes activar como idioma predeterminado el idioma Inglés y después desinstalar el idioma español y una vez hecho esto podrás entonces instalar el idioma español descargado.

Saludos

ResponderCitar
Respondido : 26/01/2012 7:44 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Tonino
 Tonino
Estimable Member

Hola Luis, el caso es que en el gestor de idiomas del backend solo está el inglés y está como predeterminado. Solamente veo idioma español en el administrador de archivos de cPanel, en la carpeta language y parece que son archivos para virtuemart, pero no se si debo borrarlo de ahí.

Saludos

ResponderCitar
Respondido : 26/01/2012 8:06 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Adjunta el archivo de idiomas que estás tratando de instalar para que revisemos si es correcto. Asegúrate que has descargado un paquete de idiomas compatible con tu versión de Joomla. Por ejemplo, los idiomas de Joomla 1.5 no son compatibles con Joomla 1.7.

Otra opción que puedes usar es descomprimir directamente los archivos con extensión .ini que vienen en el zip en la ruta administrator/language/es-ES.

ResponderCitar
Respondido : 26/01/2012 11:45 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Tonino
 Tonino
Estimable Member

Hola Pablo, los archivos de idioma son estos que te envío. Los descargué de joomlaspanish como idioma para j 1.7.4.

Saludos

ResponderCitar
Respondido : 27/01/2012 10:47 am
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

En primer lugar comprueba si el idioma español figura como instalado. Para ello, en la administración de Joomla vete a Extensiones->Gestor de extensiones. A continuación, pulsa en la pestaña Gestionar. En el filtro "Seleccione tipo" escoge el filtro por Idioma y comprueba si sale algún idioma Español. De ser así, prueba a desinstalarlo y volverlo a instalar.

Si no había ningún paquete de idiomas en español, vete al gestor de archivo de CPanel y, previa copia de seguridad, borrar el directorio administrator/language/es-ES. Después prueba de nuevo a instalar el paquete de idioma español de admin para ver si te funciona.

ResponderCitar
Respondido : 27/01/2012 11:44 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Tonino
 Tonino
Estimable Member

Hola de nuevo, he comprobado lo que me dices y no aparece nada. Luego he eliminado las carpetas es-ES tanto de public como de administrador en cPanel y después he instalado el idioma del front y del admin en español. Hasta ahí parece que todo va bién, pero cuando en el gestor de idiomas pongo por defecto tanto en admin como en sitio, el español, en Virtuemart dejan de verse los artículos de ejemplo que trae el quickstart. Además en el sitio cuando actualizo me da los errores que te envío en el adjunto.
Lo que si veo es que en las carpetas es-ES que elimino en cPanel, hay solo archivos para Virtuemart que también son eliminados. Luego el idioma que instalo no estoy seguro de que los restituya. He probado a salvarlos yo y luego subirlos, pero tampoco funciona.

Los espacios en blanco del archivo los he borrado porque hacían referencia a la base de datos y su prefijo..

Muchas gracias

Saludos

ResponderCitar
Respondido : 27/01/2012 1:26 pm
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Tonino,

Son temas completamente diferentes, ya que los paquetes de idioma de Joomla! nada tienen que ver con los de Virtuemart, ¿Que versión de Virtuemart has instalado?

Si accede a extensiones --> gestor de idiomas --> ¿te aparecen ambos idiomas en las diferentes pestañas?: Instalado - Sitio ---- Instalado - Administración ----- Contenido

Saludos,

ResponderCitar
Respondido : 27/01/2012 2:39 pm

Cursos Gratuitos WordPress

Tonino
 Tonino
Estimable Member

Hola Jordi, la versión de Virtuemart es 2.0.
Los idiomas aparecen cuando los instalo despues de borrar las carpetas del idioma en cPanel. Si no borro dichas carpetas a la hora de instalar el idioma me da el error que mencioné anteriormente.
Acompaño archivo de nuevo.

Saludos

ResponderCitar
Respondido : 27/01/2012 4:20 pm
Tonino
 Tonino
Estimable Member

Hola de nuevo. He conseguido instalar los archivos de idioma de la siguiente manera.
He renombrado los archivos index.html y he instalado los archivos de idioma sin que me diera ningún error. lo que no se a que afecta el haberlo hecho así.
En principio va bien así. El problema lo tengo cuando entro en Virtuemart. como dije antes, me desaparecen los datos de muestra cuando pongo en el gestor de idiomas, el español por defecto.
No obstante si habilito el plugin de filtro de idioma, en Virtuemart me deja habilitar ambos idiomas, pero no acaba de convencerme como se comporta. Creo que algo se me escapa..

Muchas gracias

Saludos

ResponderCitar
Respondido : 27/01/2012 6:01 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Tonino

Creo que instalaste bien los idiomas según comentas , finalmente es un reemplazo de archivos solamente.

Lo que no entiendo bien es lo último que explicas, puedes adjuntar algunas capturas de pantalla para entender mejor el problema.

Salduos.

ResponderCitar
Respondido : 27/01/2012 11:54 pm
Tonino
 Tonino
Estimable Member

Hola Jhon

Lo que me ocurre después de instalar el idioma es lo siguiente:

Si dejo el idioma por defecto en inglés tanto en admin como en front, cuando accedo a Virtuemart veo los productos de muestra y demás configuraciones de muestra aunque en inglés.

Si pongo el idioma por defecto en español en admin y front, cuando accedo a Virtuemart dejo de ver los productos y demás, pero veo Vm en español.

Lo que ocurre entonces es que cuando accedo al sitio web me da una lista larga de errores relaccionados con Virtuemart.

No se si eso es normal ya que que no he hecho ninguna otra configuración multiidioma.

Saludos

ResponderCitar
Respondido : 30/01/2012 1:09 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Jordi Sala
 Jordi Sala
Miembro Admin

Hola Tonino,

El error que muestra la captura de pantalla, es un error que no puede cargar la tabla relacionada con vendedores. El tema de vendedores en Virtuemart siempre ha dado problemas, no se si estás usando esa funcionalidad.

Saludos

ResponderCitar
Respondido : 31/01/2012 8:13 am
Tonino
 Tonino
Estimable Member

Hola Jordi
Si te refieres a esta pantalla, está configurada así.

Saludos

ResponderCitar
Respondido : 31/01/2012 12:17 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Jordi Sala
 Jordi Sala
Miembro Admin

Hola Tonino,

Nos has enviado una captura de pantalla con los errores de bases de datos, y nos indicas que suceden al acceder al sitio web.

¿ Nos puedes explicar que pasos realizas, hasta llegar a mostrar esos errores el navegador? Parece relacionado con el tema de vendedores y el idioma castellano.

Saludos

ResponderCitar
Respondido : 01/02/2012 12:43 pm
Página 1 / 2