Actualizar Joomla 1.7.3 a Joomla 2.5  

 
Ginés
 Ginés
Reputable Member

Buenas noches.

La gran pregunta que tenia que llegar, estoy barajando la posibilidad de actualizar mi joomla 1.7.3 al nuevo 2.5, decir que mi versión de joomla es de una plantilla de Gavick instalada con el Quickstart.

Estuve esperando que estuviese algo más rodada y esta semana he recibido email vuestro que ya está disponible en webempresa la versión para descargar joomla 2.5.2.

Pero claro, las dudas surgen, la web está en marcha con miles de visitas diarias y no quiero que falle nada.

¿Es importante realizar la actualización de joomla a la nueva versión 2.5?

¿Será todo compatible y funcional?

El problema que puedo encontrar en mi joomla es que está muy modificado, módulos, ajustes varios como sabeis, y claro me da un poco de miedo pasar de una versión a otra.

En fin me gustaria conocer vuestra opinión y que me dijerais la opción más fiable de llevarla a cabo.

¿Existe algún tutorial para ello?

Gracias de antemano compañeros.

URL del sitio: http://www.inveuro.es

Citar
Respondido : 09/03/2012 11:32 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Ginés,

Conociendo tu sitio web y dado el numero de extensiones que utilizas, algunas muy particulares, yo creo que tu planteamiento debería ser diferente si me lo permites.

El planteamiento para realizar una migración de Joomla! 1.7.3 a 2.5 es el siguiente:

- Podrás migrar si tus actuales extensiones ya están disponibles en Joomla! 2.5, lo cual deberás verificar en el JED: http://extensions.joomla.org/search?q=joomla+2.5 y este punto es determinante para que puedas avanzar en la migración.
- NO podrás migrar si tus extensiones no están disponibles para Joomla! 2.5, y esta premisa es fundamental para seguir hablando de migraciones.
- Podrás migrar si ADEMÁS de tus extensiones, tu plantilla en uso esta disponible para Joomla! 2.5.
- Podrás migrar a Joomla! 2.5 si tus extensiones están disponibles para Joomla! 2.5 pero NO deberías migrar si tu plantilla no está disponible para esta rama, o por el contrario tendrás, tras la migración, pasar por un proceso de ADAPTACIÓN de la misma a una liberada para 2.5 y reajuste de módulos a nuevas posiciones.

Recomendación: no realizar una migración sin previamente hacer un respaldo del sitio web, preferiblemente con Akeeba Backup.
-

Tras analizar estos puntos, la migración actualmente es relativamente sencilla y con extensiones como jUpgrade se realiza de forma rápida desde Joomla! 1.7 a Joomla! 2.5 en un solo proceso.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 10/03/2012 2:16 am

Cursos Gratuitos WordPress

Ginés
 Ginés
Reputable Member

Gracias Luis por la respuesta tan detallada, entiendo perfectamente todo lo comentado.

Antes de que mi subscripción acabase con Gavick pude descargar la actualización de mi plantilla en Gavick para la versión 2.5 de modo que ese paso se que está, también las extensiones que uso de Gavick están para joomla 2.5, el resto de extensiones tengo que verificarlas, pero creo que no tengo muchas que no sean de GAvick 😉

Realizaré pruebas en el clon antes de nada y por supuesto akeeba backup, esta extensión es como el pan de cada dia, diria que es lo mejor que se ha inventando para joomla en cuanto a extensiones, 😉

Gracias, os mantendré informado de todo.

ResponderCitar
Respondido : 11/03/2012 12:21 am
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Ginés,

Realizaré pruebas en el clon antes de nada y por supuesto akeeba backup, esta extensión es como el pan de cada dia, diria que es lo mejor que se ha inventando para joomla en cuanto a extensiones,

No lo dudes que es una de las mejores extensiones disponibles para Joomla! en lo que a seguridad y respaldos se refiere, sobre todo si la mantienes actualizada.

- https://www.webempresa.com/blog/item/838-liberado-akeeba-backup-340-para-joomla-15-y-25-con-soporte-mejorado-para-dropbox.html

Actualmente disponible la versión 3.4.1.

Sobre las actualizaciones es importante que lo veas con detenimiento para no tener problemas, pero si lo llevas controlado todo lo relativo a extensiones y copias de seguridad, no deberías tener problemas en actualizar tu Joomla.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 11/03/2012 12:41 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Ginés
 Ginés
Reputable Member

Gracias Luis.

Me bajé el jUpgrade e intenté su instalación en la web de pruebas y luego en local, en los 2 me da erro y no se instala.

¿Sabes a que puede deberse?

Gracias, esto no me urge tanto, iré poco a poco progando la migración y viendo si genera fallos con el paso de los dias, de modo que cuando puedas sin prisa.

Gracias por la enorma labor de ayuda.

ResponderCitar
Respondido : 11/03/2012 12:59 am
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola

jUpgrade solo es necesario para actualizar de Joomla! 1.5 a 2.5, por error en anterior respuesta indique sobre jUpgrade desde Joomla! 1.7 y no es necesario.

Las actualizaciones de Joomla! 1.7 a 2.5 las puedes realizar con el Gestor de Actualizaciones nativo de Joomla! 1.7 o usando Admin Tools que es bastante eficiente para estas tareas.

Si deseas actualizar tus sitios a Joomla! 1.5.25 puedes revisar el siguiente enlace:

Si deseas actualizar tus sitios a Joomla! 1.7.3 puedes revisar el siguiente enlace:

Aunque la mejor opción es instalar Admin Tools en aquellas instalaciones Joomla! desactualizadas y realizar las actualizaciones en cada una previa copia de seguridad para mayor garantía:

- https://www.webempresa.com/blog/actualizar-automaticamente-joomla-17-a-la-ultima-version-estable-con-admin-tools.html

Si actualizas desde versiones anteriores a la 1.5.22 hasta la 1.5.25 o desde la 1.7.0 a la 1.7.3 y utiliza el pack en Español de Webempresa o Joomla!Spanish, posiblemente aparezcan cadenas sin traducir al actualizarte por el método de Admin Tools que utiliza como repositorio de update el de Joomla.org en inglés.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 11/03/2012 1:42 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Ginés
 Ginés
Reputable Member

Gracias Luis no te preocupes por la confusión.

Iré probando con tiempo y realizando copias de seguridad de todo.

Un saludo compañero.

ResponderCitar
Respondido : 11/03/2012 1:48 am

Por favor Iniciar Sesión o Registro