Avisos
Vaciar todo

Editar información de facturación sale en inglés  

Página 1 / 2
 
Aida
 Aida
Reputable Member

Hola!

En la web que estoy migrando al hacer una compra e ir al formulario "Añadir/Editar información de facturación" o "Añadir/Editar información de envío" los campos a rellenar salen en inglés.

Tengo activada la opción de comprar sin registrarse, sólo quiero que el cliente rellene los campos de facturación o dirección de envío...

¿cómo los cambio para que salgan en español?

Adjunto captura de pantalla.

Gracias
Aida

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 19/06/2013 5:23 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Aida

Cual es la url de tu sitio web, la url Contenido solo visible a usuarios registrados no muestra nada

Por otro lado , has instalado el componente AIO de virtuemart? ya que es este que tiene las traducciones de los idiomas más comunes

Saludos.

ResponderCitar
Respondido : 19/06/2013 8:22 pm

Cursos Gratuitos WordPress

Aida
 Aida
Reputable Member

Hola Jhon! La url del sitio es www.tspsurf.com/jupgrade y en los formularios Añadir/Editar información de facturación" o "Añadir/Editar información de envío" los campos a rellenar salen en inglés.

El componente AIO de virtuemart lo tengo instalado.

Por si tiene relación tambien me ocurre que en el panel de control de virtuemart, la parte de configuración me sale tambien en inglés y todo el resto en español.

Gracias
Aida

ResponderCitar
Respondido : 19/06/2013 8:40 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola Aida,

Verifica si tienes seleccionado el idioma español en extensiones => gestor de idiomas => administración => marcar como predeterminado español.

Saludos.

ResponderCitar
Respondido : 20/06/2013 12:37 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Aida
 Aida
Reputable Member

Buenos dias!

Si que está seleccionado el idioma español como predeterminado en el gestor de idiomas.

Saludos,
Aida

ResponderCitar
Respondido : 20/06/2013 8:19 am
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Por lo que comentas parece como si te faltaran archivos con las constantes de idioma en español.

Te adjunto comprimido en un zip 4 archivos para colocar en la ruta administrator/language/es-ES, sustituyendo a los archivos que puedas tener con el mismo nombre.

Estos archivos son las constantes de idioma para la administración de Virtuemart, por lo que al menos esta parte la deberías ver en español.

ResponderCitar
Respondido : 20/06/2013 9:30 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Aida
 Aida
Reputable Member

Hola! Disculpa pero no veo el archivo adjunto!!

ResponderCitar
Respondido : 20/06/2013 10:24 am
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Se me había olvidado adjuntar el archivo. Aquí va.

ResponderCitar
Respondido : 20/06/2013 12:43 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Aida
 Aida
Reputable Member

Hola! Subí los archivos y ahora me han desaparecido los botones de editar información de facturación.

Te adjunto captura de pantalla.

Aida

ResponderCitar
Respondido : 20/06/2013 5:52 pm
Aida
 Aida
Reputable Member

Hola! Aunque siguen sin salir los botones de facturación y dirección de envío despues de instalar los archivos del zip que me enviasteis la configuración de virtuemart que antes salía en inglés ya sale en español.

Os envío una captura de pantalla de la configuración de campos del comprador por si tengo algo mal y por eso no salen los botones...

Me urge solucionarlo.

Gracias
Aida

ResponderCitar
Respondido : 20/06/2013 10:08 pm

Cursos Gratuitos WordPress

Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola Aida,

Estas realizado la prueba con un usuario registrado o con un usuario con privilegios de super-administrador?

Saludos.

ResponderCitar
Respondido : 21/06/2013 12:37 am
Aida
 Aida
Reputable Member

Hola! Tengo desactivada la opción de tener que registrarse para comprar, funcionaba bien hasta que subí los archivos que me enviasteis para el idioma y desaparecieron los botones de información de facturación.

He hecho una prueba tambien con la opción de registrarse activada y entrando con mi nombre de usuario y contraseña, sale la información de envío registrada pero los botones siguen sin salir.

El problema empezó porque los campos de facturación me salían en inglés...lo que necesito es que vuelvan a salir los botones sino para introducir los datos de facturación y envío sino no se puede hacer una compra

Aida

ResponderCitar
Respondido : 21/06/2013 8:14 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Revisando el código fuente de la página veo que el problema no está en las constantes de idioma sino que estos botones se están ocultando utilizando estilos CSS.

Tienes algún tipo de caché activado en la web, por lo que no se puede saber cuál es el archivo CSS implicado.

Tendrías que revisar la configuración de la plantilla de Joomla que estás utilizando para desactivar el uso de la caché. De esta forma se podría saber dónde hay que aplicar el cambio.

ResponderCitar
Respondido : 21/06/2013 9:19 am
Aida
 Aida
Reputable Member

Hola Pablo! He activado la opción "Enable developed mode" en la plantilla.

Mira ahora a ver si puedes saber el archivo css que está ocultando los botones.

Gracias
Aida

ResponderCitar
Respondido : 21/06/2013 9:39 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Verifica la versión de Virtuemart que estás utilizando. Si no es la 2.0.20b te recomiendo que lo actualices.

El problema está en el archivo components/com_virtuemart/assets/css/vmsite-ltr.css. Tendrás que cambiar la línea 2:

.general-bg,input.custom-attribute,input.quantity-input,.manufacturer-product-link a,a.ask-a-question,input.vm-default,a.product-details,a.details,div.details,button.default{background:#e8e8e8 url(../images/vmgeneral/backgrounds.png) top repeat-x;border:solid #CAC9C9 1px;border-radius:4px;-webkit-border-radius:4px;-moz-border-radius:4px;color:#777;display: none;text-decoration:none;padding:5px 5px 4px;}

por la siguiente:

.general-bg,input.custom-attribute,input.quantity-input,.manufacturer-product-link a,a.ask-a-question,input.vm-default,a.product-details,a.details,div.details,button.default{background:#e8e8e8 url(../images/vmgeneral/backgrounds.png) top repeat-x;border:solid #CAC9C9 1px;border-radius:4px;-webkit-border-radius:4px;-moz-border-radius:4px;color:#777;text-decoration:none;padding:5px 5px 4px;}

Es posible que si no tienes la última versión de Virtuemart y lo actualizas se corrija el problema de forma directa.

ResponderCitar
Respondido : 21/06/2013 10:07 am
Página 1 / 2