Fallo en el enlace de módulo noticias joomla 2.5  

 
Ricardo
 Ricardo
Usuario eminente

Buenas noches

Tengo un problema con un módulo de últimas noticias en mi sitio web. En la columna de la derecha (posición top a de mi plantilla) tengo creado dos módulos de últimas noticias: uno se llama "Noticias", y enlaza perfectamente con las noticias que el módulo contiene, y, el otro módulo que está debajo se llama "Cuaresma". Debe enlazar a artículos creados dentro de una categoría.
Al darle a cualquiera de los dos artículos que contiene ese módulo me da un fallo 404. Lo curioso es que puedo acceder a esos artículos desde el menú superior ( http://rcc-es.com/recursos/oraciones/cuaresma.html) pero cuando hago click en uno de sus títulos... vuelve a dar el fallo 404.
¿A qué puede ser debido? Esto no ocurre con ninguna otra categoría ni artículo, solo los artículos de esta categoría.
Muchas gracias

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 11/02/2016 9:03 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Parece un problema de las urls amigables, prueba a desactivarlas y verifica si el problema persiste.

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 12/02/2016 12:34 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Ricardo
 Ricardo
Usuario eminente

Hola

Claro, si quito las URL amigables el problema desaparece pero aparece otro: no tengo url amigables.

Pero, como decía en mi primer mensaje, algunas categorías y artículos enlazaban sin problema. Solo me daban error en esta categoría.

Ahora, ¿cómo puedo solucionar las url amigables, básicas para una web, y que me funcionen todos los enlaces?

Gracias

ResponderCitar
Respondido : 12/02/2016 9:04 am
Julen
 Julen
Miembro Admin

Hola,

En primer lugar, tienes que comprobar si existe un archivo llamado .htaccess en la raíz de tu web. Si no está, mira a ver si hay uno llamado htaccess.txt y renómbralo a .htaccess para ver si se soluciona tu problema con las urls amigables.

Comprueba si el artículo al que enlazas está publicado, desde Contenido -> Gestor de artículos

Del mismo modo, verifica que no uses ni sh404SEF ni ninguna otra extensión de SEO para Joomla

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 12/02/2016 9:34 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Ricardo
 Ricardo
Usuario eminente

Hola, de nuevo

Retomo el tema. Tengo los archivos que Julen menciona en su post. No tengo ninguna extensión de SEO para Joomla. Y sigue sin funcionar si quiero urls amigables.
Os adjunto una captura de la página para que veáis dónde falla. Os comento que tampoco funciona el boton "leer más" en ningún artículo.
La url es http://rcc-es.com/recursos/oraciones/cuaresma.html

Muchas gracias

ResponderCitar
Respondido : 23/02/2016 10:42 am
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Revisando tu web veo que las urls amigables no se están construyendo de la forma que usa por defecto Joomla para los artículos pertenecientes a una categoría. ¿Estás utilizando algún componente de SEO adicional en tu Joomla o has aplicado algún cambio en la configuración?

A modo de prueba, edita el artículo "23 de Febrero" perteneciente a la categoría "Cuaresma" y cambia el alias "23-de-febrero" que tiene actualmente por "cuaresma-23-de-febrero". Esto sería para comprobar si el error lo provoca el número que hay al principio del alias.

Por defecto, los enlaces que se generan para los artículos de una categoría deberían tener el id del artículo antes del alias en la url que se genera, lo que no veo en tu web.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 23/02/2016 2:46 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Ricardo
 Ricardo
Usuario eminente

Hola Pablo

Efectivamente, si añado cualquier palabra delante del número del artículo (cuaresma-23-febrero) no hay problema. En su día retoqué el archivo router siguiendo este post ( https://www.webempresa.com/foro/27-Joomla!-25/109814-Quitar-numeros-de-la-URL.html) para eliminar los id de los artículos y categorías.

¿Puede ser esto?

ResponderCitar
Respondido : 23/02/2016 4:53 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Si que puede ser ese el problema, ya que como te comenta Pablo es normal que aparezca el ID del artículo de referencia, si quieres mejorar tu SEO mejor usar algún plugin de urls amigables en lugar de tocar archivos del core de Joomla.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 23/02/2016 6:41 pm

Cursos Gratuitos WordPress

Ricardo
 Ricardo
Usuario eminente

Gracias, Jhon. Seguiré el consejo.

ResponderCitar
Respondido : 03/03/2016 10:57 pm

Por favor Iniciar Sesión o Registro