Avisos
Vaciar todo

mensaje Warning: Failed to move file! JFolder::create: Could not create directory Unable to create destination  

 
ANTONIO
 ANTONIO
Usuario experto

Hola a todos he instalado una template de themeforest con joomla 2.5, al empezar mi andadura lo primero intento instalar el pack de idioma español, cuando doy a instalar me sale el siguiente error:

Warning: Failed to move file!
JFolder::create: Could not create directory
Unable to create destination

me huele que es de permisos?

actualmente los archivos tienen permisos 644, y creo que deberían estar 666, ya que el configuration.php es con esta combinación como funciona con rw a todos, me podéis confirmar si es esto lo que sucede?

si es así, a que directorios y ficheros les tengo que dar permisos 666 para poder subir extensiones? a todos?

Un saludo.

URL del sitio:

URL del sitio:

Citar
Respondido : 13/02/2012 9:31 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Antonio

Los permisos deben :

Para archivos : 644
Para carpetas : 755

Revisa estos permisos especialmente en la carpeta tmp y log

Saludos.

URL del sitio:

ResponderCitar
Respondido : 14/02/2012 1:27 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

ANTONIO
 ANTONIO
Usuario experto

muchas gracias voy a probar esta noche a ver si así se soluciona y os digo, pero tiene toda la pinta de que es eso.....

URL del sitio:

ResponderCitar
Respondido : 14/02/2012 8:10 am
ANTONIO
 ANTONIO
Usuario experto

Hola Jhon, en teoría todos los permisos están así puestos... pero sigue sin funcionar, es más con estos permisos no me deja escribir en el configuration.php tengo que ponerle los permisos 646 para que pueda escribir por lo que sospecho que es cuestión de que el joomla no se conecta como usuario propietario de los archivos y cuando intenta acceder no le deja subir las extensiones pq no tiene permisos.

la solución es poner los ficheros a 646? no me parece una solución adecuada jeje, me puedes ayudar?

Un saludo.

ResponderCitar
Respondido : 14/02/2012 8:59 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Antonio,

No creo que tenga que ver con los permisos sino con lo que estas tratando de instalar desde el Gestor de Extensiones.

¿Puedes facilitar la url de descarga del pack de idioma que has descargado para revisarlo?.

Saludos

ResponderCitar
Respondido : 14/02/2012 9:37 pm
ANTONIO
 ANTONIO
Usuario experto

me he descargado el pack de idioma de http://www.joomlaspanish.org/

pulsando el link Administrador y Front juntos

he estado leyendo en foros, no puede ser que el servidor de apache no tenga permisos de owner y por eso da este error? es que por ejemplo el archivo configuration.php no puedo escribirlo con 644 sino con 646,

otra pregunta, he visto en otros post que para ver si los directorios son escribibles hay que ir a ayuda-información de sistema-permisos de directorios pero en 2.5 no encuentro estas opciones.... (podéis indicarme donde está en 2.5?)

saludos.

ResponderCitar
Respondido : 14/02/2012 10:07 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jordi Sala
 Jordi Sala
Miembro Admin

Hola ANTONIO,

Indicas que has instalado una plantilla de themeforest

 http://themeforest.net/category/cms-themes/joomla 

.
¿Como realizaste la instalación de la misma? Tenias un Joomla! instalado y luego instalaste la plantilla, o venia desde el proveedor para realizar la instalación de Joomla! con la plantilla incorporada.

Si tienes un Joomla! 2.5.1 el paquete de idiomas español es http://joomlacode.org/gf/download/frsrelease/16620/72374/es-ES_joomla2.5.1_front_admin.zip y el mismo se instala a través de la administración --> extensiones --> gestor de extensiones --> pestaña instalar --> Archivo empaquetado -->examinar --> Subir e instalar.

Para mirar si los directorios están correctos los permisos, tienes que acceder en Joomla! 2.5 a la administración --> sitio --> información del sistema --> Permisos directorio.

Me resulta extraño el error de lo que indicas de los permisos, entiendo que el sitio web sobre el que consultas está en Webempresa, y es extraño porque tenemos los permisos configurados correctamente para que funcione Joomla!.
https://www.webempresa.com/blog/permisos-correctos-en-joomla.html

Saludos

ResponderCitar
Respondido : 15/02/2012 2:31 pm
ANTONIO
 ANTONIO
Usuario experto

Una pregunta, para todos los ficheros de joomla, cual debe ser su propietario? apache? es posible que al subir los archivos descomprimidos me haya asignado otro usuario y por eso los permisos 644 y 755 no funcionan, y sólo funcionan los 777?

saludos.

ResponderCitar
Respondido : 16/02/2012 10:36 pm

Cursos Gratuitos WordPress

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Antonio,

Adjuntanos una captura de tu carpeta /public_html hecha desde el Administrador de Archivos de tu cPanel para ver quien es el propietario de los archivos, pero normalmente no es Apache sino tu usuario de cuenta.

Saludos

ResponderCitar
Respondido : 16/02/2012 10:42 pm
ANTONIO
 ANTONIO
Usuario experto

Hola finalmente es un problema de configuración de servidor, el hosting es suizo (es de un amigo) y efectivamente es un problema de permisos, lo que haré será permitir todos a los directorios que sean necesarios, subir todas las extensiones que necesite y posteriormente quitar permisos.

Gracias por la ayuda, no sé que haría sin vosotros....

ResponderCitar
Respondido : 26/02/2012 11:36 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress