Problema a mover joomla  

Página 1 / 3
 
Luis
 Luis
Usuario experto

Buenos dias
acabo de mover mi sitio joomla de una carpeta a la raiz del sitio desde cpanelo.
Luego he modificado las rutas del tmp y log.
Veo que ha dejado de funcionar el modulo JSlide Show, el menu y alguna otra cosa mas que en la anterior carpeta funcionaba.
¿Me falta algo de hacer?

Un saludo

URL del sitio: http://www.casa-ato.es

Citar
Respondido : 08/06/2012 12:34 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Sobre el menú superior, parece que funciona. Todos los enlaces parecen temporales, pero el último (Blog), sí que funciona correctamente.

Sobre el tema del slideshow, es raro porque las imágenes parece que sí que las encuentra. Prueba a borrar tanto el caché de Joomla como el caché del T3 framework. Para borrar el primero vete en la administración de Joomla a Sitio->Mantenimiento->Limpiar caché. Selecciona todos los elementos que salgan (en caso de que haya alguno) y pulsa en el botón Eliminar. Para borrar el caché del T3 basta con que pulse el enlace JAT3 Clean Cache que verás en la parte superior de la administración de la web.

En caso de que no te funcione esto prueba a subir una nueva imagen al slideshow para ver si te funciona. Parece que solo has añadido 4 imágenes, por lo que puede que la solución más sencilla sea subir las imágenes de nuevo.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 08/06/2012 12:55 pm

Cursos Gratuitos WordPress

Luis
 Luis
Usuario experto

Hola Pablo,
acabo de borrar ambas caches y nada.
El tema es que no funciona el mega menu, ni el JA Accordion (ultimos articulos) ni el phocagallery.
¿Alguna idea?

ResponderCitar
Respondido : 08/06/2012 1:03 pm
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Luis,

Creo que es un tema de rutas incorrectas en el configuration.php, comprueba que tengas

public $log_path = '/home/casaatoe/public_html/logs';
public $tmp_path = '/home/casaatoe/public_html/tmp';

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 08/06/2012 2:26 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Luis
 Luis
Usuario experto

Hola Jordi,
faltaba de agregar public_html pero despues de hacerlo el problema es el mismo.
Ahora tengo

public $log_path = '/home/casaatoe/public_html/logs';
public $tmp_path = '/home/casaatoe/public_html/tmp';

Antes estaba en una carpeta 'pruebas' dentro de public y funcionaba todo ok.
¿Alguna otra idea?
Gracias

ResponderCitar
Respondido : 08/06/2012 3:11 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Luis

Revisa la configuración de tu módulo slideshow, es posible que tengas algún parámetro de ruta que debes cambiar.

Por otro lado te sugiero habilitar las urls amigables correctamente ya que esto también puede causar fallos, actualmente esta apareciendo , index.php como parte de la url.
https://www.webempresa.com/blog/item/317-urls-amigables-en-joomla.html

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 08/06/2012 3:33 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Luis
 Luis
Usuario experto

Hola Jhon,
por partes:
El tema de JA Slide show solo tiene el path para la carpeta donde se encuenytran las imagenes 'images/home'.
Pero es que tampoco funciona el mega menu, ni los ultimos articulos, JA Acordion no el phocagallery.
¿Alguna idea?

He activado las url amigables como indica el video pero cuando ahora selecciono blog da error:

The requested URL /blog-casa-ato was not found on this server.

'Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.'

Espero tu respuesta.
Gracias

ResponderCitar
Respondido : 08/06/2012 3:47 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Luis

Debes tener un problema con el .htacces generado automáticamente, posiblemente no tenga contenido, revisa que el archivo tenga al menos 3kb de tamaño, si no , elimina el archivo, y renombra el archivo htacces.txt que viene con joomla.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 08/06/2012 3:51 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Luis
 Luis
Usuario experto

Hola Jhom,
OK url amigables pero ¿QUe ocurre con el resto de componentes que te indico que ha dejado de funcionar?

UN saludo

ResponderCitar
Respondido : 08/06/2012 3:54 pm
Luis
 Luis
Usuario experto

Hola Jhon,
por si sirve de ayuda estoy viendo que en algnos enlaces del blog el megamenu funciona y en otros no.
Por ejemplo en este funciona:
http://www.casa-ato.es/blog/item/11-campeonato-de-europa-de-primavera-de-epagneul-breton

y en esto NO

http://www.casa-ato.es/blog/item/9-camadas-casa-ato-2012

¿Alguna idea?

ResponderCitar
Respondido : 08/06/2012 4:12 pm

Cursos Gratuitos WordPress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Luis

Creo que puedes ser por las urls amigables, tal como te indiqué revisa el archivo .htaccess que tenga contenido.

Otra opción es que desabilites completamente las urls amigables y verifica si te va.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 08/06/2012 4:16 pm
Luis
 Luis
Usuario experto

Hola Jhon,
he desactivado las url amigable como me indicas pero sigue sin funcionar el JA Slide show, ni el Ja Accordion ni el megamenu.
Las url si que funcioanan ahora y el .htaccess tien 3,4KB
EL contenido es:

¿Alguna idea Jhon?
Gracias

##
# @package Joomla
# @copyright Copyright (C) 2005 - 2012 Open Source Matters. All rights reserved.
# @license GNU General Public License version 2 or later; see LICENSE.txt
##

##
# READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE!
#
# The line just below this section: 'Options +FollowSymLinks' may cause problems
# with some server configurations. It is required for use of mod_rewrite, but may already
# be set by your server administrator in a way that dissallows changing it in
# your .htaccess file. If using it causes your server to error out, comment it out (add # to
# beginning of line), reload your site in your browser and test your sef url's. If they work,
# it has been set by your server administrator and you do not need it set here.
##

## Can be commented out if causes errors, see notes above.
Options +FollowSymLinks

## Mod_rewrite in use.

RewriteEngine On

## Begin - Rewrite rules to block out some common exploits.
# If you experience problems on your site block out the operations listed below
# This attempts to block the most common type of exploit `attempts` to Joomla!
#
# Block out any script trying to base64_encode data within the URL.
RewriteCond %{QUERY_STRING} base64_encode[^(]*([^)]*) [OR]
# Block out any script that includes a tag in URL.
RewriteCond %{QUERY_STRING} (|%3E) [NC,OR]
# Block out any script trying to set a PHP GLOBALS variable via URL.
RewriteCond %{QUERY_STRING} GLOBALS(=|[|%[0-9A-Z]{0,2}) [OR]
# Block out any script trying to modify a _REQUEST variable via URL.
RewriteCond %{QUERY_STRING} _REQUEST(=|[|%[0-9A-Z]{0,2})
# Return 403 Forbidden header and show the content of the root homepage
RewriteRule .* index.php [F]
#
## End - Rewrite rules to block out some common exploits.

## Begin - Custom redirects
#
# If you need to redirect some pages, or set a canonical non-www to
# www redirect (or vice versa), place that code here. Ensure those
# redirects use the correct RewriteRule syntax and the [R=301,L] flags.
#
## End - Custom redirects

##
# Uncomment following line if your webserver's URL
# is not directly related to physical file paths.
# Update Your Joomla! Directory (just / for root).
##

# RewriteBase /

## Begin - Joomla! core SEF Section.
#
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
#
# If the requested path and file is not /index.php and the request
# has not already been internally rewritten to the index.php script
RewriteCond %{REQUEST_URI} !^/index.php
# and the request is for something within the component folder,
# or for the site root, or for an extensionless URL, or the
# requested URL ends with one of the listed extensions
RewriteCond %{REQUEST_URI} /component/|(/[^.]*|.(php|html?|feed|pdf|vcf|raw))$ [NC]
# and the requested path and file doesn't directly match a physical file
RewriteCond %{REQUEST_FILENAME} !-f
# and the requested path and file doesn't directly match a physical folder
RewriteCond %{REQUEST_FILENAME} !-d
# internally rewrite the request to the index.php script
RewriteRule .* index.php [L]
#
## End - Joomla! core SEF Section.

ResponderCitar
Respondido : 08/06/2012 4:24 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Luis

Al parecer los archivos .js no estan cargando correctamente, específicamente la librería jquery, tal como se muestra en la imagen adjunta.

Revisa la configuración de las extensiones algún parámetro relacionado a jquery.

Has cambiado alguna configuración antes de mover tu sitio?

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 08/06/2012 4:52 pm
Luis
 Luis
Usuario experto

Hola Jhon,
yo me habia dado cuenta de los compoenentes que estan fallando son los que usan jscripts.
NO he cambiado nada de configuracion pero no se que pasa.
Tengo una copia completa hecha desde cpanel ¿La restauro?
Imagino que me la dejara en la carpeta pruebas que es de donde la hice no?

Ya me diras.

UN slaudo

ResponderCitar
Respondido : 08/06/2012 5:01 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Luis
 Luis
Usuario experto

hola jhon, he actualizado el j3 framework y ahora la pagina sale blanco.

ResponderCitar
Respondido : 08/06/2012 5:05 pm
Página 1 / 3

Por favor Iniciar Sesión o Registro