Problemas con editores en el front  

Página 1 / 2
 
Gabriel
 Gabriel
Reputable Member

Estimada gente!
Instalé dos editores, JCE y luego CKE pero si bien los dos funcionan bien en el back-end, en el front al intentar editar, no me aparece el menú de edición, aparece el texto en html.

...Incluso me sucede con el TinyMCE

Adjunto imágenes de cómo se ve en el Front al intentar editar..

..No parecen ser los editores...
¿donde puede estar el problema?

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 23/10/2012 3:54 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Gabriel,

¿Tienes activados los plugins de JCE (centremonos en uno) en el Gestor de Plugins?.

¿Que versión "exacta" de Joomla y de JCE utilizas?

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 23/10/2012 7:40 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Gabriel
 Gabriel
Reputable Member

Hola Luis, gracias. Sí están habilitados...
Le di vueltas al JCE Admin pero no veo problema...

Joomla! 2.5.7
JCE 2.2.8.4

¿podrá ser algo de la versión del JCE... ?

ResponderCitar
Respondido : 23/10/2012 10:02 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola Gabriel,

Verifica primero cual editor de texto tienes seleccionado en tu perfil de usuario, en el caso de tener seleccionado el editor JCE puedes envíanos una captura de la configuración del perfil del la parte frontal:

Saludos.

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 24/10/2012 12:31 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Gabriel
 Gabriel
Reputable Member

Gracias Johnny.
Si, en la segunda captura que adjunté está y esta habilitado para el front

no se me ocurre que otra cosa probar ...¿?

ResponderCitar
Respondido : 24/10/2012 1:17 am
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola Gabriel,

Necesito que ingreses a dicho perfil y nos envíes los respectivas capturas para revisar parámetros.

Saludos.

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 24/10/2012 3:45 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Gabriel
 Gabriel
Reputable Member

:pinch:
Claro! perdón.. (eso hace trabajar con sueño)
Adjunto capturas creo que son las fundamentales..

ResponderCitar
Respondido : 24/10/2012 2:18 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

HOla Gabriel

Cuando pruebas con el editor por defecto TinyMCE te suce lo mismo?

Verifica colcocando este editor por defecto.

Luego si funciona, entonces te sugiero desinstales el editor JCE y lo vuelvas a instalar.

Realiza una copia de seguridad antes de realizar las modificaciones.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 24/10/2012 9:52 pm

Cursos Gratuitos WordPress

Gabriel
 Gabriel
Reputable Member

Si, si.. pasa con todos lo editores aunque seteados por defecto.. incluso con el TinyMCE

También desinstalé JCE pero la falla sigue ahí... ningún editor aparece.

... ¿que puede ser?
¿que opciones tengo?

Saludos

ResponderCitar
Respondido : 25/10/2012 3:00 am
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola Gabriel,

Verifica desactivando los plugins que se encuentra en la parte inferior pueden estar provocando algún conflicto:

Busca el fichero error_log si te brinda alguna referencia.

Saludos.

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 25/10/2012 5:31 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Gabriel
 Gabriel
Reputable Member

Gracias, si también probé desinstalar los plugins de auno fui probando:
Jvote (al que le tenía más desconfianza)
RokCandy
RokGallery..

Pero nada cambió...

En ERROR_LOG
Veo que al parecer el "rokbooster" está tirando erorres últimamente.. y como es un acelerador que comprime se me ocurre que tal vez sea parte del problema... ¿? Voy a desinstalarlo también y ver que sucede.

Otar cosa en el fichero no encuentro o no percibo

*******************************************

[17-Oct-2012 22:16:20 UTC] PHP Fatal error: Uncaught exception 'Exception' with message 'Can not write to path: `/home/gwbcom/public_html/cache/rokbooster/`' in /home/gwbcom/public_html/plugins/system/rokbooster/lib/RokBooster/Compressor/Cache/StaticFile.php:187
Stack trace:
#0 /home/gwbcom/public_html/plugins/system/rokbooster/lib/RokBooster/Compressor/Cache/StaticFile.php(226): RokBooster_Compressor_Cache_StaticFile->write('82db99a04d1fede...', '', false)
#1 /home/gwbcom/public_html/plugins/system/rokbooster/lib/RokBooster/Joomla/AbstractStrategy.php(258): RokBooster_Compressor_Cache_StaticFile->writeInlineStyleFile(Object(RokBooster_Compressor_InlineGroup))
#2 /home/gwbcom/public_html/plugins/system/rokbooster/lib/RokBooster/Joomla/AbstractStrategy.php(201): RokBooster_Joomla_AbstractStrategy->processInlineStyle()
#3 /home/gwbcom/public_html/plugins/system/rokbooster/rokbooster.php(279): RokBooster_Joomla_AbstractStrategy->process()
#4 [internal function]: plgSystemRokBooster->__destruct()
#5 {main}
thrown in /home/gwbcom/public_html/plugins/system/rokbooster/lib/RokBooster/Compressor/Cache/StaticFile.php on line 187
[17-Oct-2012 22:18:42 UTC] PHP Fatal error: Uncaught exception 'Exception' with message 'Can not write to path: `/home/gwbcom/public_html/cache/rokbooster/`' in /home/gwbcom/public_html/plugins/system/rokbooster/lib/RokBooster/Compressor/Cache/StaticFile.php:187
Stack trace:
#0 /home/gwbcom/public_html/plugins/system/rokbooster/lib/RokBooster/Compressor/Cache/StaticFile.php(226): RokBooster_Compressor_Cache_StaticFile->write('82db99a04d1fede...', '', false)
#1 /home/gwbcom/public_html/plugins/system/rokbooster/lib/RokBooster/Joomla/AbstractStrategy.php(258): RokBooster_Compressor_Cache_StaticFile->writeInlineStyleFile(Object(RokBooster_Compressor_InlineGroup))
#2 /home/gwbcom/public_html/plugins/system/rokbooster/lib/RokBooster/Joomla/AbstractStrategy.php(201): RokBooster_Joomla_AbstractStrategy->processInlineStyle()
#3 /home/gwbcom/public_html/plugins/system/rokbooster/rokbooster.php(279): RokBooster_Joomla_AbstractStrategy->process()
#4 [internal function]: plgSystemRokBooster->__destruct()
#5 {main}
thrown in /home/gwbcom/public_html/plugins/system/rokbooster/lib/RokBooster/Compressor/Cache/StaticFile.php on line 187
[17-Oct-2012 22:23:14 UTC] PHP Fatal error: Uncaught exception 'Exception' with message 'Can not write to path: `/home/gwbcom/public_html/cache/rokbooster/`' in /home/gwbcom/public_html/plugins/system/rokbooster/lib/RokBooster/Compressor/Cache/StaticFile.php:187
Stack trace:
#0 /home/gwbcom/public_html/plugins/system/rokbooster/lib/RokBooster/Compressor/Cache/StaticFile.php(226): RokBooster_Compressor_Cache_StaticFile->write('82db99a04d1fede...', '', false)
#1 /home/gwbcom/public_html/plugins/system/rokbooster/lib/RokBooster/Joomla/AbstractStrategy.php(258): RokBooster_Compressor_Cache_StaticFile->writeInlineStyleFile(Object(RokBooster_Compressor_InlineGroup))
#2 /home/gwbcom/public_html/plugins/system/rokbooster/lib/RokBooster/Joomla/AbstractStrategy.php(201): RokBooster_Joomla_AbstractStrategy->processInlineStyle()
#3 /home/gwbcom/public_html/plugins/system/rokbooster/rokbooster.php(279): RokBooster_Joomla_AbstractStrategy->process()
#4 [internal function]: plgSystemRokBooster->__destruct()
#5 {main}
thrown in /home/gwbcom/public_html/plugins/system/rokbooster/lib/RokBooster/Compressor/Cache/StaticFile.php on line 187
[20-Oct-2012 02:18:11 UTC] PHP Fatal error: Call to a member function init() on a non-object in /home/gwbcom/public_html/templates/rt_fresco/error.php on line 19
[24-Oct-2012 00:34:46 UTC] PHP Fatal error: Call to a member function init() on a non-object in /home/gwbcom/public_html/templates/rt_fresco/error.php on line 19

ResponderCitar
Respondido : 26/10/2012 7:20 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola Gabriel

En tu error log se hace referencia a un plugin rokbooster, verifica esto que puede ser el causante del problema.

home/gwbcom/public_html/plugins/system/rokbooster/lib/RokBooster/Compressor/Cache/StaticFile.php

Por otro lado usualmente los editores se basan en el editor existente y le aumentan funcionalidad, es debido a esto que el JCE no tu funciona bien incluso reinstalando.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 26/10/2012 9:31 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Gabriel
 Gabriel
Reputable Member

Si Jhon,
...efectivamente deshabilite el RokBooster y aparecen los editores en el Front pero produce otro problema: esté logueado o no.. aparece el footer agigantado y la leyenda
"Could not retrieve the specified page. Please verify correct href was passed in."

Si lo vuelvo a habilitar no desaparece peeeero vuelve el problema con los editores...
Entonces no puedo sacarlo.. pero tampoco dejarlo :blink:

...Lo que descubrí es que ingresando al RokBooster (adjunto) hay una opción para limpiar la cache, si la clickeo desaparecen los problemas.. pero apenas navego un isntante y vuelvo a intentar loguear el problema reaparece.

Arriba de la opción limpiar cache está la opción "Cache Time" que para probar le bajé el valor de 60 minutos a 1.. pero el problema no se resuelve.. Debo limpiar cache cada movimiento que hago en el sitio..

.. ¿sugerencias, alguien tiene experiencias "traumáticas" de este tipo con Rokbooster?
...

ResponderCitar
Respondido : 27/10/2012 1:21 am
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Gabriel,

Si me lo permites yo no le daría al plugin la postestad de cachear, dejaría que Joomla y solo el en exclusivo fuese el gestor de cache global de tu CMS y no cada extensión o plugin.

No olvides que tu plugin esta programado, al igual que muchas otras extensiones, por desarrolladores que con mayor o menor acierto interpretan el framework o el código de Joomla y el como deben sus extensiones interactuar con el código del core, lo que acaba muchas veces generando conflictos como el que comentas.

Te recomiendo esta lectura:

- https://www.webempresa.com/blog/item/385-gestionando-la-cache-en-joomla-con-cachecleaner.html

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 27/10/2012 1:34 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Gabriel
 Gabriel
Reputable Member

Gracias Luis.. entiendo y me fue útil la explicación.

Me gustaría desinstalarlo y olvidarlo...
Pero temo que empeore la cosa... y el sitio está al público.
Apenas lo deshabilito me modifica el footer del sitio (adjunto)

parece que alguna línea de código quedó afectada por este plugin..
¿¿como puedo resolverlo?

Gracias!

ResponderCitar
Respondido : 27/10/2012 2:17 am
Página 1 / 2

Por favor Iniciar Sesión o Registro