Stephan me reporta un posible un error 500 en el servidor  

Página 1 / 2
 
Jaime
 Jaime
Usuario eminente

Stephan me reporta un posible un error 500 en el servidor, me podrían ayudar?
el mensaje que me aparece es el siguiente:

[08-Oct-2014 17:28:18 UTC] PHP Fatal error: Uncaught exception 'InvalidArgumentException' with message 'Invalid URI detected.' in /home/sgliquid/public_html/libraries/joomla/environment/uri.php:194

la verdad no lo entiendo.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 08/10/2014 9:37 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

En el front-end de tu sitio presentas algún problema relacionado con las urls?, al parecer el error es por urls, pero no especifica cual exactmente.

Indicanos exactamente que versión de joomla tienes o si has instalado recientemente alguna extensión, especialmente relacionadas con urls o seguridad.

Verifica si tienes actualizaciones de Joomla pendientes , realiza un backup y actualiza

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 08/10/2014 10:55 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Jaime
 Jaime
Usuario eminente

Hola Jhon, hace días intente instalar la extensión sh404sef, pero al ver que generaba conflictos la desinstale.

Y con respecto a la actualización de Joomla la vercion del sitio es la 2.5.11, se que hay una versión mas actual pero me temo que al instalarla se generen problemas en el sitio, por eso no la he ejecutado.

ResponderCitar
Respondido : 08/10/2014 11:02 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Previa copia de seguridad con Akeeba Backup realiza la actualización de Joomla.

Nueva versión de seguridad de Joomla 2.5.27

Mas que generar problemas deben de solucionarlos como problemas de seguridad o bugs.

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 09/10/2014 1:48 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Jaime
 Jaime
Usuario eminente

Hola Johnny,......alguna vez intente actualizar joomla y se me cambiaban las posiciones de los módulos y cambiaban algunas cosas en el sitio,........pero independientemente de la actualizacion de Joomla,....me pueden ayudar a solucionar este problema de alguna otra manera?

Ademas en las herramientas de Google para webmasters me aparecen 188 errores de que se ha agotado el tiempo de espera de la solicitud o el sitio bloquea a Google.

Ayúdenme por favor!!!

ResponderCitar
Respondido : 09/10/2014 6:17 am
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Verifica si el siguiente enlace te es de utilidad: http://forum.joomla.org/viewtopic.php?t=800933

La recomendación de actualización se mantiene, tarde o temprano tendrás que hacerlo.

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 09/10/2014 7:06 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jaime
 Jaime
Usuario eminente

Esa recomendación no me sirvió,.....me sigue apareciendo el mismo error:

InvalidArgumentException' with message 'Invalid URI detected.' in /home/sgliquid/public_html/libraries/joomla/environment/uri.php:194

la linea es la siguiente:

// Check for quotes in the URL to prevent injections through the Host header
if ($theURI !== str_replace(array("'", '"', ''), '', $theURI))
{
throw new InvalidArgumentException('Invalid URI detected.');
}

Pero no entiendo que esta mal.

ResponderCitar
Respondido : 09/10/2014 9:02 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Jaime,

Podría ser un bug de Joomla!, cuando se realizan búsquedas con comillas en el navegador Chrome:
http://joomlacode.org/gf/project/joomla/tracker/?action=TrackerItemEdit&tracker_item_id=31036
https://github.com/joomla/joomla-cms/issues/3724
Es posible que haya quedado resuelto en las últimas versiones de Joomla! 2.5. Si no ves claro el tema de actualizar a la última versión de Joomla! 2.5,, realiza un clon de tu sitio web, y ahí procede a actualizar, si todo funciona correctamente realiza los mismo pasos en el sitio web en producción.

O a menos que sea un tema del $live_site:
https://www.akeebabackup.com/support/admin-tools/15988-in-error-log-invalid-uri-detected.html

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 09/10/2014 10:42 am

Cursos Gratuitos WordPress

Jaime
 Jaime
Usuario eminente

trate de entender esos foros pero la verdad mis conocimientos son muy básicos y al final no supe que hacer,.......podrían explicarme como debo modificar el archivo o que debo hacer?

ResponderCitar
Respondido : 10/10/2014 12:16 am
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Jaime,

¿Actualmente que versión tienes, la 2.5.27 o sigues con la 2.5.11?

No entendí esta parte:

alguna vez intente actualizar joomla y se me cambiaban las posiciones de los módulos y cambiaban algunas cosas en el sitio,........pero independientemente de la actualizacion de Joomla,....me pueden ayudar a solucionar este problema de alguna otra manera?

Una actualización "no modifica" las posiciones de módulos ni realiza cambios en la plantilla a menos que anteriormente hayas editado el código de una plantilla de las que vienen por defecto con Joomla y lógicamente al actualizar habrás perdido esos cambios por no hacer un "override" a la plantilla:

-

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 10/10/2014 12:51 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Jaime
 Jaime
Usuario eminente

Hola a todos, sigo necesitando ayuda urgente con este error, ya actualice Joomla a la ultima versión (Joomla 2.5.27) y aun así sigue apareciendo el error de esta manera:

Vemos que hay logs de errores que podrían generar un error 500 en el servidor

[13-Oct-2014 01:40:16 UTC] PHP Fatal error: Uncaught exception 'InvalidArgumentException' with message 'Invalid URI detected.' in /home/sgliquid/public_html/libraries/joomla/environment/uri.php:194

Ademas no se si sea la manera en que se visualiza este error, pero si un usuario accede al frontend logueandose e intenta navegar los productos de VirtueMart el sitio se desconfigura y se ve como en la imagen que adjunto a continuación, donde no se pueden apreciar todas las imagenes y menos navegarlas. Y si se da otro click en cualquier enlace la pagina queda en blanco. Ademas el logo del sitio se desaparece.

Ayuda POR FAVOR!!! ya no se que mas hacer......

ResponderCitar
Respondido : 13/10/2014 5:00 am
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Jaime,

¿Has probado a "desinstalar" Akeeba Backup y verificar si persiste el error?.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 13/10/2014 7:19 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Jaime
 Jaime
Usuario eminente

Hola Luis, ya desinstale Akeeba Backup y el error continua tanto en Stephan como en el sitio....... :unsure:

ResponderCitar
Respondido : 13/10/2014 7:49 am
David Noguera
 David Noguera
Miembro Admin

Hola Jaime , según estoy viendo, parece que es un mecanismo de seguridad del API de Joomla para que si alguién intenta poner una URL maliciosa en su web, le devuelva un error 500.

En realidad lo correcto debería ser enviar un error forbidden (403) o similar, pero veo que está así.

Estoy navegando por tu web y noveo errores.

Sobre lo ultimo que comentas, parece que sea otro tema diferente, en caso de haber un fatal error solo verías una pantalla en blanco, y una una página descuadrada, esto último debe ser un tema diferente y te recomiendo que abras un nuevo hilo para tratarlo y no mezclar temas y hacer que el hilo sea más complicado de atender.

Si no ves páginas en blanco al navegar por tu web creo que podrías ignorar este error 500 ya que parece el comportamiento normal de Joomla y no veo que aparezca con mucha asiduidad.

Saludos!!

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 13/10/2014 1:17 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jaime
 Jaime
Usuario eminente

Hola David,.....si veo la pantalla en blanco, pero solo cuando se navega el sitio accediendo como usuario registrado, al primer click en el link que lleva a los productos de VirtueMart sale como en las imagenes que adjunte arriba y al segundo click todo se queda en blanco,.......que hago?

ResponderCitar
Respondido : 13/10/2014 5:08 pm
Página 1 / 2

Por favor Iniciar Sesión o Registro