Ventana emergente aparece con menus, footer etc y me gustaría no apareciesen  

Página 1 / 2
 
Raúl Ramón Val
 Raúl Ramón Val
Noble Member

En la web http://www.calzadosbeyca.com/index.php?option=com_breezingforms&view=form&Itemid=114
si pulsas en enlace de acepto política de privacidad aparece un popup emergente que deseo que aparezca. Sin embargo aparece con todos los menus, footer y todas las partes de la web, sin embargo me gustaría que apareciese solamente la parte del contenido, es decir tan solo la política de privacidad.

Que tengo que decirle al enlace para indicarle que solo muestre el contenido de la pagina?

Gracias

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 11/05/2015 11:00 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Tienes un ítem de menú creado para este artículo :
Contenido solo visible a usuarios registrados

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 12/05/2015 12:07 am

Cursos Gratuitos WordPress

Raúl Ramón Val
 Raúl Ramón Val
Noble Member

Gracias por tu respuesta John pero de momento tu solución no me funciona ya que no deseo eliminar mi menú de política de privacidad que aparecen la zona inferior de la web ya que me gustaría mantenerlo para que los usuarios puedan ver en todo momento la política de privacidad.

Además aunque elimino la opción de menu da un error 404 al pulsar sobre el enlace. No entiendo porque ocurre así.

Que debo hacer para salvar este problema?¿Crear otro artículo con el mismo contenido y sin menu?¿No creo que duplicar contenido sea una buena opción.

Pueden ver la web con:
usuario: offline
password: offline

Muchas gracias

ResponderCitar
Respondido : 19/05/2015 7:31 am
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

No es necesario eliminar el elemento de menú, simplemente cambiar el enlace que se coloca en la política de privacidad del formulario.

Veo que el enlace te da el error 404 porque da la sensación de que el artículo de Joomla que carga la política de privacidad está despublicado o tiene un ID distinto de 4.

Vete en la administración de Joomla a Contenido->Gestor de Artículos y localiza el artículo creado para la política de privacidad. En la última columna se debería ver el ID del artículo. Anota ese ID. Ahora pon el siguiente enlace en el formulario:

index.php?option=com_content&view=article&id=XX&tmpl=component

reemplazando XX por el ID que has anotado. Esto debería abrir la política de privacidad en la ventana emergente sin el resto de elementos de la web.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 19/05/2015 4:23 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Raúl Ramón Val
 Raúl Ramón Val
Noble Member

Hola Pablo, he hecho todo lo que me has comentado, pero no funciona. Se sigue viendo las cabeceras y pie tal y como ocurria al principio. Algo mal debo de tener en el enlace para qu eno funcione. adjunto el enlace y asi podeis ver lo que esta mal. Si despublico el menu inferior de politica de privacidad es cuando aparece el error 404 aunque el articulo existe y este bien referenciado.

Resumiendo: Si el menu esta activo funciona y se ve el articulo pero con cabeceras y pies etc..
Si el menu no funciona y esta despubliado error 404. El articulo es el mismo.

He leído y acepto la Política de Privacidad *

gracias

ResponderCitar
Respondido : 21/05/2015 9:19 am
Julen
 Julen
Miembro Admin

Hola

¿Has instalado algún componente o plugin relacionado con temas de SEO? En el caso de tener algún plugin de SEO y urls amigables mantelos desactivados. Y verifica si de este modo, te funciona.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 21/05/2015 11:49 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Raúl Ramón Val
 Raúl Ramón Val
Noble Member

No tengo instalado ningun componente que yo sepa para seo. Alguna otra sugerencia?.

gracias

ResponderCitar
Respondido : 22/05/2015 6:04 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

HOla

Cuando revisé inicialmente tu web vi que habia como una especie de conflicto con el ítem de menú creado, por eso te sugerí quitarlo, actualmente entiendo que no tienes el ítem de menú, el ID de tu artículos = 4?

Cuando coloco la url :
Contenido solo visible a usuarios registrados

Veo que la cambia, desactiva temporalmente las urls amigables y verifica si te muestra correctametne cuando cargas la url, asumiendo que el ID = 4

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 22/05/2015 7:04 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Raúl Ramón Val
 Raúl Ramón Val
Noble Member

He desactivado las url amigables y el problema continua...no se que puede ocurrir...seguimos con el problema...te adjunto el enlace que tengo indicado por si ves algo mal.

He leído y acepto la Política de Privacidad *

ResponderCitar
Respondido : 22/05/2015 7:19 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

He probado el enlace y ahora veo que ya funciona y muestra contenido aunque completo
Contenido solo visible a usuarios registrados

El problema q veo es que tmpl=component desaparece y cambia por catid, a esto me refería cuando te comenté lo del menú, prueba creando un nuevo artículo , indícanos el ID, este nuevo artículo no tiene que estar asociado a ninguna categoría ni ningún ítem de menú.

Otra opcion es probar cambiar temporalmente de template y verificar si te sucede lo mismo ya que podría ser algún tipo de problema con el template que usas.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 22/05/2015 7:44 pm

Cursos Gratuitos WordPress

Raúl Ramón Val
 Raúl Ramón Val
Noble Member

- Cambiando el template el error continua, ningun cambio aparaente
- He creado un nuevo articulo id=11 y con la categoria -uncategorized y ni siquiera lo veo pero aparece un popup con los mismos problemas mostrand menus etc...

Alguna nueva sugerencia porque no veo solucion a un problema aparentemente facil de resolver

Saludos

ResponderCitar
Respondido : 25/05/2015 10:17 am
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Bueno todo lo que te hemos dicho debería funcionar , agregar &tmpl=component debería darte sólo el component, salvo tu template tenga no tenga el archivo component.php

Verifica si dentro de los archivos de tu template tienes el component.php , si has usado otro template verifica si tienes este archivo

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 25/05/2015 6:28 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Raúl Ramón Val
 Raúl Ramón Val
Noble Member

Mi template tiene dicho archivo

Sigo con el mismo problema...pero el tema es curioso...tengo varias web con la misma template. En todas todo funciona ok pero en esta no hay manera...
Por ejemplo : http://www.lahuertaencasa.com.es/contacto funciona ok pero en http://www.calzadosbeyca.com/contacto no funciona...sin embargo me he dado cuenta de una cosa. si os fijais cuando en la primera pulso el enlace de politica de privacidad la url del popup no tiene la url optimizada para url amigables, sin embargo la que no funciona si...es como si algun componente o plugin activara url amigables en le popup de forma automatica y al hacerlo configura las posiciones de la web y no funciona correctamente,...

ResponderCitar
Respondido : 17/06/2015 8:35 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Es como si tuvieras un ítema de menú que hace referencia al artículo de política de privacidad, si creas un nuevo artículo con otro nombre podrísa probar si te sucede lo mismo.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 17/06/2015 10:49 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Raúl Ramón Val
 Raúl Ramón Val
Noble Member

Ya he encontrado el problema pero ahora me surgen dudas...a ver como podemos solucionarlo.
El problema que tenia es que tengo activado un plugin para evitar duplicados de urls(Canonical Links). Adjunto la configuración en imagenes. En la imagen i.png podemos ver el parametro Permanent Redirect que tenía configurado a si. Si lo configuro a no el enlace de política de privacidad funciona correctamente. Pueden verlo entrando en la web

Problema: Si configuro este parámetro a No, se me duplican las url´s de la web?... No existe forma de hacer excepciones?

Por otro lado, me podrían decir para que sirve la opcion de la imagen 2 Default K2 Tag Menu? No le encuentro el significado ...gracias

ResponderCitar
Respondido : 18/06/2015 11:13 am
Página 1 / 2

Por favor Iniciar Sesión o Registro