Avisos
Vaciar todo

No puedo ver correctamente la página configuración global en joomla 3.1  

Página 1 / 2
 
EDUARDO R
 EDUARDO R
Usuario eminente

Estimados amigos.

La página de configuración global de joomla no se muestra correctamente. Solo muestra una lista sin opciones para cambiar configuraciones (Anexo 2 imágenes).

El resto de las páginas de administrator funciona correctamente.

¿Serían tan amables de ayudarme con este problema? Gracias.

Nota: Cuando intento abrir un ticket de soporte después de la revisión con Stephan, me dice que la página no se puede mostrar y no lo envía.

Quedo en espera de sus comentarios.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 04/10/2016 3:39 am
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Verifica si el siguiente enlace te es de utilidad:
https://www.webempresa.com/foro/32-Joomla!-30/146452-Error-en-la-carga-de-estilos-en-pesta%C3%B1a-Configuraci%C3%B3n-Global.html

ResponderCitar
Respondido : 04/10/2016 4:23 am

Cursos Gratuitos WordPress

EDUARDO R
 EDUARDO R
Usuario eminente

En el foro de Joomla se muestra una solución, que consiste en aplicar el siguiente parche:

From 30db89348bd2e52789fd9232782abd818c99e4c2 Mon Sep 17 00:00:00 2001
From: Michael Babker
Date: Wed, 25 Feb 2015 08:47:09 -0500
Subject: [PATCH] Add a class_exists check to PDO MySQL driver

---
libraries/joomla/database/driver/pdomysql.php | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/libraries/joomla/database/driver/pdomysql.php b/libraries/joomla/database/driver/pdomysql.php
index 4df9a15..d4dc6c7 100644
--- a/libraries/joomla/database/driver/pdomysql.php
+++ b/libraries/joomla/database/driver/pdomysql.php
@@ -99,7 +99,7 @@ public function connect()
*/
public static function isSupported()
{
- return in_array('mysql', PDO::getAvailableDrivers());
+ return class_exists('PDO') && in_array('mysql', PDO::getAvailableDrivers());
}

/**

El problema es que en administrador de archivos no puedo encontrar: ni la ruta ni el archivo que se especifican.

Solamente aparece la siguiente ruta: public_html/libraries/joomla/database/driver

Y no esté al archivo pdomysql.php, solamente aparecen dos archivos por separado: mysql.php y pdo.php.

Podría aplicar este parche en ambos archivos, pero no sé hasta que punto pueda afectar, ya que la escritura de las líneas es parecida, pero no coinciden.

ResponderCitar
Respondido : 07/10/2016 3:51 am
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Entiendo que tienes una versión antigua que es la 3.1, el parche que comentas se debería de solucionar actualizando tu Joomla a la ultima versión, siempre es recomendable realizar una copia de seguridad antes de aplicar una actualización.

ResponderCitar
Respondido : 07/10/2016 4:06 am

wpdoctor-revisa-la-salud-de-tu-wordpress

EDUARDO R
 EDUARDO R
Usuario eminente

He actualizado la versión de Joomla y ahora estoy con la última: 3.6.2. El problema NO se resolvió. Sigo sin visualizar correctamente la configuración global.

El archivo que no aparecía en la versión anterior, pdomysql.php, ya aparece en la última versión y no requiere ningún parche.

He estado revisando los diferentes hilos de conversación y nadie en este foro ha dado una solución para este problema, que al parecer muchos otros usuarios de joomla están sufriendo. Las soluciones que han servido para unos no sirven para otros.

En mi caso ya intenté con las soluciones serias que se han proporcionado y sigo sin poder usar la configuración global.

Escribí a soporte técnico para pedir ayuda y me respondieron que no entienden el problema y que preguntara aquí en el foro porque ellos no atienden este tipo de problemas.

ResponderCitar
Respondido : 07/10/2016 7:52 am
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Es posible que el archivo configuration.php, de donde se leen los datos de la configuración global, esté dañado o tenga información incorrecta.

Tendrías que comparar la estructura de ese archivo con la del archivo configuration.php-dist que tiene también en la raíz.

La idea sería probar a crear un nuevo configuration.php a partir del configuration.php-dist, colocando los datos relativos a tu web (acceso a la base de datos, rutas de logs, etc.).

Es muy importante que antes de hacer esto hagas una copia de seguridad de tu archivo configuration.php actual.

ResponderCitar
Respondido : 07/10/2016 12:52 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

EDUARDO R
 EDUARDO R
Usuario eminente

Hola.
Comparé la estructura de ambos archivos, el php y el php-dist, y ambos coinciden. Solamente al final del php hay las siguientes líneas extras, que no tiene el php-dist:
public $proxy_enable = '0';
public $proxy_host = '';
public $proxy_port = '';
public $proxy_user = '';
public $proxy_pass = '';
public $mailonline = '1';
public $frontediting = '1';
public $asset_id = '1';
public $memcache_persist = '1';
public $memcache_compress = '0';
public $memcache_server_host = 'localhost';
public $memcache_server_port = '11211';
public $memcached_persist = '1';
public $memcached_compress = '0';
public $memcached_server_host = 'localhost';
public $memcached_server_port = '11211';
public $session_memcache_server_host = 'localhost';
public $session_memcache_server_port = '11211';
public $session_memcached_server_host = 'localhost';
public $session_memcached_server_port = '11211';
}

Hice la prueba de quitar dichas líneas en el php y el problema continuó igual, así que volví a restaurarlo como está.

Desafortunadamente, esta solución tampoco resolvió el problema.

ResponderCitar
Respondido : 11/10/2016 2:23 am
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

He buscado algún error para la ultima versión pero no localizo nada concreto.

Revisaste los enlaces que te enviamos donde se corrigieron estos problemas?

https://www.webempresa.com/foro/32-Joomla%21-30/146374-Error-en-la-Configuraci%C3%B3n-global.html#231135

https://www.webempresa.com/foro/4-Preguntas-Sobre-Joomla!/146420-Error-en-estilo-al-acceder-a-Configuraci%C3%B3n-global.html

ResponderCitar
Respondido : 11/10/2016 4:39 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

EDUARDO R
 EDUARDO R
Usuario eminente

He revisado las soluciones y el problema no se resolvió, sigue igual. La solución de aplicar el parche en el archivo configuration.php ya no aplica en la versión 3.6.2 de joomla, que es la que tengo ahora después de aplicar la otra solución de actualizar Joomla.

Hace 3 años tuve el mismo problema y no pude resolverlo. Mandé un ticket a soporte técnico, ellos hicieron el favor de resolverlo aunque no me comentaron como lo lograron. Intenté hacer lo mismo pero parece que las políticas de soporte han cambiado porque me respondieron que buscara la solución en el foro ya que ellos se dedican a resolver otro tipo de problemas.

ResponderCitar
Respondido : 12/10/2016 1:00 am
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Tienes una idea desde que fecha tienes el problema?

Una opción seria recuperar una copia de seguridad sin embargo se perdería la información hasta la fecha seleccionada.

ResponderCitar
Respondido : 12/10/2016 2:20 am

Cursos Gratuitos WordPress

EDUARDO R
 EDUARDO R
Usuario eminente

Hola, gracias.

Casi no ingreso a la configuración global no sé exactamente desde cuando apareció este problema; creo recordar que hace alrededor de 1 año todavía funcionaba bien. Antes de actualizar a Joomla 3.6.2 hice 2 copias de seguridad que ya tienen el problema; las más antiguas las borré porque había cambios y para no tener archivos obsoletos.

ResponderCitar
Respondido : 12/10/2016 5:44 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Si queires comunicarte por tickets envía un correo directamente, puedes usar el formulario de contacto indicando que no puedes enviar tickets para que lo revisen.

Tienes espacio suficiente en tu cuenta de hosting?

Con la actualización debería funcionar correctamente.

Algo que podr´ias probar es reemplazar tu carpeta de Administrator por otra de una misma versión de Joomla y verificar si te sucede lo mismo, sin embargo te sugiero que primero revises el espacio y que desde tickets te pasen una revisión de Stephan o que te verifiquen tu cuenta para que tu lo hagas.

Saludos.

ResponderCitar
Respondido : 12/10/2016 7:46 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Al parecer puede ser un problema de algunos archivos de Drivers tal como se comenta en :

https://forum.joomla.org/viewtopic.php?t=690980#p2731398

La idea es ubicar esta carpeta :
public_html/libraries/joomla/database/driver

Y dejar sólo los archivos de drivers que usas en nuestros servidores que son mysql.php y mysqli.php

Saludos.

ResponderCitar
Respondido : 13/10/2016 10:35 pm
EDUARDO R
 EDUARDO R
Usuario eminente

Muchas gracias John. Esta es la solución correcta y ya funciona la configuración global. Además, agradezco que ustedes hayan movido los archivos.
No entiendo el motivo de que entren en conflicto los archivos retirados y no sé si forman parte de Joomla o fueron creados por alguna aplicación, pero espero se tome en consideración para las próximas actualicaciones de Joomla.
Nuevamente gracias.

ResponderCitar
Respondido : 14/10/2016 8:16 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Esos archivos son parte de Joomla, no se si actualizaste desde un Joomla 2.5 ya que este problema se detecto en esa versión.

No estas usando estos archivos, ya que son drivers para trabajar con otras bases de datos que no se usan en nuestros servidores. Es posible que en futuras versiones lo corrijan.

Saludos.

ResponderCitar
Respondido : 14/10/2016 11:01 pm
Página 1 / 2