Problema enlaces SEF  

Página 1 / 2
 
Aitor
 Aitor
Usuario experto

Hola

En un sitio que estamos desarrollando con la plantilla Mi_Blog, el enlace al detalle de la noticia destacada en la home devuelve un error 404 (teniendo activada la opción de URLs amigables (el .htacess ya está creado y seguido el resto de pasos...) y si desactivamos dicha opción, si funciona.

¿A qué puede ser debido?

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 12/02/2014 4:32 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

A priori el tema de las urls amigables parece bien configurado ya que el resto de enlaces (por ejemplo el de la página "Empresa") funcionan correctamente.

Prueba a crear un nuevo artículo en la categoría de noticias y comprueba si también falla el enlace. De esta forma podremos saber si el problema está en el artículo en concreto que está fallando.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 12/02/2014 5:17 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Aitor
 Aitor
Usuario experto

Hola

hemos probado creando una copia del articulo y sigue dando error...

ResponderCitar
Respondido : 13/02/2014 8:39 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Aitor,

Prueba a realizar uno nuevo, no copiado de otro anterior.

Contenido solo visible a usuarios registrados veo que fallan todos los "leer más".

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 13/02/2014 9:24 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Aitor
 Aitor
Usuario experto

He creado una nueva noticia, desde cero, y sigue dando el mismo error.

ResponderCitar
Respondido : 13/02/2014 10:03 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Aitor,

Para descartar que sea un tema de la plantilla o no, procede a seleccionar en el gestor de plantillas otra como predeterminada y ver si funciona el "leer más".

¿Como estás realizando el leer más? ¿Puedes mostrarnos el código del articulo?

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 13/02/2014 10:32 am

Cursos Gratuitos WordPress

Aitor
 Aitor
Usuario experto

Hola Jordi

Hemos activado la plantilla protostar como por defecto, y sigue ocurriendo lo mismo.

El "leer más" se crea empleando para ello la funcionalidad por defecto de Joomla, que mediante una regla horizontal (


) delimita la introducción y detalle de un articulo.

ResponderCitar
Respondido : 13/02/2014 10:58 am
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Prueba a cambiar el alias del elemento de menú "Noticias" por otro, por ejemplo "noticiasprueba" y verifica si siguen fallando los enlaces.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 13/02/2014 2:14 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Aitor
 Aitor
Usuario experto

Hola

Aun así siguen fallando

ResponderCitar
Respondido : 13/02/2014 2:21 pm
Aitor
 Aitor
Usuario experto

Además, hemos probado desactivando las url SEF y purgando la caché; y siguen sin funcionar los enlaces, ni el link que tiene el articulo en su titulo ni desde el enlace de "Leer más"...

ResponderCitar
Respondido : 13/02/2014 2:26 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Deja las urls desactivadas en la configuración global de Joomla para que podamos ver los enlaces que se generan. Estos deberían funcionar siempre.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 13/02/2014 3:18 pm
Aitor
 Aitor
Usuario experto

Hola

Ya está, los teneis desactivados

ResponderCitar
Respondido : 13/02/2014 3:25 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

HOla Aitor

Actualmente ya funcionan los links de leer más

Contenido solo visible a usuarios registrados

Revisa si cambiando nuevamente a urls amigables te sucede lo mismo.
www.webempresa.com/blog/item/317-urls-amigables-en-joomla.html

Debes asegurarte que tu archivo .htaccess tenga contenido.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 13/02/2014 4:33 pm
Aitor
 Aitor
Usuario experto

Efectivamente, tal y como indicaba al inicio de la consulta, el problema surge cuando se activa la opción de urls amigables (he vuelto a activarlas, como antes, y siguen sin funcionar).

El archivo .htaccess es el que venia por defecto con la preinstalación de Joomla; no la hemos tocado para nada...

ResponderCitar
Respondido : 13/02/2014 4:59 pm

Cursos Gratuitos WordPress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

HOla Aitor

Crea un ítem de menú para la catogoría de los architiculos que se muestran en la página de incio, ya que veo que se crea algo llamado noticiasprueba como parte de la url.

Es decir organiza tus artículos en categorías y luego crea un ítem de menú de esta categoría creada

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 13/02/2014 8:16 pm
Página 1 / 2

Por favor Iniciar Sesión o Registro