Módulo Prestashop Configurador de temas  

Página 1 / 2
 
Rober
 Rober
Reputable Member

Hola, estoy intentando poner imágenes en el módulo "Configurador de temas" en prestashop pero me da error cuándo anteriormente tenía puestas imágenes, creo que es por haber actualizado el módulo. Cómo puedo solucionarlo?

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 09/01/2015 1:09 am
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Verifica si al ejecutar Stephan te brinda referencias al error 500.

Por otro lado prueba a llenar también los otros parámetros como son image title

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 09/01/2015 2:09 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Rober
 Rober
Reputable Member

Pasando la herramienta Stephan, no existe ningún error 500.

Si relleno el campo title tampoco funciona, me sigue dando error.

Cómo te digo creo que es porque he actualizado el módulo ya que he leido esto:

http://www.prestashop.com/forums/topic/322618-theme-configurator-module-doesnt-work-properly-with-other-languages/?hl=%2Btheme+%2Bconfigurator#entry1632316

Aún así no se solucionarlo.

He probado ha realizar los pasos de Parámetros Avanzados > Rendimiento > y deshabilitar caché, después intentar subir las imágenes pero sigue sin funcionar.

Cómo puedes ver en la "panta3.jpg", en el idioma inglés no tengo nada puesto en el title y sigue funcionando así que por eso no es.

Saludos.

ResponderCitar
Respondido : 09/01/2015 3:00 am
Jordi Sala
 Jordi Sala
Miembro Admin

Hola Erlantz,

Revisa:
http://www.prestashop.com/forums/topic/384134-prestashop-fatal-error-in-module-themeconfigurator-call-to-undefined-method-toolspurifyhtml/page-2
http://www.prestashop.com/forums/topic/392278-fatal-error-in-module-themeconfigurator/

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 09/01/2015 9:04 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Rober
 Rober
Reputable Member

Disculpa pero no se muy bien lo que tengo que cambiar, te envío pantallazos de lo que tengo.

Gracias.

ResponderCitar
Respondido : 09/01/2015 12:21 pm
Lorena
 Lorena
Miembro Moderator

Hola,

Lo que te indica es que en el fichero themeconfigurator.php (siempre previa copia de seguridad del mismo)
sobre las líneas 454 y 593 hay que sustituir:

pSQL(Tools::purifyHTML($content), true)

por

html = ''.pSQL($content, true).''

y

pSQL($content, true)

por

''.pSQL($content, true).'',

Un saludo.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 09/01/2015 12:59 pm

Cursos Gratuitos WordPress

Rober
 Rober
Reputable Member

Si pero lo que te digo es que en las líneas que pone no pone el código ese. Te lo he enviado en el anterior mensaje

ResponderCitar
Respondido : 09/01/2015 1:18 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

En las pruebas que he realizado con la versión 1.1.2 del Configurador de temas y la versión 1.6.0.9 de PrestaShop no veo que tenga ningún tipo de problema.

Indícanos la versión del módulo que estás utilizando. Si lo necesitas te podemos pasar algún archivo del móduo para que pruebes a reemplazarlo y ver si se solucionan los problemas.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 09/01/2015 3:06 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Rober
 Rober
Reputable Member

Cómo pone en algún pantallazo que he enviado anteriormente, antes tenía la versión 1.6 o algo así pero al actualizar a la versión 1.1.7 me da el problema.

Si me pasais un archivo con versión inferior que funcione y me decis lo que tengo que sustituir, agradezco.

Gracias.

ResponderCitar
Respondido : 09/01/2015 8:51 pm
Jhon Marreros Guzman
 Jhon Marreros Guzman
Soporte CMS Webempresa Moderator

Hola

Tu prestashop lo tienes actualizado, acutalmente esta en la versión 1.6.0.11?

Una opcion final sería reemplazar los archivos de este módulo desde otra instalaicón de prestashop en donde si funcione correctamente

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 09/01/2015 9:37 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Rober
 Rober
Reputable Member

Eso me ha dicho anteriormente Pablo, que me ibais a pasar los archivos de la versión anterior para que los sustituya por la versión que tengo ya que la versión que tengo no me funciona.

Gracias.

ResponderCitar
Respondido : 09/01/2015 9:50 pm
Rober
 Rober
Reputable Member

Me podríais pasar los archivos de la versión 1.6 del configurador de temas??

ResponderCitar
Respondido : 12/01/2015 1:02 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Prueba a reemplazar el archivo themeconfigurator.php que tienes en la ruta modules/themeconfigurator por el que te adjunto comprimido en un zip.

A continuación reemplaza el archivo AdminThemeConfiguratorController.php que hay en la ruta modules/themeconfigurator/controllers/admin por el que te adjunto en el zip con el mismo nombre.

Antes de aplicar los reemplazos haz una copia de seguridad de tus archivos originales.

Link a post de foro, solo visible a usuarios registrados
Link a post de foro, solo visible a usuarios registrados

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 12/01/2015 11:31 am
Rober
 Rober
Reputable Member

Hola, sigue sin funcionar.

La versión sigue siendo CONFIGURADOR DE TEMAS (V.1.1.7) y no me deja subir las fotos que quiero subir cómo tengo en la página en inglés: http://kaiene.es/en/?live_configurator_token=234009711a2a8c9b0d6f88786a79ee75&id_shop=1&id_employee=2&theme_font=font7

En español me aparece de esta manera: http://kaiene.es/es/?live_configurator_token=234009711a2a8c9b0d6f88786a79ee75&id_shop=1&id_employee=2&theme_font=font7

Quiero que me aparezcan las dos imágenes de la derecha que aparecen en la página que está en inglés pero al intentar agregar la imagen, al pulsar guardar da el error que muestro en panta5.jpg.

Gracias.

ResponderCitar
Respondido : 13/01/2015 1:05 am

Cursos Gratuitos WordPress

Jordi Sala
 Jordi Sala
Miembro Admin

Hola Erlantz,

Han lanzado la versión: Configurador de temas v1.1.8 - by PrestaShop
Prueba a actualizar, según el foro de PrestaShop http://www.prestashop.com/forums/topic/384134-prestashop-fatal-error-in-module-themeconfigurator-call-to-undefined-method-toolspurifyhtml/?p=1912484 resuelve el problema.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 13/01/2015 9:22 am
Página 1 / 2

Por favor Iniciar Sesión o Registro