Avisos
Vaciar todo

Consumo de recursos elevado  

Página 1 / 3
 
STJO
 STJO
Usuario experto

Tenemos alojada con ustedes una web con el plan Joomla 5Gb:
http://www.oviedo.escuelateresiana.com

Hace unos días hemos creado la web en versión joomla 2.5 pero algunas veces el servidor ha dejado de responder o hay problemas de carga en la página. Viendo desde cPanel el consumo de recursos, vemos picos muy altos.

He probado a deshabilitar plugins, a deshabilitar/habilitar caché en la configuración, en el plugin de caché, en el plugin ice_speed... probé a cambiar el módulo que presenta fotos en la portada de la web...
Pero los picos persisten y la web está en producción. ¿Pueden ayudarme?

Puedo pasarles un usuario y contraseña de superadministrador temporal si lo necesitan.

Muchas gracias de antemano por su ayuda. Un saludo. Pablo Viñas.

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 05/09/2012 9:20 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

HOla ST JO

No es posible que compartas tus claves de superadministrador a través de este foro ya que es un foro público.

Te sugiero habiliatar correctamente las urls amigables en tu sitio web, revisa el siguiente artículo :
https://www.webempresa.com/blog/item/317-urls-amigables-en-joomla.html

Te sugiero también verificar si tu template tiene algunos parámetros de optimización como cache u optimización CSS

Evalúa el uso de cache en tu sitio web, esto lo puedes hacer usando la funcionalidad nativa de Joomla.

Verifica en que momento se dan los picos que comentas, si sigue un patron, es posible que tengas varios usuarios concurrentes a tu sitio

Saludos.

ResponderCitar
Respondido : 05/09/2012 9:58 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

STJO
 STJO
Usuario experto

Gracias.

El motor de búsqueda para URLs amigables ya lo tenía activado.
Pero acabo de activar la opción "Usar la reescritura URL" y ya renombré el archivo htaccess.txt a .htaccess

También he habilitado en "Configuración global - Servidor" la opción "Compresión GZip de las páginas".

He activado de nuevo la opción de caché progresivo en la configuración global de joomla.

Activé también el plugin ice_speed con estas opciones activadas:
Minify engine
Use YUI compressor
Optimize HTML
Optimize CSS compress and merge
Optimize Javascript compress and merge
Enable GZIP
Lazy Load Images

Este plugin trae una opción para habilitar la cache de la página pero como tengo habilitada la cache de joomla, no sé si habilitar la cache que trae ese plugin o no para que no entren en conflicto o algo así...

¿Qué más puedo hacer? ¿Cómo podría pasaros el usuario y clave de superadministrador por si veis algo que cambiar?

ResponderCitar
Respondido : 05/09/2012 10:26 pm
STJO
 STJO
Usuario experto

El problema sigue. Acabo de ver en cPanel el uso de recursos de la web las últimas 24 horas, de 8 a 8. Os lo adjunto. Al final hay un descenso, porque a esas horas no hay nadie conectado, pero ahora que empieza el día tengo miedo a sobrepasar el límite de recursos.

No sé qué más puedo hacer.

ResponderCitar
Respondido : 06/09/2012 7:16 am

Cursos Gratuitos WordPress

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola STJO,

¿Puedes comentarnos que plugins tienes instalados que puedan afectar al consumo excesivo de CPU?, ¿Utilizas extensiones colectoras de datos, tipo Vinaora Visitor Counter, Piwik (externo a Joomla) u otras?.

Saludos

ResponderCitar
Respondido : 07/09/2012 12:57 am
STJO
 STJO
Usuario experto

Hola Luis:

Gracias por tu ayuda.

La plantilla instalada es:
it_university

Otras cosas que usamos, pero que no están instaladas como componentes, sino incorporadas con un código de seguimiento a la plantilla son:
- Google analytics.
- Piwik: no está instalado como componente de joomla. En joomla 1.0.15 no dio problemas, teniéndolo instalado con vosotros.

Los componentes instalados (aparte de los propios de joomla 2.5) son:
- JCE
- AutoTweet NG Pro
- DOCman
- DOCman populate
- JoomGallery
- ninja-rss-syndicator
- userport
-

Los plugins que tenemos instalados (aparte de los propios de joomla) son:
- Button - JoonGallery (JoomBu)
- Contect - Addthis
- Content - JoomGallery
- DOCman DOClink
- DOCman Notify
- DOCman Thumbs
- Editor JCE
- Ice Megamenu
- JoomGallery Facebook like button
- JoomGallery Google +1 Button
- JoomGallery Integrate Highslide JS
- JoomGallery Integrate Shadownbox
- JoomGallery - Tweet Button
- Quick Icon JCE File Browser
- Search DOCman
- Search JoomGallery
- Sistema - AutotweetAutomator
- Sistema AutotweetContent
- System - Highlight
- System - Ice Speed

Gracias nuevamente por vuestra

ResponderCitar
Respondido : 07/09/2012 8:30 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

El único que sospecho podría estar causando los problemas serían los referentes a la extensión del Autotweet. Prueba a desactivar los plugins durante un día para ver si el consumo de recursos se reduce. No es necesario desintalar nada por ahora.

ResponderCitar
Respondido : 07/09/2012 9:12 am
STJO
 STJO
Usuario experto

Desactivé esos plugin a las 10'20 horas de la mañana.
Según aparece en cPanel:
de 11 a 12 horas la CPU se puso a 72 MCPU. En ese momento había 23-24 visitas aproximadamente.
de 16 a 17 horas la CPU se puso a 72 MCPU otra vez. En ese momento había 16 visitas aproximadamente.
de 17:20 a 17:21 se puso a 52 MCPU. En ese momento había 5 visitas.

¿Vuelvo a activar esos plugins?
¿Alguna otra idea?

Gracias por vuestra ayuda...

ResponderCitar
Respondido : 07/09/2012 4:35 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola STJO

Los usuarios que visitan tu stiio web realizan algún proceso especial? , es decir como registro, suben imágenes, etc? o sólo lo visitan?

La extensiones que me parecen sospechosas son , prueba deshabilitándolas:

-userport

- Sistema - AutotweetAutomator
- Sistema AutotweetContent
- System - Ice Speed (supongo que esto lo instalaste para mejorar performance, pero creo que no es necesario ya que igual el problema al parecer continúa)

Con la gestión de cache debería haberse optimizado tu sitio web, adicional a los reportes, presentas lentitud al consultar tu sitio?

Saludos.

ResponderCitar
Respondido : 07/09/2012 8:32 pm
STJO
 STJO
Usuario experto

Hola Jhon:

Los visitantes se dedican a leer y a ver fotos, no suben nada, sólo visitan.

Acabo de deshabilitar:
- userport: es un componente para importar usuarios a partir de un CSV.
- System Ice Speed

La cache la tengo en progresivo, con 15 minutos.

Respecto a la lentitud, no sé qué decirte. Mejor visita la web y me dirás:

Gracias por tu ayuda...

ResponderCitar
Respondido : 07/09/2012 9:25 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

STJO
 STJO
Usuario experto

Disculpad, el foro no insertó el enlace: Contenido solo visible a usuarios registrados
Ahí podréis ver si es lento o no, porque no sé qué deciros...

ResponderCitar
Respondido : 07/09/2012 9:26 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

HOla STJO

He navegado por tu sitio web y no he notado lentitud en ningún ítem.

La pantalla de estadísticas enviada anteriormente es un apoyo, no debería preocuparte que se este utlizando los recursos como CPU ya que, si es posible que llegue al 100% en algunos picos cuando tengas varios usuarios concurrentes, sin embargo si la web sigue funcionando a una velocidad aceptable no es problema.

La cache activada te ayudará en la performance, de todas maneras sigue monitoreando el sitio web en caso se presente lentitud.

Otra cosa que podrías hacer es evaluar que extensiones no estas usando y desactivarlas o desinstalarlas, te sugiero antes hacer un backup de tu sitio web en caso desinstales extensiones por error.

Saludos.

ResponderCitar
Respondido : 07/09/2012 11:37 pm

Cursos Gratuitos WordPress

STJO
 STJO
Usuario experto

Hola Jhon:

Lo que me preocupa es que cuando entro en cPanel me encuentro a veces con lo que podéis ver en el archivo cpanel1 que os adjunto en este mensaje.
Y las gráficas de las últimas 24 horas las podéis ver en el archivo cpanel2.
No es sólo el uso de la CPU, son picos raros que no deberían ocurrir.

Es una web de un colegio y ahora tiene pocas visitas porque las clases aún no han empezado, pero dentro de poco tendremos una media de 300 visitas diarias.
Si estos picos se producen por unas decenas de visitas ¿qué nos pasará entonces?

Desactivaré todos los componentes que no esté usando y seguiré monitorizando, pero hay algo que no funciona bien y no sé qué es; esto no me parece un uso normal de recursos y tengo miedo de que la web se caiga...

Gracias por vuestra ayuda.

ResponderCitar
Respondido : 08/09/2012 10:03 am
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola STJO

Tienes programado alguna tarea en tu sitio web, como envío de correos o boletines?

Si no tienes ninguna tarea y tu sitio es sólo de consulta entonces habría que monitorear y ver el momento exacto que ocurre el pico, puede deberse a alguna extensión o algún script que se esta ejecutando en tu sitio web.

Pero también puede ser debido a la cantidad de visitas, o también a que tu sitio se encuentre generando spam, etc.

Te sugiero habilitar google analytics en tu sitio web para revisar estos picos si es debido al tráfico. Revisa el siguiente artículo :

Saludos.

ResponderCitar
Respondido : 08/09/2012 3:25 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

STJO
 STJO
Usuario experto

Hola Jhon:

Sigo monitoreando.

No tenemos ninguna tarea programada.

Hoy, por ejemplo, de 20 a 21 horas, en cPanel:
la mCPU pone 92
entry process pone 6
mMEM pone 205.6
y hubo tan sólo entre 4 y 6 visitantes.

Así que por visitas no es...

En ese tiempo, las visitas sólo navegaron, no usaron ningún componente especial...

Tenemos control de visitan con google analytics desde hace tiempo y también con PIWIK, ambos arrojan iguales resultados.

Sinceramente, no sé dónde está el error...

ResponderCitar
Respondido : 08/09/2012 9:26 pm
Página 1 / 3