Hosting WordPress Divi con Soporte en Español

Error al guardar la dirección de envío en VirtueMart  

 
Alvaro
 Alvaro
Estimable Member

Hola
Pues ésto es lo que sale al intentar guardar la dirección de envío:
"vmError: VmTable #__virtuemart_vendors_es_es Check not passed. Neither slug nor obligatory value at vendor_store_name for auto slug creation is given"

Adjunto pantallazo:

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 07/11/2012 4:09 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Vete a la administración de Virtuemart y pulsa en el botón Tienda. En la pantalla que se muestra asegúrate que has rellenado correctamente los datos de las 2 pestañas. Es posible que el problema se produzca porque falten algunos datos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 07/11/2012 4:36 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Alvaro
 Alvaro
Estimable Member

Hola

Pues faltaba lo de la información de la imagen y tal, ya lo he rellenado y sigue apareciendo el mismo error, de manera que aunque tengo configurado un método de envío para España me dice que:
"No hay envío definido en su dirección de envío. Por favor contacte con nosotros."

No será algo de esto?
https://forum.virtuemart.net/index.php?topic=109245.0

parece un tema de servidor aunque no sé mucho de inglés ni de servidores

EDITO: Por que acabo de comprobar que precisamente al intentar guardar la dirección de envío se borran los datos de informacion de vendedor en la pestaña vendedor del apartado tienda
Ultimamente me pasan cosas rarísimas... ya he actualizado a vm 2.0.12

ResponderCitar
Respondido : 07/11/2012 4:57 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Sobre el tema de la edición de los datos de la tienda en la administración de Virtuemart, el problema está en que si no se rellenan correctamente todos los datos obligatorio (los de las 2 pestañas), la información no se guarda. Por tanto, debes asegurarte de que pones toda la información marcada como obligatoria.

Por otro lado, ¿la tienda la tienes configurada para un único idioma o es multiidioma? Esto podría estar afectando al error que te está saliendo.

Envíanos también una captura de pantalla donde se pueda ver la configuración del método de envío que tienes para España, para verificar que todo sea correcto. Normalmente si no te muestra ese método de envío puede ser una cuestión de la dirección de envío (país y código postal), peso del pedido o importe total.

Veo que tienes la tienda en mantenimiento, por lo que no puedo hacer alguna prueba y comprobar si funciona. Te paso un enlace a nuestro blog donde se explica cómo puedes crear un usuario de prueba que pueda acceder al frontal de la web cuando está en mantenimiento pero no a la administración de la misma:

https://www.webempresa.com/blog/item/766-el-sitio-est%C3%A1-desactivado-por-mantenimiento-%C2%BFc%C3%B3mo-lo-puedo-ver?.html

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 08/11/2012 9:33 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Alvaro
 Alvaro
Estimable Member

Ahí van los pantallazos, acabo de activar el sitio para que sea visible, tendré que ponerlo en mantenimiento cuanto antes.
Lo cierto es que sí que me guardaba los cambios pero al guardar una nuva dirección de envío desde el front-end los datos de imagen del vendedor se borraban.
EDITO: Ah! la tienda está en multiidioma, SI

ResponderCitar
Respondido : 08/11/2012 11:11 am
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

En el tema de portes se ve un error. En el campo Cantidad máxima de pedido has puesto el valor 10. Esto significa que este método de envío se aplica a los pedidos cuyo importe no supere los 10 euros.

Pon un valor mayor (99999 por ejemplo) y comprueba si te funciona.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 08/11/2012 12:04 pm

Cursos Gratuitos WordPress

Alvaro
 Alvaro
Estimable Member

Bien! pues ahora sí que permite elegir el método de envío, aunque al guardar la nueva dirección sigue mostrándose el error que puse en el pantallazo del primer mensaje de este post:
"vmError: VmTable #__virtuemart_vendors_es_es Check not passed. Neither slug nor obligatory value at vendor_store_name for auto slug creation is given"

ResponderCitar
Respondido : 08/11/2012 12:14 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola Alvaro,

Verifica el siguiente hilo: https://forum.virtuemart.net/index.php?topic=109245.0

Saludos.

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 09/11/2012 12:43 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Alvaro
 Alvaro
Estimable Member

Hola ese enlace es el que os pasé en el tercer mensaje de este post.

No sé mucho de inglés pero parece que habla de versiones de PHP, por lo tanto servidores y hosting... y entiendo que este hosting está especialmente preparado para Joomla y VirtueMart, no?

¿Qué hacemos ahora?

ResponderCitar
Respondido : 09/11/2012 12:28 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola Alvaro,

Intenta actualizando las tablas, recuerda realizar una copia de seguridad antes de este proceso.

Saludos.

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 09/11/2012 11:43 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Alvaro
 Alvaro
Estimable Member

Hola ya he hecho lo de insertar o actualizar tablas y el error sigue apareciendo..

¿Influirá ese error en el funcionamiento de la tienda?

ResponderCitar
Respondido : 10/11/2012 1:47 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

En principio este mensaje de error que te sale no debería de afectar al funcionamiento de la tienda. Lo único que tendrías que verificar es que este no salga cuando se está haciendo la compra con un usuario registrado no, no con un administrador.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 12/11/2012 3:25 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Alvaro
 Alvaro
Estimable Member

Pues no aparece, lo que ocurre es que creé un nuevo usuario desde el front-end, compré este producto:
http://alvarortega-online.com/index.php?option=com_virtuemart&view=productdetails&virtuemart_product_id=91&virtuemart_category_id=11&lang=es

Y a pesar de llegarme el recibo de pago PayPal el pedido no sale en la lista de pedidos ni el administrador ha recibido ningún mail, y eso que tiene "Recibir email del sistema" activado en su cuenta.

¿Cómo lo solucionamos?
¿Debo crear un nuevo tema?

EDITO:
El pedido aparece en pedidos como "pendiente" aunque no se ve el método de pago elegido (PayPal), donde no aparece es en tienda/lista de pedidos
El administrador no ha recibido ningún aviso por mail. ¿Qué hay que hacer para que lo reciba ?
¿puede ser porque el nuevo usuario tiene la misma cuenta de correo que un administrador??

ResponderCitar
Respondido : 15/11/2012 12:36 pm
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola Alvaro,

El tema del email verifícalo en Configuración => Tienda => Información Adicional:

Saludos.

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 15/11/2012 10:09 pm

Cursos Gratuitos WordPress

Hosting WordPress Divi con Soporte en Español

Por favor Iniciar Sesión o Registro