Avisos
Vaciar todo

[Resuelto] Errores en Página y searchand filter  

Página 1 / 2
 
Mónica
 Mónica
Usuario experto

Buenos días!

 

Tengo un problema desde hace unos días que dejó de filtrar la búsqueda de searchandfilter por categoría y taxonomía según lo definí. 

image

Si elijo una categoría y un país, filtra solo por categoría. Ya desactivé todos los plugins y el searchandfilter sigue fallando. No puedo determinar exactamente desde cuando dejó de filtrar, quizás fue después de la migración. Solo lo detecté hace unos días porque daba por sentado que funcionaba bien.

Al mismo tiempo revisando la página me aparecen estos errores:

jquery-migrate.min.js?ver=3.3.2:2 JQMIGRATE: Migrate is installed, version 3.3.2(index):214 Uncaught ReferenceError: function_exists is not defined
at (index):214
DevTools failed to load source map: Could not load content for https://portalalba.org/wp-content/themes/Divi/js/custom.unified.js.map: HTTP error: status code 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE

Sé que son dos temas para una sola pregunta, pero en realidad pienso que pueden estar relacionados estos errores con la falla en el filtro de searchandfilter. 

Gracias.

 

 

Contenido solo visible a usuarios registrados

Respondido : 02/07/2021 5:17 pm
Bruno
 Bruno
Soporte CMS Webempresa Moderator

Que tal Mónica,

Entiendo el problema, has actualizado algo recientemente? sean plugins o el core del WP?

Usando el asistente virtual Stephan he podido ver tambien la siguiente alerta:

[02-Jul-2021 02:50:33 UTC] PHP Fatal error: Allowed memory size of 1073741824 bytes exhausted (tried to allocate 262144 bytes) in /home/portalal/public_html/portalalba.org/wp-includes/class-wp-user.php on line 747

Prueba hacer lo siguiente, primero aumentar las prestaciones de las opciones de PHP desde tu Cpanel

Luego para el error actual prueba desactivando yoast ya que al revisar el error me lleva a una linea donde me muestra que tiene que ver con las breadcrumbs de ese plugin

Nos comentas como te va, Saludos!

Respondido : 02/07/2021 5:38 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Mónica
 Mónica
Usuario experto

@bruno-vichetti las prestaciones de PHP lo puedo hacer con auda del servicio técnico de Webempresa? porque no sabría cómo hacerlo.

 

Respondido : 02/07/2021 5:42 pm
Bruno
 Bruno
Soporte CMS Webempresa Moderator

Hola Mónica,

Si te fijas en mi comentario anterior te deje un enlace con una guía muy sencilla de como hacerlo, sin embargo te lo simplifico por aca.

Iniciando sesión en tu Cpanel vamos a las opciones Aplicaciones Webempresa-> Configurar PHP

01

Desde alli tendras las opciones para aumentar parámetros, donde te recomiendo aumentarlos todos y sobre todo el marcado en la img

02

Atentos por aca, Saludos

Respondido : 02/07/2021 5:54 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Mónica
 Mónica
Usuario experto

Desactivé el Yoast y sigue mostrando el error de las migas de pan. Pero si eso no tiene que ver con el searchandfilter y tampoco afecta el funcionamiento del sitio, no me molesta, lo que quisiera ver bien es lo que me comentas de aumentar las pretaciones de PHP, que no sé como hacerlo.

gracias.

Mónica

Respondido : 02/07/2021 5:55 pm
Mónica
 Mónica
Usuario experto

@bruno-vichetti ok gracias!

Respondido : 02/07/2021 5:55 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Bruno
 Bruno
Soporte CMS Webempresa Moderator

Que tal Mónica,

Genial, nos comentas si notas mejoría, recuerda que si utilizas plugins que gestionen la cache debes vaciarla en cada cambio que hagas incluyendo activar/desactivar plugins

Saludos!

Respondido : 02/07/2021 6:01 pm
Mónica
 Mónica
Usuario experto

Ya aumenté las prestaciones de PHP, sigue arrojando este mensaje:

DevTools failed to load source map: Could not load content for https://portalalba.org/wp-content/themes/Divi/js/custom.unified.js.map: HTTP error: status code 404, net::ERR_HTTP_RESPONSE_CODE_FAILURE

puede ser este error el causante de que no funcione searchandfilter?

Respondido : 02/07/2021 6:03 pm

Cursos Gratuitos WordPress

Bruno
 Bruno
Soporte CMS Webempresa Moderator

Hola Mónica,

Pude fijarme en la web probando los buscadores y me funcionan sin problemas, sin embargo el error mostrado por Divi es curioso, has validado la version del theme? verifica si el plugin que usas para la gestión de la cache el cual creo es WP-Optimize tiene activas algunas opciones de minificado.

Pero como mencione antes las búsquedas me funcionaron sin problema

Saludos

Respondido : 02/07/2021 6:18 pm
Mónica
 Mónica
Usuario experto

@bruno-vichetti

1) Activé el minificado de WP-Optimize y no aparece el error de Divi.

2) Sigue sin funcionar la búsqueda avanzada que definí con Searchandfilter. Los otros buscadors sí funcionan, pero no filtra si buscas por ejemplo Cultura y un país determinado como Argentina, en el resultado te muestra todos los de Cultura (de todos los países), antes me mostraba solo los de Cultura y Argentina.

No se me ocurre qué otra cosa puede ser, cualquier ayuda será apreciada...

Saludos!

 

Respondido : 02/07/2021 6:32 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Bruno
 Bruno
Soporte CMS Webempresa Moderator

Que tal Mónica,

Genial! con respecto a Divi un problema menos, ahora bien volviendo a los filtros al probarlos vi un funcionamiento normal por lo que interprete que no hay problema pero entiendo el caso que planteas asi que puedes validar lo siguiente:

-Revisa la configuración de esta busqueda avanzanda, te dejo la documentación de la version free y la sintaxis de los shortcodes https://free.searchandfilter.com/#examples
-Solo por verificar vuelve a guardar tus enlaces permanentes, esto puedes hacerlo desde las opciones Ajustes-> Enlaces permanentes

Saludos!

Respondido : 02/07/2021 6:41 pm
Mónica
 Mónica
Usuario experto

- La configuración de la sintaxis de los shortcodes está bien, de hecho antes me funcionaba... Igual la volví a revisar y está bien.

- Revisé los enlaces permanentes y cambié la configuración, para la forma simple, pero sigue sin funcionar el searchandfilter, así que volví a la personalizada.

Si hay algo más para intentar o conoces algún otro plugin que haga la misma función de filtro, te lo agradezco

 

Respondido : 02/07/2021 6:55 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Karen Rios
 Karen Rios
Soporte CMS Webempresa Moderator

Hola Monica, 

Es posible que el plugin esté generando algún problema con su funcionamiento, has realizado algún cambio reciente en el como por ejemplo actualizarlo?, sin embargo he realizado una búsqueda desde la opción del filtro que tienes ahora añadida y veo que funciona. 

Te envió un video donde puedes ver como lo veo -> Contenido solo visible a usuarios registrados

Un Saludo 

 

 

Respondido : 02/07/2021 7:10 pm
Mónica
 Mónica
Usuario experto

Si te fijas filtra solo por categoría, en el resultado muestra todos los post de la categoría y no filtra por el país seleccionado. Por ejemplo si pones cultura y Argentina, te muestra la sección cultura con todos los países. Antes mostraba solamente los post de Cultura y Argentina. Y no puedo detectar, cuál es el problema, porque he probado desactivando todos los plugins menos el searchandfilter, y sigue pasando lo mismo.

 

Esta publicación ha sido modificada el hace 4 meses por Mónica
Respondido : 02/07/2021 8:37 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Bruno
 Bruno
Soporte CMS Webempresa Moderator

Hola Mónica,

Tal como reviso mi compañera y en mi caso al revisar nos funciona bien el filtro pero existe el inconveniente que mencionas que no hace la búsqueda múltiple (al seleccionar dos categorías), teniendo en cuenta que ya hemos revisado estatus de plugins, cache (arreglando el error de Divi) y enlaces permanentes solo nos queda recomendarte lo siguiente:

-Crear una nueva búsqueda avanzada y validar su funcionamiento
-Probar si el plugin al actualizarse perdió la funcionalidad que necesitas, puedes hacer un downgrade a un plugin con la siguiente herramienta https://es.wordpress.org/plugins/wp-rollback/
-Tenemos en cuenta que los problemas se generan desde que migraste el sitio, has probado restaurar esa version exactamente igual en un clon para probar su funcionamiento?
-Por ultimo te dejo el support del desarrollador del plugin donde podria indicarte directamente que sucede en tu caso https://es.wordpress.org/plugins/search-filter/

Saludos!

Respondido : 02/07/2021 8:48 pm
Página 1 / 2