problemas prestashop cms  

Página 1 / 2
 
RAFAEL
 RAFAEL
Usuario activo

Hola buenas,

estoy intentando añadir nuevas páginas de CMS en el prestashop instalado en el hosting para el, pero no lo consigo cuando le meto la información prestashop guarda la nueva página vacía sin contenido, ni nombre, ni URL amigable, cuando intento ver los CMS que trae ya este theme pasa exactamente lo mismo, y cuando intento añadir una nueva categorí­a... me encuentro con el mismo problema salvo que esta vez me devuelve este error "Se ha producido un error mientras se actualizaba el objeto cms_category (Unknown column 'id_shop' in 'field list')", por favor dí­ganme a que es debido me urge terminar la web

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 13/07/2015 9:42 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Has instalado un prestashop manualmente o has usado un Pack?, que versión de prestashop tienes?

Has realizado recientemente algún tipo de modificación, anteriormente te funcionaba? Verifica si hay actualizaciones pendientes.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 13/07/2015 11:16 pm

Cursos Gratuitos WordPress

RAFAEL
 RAFAEL
Usuario activo

Instalé el prestashop manualmente es 1.6.0.14, no se si funcionaba porque no entré en los CMS hasta hoy pero al menos antes en el Fronted en "Information" aparecian las páginas de CMS que venían creadas con el Theme, tenía por actualizar un modulo sobre la política de cookies y tras actualizarlo sigue igual sigue apareció el error al crear categorías de CMS:

Se ha producido un error mientras se actualizaba el objeto cms_category (Unknown column 'id_shop' in 'field list')

ResponderCitar
Respondido : 14/07/2015 12:18 am
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Es extraño, es como si la BD no estuviera acorde con la versión de los archivos que tienes, podrías verificar entrando a la BD, buscando la tabla cms_category y luego buscando si tienes la columna id_shop

Puedes usar la aplicación de PHPMyadmin del Cpanel de tu cuenta de hosting.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 14/07/2015 12:44 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

RAFAEL
 RAFAEL
Usuario activo

Hola de nuevo te adjunto una captura del phpmyadmin de la tabla cms_category, yo no veo esa columna de id_shop, pero por si me estoy confundiendo...

También debo decirte que ese no es solo el error que tengo, como dije en mi primera entrada, tampoco consigo que se guarde nada dentro de ninguna página de CMS que creo, al escribirla y darle a guardar no sale ningún error, pero luego cuando sales a la vista general del indice de todas no muestra ni el nombre ni nada solo guiones y al entrar a editar no hay nada, y por mucho que introduzca datos no los guarda.

Espero que me puedas ayudar, Gracias

ResponderCitar
Respondido : 14/07/2015 1:56 am
RAFAEL
 RAFAEL
Usuario activo

Debo decir que además ahora acabo de mirar en las tablas de la BD y en cms_lang si está el contenido de las páginas de CMS que traía por defecto el Theme pero en el panel de control de prestashop salen todas vacías

ResponderCitar
Respondido : 14/07/2015 2:01 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Verifica si instalando un segundo Pack en tu cuenta te sucede lo mismo.

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 14/07/2015 2:08 am
RAFAEL
 RAFAEL
Usuario activo

Además acabo de ver que en localización/regla de impuestos aparece el siguiente mensaje:

Consulta SQL incorrecta
Unknown column 'a.deleted' in 'where clause'

Y no hay otro camino que instalar un segundo pack, es que es algo largo y la verdad si funciona tener que empezar de cero me hace llorar XD

ResponderCitar
Respondido : 14/07/2015 2:32 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

RAFAEL
 RAFAEL
Usuario activo

También he entrado en las traducciones y están todas puestas pero sin embargo en el Fronted se muestra en ingles, y en localización está puesto por defecto como país España y como idioma español

ResponderCitar
Respondido : 14/07/2015 2:36 am
Johnny Heredia Montiel
 Johnny Heredia Montiel
Miembro Moderator

Hola,

Si seria recomendable que instales un segundo pack, no para que comiences desde cero sino para realizar una prueba.

Debes enviarnos capturas para saber exactamente donde te muestra los errores.

Si nuestra ayuda te ha sido útil, déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 14/07/2015 5:56 am

Cursos Gratuitos WordPress

RAFAEL
 RAFAEL
Usuario activo

Ya lo he intentado 4 veces y cuando subo todo los archivos de prestashop 1.6.0.14 al directorio que cree para la prueba me sale el siguiente error

¡Uups! Por favor corrija los siguientes puntos marcados como errores y después hacer Clic en el botón "Actualizar esta información" con el fin de probar de nuevo la compatibilidad de tu sistema.

no se porque ahora me sale tal error cuando he podido hace días hacerlo en la raiz del hosting.

Alguna otra idea para decirme????

ResponderCitar
Respondido : 14/07/2015 5:46 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

HOla

Creo que el error del campo id_shop esta relacionado con el hecho de que no puedes guardar en páginas CMS puedes verificarlo con la opción de guardado y previsualizado, desde una página CMS

Hay discusiones similares que al parecer se relacionan con la carga de datos desde un quickstart, que entiendo es tu caso, tendrías que ver esto con los desarrolladores del theme ya que es posible que los datos que cargas sean inconsistentes y te producen problemas.
https://www.prestashop.com/forums/topic/437793-como-solucionar-el-error-cms-unknown-column-id-shop-in-field-list/

Tendrías que instalarte de nuevo tu quickstart en otra carpeta y revisar cargando datos y luego verificar las páginas de CMS , prueba con esto pero sin actualizar nada

Salduos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 14/07/2015 6:54 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

RAFAEL
 RAFAEL
Usuario activo

el prestashop no es del paquete que viene en vuestro host es descargado de la web oficial y sobre instalar de nuevo el prestashop en una nueva carpeta del hosting... como puse en mi anterior entrada "No me deja" mira lo que puse y la captura que adjunte, me da error

ResponderCitar
Respondido : 14/07/2015 7:14 pm
Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

El error indica, al menos lo que se ve en la captura , es que no todos los archivos han sido descargados o que el instalador esta incompleto.

Debido a que es una prueba será mejor que usese el pack webmpresa prestashop instala el pack en una carpeta, instala tu theme que has comprado, lo activas y verifica si te deja trabajar con las páginas CMS, si has realizado algún paso adicional puedes hacerlo en esta nueva instalación y ver en que punto se produce el problema.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 14/07/2015 8:49 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

RAFAEL
 RAFAEL
Usuario activo

Hablé con el servicio técnico del hosting y me dijeron que el archivo "tools/tar/Archive_Tar.php" que el sistema antivirus del host había bloqueado este archivo por eso no podía instalarlo. Ya lo hice pero el fallo se replica, tal como instalar el theme dejan de funcionar el modulo de CMS y no muestra el contenido de estas, ni las graba ni nada, ni las páginas CMS que están creadas, ni las que quiera crear, ni las categorías de las mismas y en la zona de impuestos sigue saliendo el mismo fallo

Consulta SQL incorrecta
Unknown column 'a.deleted' in 'where clause'

ResponderCitar
Respondido : 15/07/2015 1:20 am
Página 1 / 2

Por favor Iniciar Sesión o Registro