Cambiar el nombre del boton "agregar carrito" de Woocommerce en varios idiomas  

Página 1 / 2
 
Tomas
 Tomas
Usuario eminente

Hola Pepe, una pregunta, necesito cambiar el nombre del boton "añadir al carrito" en varios idiomas, estoy usando polylang como plugin traductor, ¿hay alguna manera de hacerlo?

Muchas gracias!

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 08/10/2019 8:46 am
Pepe
 Pepe
Soporte CMS Webempresa Moderator

Hola Tomas.

Para traducir o cambiar las cadenas de texto utiliza el plugin Loco Translate:
-> https://es.wordpress.org/plugins/loco-translate/

Una vez instalado y activado:
.- Accede a Loco translate -> Plugins
.- Busca Woocommerce y lo editas
.- Edita el idioma que quieres modificar la cadena de texto
.- En el filtro añade el texto que quieres modificar y modifica por el que quieres mostrar

Espero que esto sirva para lo que buscas, de no ser así por favor indícalo para que podamos seguir ayudándote.

Un saludo

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¿Has probado WpCenter?, es nuestro nuevo manager de WordPress desde el propio cPanel sin necesidad de acceder a tu administración, te permitirá configurar actualizaciones automáticas y mucho más.
Pruébalo accediendo a tu cPanel > Aplicaciones Webempresa > WpCenter
¡Gracias!.

ResponderCitar
Respondido : 08/10/2019 11:07 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Tomas
 Tomas
Usuario eminente

Gracias Pepe por la respuesta. Me esta tirando un error. Adjunto una captura.

ResponderCitar
Respondido : 08/10/2019 7:09 pm
Jhon Marreros Guzman
 Jhon Marreros Guzman
Soporte CMS Webempresa Moderator

Hola

Podría ser algo relacionado con la versión de PHP o con alguna regla de seguridad, tal como se comenta en:
https://wordpress.org/support/topic/error-page-not-found-8/

Prueba cambiar la versión de PHP y verifica, para cambiar la versión de PHP revisa: https://guias.webempresa.com/preguntas-frecuentes/cambiar-la-version-php/

Puesto que esa acción modifica un archivo, es posible que el archivo no tenga permisos correctos o que necesite espacio extra, para lo primero pasa una revisión de tu cuenta de hosting desde tu área de cliente, revisa:
https://guias.webempresa.com/preguntas-frecuentes/revision-automatica-asistente-virtual-stephan/

Para lo segundo revisa si tienes espacio suficiente en tu cuenta de hosting.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 08/10/2019 8:02 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Tomas
 Tomas
Usuario eminente

Intente cambiar los permisos del archivo q esta editando pero sigue igual. Investigando en internet sobre este error encontre esto, podra ser?

Ey Tim, solved!

Guess what: The hosting had a security rule that was limiting the access to admin-ajax.php

If someone has the same problem please be sure:

-Your hosting is checking the specific domain where the problem is. (The rule applies to the domains and not the entire server, so you can have another domain with wordpress where everything works -also my hosting was applying rules to other domain, so please check with your hosting that they are working in the right domain)

-Push your hosting to fix it. At the beginning they were telling me is not their problem, it was.

Thanks Tim for your help!

ResponderCitar
Respondido : 08/10/2019 10:43 pm
Bulmaro
 Bulmaro
Miembro Moderator

Hola Tomas,

¿Hiciste lo que Jhon te sugirió? ¿Qué resultados obtuviste? Creo que no era necesario cambiar permisos. ¿Cómo lo hiciste?

Veo tu sitio web en modo mantenimiento, lo cual complica que podamos ayudarte. Sin embargo, puedo ver que no está funcionando la API REST de WordPress, ¿La desactivaste? De no ser así te sugiero contactar a soporte técnico mediante tickets para que revisen si existe algún bloqueo de seguridad a nivel servidor.

Saludos.

Bulmaro Arellano N.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

¡Gracias!.

ResponderCitar
Respondido : 08/10/2019 11:13 pm

Cursos Gratuitos WordPress

Tomas
 Tomas
Usuario eminente

Hola, si hice los cambios, cambie la version de PHP pero sigue sin funcionar, ahora la volvi a la version que estaba antes, la 7.3, pero probe con ña 5.6 que decia en el link q me pasaron y no funciono. Ejecute a stephan y dice esto en relacion a idfntours.com.ar:

Atención, hay un 'deny from all' en el fichero /home2/tomaspa1/public_html/www.idfntours.com.ar/.htaccess, si no está en un if podría no funcionar la web:
-----------------------------------------------------------------------------------------------------------
/home2/tomaspa1/public_html/www.idfntours.com.ar/.htaccess

SetHandler application/x-lsphp73

# proteger wpconfig.php

order allow,deny
deny from all

# proteger htaccess

order allow,deny
deny from all

RewriteEngine On
RewriteCond %{ENV:HTTPS} !on [NC]
RewriteCond %{QUERY_STRING} !wc-api [NC]
RewriteCond %{HTTP_HOST} ^(www.)?idfntours.com.ar
RewriteRule ^(.*)$ https://idfntours.com.ar/$1 [R=301,L,NE]
# BEGIN WordPress

RewriteEngine On
RewriteBase /
RewriteRule ^index.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]

# END WordPress

Mas alla de esto hay un par de soluciones que me proponen que creo que estan mas en manos de ustedes que mias, como cambiar permisos de archivos especificos del serivdor. Hago un resumen de posibles problemas que me pasaron ustedes y otros que investigue. Ademas ya deshabilite la funcion de MODO PROXIMAMENTE, asi que ahora pueden entrar, si es necesario les puedo crear un usuario.

En un link q me pasaron decia que se solucion asi
“Disabled mod_security for crimco.ru, translation works.”

Y en otro lada decia es:

Ey Tim, solved!

Guess what: The hosting had a security rule that was limiting the access to admin-ajax.php

If someone has the same problem please be sure:

-Your hosting is checking the specific domain where the problem is. (The rule applies to the domains and not the entire server, so you can have another domain with wordpress where everything works -also my hosting was applying rules to other domain, so please check with your hosting that they are working in the right domain)

-Push your hosting to fix it. At the beginning they were telling me is not their problem, it was.

Thanks Tim for your help!

Me parece ya medio problematica la solucion de usar loco translate, sino podria probar de usar el programa Poedit para cambiar la traduccion manualmente.

Bueno espero respuesta, muchas gracias!

ResponderCitar
Respondido : 09/10/2019 7:38 pm
Jhon Marreros Guzman
 Jhon Marreros Guzman
Soporte CMS Webempresa Moderator

Hola

Esas reglas de protección de arhivos en el .htaccess las agregaste manualmente?, podrías probar quitarlas e incluso eliminar el .htaccess que tienes y generarlo nuevamente.

Los permisos en el servidor deben ser 644 para los archivos y 755 para carpetas, puedes pasar una revisión de tu cuenta de hosting, esta herramienta ya te cambiará los permisos: https://guias.webempresa.com/preguntas-frecuentes/revision-automatica-asistente-virtual-stephan/

Como última opción, efectivamente puedes usar poedit, tendrías que descargarte el programa, luego ejecutarlo en tu ordenador descargar los archivos pot o po , realizar las ediciones y luego te generará los archivos .mo que son los que usa Wordpress, igual vuelve a subir todos los archivos modificados.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 09/10/2019 8:28 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Tomas
 Tomas
Usuario eminente

No, yo no desactive nada, tampoco habia desactivado la API REST de WordPress que me mencionaron antes. Lo de .htaccess es algo que tiro el asistente virtual cuando lo pase. No se que significa. Simplemente loco translate tira ese error, y al parecer es un error comun. Ya pase el asistente virtial pero no lo soluciono.

ResponderCitar
Respondido : 09/10/2019 8:35 pm
Jhon Marreros Guzman
 Jhon Marreros Guzman
Soporte CMS Webempresa Moderator

Hola

Si tienes espacio en tu cuenta de hosting, podrías realizar la siguiente prueba.

Instala un nuevo sito web tienda en una carpeta (basada en tu dominio principal), luego instala Loco Translate y verifica si te sucede lo mismo, usa la misma versión de PHP que tienes en tu sitio original.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 09/10/2019 10:17 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Tomas
 Tomas
Usuario eminente

Hola, instale un nuevo sitio con woocommerce totalmente de cero y con ningun otro plugin que el loco translate y sigue haciendo el mismo error.

ResponderCitar
Respondido : 10/10/2019 7:35 pm
Tomas
 Tomas
Usuario eminente

Y otra cosa que talvez pueda ayudar, desde el plugin hay una opcion para descargar el archivo .po, cuando clickee ahi me dice que la pagina no existe, lo mismo que me dice cuando intenta grabar las modificaciones de las traducciones. Y el archivo en cuestion pareceria ser el admin-ajax.php. Me fije a travez del filezilla y el archivo existe en la ubicacion donde lo estaria buscando el plugin, le puse permiso de escritura publicos a traves del fillezilla pero no soluciono el problema

Adjunto dos capturas

ResponderCitar
Respondido : 10/10/2019 7:46 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Tomas
 Tomas
Usuario eminente

Otra cosa que acabo de descubrir, el Loco translate anda bien si la cadena que intento traducir no es de algo de Woocommerce, el problema es cuando intento traducir algo de este plugin

ResponderCitar
Respondido : 10/10/2019 8:33 pm
Jhon Marreros Guzman
 Jhon Marreros Guzman
Soporte CMS Webempresa Moderator

Hola

Posiblemente tenga que ver con los límites de PHP
https://localise.biz/wordpress/plugin/faqs/postdata-limit

Envía un ticket de soporte para que te amplien los parámetros de PHP, especialmente el de: post-max-size

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 10/10/2019 10:41 pm

Cursos Gratuitos WordPress

Tomas
 Tomas
Usuario eminente

Finalmente pude resolver el problema, no se que fue de las dos cosas que hice, por un lado le pedi a los chicos del servidor que amplieen el post-max-size, pero creo q ni lo deben haber llegado a hacer, porque al toque que se los pedi probe una opcion que trae el plugin y eso creo q fue lo q lo soluciono. Siguien con la logica que el problema estaba en la limitacion para subir archivos .po muy grandes, vi que habia una opcion que decia "Submit PO data as multipart file uploads (Experimental)", la clikee y soluciono el problema.

Loco Translate > Configuracion > Submit PO data as multipart file uploads (Experimental)

Gracias!

ResponderCitar
Respondido : 10/10/2019 11:54 pm
Página 1 / 2

Por favor Iniciar Sesión o Registro