Avisos
Vaciar todo

Errores al compartir los nuevos post de mis sites a Facebook  

P√°gina 2 / 3
 
Albert Espinola
 Albert Espinola
Usuario eminente

Hola,

Desde ayer, día 8/06/2019, mis sites hospedados en webempresa han dejado de trabajar al compartir los post a mis páginas de Facebook.

(1) Ver captura de errores en "Depurador de contenido compartido en Facebook" con cualquiera de mis sites. (con los post nuevos publicados en Wordpress a partir de dicha fecha).

En dicha captura se ven 4 errores. Y no sé porque se han dado así de repente en todas mis páginas web. "No he instalado nada ni nada. Todo ha estado como siempre."

Me di cuenta del problema cuando instalaba de forma manual los articulos en INSTAN ARTICLES DE FACEBOOK, (sin el rss) porque me daba el siguiente error: (2) Ver segunda captura: segun facebook un error (502)

Visto este error pasé a poner el RSS y dejar que facebook agarrara los nuevos post de forma automática. Luego funcionaba bien en la plataforma. Suben bien los post sin error, pero aparece el error de la captura 1. Al publicar no se comparten bien y al tratar de depurar sigue el problema.

Estoy desesperado ūüôĀ porque trabajo en esto y debo publicar cada d√≠a nuevos contenidos en la red social y he tratado de hacer de todo y no consigo solucionar el problema.

El tema es:

-No he instalado nada en ninguna de las webs.
-Se da el problema en todas al mismo tiempo.
-Una de ellas tiene diferente plantilla de Wordpress. (por lo que corrobora a que no es la plantilla).
-IMPORTANTE: (los de antes de dicha fecha comparten bien y depuran bien) ¬ŅExtra√Īo verdad? :blink:

Los dominios afectados son:

Contenido solo visible a usuarios registrados

Citar
Respondido : 09/06/2019 1:04 pm
Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Albert.

Es decir no pasa nada porque de ese error?
No, no es un problema, solo son avisos que no tiene por que afectar.

De todas formas si utilizar yoast, el propio plugin a√Īade las etiquetas Open Graph
-> https://kb.yoast.com/kb/getting-open-graph-for-your-articles/

Un saludo

ResponderCitar
Respondido : 10/06/2019 1:58 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Albert Espinola
 Albert Espinola
Usuario eminente

Veo que seguido ese error desparece de wordpress y todo va bien.

En cuanto a lo de seo yoast, no le hago mucho caso verdad?

ResponderCitar
Respondido : 10/06/2019 1:58 pm
Albert Espinola
 Albert Espinola
Usuario eminente

ostras he hecho lo mismo que en foro en concienciacolectiva y esta ultima no funciona.

me dice esto:

Error: Facebook Open Graph Tags cache NOT updated/purged.
Facebook returned: (#15) This method cannot be called with a client token or an app secret embedded in the client code
This is NOT a plugin error.
- Do not open support tickets about this issue. - Lately and unfortunately, Facebook is not allowing to update the cache programmatically.
- Have you already configured the App ID and App Secret, needed for flushing the cache on Facebook? If you haven't, go to the settings page (Open Graph tab), and do it now.
or
- Click here to try to clear the cache manually and then click "Scrape Again"

Que puede ser?

ResponderCitar
Respondido : 10/06/2019 2:08 pm

Cursos Gratuitos WordPress

Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Albert.

Es el mismo aviso que el anterior, revisa lo siguiente:
-> https://stackoverflow.com/questions/5776567/facebook-open-graph-not-clearing-cache

Un saludo

ResponderCitar
Respondido : 10/06/2019 2:13 pm
Albert Espinola
 Albert Espinola
Usuario eminente

Sí pero en este caso no funciona.

Ostras lo siento pero ya me pierdo. No se que mas hacer ūüôĀ

ResponderCitar
Respondido : 10/06/2019 2:18 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Albert.

Accede a developer de facebook.
-> https://developers.facebook.com/tools/debug/og/object

.- A√Īade la URl de una des entradas que quieres compartir
.- selecciona "recuperar información: "

de todas formas si reviso esta URL:
->Contenido solo visible a usuarios registrados

¬Ņ Puede ser que no tengas imagen destacada en la entrada ?

Un saludo

ResponderCitar
Respondido : 10/06/2019 2:45 pm
Albert Espinola
 Albert Espinola
Usuario eminente

Si hago lo que me dices me aparece esto:

No sé me estoy volviendo loco llevo 3 dias con esto. Y justo concienciaceolectiva es la que mas necesito.

ResponderCitar
Respondido : 10/06/2019 3:53 pm

Gestor de Contrase√Īas - VPN Conexi√≥n Segura - Gestor 2FA (Segundo Factor de Autenticaci√≥n

Albert Espinola
 Albert Espinola
Usuario eminente

me sigue dando este error (15)

ResponderCitar
Respondido : 10/06/2019 3:56 pm
Albert Espinola
 Albert Espinola
Usuario eminente

Ostras Pepe, ahora foro vuelve a fallar. Yo debo tenr algun problema serio porque esto aparecio en todas las webs de repente y no le veo solucion.

Que harías tu en este caso?

ResponderCitar
Respondido : 10/06/2019 4:56 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Pepe
 Pepe
Soporte CMS Webempresa Admin

Hola Albert.

Estamos mezclando demasiadas cosas, una detrás de otra o no lo solucionaremos nunca, primero un dominio y cuando esté solucionado, los demás.

Para el √ļltimo error que muestras.

El problema lo tienes en las credenciales, te explico. Facebook dejó de aceptar llamadas no autenticadas a la URL de borrado de la memoria caché, es decir tienes que crear una api con las key.

Otra opción es con el debug de facebook pero tendrás que realizarlo cada vez que quieras compartir algo.
-> https://developers.facebook.com/tools/debug/sharing/

Un saludo

ResponderCitar
Respondido : 10/06/2019 5:49 pm
Albert Espinola
 Albert Espinola
Usuario eminente

Pero el debug lo hago y no funciona.

Lo de la API ya le puse una, funcionó y mas tarde dejó de funcioanr otra vez. (solo en foromujer) en conciencia ni lo conseguí.

Mira el debug en adjunto.

Por eso te decía que ya no se que mas hacer.

ResponderCitar
Respondido : 10/06/2019 5:59 pm

Cursos Gratuitos WordPress

Jhon
 Jhon
Soporte CMS Webempresa Moderator

Hola

Actualmente veo que ya lo recupera correctamente, al menos para esa url que envías en tu imagen
Contenido solo visible a usuarios registrados
Tienes que darle en la opción de Volver a Extraer, para que fuerce la recuperación de los datos en facebook

Igual estoy viendo que tienes doble información de metadata, es posible que tengas dos plugins activo con la misma funcionalidad e opengraph, de manera general si estas usando WordPress sólo sería necesario SEO Yoast para colocar la metadata de opengraph

Saludos.

ResponderCitar
Respondido : 10/06/2019 6:59 pm
Albert Espinola
 Albert Espinola
Usuario eminente

Si este antes no iba y ahora sí. No entiendo nada. Igualmente la web de conciencia clectova sigue el problema.

El tema que me mencionas de que se duplican las meta tag, no entiendo, tu compa√Īero fue el que me dijo que lo hiciera as√≠; que no importaba que estuvieran los dos al mismo tiempo.

Y si quito el pluguin y solo dejo SEO yoast, pues asi lo tenido siempre pero estoy con este problema por eso mismo porque solo con el yoast no funciona desde hace 3 días.

No se la verdad un lio total.

que me aconsejas mas?

Por favor lee bien el primer mensaje y a ver si tu si puedes ayudarme, please.

ResponderCitar
Respondido : 10/06/2019 11:15 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Bulmaro
 Bulmaro
Soporte CMS Webempresa Moderator

Hola Albert,

¬ŅProbaste ya deshabilitando la compresion HTML, limpiando cach√© y deshabilitando el plugin de Yoast?¬ŅQu√© versi√≥n de Yoast est√°s usando en tus sitios?

ResponderCitar
Respondido : 10/06/2019 11:42 pm
Albert Espinola
 Albert Espinola
Usuario eminente

Pues no, lo pruebo. Deshabilitar html que es?

y limpiar cache con el varnish?

ResponderCitar
Respondido : 10/06/2019 11:52 pm

Gestor de Contrase√Īas - VPN Conexi√≥n Segura - Gestor 2FA (Segundo Factor de Autenticaci√≥n

P√°gina 2 / 3