Paginacion no funciona  

Página 1 / 2
 
Carles
 Carles
Reputable Member

Buenas tardes. Desde hace algunas semanas me he dado cuenta que no funciona la paginación de las diferentes categorias. Es decir, cuando al final de los posts quiero pasar a la página 2 para ver noticias mas antiguas, me vuelve a aparecer la misma página, siempre la primera. Y esto en todas las secciones, por la cual cosa no se puede consultar más que la primera página. Esto es muy raro y un gran inconveniente, obviamente.

Gracias

URL del sitio: Contenido solo visible a usuarios registrados

Citar
Respondido : 06/02/2016 7:49 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Carles,

Lo primero que habría que ver es que no sea un conflicto de javascript causado por algún plugin instalado.

- Paginación en WordPress - https://www.webempresa.com/blog/item/1503-paginacion-en-wordpress.html
- Paginación en WordPress ¿cómo mejorarla? - https://www.webempresa.com/blog/item/2043-paginacion-en-wordpress-como-mejorarla.html

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 06/02/2016 10:26 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Carles
 Carles
Reputable Member

Hace tiempo que no instalo ningun plugin nuevo, por el contrario, he desinstalado unos cuantos. He estado mirando los vídeos, pero no logro dar con la razón por la cual pasa este problema con la paginación. Es un problema grande, ya que los visitantes no pueden acceder a las entradas antiguas. Que puedo hacer? Como saber desde cuando no funciona? (teniendo en cuenta que haya dejado de funcionar por haber desinstalado algun plugin que no tenia nada que ver). Gracias.

ResponderCitar
Respondido : 17/02/2016 6:55 pm
Jhon Marreros Guzman
 Jhon Marreros Guzman
Soporte CMS Webempresa Moderator

Hola

Como es que estas mostrando estos artículos?, por ejemplo el ítem de menú Actualitat => Comarca , de que tipo est ?
Contenido solo visible a usuarios registrados

Anteriormente la paginación de esta parte te ha funcionado?

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 17/02/2016 8:33 pm

Cursos Gratuitos WordPress

Carles
 Carles
Reputable Member

Siempre me habia funcionado la paginación, en toda la página, lo sé bien por que lo utilizaba frecuentemente para hacer consultas. En el ejemplo que pones aparecen las mismas entradas que en y así en totas las demás secciones o "categorias". No sé exactamente desde cuando no funciona, sencillamente un dia me dí cuenta que sólo aparecia la primera página de cada categoria, y en las siguientes sólo se repetian las misma entradas de la primera página, aunque las entradas obviamente existen ya que están en el escritorio de wordpress.

ResponderCitar
Respondido : 18/02/2016 10:49 am
Julen
 Julen
Miembro Admin

Hola,

Prueba a desactivar y a activar las urls amigables en tu web, es posible que resuelva el problema y, además, mejorará el posicionamiento de tu web en los buscadores.

Para hacer esto vete a AJustes->Enlaces permanentes, en el apartado Ajustes comunes elige la opción Nombre entrada y guarda los cambios y regenere las urls permanentes desde Ajuste -> Enlaces permanentes pulsando en guardar cambios (no es necesario realizar ningún cambio adicional aquí)

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 18/02/2016 11:17 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Carles
 Carles
Reputable Member

Ya lo he hecho. En enlaces permanentes ya tenia seleccionada la opción Nombre entrada. He probado con otras opciones, y al final he vuelto a seleccionar Nombre de Entrada, pero todo sigue igual.

ResponderCitar
Respondido : 18/02/2016 12:46 pm
Jhon Marreros Guzman
 Jhon Marreros Guzman
Soporte CMS Webempresa Moderator

Hola

Deja las urls como predeterminadas , la primera opción en Ajustes > Enlaces permanentes

Tendráis que probar adicionalmente desactivar los plugins que recientemente has instaldo ya que es posible que alguno de ellos te este causando el problema

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 18/02/2016 5:09 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Carles
 Carles
Reputable Member

Te refieres a que deje marcada la primera opción?

Me pasa esto:

ResponderCitar
Respondido : 18/02/2016 6:49 pm
Carles
 Carles
Reputable Member

Hace meses que no instalo ningún plugin

ResponderCitar
Respondido : 18/02/2016 6:58 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jhon Marreros Guzman
 Jhon Marreros Guzman
Soporte CMS Webempresa Moderator

HOla

Si , la primera opción, desactiva el plugin de SEO by Yoast temporalmente

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 18/02/2016 9:32 pm
Carles
 Carles
Reputable Member

Bien, ya lo he hecho. He seleccionado la primera opción y he desactivado el Yosat SEO. De momento todo sigue igual, no se ha solucionado el problema y además ahora no funciona el WP Super Caché por que dice que

«Permlink Structure Error: A custom url or permalink structure is required for this plugin to work correctly. Please go to the Permalinks Options Page to configure your permalinks».

ResponderCitar
Respondido : 20/02/2016 12:13 am

Cursos Gratuitos WordPress

Jhon Marreros Guzman
 Jhon Marreros Guzman
Soporte CMS Webempresa Moderator

Hola

El elemento de menú VI Blog, de que tipo es?, es un elemento de menú de categoría o es un short-code puesto en una página?, envia alguna captura de pantalla.

Saludos.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio
¡Gracias!.

ResponderCitar
Respondido : 20/02/2016 1:10 am
Carles
 Carles
Reputable Member

Es un enlace a una página del mismo wordpress, es un enlace que siempre ha estado. Ya te digo, hace tiempo que no estreno plugins, ha sido totdo lo contrario, he sacado algunos en los ultimos meses.

ResponderCitar
Respondido : 21/02/2016 12:39 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola Carles,

Tu tema "WorldWide" ¿utiliza algún tipo de constructor (builder) de páginas? porque la portada o página inicial no es una página sencilla, sino una página personalizada y por lo que he podido ver con bastantes plugins.

No creo que tengas que estar volviéndote loco con "urls amigables" etc, así que mi recomendación es que "Enlaces permanentes" lo dejes como lo tenias que es lo correcto, sobre todo porque si lo cambias ahora te fastidiará el SEO on-page con lo que eso supone.

¿Puedes facilitar la url del autor del tema que usas? no lo he encontrado, para poder ver de que esta compuesto, etc.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 21/02/2016 6:16 am
Página 1 / 2

Por favor Iniciar Sesión o Registro