de local remoto  

Página 1 / 2
 
jj
 jj
Usuario experto

Hola de nuevo...
tengo un sitio con virtuemart que voy haciendo en local. He intentado pasarla a remoto subiendo todos los archivos a remoto, subiendo la base de datos y por último haciendo los cambios en el archivo config.php. El problema es que, de primeras no me ha cogido la plantilla de joomla, y el componente de virtuemart, la administración no se ve de forma correcta, sale desorganizado. En el frontend no salen los productos.

Hay alguna otra cosa que haya que cambiar para que aparezca como lo tengo en local?

Muchas gracias... de nuevo.

Citar
Respondido : 04/09/2010 10:14 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola joterob,

Habría algunos datos más que aportar para centrar la ayuda:

Que Hosting utilizas (de pago o gratuito) -aunque no lo parezca eso influye a la hora de disponer de determinados soportes para ejecutar Joomla! de forma adecuada.

Como esta el safe_mode de tu Hosting (backend > Ayuda > Información del Sitio)

¿Has modificado las rutas de VirtueMart en la configuración de este?

¿En local utilizabas la compresion Gzip en Configuración Global?, ¿esta igual en remoto?.

Y si ya aportases la URL para ver el problema seria de más ayuda para ayudarte.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 04/09/2010 10:35 pm

Cursos Gratuitos WordPress

Lucas
 Lucas
Miembro Admin

Hola,

Lo más probable es que falten archivos, no tengas permisos correctos o bien las rutas del configuration.php sean incorrectas.

Sin ver la url en el servidor online es complicado darte más datos.

Si te ha servido de ayuda, déjanos tu testimonio con un link hacia tu Web y mejora su posicionamiento:
Enviar testimonio
¡Gracias!.

ResponderCitar
Respondido : 05/09/2010 6:15 am
jj
 jj
Usuario experto

Muchas gracias gnumax y lucas...

Utilizo un servidor de pago, he subido varias veces los archivos por lo que creo que no falte nada. Acabo de modificar el archivo virtuemart.cfg.php y parece que se ha solucionado lo del backend... se ve correcto. ¿Hay algún archivo más que tengo que modificar respesto al virtuemart?

El safe_mode lo tengo desactivado y lo del Gzip no lo veo por ningún lado.

Supongo que lo que falla sean las rutas del virtuemart ya que la plantilla joomla aparece correcta, el problema está con el menú de los productos y los productos en sí, ya que tampoco aparecen las imágenes.

Muchas gracias
Un saludo

ResponderCitar
Respondido : 05/09/2010 11:52 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jordi Sala
 Jordi Sala
Miembro Admin

Hola,

Respecto al: Gzip no lo veo por ningún lado.

Administración --> sitio --> configuración global --> pestaña Servidor --> Compresión GZIP de las páginas.

Si no se visualizan imagenes en menús y en productos, seguramente alguna de las rutas de virtuemart esta incorrecta. Revisa en el código de las páginas en cuestión, en la imagen que indique la url desde la que carga. A veces si no se pone la ruta correcta, puede que intente cargar la imagen en algún punto de la url con // y de ahí que no la encuentre.

Sin ver la url del sitio web no es posible visualizar el problema, de ahí que no puedo asegurar que mi sugerencia sea la solución.

Saludos,

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 06/09/2010 10:58 am
jj
 jj
Usuario experto

ok Jordi... al final he reinstalado todo ya que tenia pocas cosas.

Gracias

ResponderCitar
Respondido : 19/09/2010 6:15 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

Enrique
 Enrique
Usuario activo

Hola a todos,

Yo tengo mas o menos el mismo problema.

Estoy subiendo un sitio de local a remoto, pero en mi caso no puedo ni acceder al sitio/administrator.
La página se queda en blanco.

Puede ser problema de los permisos?

saludos

ResponderCitar
Respondido : 21/09/2010 11:06 am
Enrique
 Enrique
Usuario activo

otra cosilla,

para poder volver a subir todo de nuevo, que carpetas puedo borrar y cuales hay que dejar?

thanks

ResponderCitar
Respondido : 21/09/2010 11:19 am

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola kike_10,

Si vas a subir nuevamente tu sitio local al Hosting y no has realizado cambios en el mismo puedes tranquilamente eliminar todo lo que cuelgue de tu /public_html o /www, depende de como sea en tu Hosting, y subir nuevamente los archivos de Joomla!.

¿Que tipo de Hosting es, gratuito o de pago? ya que aunque parezca una cosa sin importancia, si la tiene ya que una de las bases de muchos sitios gratuitos es la limitación en los servicios que ofrecen y las tecnologías que ponen a disposición de los usuarios.

El tema de permisos quizás sea la parte más importante de todas, no es la primera vez que dejo de usar un Hosting porque "casi" me obligan a trabajar con permisos 777 algo que es un error y un problema para la seguridad del sitio ya que lo normal es disponer de permisos 755 para carpetas y 644 para archivos.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 21/09/2010 6:08 pm
Enrique
 Enrique
Usuario activo

gnumax escribió:

Hola kike_10,

Si vas a subir nuevamente tu sitio local al Hosting y no has realizado cambios en el mismo puedes tranquilamente eliminar todo lo que cuelgue de tu /public_html o /www, depende de como sea en tu Hosting, y subir nuevamente los archivos de Joomla!.

¿Que tipo de Hosting es, gratuito o de pago? ya que aunque parezca una cosa sin importancia, si la tiene ya que una de las bases de muchos sitios gratuitos es la limitación en los servicios que ofrecen y las tecnologías que ponen a disposición de los usuarios.

El tema de permisos quizás sea la parte más importante de todas, no es la primera vez que dejo de usar un Hosting porque "casi" me obligan a trabajar con permisos 777 algo que es un error y un problema para la seguridad del sitio ya que lo normal es disponer de permisos 755 para carpetas y 644 para archivos.

Saludos

Pues no lo consigo resolver.

Borre todo y lo volvi a subir y tras hacer los cambios en el configuration.php, no se ve nada, es decir ni errores, ni mensajes ni la pantalla principal, ninguna letra. Tampoco puedo acceder a midominio.es/administrator ............

Estoy un poco perdido, todos los permisos estan correctamente asignados.

Ahora mismo tengo la web en un servidor propio, con Ubutnu Server + Php + MySql + Joomla! y funciona todo ok, la verdad es que estoy perdido...

ResponderCitar
Respondido : 21/09/2010 9:59 pm

Cursos Gratuitos WordPress

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola kike_10,

Desde tu administrador de archivos de cPanel, o el que tengas, mira a ver si en el raiz de tu Joomla! tienes un .htaccess, si lo tienes renombralo a htacces.txt y prueba a cargar la web y nos cuentas.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 21/09/2010 10:09 pm
Enrique
 Enrique
Usuario activo

Nada, la cosa continua igual, he dejado el htaccess del servidor que tengo en funcionamiento y sigue exactamente igual. No sale ningun error.

Unicamente en IE 8 aparece HTTP 500 Error interno del servidor

ResponderCitar
Respondido : 21/09/2010 10:24 pm

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Enrique
 Enrique
Usuario activo

Continuo probando, y me encuentro con una cosa curiosa, cada vez que renombro o borro el .htaccess, me lo vuelve a crear automaticamente. Aunque tenga el htaccess.txt

Sabeis porque puede ser esto??

ResponderCitar
Respondido : 21/09/2010 11:17 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola

La verdad es que lo que comentas es curioso, aunque supongo que sera alguna medida implementada por el Hosting para que en las cuentas de clientes haya siempre un .htaccess (entiendo que con datos y no a 0 bytes) y no quede a merced de posible ataques.

Aquí te pongo un .htaccess que funciona muy bien, al menos en los servidores de Webempresa:

##
# @version $Id: htaccess.txt 14401 2010-01-26 14:10:00Z louis $
# @package Joomla
# @copyright Copyright (C) 2005 - 2010 Open Source Matters. All rights reserved.
# @license  http://www.gnu.org/copyleft/gpl.html  GNU/GPL
# Joomla! is Free Software
##


#####################################################
# READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE
#
# The line just below this section: 'Options +FollowSymLinks' may cause problems
# with some server configurations. It is required for use of mod_rewrite, but may already
# be set by your server administrator in a way that dissallows changing it in
# your .htaccess file. If using it causes your server to error out, comment it out (add # to
# beginning of line), reload your site in your browser and test your sef url's. If they work,
# it has been set by your server administrator and you do not need it set here.
#
#####################################################

## Can be commented out if causes errors, see notes above.
Options +FollowSymLinks

#
# mod_rewrite in use

RewriteEngine On

########## Begin - Rewrite rules to block out some common exploits
## If you experience problems on your site block out the operations listed below
## This attempts to block the most common type of exploit `attempts` to Joomla!
#
## Deny access to extension xml files (uncomment out to activate)
#
#Order allow,deny
#Deny from all
#Satisfy all
#
## End of deny access to extension xml files
RewriteCond %{QUERY_STRING} mosConfig_[a-zA-Z_]{1,21}(=|%3D) [OR]
# Block out any script trying to base64_encode crap to send via URL
RewriteCond %{QUERY_STRING} base64_encode.*(.*) [OR]
# Block out any script that includes a  tag in URL
RewriteCond %{QUERY_STRING} (|%3E) [NC,OR]
# Block out any script trying to set a PHP GLOBALS variable via URL
RewriteCond %{QUERY_STRING} GLOBALS(=|[|%[0-9A-Z]{0,2}) [OR]
# Block out any script trying to modify a _REQUEST variable via URL
RewriteCond %{QUERY_STRING} _REQUEST(=|[|%[0-9A-Z]{0,2})
# Send all blocked request to homepage with 403 Forbidden error!
RewriteRule ^(.*)$ index.php [F,L]
#
########## End - Rewrite rules to block out some common exploits

# Uncomment following line if your webserver's URL
# is not directly related to physical file paths.
# Update Your Joomla! Directory (just / for root)

# RewriteBase /


########## Begin - Joomla! core SEF Section
#
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !^/index.php
RewriteCond %{REQUEST_URI} (/|.php|.html|.htm|.feed|.pdf|.raw|/[^.]*)$ [NC]
RewriteRule (.*) index.php
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]
#
########## End - Joomla! core SEF Section

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 22/09/2010 5:42 am

wpdoctor-revisa-la-salud-de-tu-wordpress

Enrique
 Enrique
Usuario activo

La verdad, es muy curioso, he borrado todo de nuevo y e instalado el pack JoomlaSpanish y aparece un .htaccess en blanco, sin embargo los ejemplos cargan correctamente.

Volver a subir mis archivos de nuevo, y pondre ese .htaccess y probaremos a ver si funciona. No me gustaria nada tener que subir las cosas del sitio de nuevo manualmente..

Thanks por la ayuda

ResponderCitar
Respondido : 22/09/2010 9:56 am
Página 1 / 2

Por favor Iniciar Sesión o Registro