Desaparecen datos usuarios  

Página 1 / 2
 
David Romero
 David Romero
Reputable Member

Hola, aqui estoy con mis problemillas...ahora he observado haciendo pruebas con los usuarios que si a un usuario dado de alta correctamente en la web le cambio el grupo de comprador se borran todos los datos que Vm tiene de él (salvo mail, usuario...), y además cuando intento en su ficha volver a meter sus datos me dice que ok, que se han grabado correctamente pero cuando vuelves a la ficha está en blanco, ¿que sucede?

Citar
Respondido : 21/07/2011 6:55 pm
Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola David Romero,

¿Podrías facilitar alguna captura del antes y después (si aún conservas) para ver como estaban los usuarios antes de asociarlos a un grupo y de paso explicarnos como tienes creados los grupos en VirtueMart.?

¿Que versión de VirtueMart tienes?

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 21/07/2011 8:29 pm

wpdoctor-revisa-la-salud-de-tu-wordpress

David Romero
 David Romero
Reputable Member

Hola gnumax,

la version que uso es la 1.1.8 stable.
Adjunto captura de los grupos de compradores que tengo y captura de la ficha de un usuario normal cuando se inscribe, lo que sucede es que en cuanto le cambio en esa solapa de información el grupo al que pertenece y lo paso por ejemplo al grupo empresa o a cualquier otro, desaparecen todos los datos de facturación.

ResponderCitar
Respondido : 22/07/2011 4:26 pm
Jordi Sala
 Jordi Sala
Miembro Admin

Hola David,

Veo en las capturas de pantalla, que los campos de usuario se han modificado los que hay por defecto en Virtuemart. Más información http://virtuemart.webempresa.eu/index.php?title=Campos_de_Usuarios

A veces puede dar errores, si se utilizan los campos que vienen por defecto, y se editan. Lo correcto es crear campos nuevos, desconozco como lo has realizado.

Saludos,

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 25/07/2011 8:21 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

David Romero
 David Romero
Reputable Member

Hola Jordi,

efectivamente eso ya me dió algun problema de otro tipo y lo subsané pero ahora los campos añadidos están hechos como nuevos, y funciona todo correctamente hasta que realizo el cambio de tipo de comprador.

ResponderCitar
Respondido : 25/07/2011 10:54 am
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

Haz la prueba de despublicar (no hace falta borrarlos) los campos nuevos que has creado. Después realiza un alta de usuario y por último prueba a cambiar el grupo de usuarios para ver si te sigue borrando los datos.

De esta forma podremos saber si el problema está en los campos personalizados.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 25/07/2011 1:33 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

David Romero
 David Romero
Reputable Member

Hola pablo,

lo he hecho y no ha resultado, acabo igual con la pantalla sin datos y sin posibilidad de recuperarlos. Cuando hago el cambio me dice que los cambios han sido guardados pero cuando entro en la ficha de nuevo está sin los datos. te envío una captura de como me deja la ficha:

ResponderCitar
Respondido : 25/07/2011 5:28 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola,

He realizado algunas pruebas y veo que me funciona bien en una web de prueba. Es decir, aunque el grupo de usuarios de Virtuemart a un usuario no se pierden los datos.

Sigo pensando que se podría tratar de un problema con los campos de usuario.

Envíanos una captura de pantalla de los campos de usuario de Virtuemart, para que podamos comprobar si hay algo mal.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 26/07/2011 9:22 am

Cursos Gratuitos WordPress

David Romero
 David Romero
Reputable Member

Hola Pablo,
te adjunto las dos capturas de sendas pantallas de los campos de usuarios. Me he fijado en que en la segunda pantalla, donde salen los extra fields, el primero de ellos, que es el que en un principió modifiqué para crear el de fecha de nacimiento, no ha quedado como los demás y se ha renombrado con el prefijo vm, míralo y dime a ver que opinas si está ahí el problema. un saludo y muchas gracias.

ResponderCitar
Respondido : 26/07/2011 6:54 pm
Pablo Velasco
 Pablo Velasco
Illustrious Member

Hola David,

He revisado las imágenes que has enviado. En efecto, es un poco raro el tema del campo extra field, aunque no debería afectar si está desactivado.

Una prueba que podrías hacer sería despublicar los campos extra que has añadido (CIF, fecha de nacimiento, NIF) y comprobar si así te sigue perdiendo los datos cuando cambias el grupo de compradores. Es posible que alguno de estos campos no esté funcionando bien y provoque el problema.

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 28/07/2011 9:57 am

wpdoctor-revisa-la-salud-de-tu-wordpress

David Romero
 David Romero
Reputable Member

Hola pablo,

lo he hecho y no ha resultado, acabo igual con la pantalla sin datos y sin posibilidad de recuperarlos. Cuando hago el cambio me dice que los cambios han sido guardados pero cuando entro en la ficha de nuevo está sin los datos. te envío una captura de como me deja la ficha:

Hola Pablo,

ya me indicastes que lo hiciera y no dió resultado, no sé que puede pasar...

ResponderCitar
Respondido : 28/07/2011 10:20 am
David Romero
 David Romero
Reputable Member

Pablo, como lo anterior no funciona he pensado hacer otra cosa. Tengo copias de seguridad de hace varios meses y seguro que aun no había modificado los campos de usuario, he pensado en intentarlo en modo local.
Lo he instalado sin problemas y accedo al backend, entro en VM, pero en cuanto intento ver la configuración de usuarios del VM me manda a la configuración del Vm pero del site, ¿dónde tengo que configurar el Vm para que siga en local?

ResponderCitar
Respondido : 28/07/2011 10:37 am

Gestor de Contraseñas - VPN Conexión Segura - Gestor 2FA (Segundo Factor de Autenticación

Jordi Sala
 Jordi Sala
Miembro Admin

Hola David,

El tema es que Virtuemart en los parámetros de configuración (Administración --> componentes --> Virtuemart --> configuración --> pestaña seguridad --> Site URL y SECUREURL - URL segura tiene que tener la url del dominio.

Se puede modificar también en el archivoadministrator/components/com_virtuemart/virtuemart.cfg.php ya que hace referencias al dominio.

Saludos,

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar mi Testimonio

ResponderCitar
Respondido : 28/07/2011 4:50 pm
David Romero
 David Romero
Reputable Member

Hola Jordi y Pablo,

gracias, así lo he hecho, y he podido hacer las pruebas necesarias en local sobre una copia de seguridad en la que no había modificado aún los campos de usuario, y el resultado ha sido....que sí que funciona.
Lo que podríamos seguir pensando es que el error puede estar en los campos de usuario, pero probando en local, me he fijado que también puede estar en la modificación de los grupos de compradores, que también los he personalizado, lo veo improbable ya que no hay mucho que "estropear"ahí pero os pongo una captura y a ver que opinais. De no ser así como solucionamos lo de los campos de usuario? Gracias.

ResponderCitar
Respondido : 28/07/2011 7:31 pm

optimiza-automaticamente-todas-las-imagenes-de-tu-wordpress

Luis Mendez Alejo
 Luis Mendez Alejo
Miembro Admin

Hola David Romero,

No veo ninguna diferencia entre esta captura y la de hace 2 días

¿Que cambios realizaste al respecto de los usuarios o los campos de los mismos?.

Saludos

Si nuestra ayuda te sirve déjanos tu testimonio y mejora así el posicionamiento de tu web:
Enviar Testimonio
¡Gracias!.

ResponderCitar
Respondido : 28/07/2011 7:35 pm
Página 1 / 2

Por favor Iniciar Sesión o Registro